The return value wasn't checked by any of the callers. Assuming this is
correct behaviour, we can simplify some code by not bothering to
generate it.
Signed-off-by: Joern Engel
---
drivers/infiniband/ulp/srpt/ib_srpt.c| 14 +-
drivers/scsi/qla2xxx/tcm_qla2
These things caught my eye while debugging something else. Nothing
too exciting.
Joern Engel (3):
target: remove iscsit_find_cmd_from_itt_or_dump()
target: remove unused codes from enum tcm_tmrsp_table
target: make queue_tm_rsp() return void
drivers/infiniband/ulp/srpt/ib_srpt.c
default case then return success.
Signed-off-by: Joern Engel
---
drivers/target/iscsi/iscsi_target.c |2 --
drivers/target/tcm_fc/tfc_cmd.c |3 ---
include/target/target_core_base.h | 13 +
3 files changed, 5 insertions(+), 13 deletions(-)
diff --git a/drivers/target
Code is a copy of iscsit_find_cmd_from_itt(). Afaics this is debug code
from at least two years ago. Either the bug in question has been long
fixed or this debug code doesn't help fixing it. Whichever way you look
at it, we should remove the debug code.
Signed-off-by: Joern Engel
---
dr
sys_write+0x51/0x90
system_call_fastpath+0x16/0x1b
core_tpg_set_initiator_node_queue_depth() calls
lio_tpg_shutdown_session() inside a spin_lock_irqsave-protected block.
Calling spin_unlock_bh later in the call chain always triggers the
warning.
Signed-off-by: Joern Engel
Cc: Johannes Berg
Cc
First two are cleanups, third adds hugetlbfstest. This test fails on
current kernels, but I have previously sent a patchset to fix the two
failures.
Joern Engel (3):
selftests: exit 1 on failure
self-test: fix make clean
selftests: add hugetlbfstest
tools/testing/selftests/vm/Makefile
In case this ever gets scripted, it should return 0 on success and 1 on
failure. Parsing the output should be left to meatbags.
Signed-off-by: Joern Engel
---
tools/testing/selftests/vm/Makefile|2 +-
tools/testing/selftests/vm/run_vmtests |5 +
2 files changed, 6 insertions
As the confusing naming indicates, this test has some overlap with
pre-existing tests. Would be nice to merge them eventually. But since
it is only test code, cleanliness is much less important than mere
existence.
Signed-off-by: Joern Engel
---
tools/testing/selftests/vm/Makefile
thuge-gen was forgotten. Fix it by removing the duplication, so we
don't get too many repeats.
Signed-off-by: Joern Engel
---
tools/testing/selftests/vm/Makefile |5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/tools/testing/selftests/vm/Makefile
b/tools/te
It is counterintuitive at best that mmap'ing a hugetlbfs file with
MAP_HUGETLB fails, while mmap'ing it without will a) succeed and b)
return huge pages.
Signed-off-by: Joern Engel
---
mm/mmap.c | 12 ++--
1 file changed, 10 insertions(+), 2 deletions(-)
diff --git a/mm/m
.
Test program below is failing before these two patches and passing
after.
Joern Engel (2):
hugetlb: properly account rss
mmap: allow MAP_HUGETLB for hugetlbfs files
mm/hugetlb.c |4
mm/mmap.c| 12 ++--
2 files changed, 14 insertions(+), 2 deletions(-)
--
1.7.10.4
e
is every chance existing programs depend on hugepages not being counted
as rss.
I think the correct solution is to fix the bug and wait for someone to
complain. It is just as likely that noone cares - as evidenced by the
fact that noone seems to have noticed for ten years.
Signed-off-by: Joern Enge
Signed-off-by: Joern Engel
---
fs/btrfs/backref.c | 15 +++
fs/btrfs/compression.c |4 +---
fs/btrfs/disk-io.c |6 +-
fs/btrfs/extent-tree.c | 17 +++--
fs/btrfs/extent_io.c|8 ++--
fs/btrfs/inode.c| 16
x27;t
there yet. Or maybe I just messed up - patches are only
compile-tested after all. Comments/ideas are welcome.
Joern Engel (2):
list: add list_for_each_entry_del
btrfs: use list_for_each_entry_del
fs/btrfs/backref.c | 15 +++
fs/btrfs/compression.c |4 +---
fs/
le can use
list_for_each_entry_del(pos, head, list) {
...
}
The patch also adds a list_for_each_del variant, even though I have
only found a single user for that one so far.
Signed-off-by: Joern Engel
---
include/linux/list.h | 33 ++
rqsave() and uses it in
target_put_sess_cmd() to close the race window.
Signed-off-by: Joern Engel
---
drivers/target/target_core_transport.c | 11 +--
include/linux/kref.h | 33
2 files changed, 38 insertions(+), 6 deletions(-)
is an unrelated trivial cleanup. I just happened to spot it
while I was in the area.
Joern Engel (3):
target: removed unused transport_state flag
target: close target_put_sess_cmd() vs. core_tmr_abort_task() race v5
target: simplify target_wait_for_sess_cmds()
drivers/infiniband/ulp/srpt/ib_s
this is rmmod, afaics, so I
didn't want the overhead of a waitqueue.
Signed-off-by: Joern Engel
---
drivers/infiniband/ulp/srpt/ib_srpt.c |2 +-
drivers/scsi/qla2xxx/tcm_qla2xxx.c |2 +-
drivers/target/target_core_transport.c | 64 +
Signed-off-by: Joern Engel
---
include/target/target_core_base.h |1 -
1 file changed, 1 deletion(-)
diff --git a/include/target/target_core_base.h
b/include/target/target_core_base.h
index c4af592..068ec0f 100644
--- a/include/target/target_core_base.h
+++ b/include/target
From: Takashi Iwai
Signed-off-by: Takashi Iwai
---
drivers/block/blockconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block/blockconsole.c b/drivers/block/blockconsole.c
index 40cc96e..01ddbc6 100644
--- a/drivers/block/blockconsole.c
+++ b/drivers/block
Joern Engel (8):
do_mounts: constify name_to_dev_t parameter
add blockconsole version 1.1
printk: add CON_ALLDATA console flag
netconsole: use CON_ALLDATA
blockconsole: use CON_ALLDATA
bcon: add a release work struct
bcon: check for hdparm in bcon_tail
bcon: remove version 1.0
both.
Signed-off-by: Joern Engel
---
Documentation/networking/netconsole.txt | 16
1 file changed, 12 insertions(+), 4 deletions(-)
diff --git a/Documentation/networking/netconsole.txt
b/Documentation/networking/netconsole.txt
index 2e9e0ae2..c59d2bf 100644
--- a/Document
From: Borislav Petkov
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole/bcon_tail |5 +
1 file changed, 5 insertions(+)
diff --git a/Documentation/block/blockconsole/bcon_tail
b/Documentation/block/blockconsole/bcon_tail
index b4bd660..eb3524b 100755
--- a/Documentation
This seems to have broken around the introduction of format 1.1. When
wrapping around, we should increment the wrap counter before writing it
out, not after.
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a
reproduced
by "yes h > /proc/sysrq-trigger" and concurrently pulling and replugging
the blockconsole device. It took be somewhere around 30 pulls and sore
thumbs to reproduce and I never found the time to get to the bottom of
it. Quite likely the two issues are identical.
Signed-
66 66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 0f 1f 44 00 00
[166135.634384] 48 8b 14 25 98 24 01 00 48 8d 14 92 48 8d 04 bd 00 00 00 00
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block
66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 0f 1f 44 00 00
[166135.634384] 48 8b 14 25 98 24 01 00 48 8d 14 92 48 8d 04 bd 00 00 00 00
Signed-off-by: Joern Engel
---
drivers/net/netconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/netconsole.c b
d get spammed by messages while trying to login
or similar. So ignore_loglevel doesn't work as a one-size-fits-all
approach. Add a per-console flag instead so that netconsole and
blockconsole can opt-in.
Signed-off-by: Joern Engel
---
include/linux/console.h |1 +
kernel/printk.c
Hodgson added a panic notifier.
- Added improvements and cleanups from Borislav Petkov.
Signed-off-by: Steve Hodgson
Signed-off-by: Borislav Petkov
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole.txt| 94
Documentation/block/blockconsole/bcon_tail | 62
From: Takashi Iwai
Avoid the name conflict with device_lock() defined in linux/device.h.
Signed-off-by: Takashi Iwai
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/block/blockconsole.c b
From: Takashi Iwai
... instead of always looking through all devices.
Minor tweak: Moved the "CANDIDATES=" line below Takashi's new code.
Signed-off-by: Takashi Iwai
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole/bcon_tail | 15 +++
1 f
Signed-off-by: Joern Engel
---
include/linux/mount.h |2 +-
init/do_mounts.c |2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/mount.h b/include/linux/mount.h
index d7029f4..6b5fa77 100644
--- a/include/linux/mount.h
+++ b/include/linux/mount.h
Very few machines ever ran with 1.0 format and by now I doubt whether a
single one still does. No need to carry that code along.
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c | 19 ++-
1 file changed, 2 insertions(+), 17 deletions(-)
diff --git a/drivers/block
[] kernel_thread_helper+0x4/0x10
[] ? retint_restore_args+0x13/0x13
[] ? kthread_freezable_should_stop+0x70/0x70
[] ? gs_change+0x13/0x13
Signed-off-by: Joern Engel
---
drivers/scsi/mpt2sas/mpt2sas_base.h |1 +
drivers/scsi/mpt2sas/mpt2sas_scsih.c | 55 --
2 files changed
and kicking my
behind to provide a proper git tree and resend patches.
Git tree is on kernel.org and I intend to keep it stable, as people
seem to be using it already. It has been in -next since Mar 7.
git://git.kernel.org/pub/scm/linux/kernel/git/joern/bcon2.git
Joern Engel (10):
do_mounts
[] kernel_thread_helper+0x4/0x10
[] ? retint_restore_args+0x13/0x13
[] ? kthread_freezable_should_stop+0x70/0x70
[] ? gs_change+0x13/0x13
Signed-off-by: Joern Engel
---
drivers/scsi/mpt2sas/mpt2sas_base.h |1 +
drivers/scsi/mpt2sas/mpt2sas_scsih.c | 57 --
drivers/scsi
From: Takashi Iwai
Signed-off-by: Takashi Iwai
---
drivers/block/blockconsole.c |1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/block/blockconsole.c b/drivers/block/blockconsole.c
index e88b8ee..c22272f 100644
--- a/drivers/block/blockconsole.c
+++ b/drivers/block/blockconsole.c
From: Borislav Petkov
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole/bcon_tail |5 +
1 file changed, 5 insertions(+)
diff --git a/Documentation/block/blockconsole/bcon_tail
b/Documentation/block/blockconsole/bcon_tail
index b4bd660..eb3524b 100755
--- a/Documentation
66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 0f 1f 44 00 00
[166135.634384] 48 8b 14 25 98 24 01 00 48 8d 14 92 48 8d 04 bd 00 00 00 00
Signed-off-by: Joern Engel
---
drivers/net/netconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/netconsole.c b
66 66 66 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 0f 1f 44 00 00
[166135.634384] 48 8b 14 25 98 24 01 00 48 8d 14 92 48 8d 04 bd 00 00 00 00
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block
From: Takashi Iwai
... instead of always looking through all devices.
Minor tweak: Moved the "CANDIDATES=" line below Takashi's new code.
Signed-off-by: Takashi Iwai
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole/bcon_tail | 15 +++
1 f
Very few machines ever ran with 1.0 format and by now I doubt whether a
single one still does. No need to carry that code along.
Signed-off-by: Joern Engel
---
drivers/block/blockconsole.c | 19 ++-
1 file changed, 2 insertions(+), 17 deletions(-)
diff --git a/drivers/block
Hodgson added a panic notifier.
- Added improvements and cleanups from Borislav Petkov.
Signed-off-by: Steve Hodgson
Signed-off-by: Borislav Petkov
Signed-off-by: Joern Engel
---
Documentation/block/blockconsole.txt| 94
Documentation/block/blockconsole/bcon_tail | 62
reproduced
by "yes h > /proc/sysrq-trigger" and concurrently pulling and replugging
the blockconsole device. It took be somewhere around 30 pulls and sore
thumbs to reproduce and I never found the time to get to the bottom of
it. Quite likely the two issues are identical.
Signed-
d get spammed by messages while trying to login
or similar. So ignore_loglevel doesn't work as a one-size-fits-all
approach. Add a per-console flag instead so that netconsole and
blockconsole can opt-in.
Signed-off-by: Joern Engel
---
include/linux/console.h |1 +
kernel/printk.c
Signed-off-by: Joern Engel
---
include/linux/mount.h |2 +-
init/do_mounts.c |2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/mount.h b/include/linux/mount.h
index d7029f4..6b5fa77 100644
--- a/include/linux/mount.h
+++ b/include/linux/mount.h
Joern Engel (8):
do_mounts: constify name_to_dev_t parameter
add blockconsole version 1.1
printk: add CON_ALLDATA console flag
netconsole: use CON_ALLDATA
blockconsole: use CON_ALLDATA
bcon: add a release work struct
bcon: check for hdparm in bcon_tail
bcon: remove version 1.0
47 matches
Mail list logo