On Thu, 6 Feb 2025 at 23:42, Tamir Duberstein wrote:
>
> On Thu, Feb 6, 2025 at 4:27 AM Rasmus Villemoes
> wrote:
> >
> > On Tue, 4 Feb 2025 at 20:36, Tamir Duberstein wrote:
> > >
> > > This is one of just 3 remaining "Test Module" kselftests (the others
> > > being bitmap and scanf), the rest
On 2025-02-06 21:45:37-0800, Shyam Saini wrote:
> lookup_or_create_module_kobject() is static and marked as __init,
> this is not ideal for global usage.
FYI missing "PATCH" in patch subject.
> Fix this limitation by refactoring and declaring this as global:
> - Refactor it by removing BUG_ON()
On Wed, 5 Feb 2025 at 03:26, Tamir Duberstein wrote:
>
> This is one of just 3 remaining "Test Module" kselftests (the others
> being bitmap and printf), the rest having been converted to KUnit. In
> addition to the enclosed patch, please consider this an RFC on the
> removal of the "Test Module"
On Thu, Feb 06, 2025 at 05:19:34PM -0800, Jay Vosburgh wrote:
> I think this now deserves some commentary in the code. Not
> because this function itself is unclear, but because there's the
> similarly-named slave_set_ns_maddr() (singular, not plural as in this
> patch) that will behave in a
Amit Shah writes:
>>
>>
>> Thanks all your help and comments during the guest_memfd upstream
>> calls,
>> and thanks for the help from AMD.
>>
>> Extending mmap() support from Fuad with 1G page support introduces
>> more
>> states that made it more complicated (at least for me).
>>
>> I'm mod
Hi Everyone,
This patch series fixes handling of module_kobject creation.
A driver expect module_kset list populated with its corresponding
module_kobject to create its /sys/module//drivers
directory.
Since,
[1] commit 96a1a2412acb ("kernel/params.c: defer most of param_sysfs_init() to
late_init
module_add_driver() relies on module_kset list for
/sys/module//drivers directory creation.
Since,
commit 96a1a2412acba ("kernel/params.c: defer most of param_sysfs_init() to
late_initcall time")
drivers which are initialized from subsys_initcall() or any other
higher precedence initcall couldn't
lookup_or_create_module_kobject() is static and marked as __init,
this is not ideal for global usage.
Fix this limitation by refactoring and declaring this as global:
- Refactor it by removing BUG_ON() and 'if else' construct by returning
early
- Remove static and __init markers from the func
Iterating through array of maps may encounter non existing keys. The
batch operation should not fail on when this happens.
Signed-off-by: Yan Zhai
---
.../bpf/map_tests/map_in_map_batch_ops.c | 62 +--
1 file changed, 44 insertions(+), 18 deletions(-)
diff --git a/tools/tes
The locate_module_kobject() function looks up an existing
module_kobject for a given module name. If it cannot find the
corresponding module_kobject, it creates one for the given name.
This commit renames locate_module_kobject() to
lookup_or_create_module_kobject() to better describe its operation
The generic_map_lookup_batch currently returns EINTR if it fails with
ENOENT and retries several times on bpf_map_copy_value. The next batch
would start from the same location, presuming it's a transient issue.
This is incorrect if a map can actually have "holes", i.e.
"get_next_key" can return a k
generic_map_lookup_batch
The generic_map_lookup_batch currently returns EINTR if it fails with
ENOENT and retries several times on bpf_map_copy_value. The next batch
would start from the same location, presuming it's a transient issue.
This is incorrect if a map can actually have "holes", i.e.
"ge
Hi Everyone,
On Wed, Feb 05, 2025 at 09:43:12AM +0100, Rasmus Villemoes wrote:
> On Mon, Feb 03 2025, Shyam Saini wrote:
>
> > Move the following to module.h to allow common usages:
> > - lookup_or_create_module_kobject()
> > - to_module_attr
> > - to_module_kobject
> >
> > This makes lookup_
On Wed, Jan 29, 2025 at 10:58:00AM -0400, Jason Gunthorpe wrote:
> On Wed, Jan 29, 2025 at 02:44:12PM +0100, Eric Auger wrote:
> > On 1/11/25 4:32 AM, Nicolin Chen wrote:
> > > For systems that require MSI pages to be mapped into the IOMMU translation
> > > the IOMMU driver provides an IOMMU_RESV_S
On Thu, Feb 6, 2025 at 2:20 AM Yan Zhai wrote:
>
> On Thu, Feb 6, 2025 at 12:40 AM Hou Tao wrote:
> >
> >
> >
> > Yes, the retry logic doesn't change the previous key. Thanks for the
> > clarifying.
> > > And by "skipping to the next key", it's simply
> > >
> > > if (err == -ENOENT)
> > >
Commit 918327e9b7ff ("ubsan: Remove CONFIG_UBSAN_SANITIZE_ALL")
removed the CONFIG_UBSAN_SANITIZE_ALL configuration option.
Eliminate invalid configurations to improve code readability.
Reviewed-by: Simon Horman
Signed-off-by: WangYuli
---
Changelog:
*v1->v2: Add Simon Horman's "Reviewed-by" ta
On Fri, Feb 7, 2025 at 10:31 AM Josh Poimboeuf wrote:
>
> On Mon, Jan 27, 2025 at 02:35:26PM +0800, Yafang Shao wrote:
> > The atomic replace livepatch mechanism was introduced to handle scenarios
> > where we want to unload a specific livepatch without unloading others.
> > However, its current i
Test that queues which are used for AF_XDP have the xsk nest attribute.
The attribute is currently empty, but its existence means the AF_XDP is
being used for the queue.
Signed-off-by: Joe Damato
Suggested-by: Jakub Kicinski
---
v3:
- Change comment style of helper C program to avoid kdoc wa
Greetings:
Welcome to v4. Small functional change, which makes the code cleaner
(see changelog) and tests pass on my machine with mlx5 and netdevsim.
This is an attempt to followup on something Jakub asked me about [1],
adding an xsk attribute to queues and more clearly documenting which
queues a
On Mon, Jan 27, 2025 at 02:35:26PM +0800, Yafang Shao wrote:
> The atomic replace livepatch mechanism was introduced to handle scenarios
> where we want to unload a specific livepatch without unloading others.
> However, its current implementation has significant shortcomings, making
> it less than
Hangbin Liu wrote:
>When validation on the backup slave is enabled, we need to validate the
>Neighbor Solicitation (NS) messages received on the backup slave. To
>receive these messages, the correct destination MAC address must be added
>to the slave. However, the target in bonding is a unicast a
On Thu, Feb 06, 2025 at 11:38:04AM +, Mark Brown wrote:
There are a number of architectures with shadow stack features which we are
presenting to userspace with as consistent an API as we can (though there
are some architecture specifics). Especially given that there are some
important consid
On Thu, 06 Feb 2025 16:41:19 +,
Ganapatrao Kulkarni wrote:
>
> This patch adds the required changes to init vcpu in vEL2 context.
> Also adds a KVM selftest to execute guest code as a guest hypervisor(L1).
>
> Signed-off-by: Ganapatrao Kulkarni
> ---
> tools/testing/selftests/kvm/Makefile.
From: Matti Lehtimäki
Support platforms such as MSM8226 and MSM8974 with only one power rail
(CX) modelled as power domain while MX and PX are regulators.
Signed-off-by: Matti Lehtimäki
[luca: reword commit message, expand based on feedback from
Stephan Gerhold]
Signed-off-by: Luca Weiss
---
From: Matti Lehtimäki
Both MSM8974 and MSM8226 have only CX as power domain with MX & PX being
handled as regulators. Handle this case by reodering pd_names to have CX
first, and handling that the driver core will already attach a single
power domain internally.
Signed-off-by: Matti Lehtimäki
[
Both MSM8974 and MSM8226 only model CX as power domain, leaving MX & PX
as regulators. Add some patches to support this use case.
Signed-off-by: Luca Weiss
---
Changes in v2:
- Narrow down dt-schema to only allow one of these three options:
- cx regulator + mx regulator (still deprecated)
On Wed, Feb 5, 2025 at 6:55 PM Yafang Shao wrote:
[...]
> > I think we should first understand why the trampoline is not
> > freed.
>
> IIUC, the fexit works as follows,
>
> bpf_trampoline
> + __bpf_tramp_enter
>+ percpu_ref_get(&tr->pcref);
>
> + call do_exit()
>
> + __bpf_t
On Thu, Feb 06, 2025 at 02:15:09AM -0800, Paul E. McKenney wrote:
> The WARN_ON_ONCE() in ct_kernel_exit_state() follows the call to
> ct_state_inc(), which means that RCU is not watching this WARN_ON_ONCE().
> This can (and does) result in extraneous lockdep warnings when this
> WARN_ON_ONCE() tri
Hou Tao writes:
> +cc Cody Haas
>
> Sorry for the resend. I sent the reply in the HTML format.
>
> On 2/4/2025 4:28 PM, Hou Tao wrote:
>> Currently, the update of existing element in hash map involves two
>> steps:
>> 1) insert the new element at the head of the hash list
>> 2) remove the old ele
On Thu, 06 Feb 2025 16:41:20 +,
Ganapatrao Kulkarni wrote:
>
> With NV2 enabled, some of the EL1/EL2/EL12 register accesses are
> transformed to memory accesses. This test code accesses all those
> registers in guest code to validate that they are not trapped to L0.
>
Traps to L0 are invisib
On 06-02-2025 10:11 pm, Ganapatrao Kulkarni wrote:
In this patch seried, modified kvm selftests code to enable
guest code to run in vEL2(As guest Hypervisor).
Also added test cases to test guest code booting in vEL2
and register access of VNCR mapped registers.
This patchset is created as per
With NV2 enabled, some of the EL1/EL2/EL12 register accesses are
transformed to memory accesses. This test code accesses all those
registers in guest code to validate that they are not trapped to L0.
Signed-off-by: Ganapatrao Kulkarni
---
tools/testing/selftests/kvm/Makefile.kvm | 1 +
..
This patch adds the required changes to init vcpu in vEL2 context.
Also adds a KVM selftest to execute guest code as a guest hypervisor(L1).
Signed-off-by: Ganapatrao Kulkarni
---
tools/testing/selftests/kvm/Makefile.kvm | 1 +
.../selftests/kvm/arm64/nv_guest_hypervisor.c | 83 +++
In this patch seried, modified kvm selftests code to enable
guest code to run in vEL2(As guest Hypervisor).
Also added test cases to test guest code booting in vEL2
and register access of VNCR mapped registers.
This patchset is created as per discussions over ml[1].
Posting RFC patch for the early
On 2/6/25 11:04 AM, Kirill A. Shutemov wrote:
> On Thu, Feb 06, 2025 at 09:59:58AM +0100, Eric Auger wrote:
>> Hi,
>>
>> On 2/4/25 12:46 PM, Eric Auger wrote:
>>> Hi,
>>>
>>> On 2/3/25 3:48 PM, Michael S. Tsirkin wrote:
On Fri, Jan 31, 2025 at 10:53:15AM +0100, Eric Auger wrote:
> Hi Ki
On Wed, Feb 05, 2025 at 02:11:50PM +0100, Peter Seiderer wrote:
> In hex32_arg() and num_arg() error out in case no characters are available
> (maxlen = 0).
>
> Signed-off-by: Peter Seiderer
Hi Peter,
This patch and the following could benefit from:
* A more succinct subject
* An explanation o
On Wed, Feb 05, 2025 at 02:11:49PM +0100, Peter Seiderer wrote:
> Honour the user given buffer size for the hex32_arg(), num_arg(),
> strn_len(), get_imix_entries() and get_labels() calls (otherwise they will
> access memory outside of the user given buffer).
>
> Signed-off-by: Peter Seiderer
> -
On Thu, Feb 6, 2025 at 4:27 AM Rasmus Villemoes
wrote:
>
> On Tue, 4 Feb 2025 at 20:36, Tamir Duberstein wrote:
> >
> > This is one of just 3 remaining "Test Module" kselftests (the others
> > being bitmap and scanf), the rest having been converted to KUnit.
> >
> > I tested this using:
> >
> > $
> After some debugging this is what I found:
>
> devtmpfsd() calls devtmpfs_work_loop() which is marked '__noreturn' and has an
> infinite loop. The compiler puts the `bl` to devtmpfs_work_loop() as the the
> last instruction in devtmpfsd() and therefore on entry to
> devtmpfs_work_loop(),
> LR p
On Wed, Feb 05, 2025 at 02:11:36PM +0100, Peter Seiderer wrote:
> hile taking a look at '[PATCH net] pktgen: Avoid out-of-range in
> get_imix_entries' ([1]) and '[PATCH net v2] pktgen: Avoid out-of-bounds access
> in get_imix_entries' ([2], [3]) and doing some tests and code review I
> detected tha
On Wed, Feb 05, 2025 at 02:11:45PM +0100, Peter Seiderer wrote:
> Align some variable declarations (in get_imix_entries and get_labels) to
> the most common pattern (int instead of ssize_t/long) and adjust function
> return value accordingly.
>
> Signed-off-by: Peter Seiderer
Hi Peter,
These co
On Wed, Feb 05, 2025 at 02:11:44PM +0100, Peter Seiderer wrote:
> Use defines for the various dec/hex number parsing digits lengths
> (hex32_arg/num_arg calls).
>
> Signed-off-by: Peter Seiderer
> ---
> Changes v3 -> v4
> - new patch (suggested by Simon Horman)
Reviewed-by: Simon Horman
On Wed, Feb 05, 2025 at 02:11:46PM +0100, Peter Seiderer wrote:
> Remove extra tmp variable in pktgen_if_write (re-use len instead).
>
> Signed-off-by: Peter Seiderer
Reviewed-by: Simon Horman
On Wed, Feb 05, 2025 at 02:11:47PM +0100, Peter Seiderer wrote:
> Remove some superfluous variable initializing before hex32_arg call (as the
> same init is done here already).
>
> Signed-off-by: Peter Seiderer
Reviewed-by: Simon Horman
On Wed, Feb 05, 2025 at 02:11:48PM +0100, Peter Seiderer wrote:
> Fix mpls maximum labels list parsing up to MAX_MPLS_LABELS/16 entries
> (instead of up to MAX_MPLS_LABELS - 1).
>
> Fixes:
"Fixes: " has a special meaning, it is recognised as a tag by tooling, and
implies a bug fix. Please consid
On Mon, 2025-02-03 at 08:35 +, Ackerley Tng wrote:
> Amit Shah writes:
>
> > Hey Ackerley,
>
> Hi Amit,
>
> > On Tue, 2024-09-10 at 23:43 +, Ackerley Tng wrote:
> > > Hello,
> > >
> > > This patchset is our exploration of how to support 1G pages in
> > > guest_memfd, and
> > > how the
The clone_args structure is extensible, with the syscall passing in the
length of the structure. Inside the kernel we use copy_struct_from_user()
to read the struct but this has the unfortunate side effect of silently
accepting some overrun in the structure size providing the extra data is
all zero
Add basic test coverage for specifying the shadow stack for a newly
created thread via clone3(), including coverage of the newly extended
argument structure. We check that a user specified shadow stack can be
provided, and that invalid combinations of parameters are rejected.
In order to facilita
In order to make it easier to add more configuration for the tests and
more support for runtime detection of when tests can be run pass the
structure describing the tests into test_clone3() rather than picking
the arguments out of it and have that function do all the per-test work.
No functional c
Unlike with the normal stack there is no API for configuring the shadow
stack for a new thread, instead the kernel will dynamically allocate a
new shadow stack with the same size as the normal stack. This appears to
be due to the shadow stack series having been in development since
before the more
Currently as a result of templating from x86 code gcs_alloc_thread_stack()
returns a pointer as an unsigned int however on arm64 we don't actually use
this pointer value as anything other than a pass/fail flag. Simplify the
interface to just return an int with 0 on success and a negative error code
Since there were widespread issues with output not being flushed the
kselftest framework was modified to explicitly set the output streams
unbuffered in commit 58e2847ad2e6 ("selftests: line buffer test
program's stdout") so there is no need to explicitly flush in the clone3
tests.
Reviewed-by: Ke
While almost all users of shadow stacks should be relying on the dynamic
linker and libc to enable the feature there are several low level test
programs where it is useful to enable without any libc support, allowing
testing without full system enablement. This low level testing is helpful
during b
There are a number of architectures with shadow stack features which we are
presenting to userspace with as consistent an API as we can (though there
are some architecture specifics). Especially given that there are some
important considerations for userspace code interacting directly with the
feat
The kernel has recently added support for shadow stacks, currently
x86 only using their CET feature but both arm64 and RISC-V have
equivalent features (GCS and Zicfiss respectively), I am actively
working on GCS[1]. With shadow stacks the hardware maintains an
additional stack containing only the
The WARN_ON_ONCE() in ct_kernel_exit_state() follows the call to
ct_state_inc(), which means that RCU is not watching this WARN_ON_ONCE().
This can (and does) result in extraneous lockdep warnings when this
WARN_ON_ONCE() triggers. These extraneous warnings are the opposite
of helpful.
Therefore,
On Thu, Feb 06, 2025 at 09:59:58AM +0100, Eric Auger wrote:
> Hi,
>
> On 2/4/25 12:46 PM, Eric Auger wrote:
> > Hi,
> >
> > On 2/3/25 3:48 PM, Michael S. Tsirkin wrote:
> >> On Fri, Jan 31, 2025 at 10:53:15AM +0100, Eric Auger wrote:
> >>> Hi Kirill, Michael
> >>>
> >>> On 8/8/24 9:51 AM, Kirill
The correct mac address for NS target 2001:db8::254 is 33:33:ff:00:02:54,
not 33:33:00:00:02:54. The same with client maddress.
Fixes: 86fb6173d11e ("selftests: bonding: add ns multicast group testing")
Signed-off-by: Hangbin Liu
---
tools/testing/selftests/drivers/net/bonding/bond_options.sh |
When validation on the backup slave is enabled, we need to validate the
Neighbor Solicitation (NS) messages received on the backup slave. To
receive these messages, the correct destination MAC address must be added
to the slave. However, the target in bonding is a unicast address, which
we cannot u
The mac address on backup slave should be convert from Solicited-Node
Multicast address, not from bonding unicast target address.
v2: fix patch 01's subject
Hangbin Liu (2):
bonding: fix incorrect MAC address setting to receive NS messages
selftests: bonding: fix incorrect mac address
drive
On Tue, 4 Feb 2025 at 20:36, Tamir Duberstein wrote:
>
> This is one of just 3 remaining "Test Module" kselftests (the others
> being bitmap and scanf), the rest having been converted to KUnit.
>
> I tested this using:
>
> $ tools/testing/kunit/kunit.py run --arch arm64 --make_options LLVM=1 print
Hi,
On 2/4/25 12:46 PM, Eric Auger wrote:
> Hi,
>
> On 2/3/25 3:48 PM, Michael S. Tsirkin wrote:
>> On Fri, Jan 31, 2025 at 10:53:15AM +0100, Eric Auger wrote:
>>> Hi Kirill, Michael
>>>
>>> On 8/8/24 9:51 AM, Kirill A. Shutemov wrote:
Hongyu reported a hang on kexec in a VM. QEMU reported i
On Thu, Feb 6, 2025 at 12:40 AM Hou Tao wrote:
>
> Hi,
>
> On 2/6/2025 12:57 AM, Yan Zhai wrote:
> > The generic_map_lookup_batch currently returns EINTR if it fails with
> > ENOENT and retries several times on bpf_map_copy_value. The next batch
> > would start from the same location, presuming it
On Tue, 4 Feb 2025 22:14:10 -0500 Zi Yan wrote:
> This patchset adds a new buddy allocator like (or non-uniform) large folio
> split to reduce the total number of after-split folios, the amount of memory
> needed for multi-index xarray split, and keep more large folios after a split.
It would b
64 matches
Mail list logo