On Fri, 1 Nov 2024 06:14:14 -0700 Mina Almasry wrote:
> But what is the 'missing input validation'? Do you mean the input
> validation for the SO_DEVMEM_DONTNEED API? That should be handled in
> the patch "net: fix SO_DEVMEM_DONTNEED looping too long" in this
> series, unless I missed something.
The pull request you sent on Fri, 1 Nov 2024 16:25:59 -0600:
> git://git.kernel.org/pub/scm/linux/kernel/git/shuah/linux-kselftest
> tags/linux_kselftest-fixes-6.12-rc6
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/11066801dd4b7c4d75fce65c812723a80c1481ae
Thank you!
Add an epoll busy poll test using netdevsim.
This test is comprised of:
- busy_poller (via busy_poller.c)
- busy_poll_test.sh which loads netdevsim, sets up network namespaces,
and runs busy_poller to receive data and netcat to send data.
The selftest tests two different scenarios:
- bu
syzbot has found a reproducer for the following issue on:
HEAD commit:6c52d4da1c74 Merge tag 'for-linus' of git://git.kernel.org..
git tree: upstream
console+strace: https://syzkaller.appspot.com/x/log.txt?x=1288963058
kernel config: https://syzkaller.appspot.com/x/.config?x=672325e
On Fri, Nov 01, 2024 at 11:12:06PM +0100, Miguel Ojeda wrote:
> On Fri, Nov 1, 2024 at 10:38 PM Boqun Feng wrote:
> >
> > but this lint doesn't make sense to me, I would say we just drop this
> > lint?
>
> I am not sure if it is intended to fire there (i.e. to resolve
> constants), but seems OK s
On Fri, 2024-11-01 at 12:30 +, Mark Brown wrote:
> > Where can I find this base commit?
>
> Ah, that's still my branch from when I posted what's now applied in the
> arm64 tree, this is the same code:
>
> https://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git for-
> next/gcs
>
>
Hi Linus,
Please pull the following kselftest fixes update for Linux 6.12-rc6.
Kselftest fixes for Linux 6.12-rc6
- fix syntax error in frequency calculation arithmetic expression in
intel_pstate run.sh
- add missing cpupower dependency check intel_pstate run.sh
- fix idmap_mount_tree_invalid
On Fri, Nov 1, 2024 at 10:38 PM Boqun Feng wrote:
>
> but this lint doesn't make sense to me, I would say we just drop this
> lint?
I am not sure if it is intended to fire there (i.e. to resolve
constants), but seems OK since it is not something one would want
normally to write except in exceptio
On Fri, Nov 01, 2024 at 11:31:48AM -0300, Pedro Tammela wrote:
> Add 3 tests to check for the expected behaviour of
> qdisc_tree_reduce_backlog in special scenarios.
>
> - The first test checks if the qdisc class is notified of deletion for
> major handle ':'.
> - The second test checks the sa
On Fri, Nov 01, 2024 at 02:45:02PM +0800, David Gow wrote:
[...]
> +/// ```
> +/// // Import our mock naming it as the real module.
> +/// #[cfg(CONFIG_KUNIT)]
> +/// use bindings_mock_example as bindings;
> +///
> +/// // This module mocks `bindings`.
> +/// mod bindings_mock_example {
> +///
On Thu, Oct 31, 2024 at 01:00:28PM -0700, Matthew Maurer wrote:
> > The question is, if only extended moversions are used, what new tooling
> > requirements are there? Can you test using only extended modversions?
> >
> > Luis
>
> I'm not sure precisely what you're asking for. Do you want:
> 1.
On Fri, Nov 01, 2024 at 02:45:00PM +0800, David Gow wrote:
> From: José Expósito
>
> Add a couple of Rust const functions and macros to allow to develop
> KUnit tests without relying on generated C code:
>
> - The `kunit_unsafe_test_suite!` Rust macro is similar to the
>`kunit_test_suite` C
On Fri, Nov 01, 2024 at 06:34:26AM -0700, Jakub Kicinski wrote:
> On Fri, 1 Nov 2024 00:48:33 + Joe Damato wrote:
> > + ip netns exec nscl nc -N 192.168.1.1 48675 < $tmp_file
>
> Thanks a lot for adding the test.
Thanks for the review.
> Could you replace nc with socat or
> a similar tool
On Fri, 1 Nov 2024 19:15:57 +0500 Muhammad Usama Anjum
wrote:
> The test should be skipped if initial conditions aren't fulfilled in
> the start instead of failing and outputting non-compliant TAP logs. This
> kind of failure pollutes the results. The initial conditions are:
> - The test should
On 11/1/2024 10:03 AM, Krzysztof Kozlowski wrote:
Document compatible for Qualcomm SM8750 SoC ADSP PAS which looks fully
compatible with SM8550 variant. The only difference from bindings point
of view is one more interrupt ("shutdown-ack"). Marking devices as
compatible, using SM8550 ADSP PA
On Mon, 28 Oct 2024 20:22:31 +, Mark Brown wrote:
> The test for SVE_B16B16 had a cut'n'paste of a SME instruction, fix it with
> a relevant SVE instruction.
>
>
Applied to arm64 (for-next/kselftest), thanks!
[1/1] kselftest/arm64: Fix encoding for SVE B16B16 test
https://git.kernel.o
On Thu, Oct 31, 2024 at 07:25:02PM +, Mark Brown wrote:
> Currently as a result of templating from x86 code gcs_alloc_thread_stack()
> returns a pointer as an unsigned int however on arm64 we don't actually use
> this pointer value as anything other than a pass/fail flag. Simplify the
> interfa
On Tue, 29 Oct 2024 12:34:21 +, Mark Brown wrote:
> The logging in the allocation helpers variously uses ksft_print_msg() with
> very intermittent logging of errno and perror() (which won't produce KTAP
> conformant output) when logging the result of API calls that set errno.
> Standardise on u
On Fri, Nov 1, 2024 at 2:55 PM Luis Chamberlain wrote:
>
> On Wed, Oct 30, 2024 at 05:16:34PM +, Matthew Maurer wrote:
> > This script has been broken for 5 years with no user complaints.
> >
> > It first had its .mod.c parser broken in commit a3d0cb04f7df ("modpost:
> > use __section in the o
Document compatible for Qualcomm SM8750 SoC ADSP PAS which looks fully
compatible with SM8550 variant. The only difference from bindings point
of view is one more interrupt ("shutdown-ack"). Marking devices as
compatible, using SM8550 ADSP PAS fallback, requires changing some of
the conditionals
On 2024-11-01 10:49:36-0400, Tamir Duberstein wrote:
> On Fri, Nov 1, 2024, 09:52 Alyssa Ross wrote:
> >
> > On Fri, Oct 25, 2024 at 05:03:54PM -0400, Tamir Duberstein wrote:
> > > @@ -124,6 +125,29 @@ class
> > > LinuxSourceTreeOperationsQemu(LinuxSourceTreeOperations):
> > >
Hi,
I just ran into a NULL-deref in a qrts/mhi path during boot of the
x1e80100 CRD for the second time.
First time was with a 6.11 kernel (but I never got around to reporting
it) and today it happened again with 6.12-rc5.
Both times I was using the in-kernel pd-mapper, which has exposed a
numbe
On Fri, Nov 1, 2024, 09:52 Alyssa Ross wrote:
>
> On Fri, Oct 25, 2024 at 05:03:54PM -0400, Tamir Duberstein wrote:
> > @@ -124,6 +125,29 @@ class
> > LinuxSourceTreeOperationsQemu(LinuxSourceTreeOperations):
> > '-no-reboot',
> > '-nogr
On Fri, Nov 1, 2024 at 7:03 AM Boqun Feng wrote:
>
> This time, I try implementing a generic atomic type `Atomic`, since
> Benno and Gary suggested last time, and also Rust standard library is
> also going to that direction [1].
I would like to thank Boqun for trying out this approach, even when
Add 3 tests to check for the expected behaviour of
qdisc_tree_reduce_backlog in special scenarios.
- The first test checks if the qdisc class is notified of deletion for
major handle ':'.
- The second test checks the same as the first test but with ':' as the root
qdisc.
- The third test c
The test should be skipped if initial conditions aren't fulfilled in
the start instead of failing and outputting non-compliant TAP logs. This
kind of failure pollutes the results. The initial conditions are:
- The test should only execute if /tmp file can be allocated.
- The test should only execut
On Fri, Nov 01, 2024 at 07:41:27AM +, Cheng-Jui Wang (王正睿) wrote:
> On Wed, 2024-10-30 at 06:54 -0700, Paul E. McKenney wrote:
> > > > Alternatively, arm64 could continue using
> > > > nmi_trigger_cpumask_backtrace()
> > > > with normal interrupts (for example, on SoCs not implementing true
>
On Fri, Oct 25, 2024 at 05:03:54PM -0400, Tamir Duberstein wrote:
> @@ -124,6 +125,29 @@ class
> LinuxSourceTreeOperationsQemu(LinuxSourceTreeOperations):
> '-no-reboot',
> '-nographic',
> '-serial', self._se
On Fri, Nov 01, 2024 at 01:44:15AM +, Cheng-Jui Wang (王正睿) wrote:
> On Thu, 2024-10-31 at 14:27 -0700, Doug Anderson wrote:
> > Hi,
> >
> > On Wed, Oct 30, 2024 at 10:03 PM Paul E. McKenney
> > wrote:
> > >
> > > > > > Note that:
> > > > > >
> > > > > > * Switching to real NMIs is impossib
On Fri, Nov 01, 2024 at 12:15:25PM +0100, Mirsad Todorovac wrote:
> Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition
> to improve the code readability:
>
> ./tools/testing/selftests/mm/uffd-unit-tests.c:1484:32-33: WARNING: Use
> ARRAY_SIZE
> ./tools/testing/selftest
On Fri, 1 Nov 2024 00:48:33 + Joe Damato wrote:
> + ip netns exec nscl nc -N 192.168.1.1 48675 < $tmp_file
Thanks a lot for adding the test. Could you replace nc with socat or
a similar tool? There are multiple incompatible implementations of
netcat packaged by various distros, we get:
#
On Thu, Oct 31, 2024 at 7:42 PM Jakub Kicinski wrote:
>
> On Tue, 29 Oct 2024 20:55:20 + Mina Almasry wrote:
> > A few unrelated devmem TCP fixes bundled in a series for some
> > convenience (if that's ok).
>
> These two should go to net I presume? It's missing input validation.
>
> Either way
On Fri, Nov 1, 2024 at 4:14 AM Yunsheng Lin wrote:
>
> On 2024/10/30 4:45, Mina Almasry wrote:
> > Create page_pool_alloc_netmem to be the mirror of page_pool_alloc.
> >
> > This enables drivers that want currently use page_pool_alloc to
> > transition to netmem by converting the call sites to
> >
On Thu, Oct 31, 2024 at 09:06:09PM +, Edgecombe, Rick P wrote:
> On Thu, 2024-10-31 at 19:25 +, Mark Brown wrote:
> > base-commit: d17cd7b7cc92d37ee8b2df8f975fc859a261f4dc
> Where can I find this base commit?
Ah, that's still my branch from when I posted what's now applied in the
arm64 t
On Fri, Nov 01, 2024 at 03:54:58PM +0800, Chen-Yu Tsai wrote:
> On Sat, Oct 26, 2024 at 5:16 AM Nícolas F. R. A. Prado
> wrote:
> >
> > Currently the set_config callback in the gpio_chip registered by the
> > pinctrl-mtk-common driver only supports configuring a single parameter
> > on specific pi
y(mapping) || wbc->sync_mode != WB_SYNC_ALL)
---
base-commit: 81983758430957d9a5cbfe324fd70cf63e7e
change-id: 20241101-dax-page-size-83a1073b4e1b
Cheers,
~~ Lina
On 11/1/24 4:15 PM, Mirsad Todorovac wrote:
> Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition
> to improve the code readability:
>
> ./tools/testing/selftests/x86/syscall_numbering.c:316:35-36: WARNING: Use
> ARRAY_SIZE
>
> Fixes: 15c82d98a0f78 ("selftests/x86/sysc
Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition
to improve the code readability:
./tools/testing/selftests/x86/syscall_numbering.c:316:35-36: WARNING: Use
ARRAY_SIZE
Fixes: 15c82d98a0f78 ("selftests/x86/syscall: Update and extend
syscall_numbering_64")
Cc: Thomas
Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition
to improve the code readability:
./tools/testing/selftests/mm/uffd-unit-tests.c:1484:32-33: WARNING: Use
ARRAY_SIZE
./tools/testing/selftests/mm/uffd-unit-tests.c:1485:30-31: WARNING: Use
ARRAY_SIZE
Fixes: 16a45b57cb
On 2024/10/30 4:45, Mina Almasry wrote:
> Create page_pool_alloc_netmem to be the mirror of page_pool_alloc.
>
> This enables drivers that want currently use page_pool_alloc to
> transition to netmem by converting the call sites to
> page_pool_alloc_netmem.
For old API, page_pool_alloc_pages() al
Hi Ricardo, André,
On Wed, Oct 30, 2024 at 12:25:25PM +0100, Ricardo Ribalda Delgado wrote:
> Hi Andre
>
> On Mon, Oct 21, 2024 at 12:14 AM André Apitzsch via B4 Relay
> wrote:
> >
> > From: André Apitzsch
> >
> > The driver defines IMX214_DEFAULT_LINK_FREQ 48000, and then
> > IMX214_DEFAUL
On Sat, Oct 26, 2024 at 5:16 AM Nícolas F. R. A. Prado
wrote:
>
> Currently the set_config callback in the gpio_chip registered by the
> pinctrl-mtk-common driver only supports configuring a single parameter
> on specific pins (the input debounce of the EINT controller, on pins
> that support it),
On Sat, Oct 26, 2024 at 4:14 AM Nícolas F. R. A. Prado
wrote:
>
> Currently the set_config callback in the gpio_chip registered by the
> pinctrl_moore driver only supports configuring a single parameter on
> specific pins (the input debounce of the EINT controller, on pins that
> support it), even
On Sat, Oct 26, 2024 at 4:06 AM Nícolas F. R. A. Prado
wrote:
>
> Currently the set_config callback in the gpio_chip registered by the
> pinctrl_paris driver only supports configuring a single parameter on
> specific pins (the input debounce of the EINT controller, on pins that
> support it), even
On Wed, 2024-10-30 at 06:54 -0700, Paul E. McKenney wrote:
> > > Alternatively, arm64 could continue using nmi_trigger_cpumask_backtrace()
> > > with normal interrupts (for example, on SoCs not implementing true NMIs),
> > > but have a short timeout (maybe a few jiffies?) after which its returns
>
On Fri, Nov 01, 2024 at 02:55:23PM +0800, David Gow wrote:
> On Fri, 1 Nov 2024 at 14:07, Boqun Feng wrote:
> >
> > Memory barriers are building blocks for concurrent code, hence provide
> > a minimal set of them.
> >
> > The compiler barrier, barrier(), is implemented in inline asm instead of
> >
Memory barriers are building blocks for concurrent code, hence provide
a minimal set of them.
The compiler barrier, barrier(), is implemented in inline asm instead of
using core::sync::atomic::compiler_fence() because memory models are
different: kernel's atomics are implemented in inline asm ther
47 matches
Mail list logo