[PATCH] rpmsg: glink: use only lower 16-bits of param2 for CMD_OPEN name length

2024-10-06 Thread Jonathan Marek
The name len field of the CMD_OPEN packet is only 16-bits and the upper 16-bits of "param2" are a different field, which can be nonzero in certain situations, and CMD_OPEN packets can be unexpectedly dropped because of this. Fix this by masking out the upper 16 bits of param2. (the commit in this

Re: [PATCH v6 1/2] selftests: Rename sigaltstack to generic signal

2024-10-06 Thread Dev Jain
On 9/16/24 09:28, Dev Jain wrote: On 9/9/24 23:24, Shuah Khan wrote: On 9/8/24 23:16, Dev Jain wrote: On 9/7/24 01:29, Shuah Khan wrote: On 9/4/24 23:56, Dev Jain wrote: On 9/4/24 22:35, Shuah Khan wrote: On 9/3/24 22:52, Dev Jain wrote: On 9/4/24 03:14, Shuah Khan wrote: On 8/30/24

Re: [PATCH bpf v5 2/2] selftests/bpf: fix perf_event link info name_len assertion

2024-10-06 Thread Yafang Shao
On Mon, Oct 7, 2024 at 3:51 AM tyrone-wu wrote: > > Fix `name_len` field assertions in `bpf_link_info.perf_event` for > kprobe/uprobe/tracepoint to validate correct name size instead of 0. > > Link: > https://lore.kernel.org/bpf/cabvu1kxwqxhqqge0rtrr7eegtm6svw_kayzby16-yb0snzt...@mail.gmail.com/

Re: [PATCH bpf v5 1/2] bpf: fix unpopulated name_len field in perf_event link info

2024-10-06 Thread Yafang Shao
On Mon, Oct 7, 2024 at 3:51 AM tyrone-wu wrote: > > Previously when retrieving `bpf_link_info.perf_event` for > kprobe/uprobe/tracepoint, the `name_len` field was not populated by the > kernel, leaving it to reflect the value initially set by the user. This > behavior was inconsistent with how oth

Re: [PATCH 09/13] media: i2c: imx214: Extract format and crop settings

2024-10-06 Thread André
Hi Ricardo, Am Donnerstag, dem 12.09.2024 um 15:40 +0200 schrieb Ricardo Ribalda Delgado: > On Mon, Sep 2, 2024 at 11:54 PM André Apitzsch via B4 Relay > wrote: > > > > From: André Apitzsch > > > > Remove format and crop settings from register sequences and set > > them > > programmatically. >

Re: [PATCH 08/13] media: i2c: imx214: Add vblank and hblank controls

2024-10-06 Thread André
Hi Dave, Am Freitag, dem 13.09.2024 um 18:40 +0100 schrieb Dave Stevenson: > On Thu, 12 Sept 2024 at 15:51, Dave Stevenson > wrote: > > > > Hi André & Ricardo > > > > On Thu, 12 Sept 2024 at 14:41, Ricardo Ribalda Delgado > > wrote: > > > > > > Hi > > > > > > Arent you missing some chage in

Re: [RFC PATCH v2 2/4] Documentation: RCU: Refer to ptr_eq()

2024-10-06 Thread Paul E. McKenney
On Sun, Oct 06, 2024 at 07:52:49PM +, David Laight wrote: > From: Mathieu Desnoyers > > Sent: 04 October 2024 19:28 > > > > Refer to ptr_eq() in the rcu_dereference() documentation. > > > > ptr_eq() is a mechanism that preserves address dependencies when > > comparing pointers, and should be

Re: [PATCH] arm64: dts: qcom: sm6350: Fix GPU frequencies missing on some speedbins

2024-10-06 Thread Dmitry Baryshkov
On Wed, Oct 02, 2024 at 02:58:06PM GMT, Luca Weiss wrote: > Make sure the GPU frequencies are marked as supported for the respective > speedbins according to downstream msm-4.19 kernel: > > * 850 MHz: Speedbins 0 + 180 > * 800 MHz: Speedbins 0 + 180 + 169 > * 650 MHz: Speedbins 0 + 180 + 169 + 138

Re: [PATCH] arm64: dts: qcom: qcm6490-fairphone-fp5: Add thermistor for UFS/RAM

2024-10-06 Thread Dmitry Baryshkov
On Wed, Oct 02, 2024 at 03:01:08PM GMT, Luca Weiss wrote: > Configure the ADC and thermal zone for the thermistor next to the > UFS+RAM chip which is connected to GPIO_12 of PM7250B. It is used to > measure the temperature of that area of the PCB. > > Signed-off-by: Luca Weiss > --- > arch/arm64

RE: [RFC PATCH v2 2/4] Documentation: RCU: Refer to ptr_eq()

2024-10-06 Thread David Laight
From: Mathieu Desnoyers > Sent: 04 October 2024 19:28 > > Refer to ptr_eq() in the rcu_dereference() documentation. > > ptr_eq() is a mechanism that preserves address dependencies when > comparing pointers, and should be favored when comparing a pointer > obtained from rcu_dereference() against a

[PATCH bpf v5 2/2] selftests/bpf: fix perf_event link info name_len assertion

2024-10-06 Thread tyrone-wu
Fix `name_len` field assertions in `bpf_link_info.perf_event` for kprobe/uprobe/tracepoint to validate correct name size instead of 0. Link: https://lore.kernel.org/bpf/cabvu1kxwqxhqqge0rtrr7eegtm6svw_kayzby16-yb0snzt...@mail.gmail.com/ Fixes: 23cf7aa539dc ("selftests/bpf: Add selftest for fill_l

[PATCH bpf v5 1/2] bpf: fix unpopulated name_len field in perf_event link info

2024-10-06 Thread tyrone-wu
Previously when retrieving `bpf_link_info.perf_event` for kprobe/uprobe/tracepoint, the `name_len` field was not populated by the kernel, leaving it to reflect the value initially set by the user. This behavior was inconsistent with how other input/output string buffer fields function (e.g. `raw_tr

Re: [PATCH 1/6] dt-bindings: remoteproc: qcom,pas-common: Introduce iommus and qcom,devmem property

2024-10-06 Thread Dmitry Baryshkov
On Sat, Oct 05, 2024 at 02:53:54AM GMT, Mukesh Ojha wrote: > From: Shiraz Hashim > > Qualcomm’s PAS implementation for remote processors only supports a > single stage of IOMMU translation and is presently managed by the > Qualcomm EL2 hypervisor (QHEE) if it is present. In the absence of QHEE, >

Re: [PATCH 0/6] Peripheral Image Loader support for Qualcomm SoCs

2024-10-06 Thread Dmitry Baryshkov
On Sat, Oct 05, 2024 at 02:53:53AM GMT, Mukesh Ojha wrote: > Qualcomm is looking to enable remote processors on the SA8775p SoC > running KVM Linux host and is currently trying to figure out an > upstream-compatible solution for the IOMMU translation scheme problem it > is facing when SoCs running

Re: [PATCH 1/2] selftests/mm: replace atomic_bool with pthread_barrier_t

2024-10-06 Thread Muhammad Usama Anjum
On 10/4/24 2:17 AM, Edward Liaw wrote: > Swaps synchronization primitive with pthread_barrier, so that > stdatomic.h does not need to be included. > > The synchronization is needed on Android ARM64; we see a deadlock with > pthread_create when the parent thread races forward before the child has >

Re: [PATCH] selftests: make kselftest-clean remove libynl outputs

2024-10-06 Thread Muhammad Usama Anjum
On 10/6/24 2:56 AM, Greg Thelen wrote: > Starting with 6.12 commit 85585b4bc8d8 ("selftests: add ncdevmem, netcat > for devmem TCP") kselftest-all creates additional outputs that > kselftest-clean does not cleanup: > $ make defconfig > $ make kselftest-all > $ make kselftest-clean > $ git c

Re: [PATCH v3 01/20] scripts: import more list macros

2024-10-06 Thread Masahiro Yamada
On Tue, Sep 24, 2024 at 3:19 AM Sami Tolvanen wrote: > > Import list_is_first, list_is_last, list_replace, and list_replace_init. > > Signed-off-by: Sami Tolvanen This one was applied to linux-kbuild. Thanks. > --- > scripts/include/list.h | 50 ++ > 1

Re: [PATCH V3 1/1] livepatch: Add "stack_order" sysfs attribute

2024-10-06 Thread zhang warden
> On Oct 3, 2024, at 23:25, Josh Poimboeuf wrote: > > On Thu, Oct 03, 2024 at 10:59:11PM +0800, zhang warden wrote: >>> This attribute specifies the sequence in which live patch modules >>> are applied to the system. If multiple live patches modify the same >>> function, the implementation wit

[PATCH net-next v7] ptp: Add support for the AMZNC10C 'vmclock' device

2024-10-06 Thread David Woodhouse
From: David Woodhouse The vmclock device addresses the problem of live migration with precision clocks. The tolerances of a hardware counter (e.g. TSC) are typically around ±50PPM. A guest will use NTP/PTP/PPS to discipline that counter against an external source of 'real' time, and track the pre