Hi All,
On 22/08/24 21:47, Mathieu Poirier wrote:
Hi Baolu,
Sorry for the late reply, this slipped through the cracks.
On Mon, Aug 12, 2024 at 03:28:11PM +0800, Lu Baolu wrote:
> An iommu domain is allocated in rproc_enable_iommu() and is attached to
> rproc->dev.parent in the same function.
>
On Thu, Aug 29, 2024 at 12:49:24PM +0800, Jason Wang wrote:
> On Thu, Aug 29, 2024 at 2:16 AM Carlos Bilbao
> wrote:
> >
> > From: Carlos Bilbao
> >
> > mlx5_vdpa vDPA devices currently don't support reporting or setting the
> > speed and duplex and hence should be UNKNOWN instead of zero.
> >
>
On Tue, Aug 20, 2024 at 02:42:31PM GMT, Gokul Sriram Palanisamy wrote:
> From: Vignesh Viswanathan
>
> q6v5 fatal and watchdog IRQ handlers always retrieves the crash reason
> information from SMEM global partition (QCOM_SMEM_HOST_ANY).
>
> For some targets like IPQ9574 and IPQ5332, crash reason
On Thu, Aug 29, 2024 at 2:16 AM Carlos Bilbao
wrote:
>
> From: Carlos Bilbao
>
> mlx5_vdpa vDPA devices currently don't support reporting or setting the
> speed and duplex and hence should be UNKNOWN instead of zero.
>
> Signed-off-by: Carlos Bilbao
> ---
> drivers/vdpa/mlx5/net/mlx5_vnet.c |
From: Chi Zhiling
We found a null pointer accessing in tracefs[1], the reason is that
the variable 'ei_child' is set to LIST_POISON1, that means the list
was removed in eventfs_remove_rec. so when access the ei_child->is_freed,
the panic triggered.
the linked list is protected by eventfs_mutex i
When current node doesn't have a EPC section configured by firmware and
all other EPC sections memory are used up, CPU can stuck inside the
while loop in __sgx_alloc_epc_page() forever and soft lockup will happen.
Note how nid_of_current will never equal to nid in that while loop because
nid_of_cur
Huacai,
On 2024/8/28 下午10:27, Huacai Chen wrote:
Hi, Bibo,
On Fri, Aug 23, 2024 at 2:39 PM Bibo Mao wrote:
Interrupts can be routed to maximal four virtual CPUs with one HW
EIOINTC interrupt controller model, since interrupt routing is encoded with
CPU bitmap and EIOINTC node combined method
On Wed, Aug 28, 2024 at 02:35:29PM +0200, Petr Pavlu wrote:
> On 8/15/24 19:39, Sami Tolvanen wrote:
> > diff --git a/scripts/gendwarfksyms/dwarf.c b/scripts/gendwarfksyms/dwarf.c
> > index 65a29d0bd8f4..71cfab0553da 100644
> > --- a/scripts/gendwarfksyms/dwarf.c
> > +++ b/scripts/gendwarfksyms/dwa
Hi Masahiro,
On Wed, Aug 28, 2024 at 04:04:09PM +0900, Masahiro Yamada wrote:
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> >
> > The first 16 patches of this series add a small tool for computing
>
>
> Splitting a new tool into small chunks makes line-by-line review difficult.
I sp
On Thu, Aug 29, 2024 at 03:15:02AM +0900, Masahiro Yamada wrote:
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> > +static int append_item(struct die *cd, struct die_fragment **res)
> > +{
> > + struct die_fragment *prev;
> > + struct die_fragment *df;
> > +
> > + df = m
On Wed, Aug 28, 2024 at 02:46:03PM +0200, Petr Pavlu wrote:
> > +static int process_fmt(struct state *state, const char *fmt, ...)
>
> Nit: The state parameter is unused by a number of these process_*()
> functions, including the leaf process(). I suggest removing it so it
> doesn't need to be pas
On Wed, Aug 28, 2024 at 04:15:03PM +0900, Masahiro Yamada wrote:
> On Wed, Aug 28, 2024 at 3:50 PM Masahiro Yamada wrote:
> >
> > On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen
> > wrote:
> > >
> > > The compiler may choose not to emit type information in DWARF for
> > > external symbols. Clang,
On Thu, Aug 29, 2024 at 03:22:25AM +0900, Masahiro Yamada wrote:
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> > int symbol_read_exports(FILE *file)
> > @@ -57,13 +93,14 @@ int symbol_read_exports(FILE *file)
> > if (is_exported(name))
> > contin
On Thu, Aug 29, 2024 at 03:16:21AM +0900, Masahiro Yamada wrote:
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> > @@ -105,6 +105,8 @@ int main(int argc, const char **argv)
> > if (parse_options(argc, argv) < 0)
> > return usage();
> >
> > + check(symbol_read
Hi Masahiro,
On Thu, Aug 29, 2024 at 02:45:03AM +0900, Masahiro Yamada wrote:
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> > +static int usage(void)
> > +{
> > + error("usage: gendwarfksyms [options] elf-object-file ...");
>
>
>
> Description for each option, please.
Sure, w
On Wed, Aug 28, 2024 at 02:31:05PM +0200, Petr Pavlu wrote:
> On 8/26/24 20:47, Sami Tolvanen wrote:
> > How do you propose using the function? This loop goes through multiple
> > input files, should we need them, and we iterate through all the CUs
> > in process_modules.
>
> I was thinking it cou
On Tue, Aug 20, 2024 at 11:39:43AM GMT, Gokul Sriram Palanisamy wrote:
> From: Vignesh Viswanathan
>
> Currently the SSR subdevice notifies the client driver on crash of the
> rproc from the recovery workqueue using the BEFORE_SHUTDOWN event.
> However, the client driver might be interested to kn
On 8/27/24 05:30, Lukas Hruska wrote:
> From: Josh Poimboeuf
>
> Add a new livepatch sample in samples/livepatch/ to make use of symbols
> that must be post-processed to enable load-time relocation resolution.
> As the new sample is to be used as an example, it is annotated with
> KLP_RELOC_SYMBO
On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
>
> The compiler may choose not to emit type information in DWARF for all
> aliases, but it's possible for each alias to be exported separately.
> To ensure we find type information for the aliases as well, read
> {section, address} tuples from
On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
>
> Add support for passing a list of exported symbols to gendwarfksyms
> via stdin and filter out non-exported symbols from the output.
>
> Signed-off-by: Sami Tolvanen
> ---
> scripts/gendwarfksyms/Makefile| 1 +
> scripts/gendwarfk
From: Carlos Bilbao
mlx5_vdpa vDPA devices currently don't support reporting or setting the
speed and duplex and hence should be UNKNOWN instead of zero.
Signed-off-by: Carlos Bilbao
---
drivers/vdpa/mlx5/net/mlx5_vnet.c | 7 +++
drivers/vdpa/vdpa.c | 23
On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
>
> Basic types in DWARF repeat frequently and traversing the DIEs using
> libdw is relatively slow. Add a simple hashtable based cache for the
> processed DIEs.
>
> Signed-off-by: Sami Tolvanen
> ---
> scripts/gendwarfksyms/Makefile|
On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
>
> Add a basic DWARF parser, which uses libdw to traverse the debugging
> information in an object file and looks for functions and variables.
> In follow-up patches, this will be expanded to produce symbol versions
> for CONFIG_MODVERSIONS fro
Hello,
On 8/27/24 11:54 AM, Dragos Tatulea wrote:
>
> On 27.08.24 04:03, Jason Wang wrote:
>> On Tue, Aug 27, 2024 at 12:11 AM Dragos Tatulea wrote:
>>>
>>> On 26.08.24 16:24, Andrew Lunn wrote:
On Mon, Aug 26, 2024 at 11:06:09AM +0200, Dragos Tatulea wrote:
>
> On 23.08.24 18:54, Ca
On Thu, Aug 22, 2024 at 10:52:40AM +0530, Beleswar Prasad Padhi wrote:
>
> On 21-08-2024 23:40, Jan Kiszka wrote:
> > On 21.08.24 07:30, Beleswar Prasad Padhi wrote:
> > > On 19-08-2024 20:54, Jan Kiszka wrote:
> > > > From: Jan Kiszka
> > > >
> > > > By simply bailing out, the driver was violat
Handle the case where the meta-page content is bigger than the system
page-size. This prepares the ground for extending features covered by
the meta-page.
Signed-off-by: Vincent Donnefort
diff --git a/tools/testing/selftests/ring-buffer/map_test.c
b/tools/testing/selftests/ring-buffer/map_test.
Improve the ring-buffer meta-page test coverage by checking for the
entire padding region to be 0 instead of just looking at the first 4
bytes.
Signed-off-by: Vincent Donnefort
--
Hi,
I saw you have sent "Align meta-page to sub-buffers for improved TLB usage" to
linux-next, so here's a follow-
Hello,
On 8/26/24 9:07 PM, Jason Wang wrote:
> On Tue, Aug 27, 2024 at 3:23 AM Carlos Bilbao
> wrote:
>> Hello,
>>
>> On 8/26/24 10:53 AM, Dragos Tatulea wrote:
>>> On 26.08.24 16:26, Carlos Bilbao wrote:
Hello Dragos,
On 8/26/24 4:06 AM, Dragos Tatulea wrote:
> On 23.08.24 18
Convert the definition of the system call enter/exit tracepoints to
faultable tracepoints now that all upstream tracers handle it.
This allows tracers to fault-in userspace system call arguments such as
path strings within their probe callbacks.
Link:
https://lore.kernel.org/lkml/20231002202531.
In preparation for converting system call enter/exit instrumentation
into faultable tracepoints, make sure that perf can handle registering
to such tracepoints by explicitly disabling preemption within the perf
tracepoint probes to respect the current expectations within perf ring
buffer code.
Thi
In preparation for converting system call enter/exit instrumentation
into faultable tracepoints, make sure that bpf can handle registering to
such tracepoints by explicitly disabling preemption within the bpf
tracepoint probes to respect the current expectations within bpf tracing
code.
This chang
In preparation for converting system call enter/exit instrumentation
into faultable tracepoints, make sure that ftrace can handle registering
to such tracepoints by explicitly disabling preemption within the ftrace
tracepoint probes to respect the current expectations within ftrace ring
buffer code
When invoked from system call enter/exit instrumentation, accessing
user-space data is a common use-case for tracers. However, tracepoints
currently disable preemption around iteration on the registered
tracepoint probes and invocation of the probe callbacks, which prevents
tracers from handling pa
Wire up the system call tracepoints with Tasks Trace RCU to allow
the ftrace, perf, and eBPF tracers to handle page faults.
This series does the initial wire-up allowing tracers to handle page
faults, but leaves out the actual handling of said page faults as future
work.
I have tested this agains
The convention used in other kernel headers (e.g. wait.h, percpu-defs.h)
is to use "DECLARE_" prefix for macros emitting externs, static inlines
and type definitions.
The "DEFINE_" prefix is used for variable definitions.
In preparation to introduce a "DEFINE_INACTIVE_GUARD()" to actually
define
To cover scenarios where the scope of the guard differs from the scope
of its activation, introduce DEFINE_INACTIVE_GUARD() and activate_guard().
Here is an example use for a conditionally activated guard variable:
void func(bool a)
{
DEFINE_INACTIVE_GUARD(preempt_notrace, myguard);
In preparation to introduce a "DEFINE_INACTIVE_GUARD()" to actually
define a guard variable, rename all the guard "DEFINE_" prefix to
"DECLARE_".
To cover scenarios where the scope of the guard differs from the scope
of its activation, introduce DEFINE_INACTIVE_GUARD() and activate_guard().
The f
Hi, Bibo,
On Fri, Aug 23, 2024 at 2:39 PM Bibo Mao wrote:
>
> Interrupts can be routed to maximal four virtual CPUs with one HW
> EIOINTC interrupt controller model, since interrupt routing is encoded with
> CPU bitmap and EIOINTC node combined method. Here add the EIOINTC virt
> extension suppor
On 2024-08-20 01:00, Steven Rostedt wrote:
On Thu, 27 Jun 2024 11:23:35 -0400
Mathieu Desnoyers wrote:
To cover scenarios where the scope of the guard differs from the scope
of its activation, introduce DEFINE_INACTIVE_GUARD() and activate_guard().
Here is an example use for a conditionally a
On Fri, Aug 16, 2024 at 11:03 AM Dragos Tatulea wrote:
>
> change_num_qps() is still suspending/resuming VQs one by one.
> This change switches to parallel suspend/resume.
>
> When increasing the number of queues the flow has changed a bit for
> simplicity: the setup_vq() function will always be c
Hi Trevor,
Thanks a lot for the thorough review!
"Trevor Gross" writes:
> On Mon, Aug 19, 2024 at 8:35 AM Andreas Hindborg wrote:
>>
>> From: Andreas Hindborg
>>
>> This patch includes changes required for Rust kernel modules to utilize
>> module parameters. This code implements read only s
On Fri, Aug 16, 2024 at 11:03 AM Dragos Tatulea wrote:
>
> change_num_qps() has a lot of multiplications by 2 to convert
> the number of VQ pairs to number of VQs. This patch simplifies
> the code by doing the VQP -> VQ count conversion at the beginning
> in a variable.
>
> Signed-off-by: Dragos T
On 8/15/24 19:39, Sami Tolvanen wrote:
> Start making gendwarfksyms more useful by adding support for
> expanding DW_TAG_base_type types and basic DWARF attributes.
>
> Example:
>
> $ echo loops_per_jiffy | \
> scripts/gendwarfksyms/gendwarfksyms --debug vmlinux.o
> ...
> gendwarfksym
On Fri, Aug 16, 2024 at 11:02 AM Dragos Tatulea wrote:
>
> Switch firmware vq modify command to be issued via the async API to
> allow future parallelization. The new refactored function applies the
> modify on a range of vqs and waits for their execution to complete.
>
> For now the command is st
On 8/15/24 19:39, Sami Tolvanen wrote:
> diff --git a/scripts/gendwarfksyms/dwarf.c b/scripts/gendwarfksyms/dwarf.c
> index 65a29d0bd8f4..71cfab0553da 100644
> --- a/scripts/gendwarfksyms/dwarf.c
> +++ b/scripts/gendwarfksyms/dwarf.c
> @@ -5,6 +5,48 @@
> [...]
> +
> +static bool is_export_symbol(st
On Fri, Aug 16, 2024 at 11:02 AM Dragos Tatulea wrote:
>
> Switch firmware vq query command to be issued via the async API to
> allow future parallelization.
>
> For now the command is still serial but the infrastructure is there
> to issue commands in parallel, including ratelimiting the number
>
On Fri, Aug 16, 2024 at 11:02 AM Dragos Tatulea wrote:
>
> Introduce a new function mlx5_vdpa_exec_async_cmds() which
> wraps the mlx5_core async firmware command API in a way
> that will be used to parallelize certain operation in this
> driver.
>
> The wrapper deals with the case when mlx5_cmd_e
On 8/26/24 20:47, Sami Tolvanen wrote:
> On Mon, Aug 26, 2024 at 10:42 AM Petr Pavlu wrote:
>> On 8/15/24 19:39, Sami Tolvanen wrote:
>>> [...]
>>> +int main(int argc, const char **argv)
>>> +{
>>> + unsigned int n;
>>> +
>>> + if (parse_options(argc, argv) < 0)
>>> + return us
On Tue, 27 Aug 2024 at 10:35, Jason Wang wrote:
>
> On Mon, Aug 19, 2024 at 5:29 PM Cindy Lu wrote:
> >
> > In commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads"),
> > vhost removed the support for the kthread API. However, there are
> > still situations where there is a request to
On Tue, 27 Aug 2024 at 10:32, Jason Wang wrote:
>
> On Mon, Aug 19, 2024 at 5:29 PM Cindy Lu wrote:
> >
> > Add a new UAPI to support setting the vhost device to
> > use kthread mode. The user space application needs to use
> > VHOST_SET_USE_KTHREAD to set the mode. This setting must
> > be set b
On 8/28/2024 5:07 PM, Krzysztof Kozlowski wrote:
> On 28/08/2024 09:28, Jingyi Wang wrote:
>>
>>
>> On 8/28/2024 3:22 PM, Krzysztof Kozlowski wrote:
>>> On Wed, Aug 28, 2024 at 11:05:10AM +0800, Jingyi Wang wrote:
Document the components used to boot the ADSP, CDSP and GPDSP on the
QCS
On 28.08.24 11:00, Cindy Lu wrote:
> On Wed, 28 Aug 2024 at 09:51, Jason Wang wrote:
>>
>> On Wed, Aug 28, 2024 at 12:03 AM Dragos Tatulea wrote:
>>>
>>> When the vdpa device is configured without a specific MAC
>>> address, the vport MAC address is used. However, this
>>> address can be 0 whi
On Tue, 27 Aug 2024 at 10:36, Jason Wang wrote:
>
> On Mon, Aug 19, 2024 at 5:29 PM Cindy Lu wrote:
> >
> > Added back the previously removed function vhost_worker_queue() and
> > renamed it to vhost_worker_queue_khtread(). The new vhost_worker_queue()
> > will select the different mode based on
On 8/28/2024 3:24 PM, Krzysztof Kozlowski wrote:
> On Wed, Aug 28, 2024 at 11:05:11AM +0800, Jingyi Wang wrote:
>> Add support for PIL loading on ADSP, CDSP and GPDSP on QCS8300
>> platform.
>>
>> Co-developed-by: Xin Liu
>> Signed-off-by: Xin Liu
>> Signed-off-by: Jingyi Wang
>> ---
>> driv
On 28/08/2024 09:28, Jingyi Wang wrote:
>
>
> On 8/28/2024 3:22 PM, Krzysztof Kozlowski wrote:
>> On Wed, Aug 28, 2024 at 11:05:10AM +0800, Jingyi Wang wrote:
>>> Document the components used to boot the ADSP, CDSP and GPDSP on the
>>> QCS8300 SoC.
>>>
>>> Co-developed-by: Xin Liu
>>> Signed-off
On Wed, 28 Aug 2024 at 09:51, Jason Wang wrote:
>
> On Wed, Aug 28, 2024 at 12:03 AM Dragos Tatulea wrote:
> >
> > When the vdpa device is configured without a specific MAC
> > address, the vport MAC address is used. However, this
> > address can be 0 which prevents the driver from properly
> > c
On 28.08.24 08:22, Si-Wei Liu wrote:
>
>
> On 8/27/2024 9:08 AM, Dragos Tatulea wrote:
>> Certain error paths from mlx5_vdpa_dev_add() can end up releasing mr
>> resources which never got initialized in the first place.
>>
>> This patch adds the missing check in mlx5_vdpa_destroy_mr_resources(
On 28.08.24 07:54, Si-Wei Liu wrote:
>
>
> On 8/27/2024 9:02 AM, Dragos Tatulea wrote:
>> When the vdpa device is configured without a specific MAC
>> address, the vport MAC address is used. However, this
>> address can be 0 which prevents the driver from properly
>> configuring the MPFS and b
On 8/28/2024 3:22 PM, Krzysztof Kozlowski wrote:
> On Wed, Aug 28, 2024 at 11:05:10AM +0800, Jingyi Wang wrote:
>> Document the components used to boot the ADSP, CDSP and GPDSP on the
>> QCS8300 SoC.
>>
>> Co-developed-by: Xin Liu
>> Signed-off-by: Xin Liu
>> Signed-off-by: Jingyi Wang
>> ---
On Wed, Aug 28, 2024 at 11:05:11AM +0800, Jingyi Wang wrote:
> Add support for PIL loading on ADSP, CDSP and GPDSP on QCS8300
> platform.
>
> Co-developed-by: Xin Liu
> Signed-off-by: Xin Liu
> Signed-off-by: Jingyi Wang
> ---
> drivers/remoteproc/qcom_q6v5_pas.c | 55 +
On Wed, Aug 28, 2024 at 11:05:11AM +0800, Jingyi Wang wrote:
> Add support for PIL loading on ADSP, CDSP and GPDSP on QCS8300
> platform.
>
> Co-developed-by: Xin Liu
> Signed-off-by: Xin Liu
> Signed-off-by: Jingyi Wang
> ---
> drivers/remoteproc/qcom_q6v5_pas.c | 55 +
On Wed, Aug 28, 2024 at 11:05:10AM +0800, Jingyi Wang wrote:
> Document the components used to boot the ADSP, CDSP and GPDSP on the
> QCS8300 SoC.
>
> Co-developed-by: Xin Liu
> Signed-off-by: Xin Liu
> Signed-off-by: Jingyi Wang
> ---
> .../bindings/remoteproc/qcom,sa8775p-pas.yaml | 22 +
On Wed, Aug 28, 2024 at 3:50 PM Masahiro Yamada wrote:
>
> On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
> >
> > The compiler may choose not to emit type information in DWARF for
> > external symbols. Clang, for example, does this for symbols not
> > defined in the current TU.
> >
> > To p
On Fri, Aug 16, 2024 at 2:39 AM Sami Tolvanen wrote:
>
> Hi,
>
> Here's v2 of the DWARF modversions series [1]. The main motivation
> remains modversions support for Rust, which is important for
> distributions like Android that are eager to ship Rust kernel
> modules. However, per Luis' request [
64 matches
Mail list logo