On Wed, Jul 17, 2024 at 2:00 PM Michael S. Tsirkin wrote:
>
> On Wed, Jul 17, 2024 at 09:19:02AM +0800, Jason Wang wrote:
> > On Wed, Jul 10, 2024 at 11:03 AM Jason Wang wrote:
> > >
> > > On Tue, Jul 9, 2024 at 9:28 PM Michael S. Tsirkin wrote:
> > > >
> > > > On Tue, Jul 09, 2024 at 04:02:14PM
On Wed, Jul 17, 2024 at 09:19:02AM +0800, Jason Wang wrote:
> On Wed, Jul 10, 2024 at 11:03 AM Jason Wang wrote:
> >
> > On Tue, Jul 9, 2024 at 9:28 PM Michael S. Tsirkin wrote:
> > >
> > > On Tue, Jul 09, 2024 at 04:02:14PM +0800, Jason Wang wrote:
> > > > This patch synchronize operstate with a
On Wed, Jul 10, 2024 at 11:03 AM Jason Wang wrote:
>
> On Tue, Jul 9, 2024 at 9:28 PM Michael S. Tsirkin wrote:
> >
> > On Tue, Jul 09, 2024 at 04:02:14PM +0800, Jason Wang wrote:
> > > This patch synchronize operstate with admin state per RFC2863.
> > >
> > > This is done by trying to toggle the
On Tue, 16 Jul 2024 22:19:05 +0300
Nikita Kiryushin wrote:
> On 7/16/24 12:45, Alexey Khoroshilov wrote:
> > Yes, but there is another possible modification: replacement of call to
> > nonseekable_open() by a call to some other function that returns error.
> > Current code is already ready for su
On 7/16/24 12:45, Alexey Khoroshilov wrote:
Yes, but there is another possible modification: replacement of call to
nonseekable_open() by a call to some other function that returns error.
Current code is already ready for such modification.
The change of which function is called would change
Introduce tracepoint support for smp2p to enable
communication logging between local and remote processors.
Include tracepoints with information about the remote subsystem
name, negotiation details, supported features, bit change
notifications, and ssr activity. These logs are useful for
debugging
This commit enhances the smp2p driver by adding support for using the device
name in interrupt descriptions and introducing tracepoint functionality.
These improvements facilitate more effective debugging of smp2p-related issues.
The devname patch, along with the callback to print the irq chip nam
From: Chris Lew
When using /proc/interrupts to collect statistics on smp2p interrupt
counts, it is hard to distinguish the different instances of smp2p from
each other. For example to debug a processor boot issue, the ready and
handover interrupts are checked for sanity to ensure the firmware
rea
On Tue, Jul 16, 2024 at 06:49:39PM +0300, Iuliana Prodan wrote:
> Hi Mathieu,
>
> On 7/16/2024 6:16 PM, Mathieu Poirier wrote:
> > Good morning,
> >
> > On Fri, Jul 12, 2024 at 04:34:54PM +0800, Peng Fan (OSS) wrote:
> > > From: Peng Fan
> > >
> > > The DDR Alias address should be 0x4000 acc
On Fri, Jul 12, 2024 at 04:34:59PM +0800, Peng Fan (OSS) wrote:
> From: Peng Fan
>
> The i.MX7ULP Cortex-A7 is under control of Cortex-M4. The i.MX7ULP Linux
> poweroff and restart rely on rpmsg driver to send a message to Cortex-M4
> firmware. Then Cortex-A7 could poweroff or restart by Cortex-M
On Fri, Jul 12, 2024 at 04:34:58PM +0800, Peng Fan (OSS) wrote:
> From: Peng Fan
>
> Current tx_block is set to true, but there is case that no need to wait
> response. Linux just needs to send data to remote processor, so let's
> allow tx_block could be set to false.
Ok, maybe - but this patch
On Fri, Jul 12, 2024 at 04:34:57PM +0800, Peng Fan (OSS) wrote:
> From: Peng Fan
>
> Merge contiguous TCML/U regions into one to avoid load elf files which
> has large sections failure.
>
> Signed-off-by: Peng Fan
> ---
> drivers/remoteproc/imx_rproc.c | 18 ++
> 1 file changed
On Fri, Jul 12, 2024 at 04:34:56PM +0800, Peng Fan (OSS) wrote:
> From: Peng Fan
>
> Initialize workqueue before requesting mailbox channel, otherwise if
> mailbox interrupt comes before workqueue ready, the imx_rproc_rx_callback
> will trigger issue.
>
> Reviewed-by: Richard Zhu
All reviews s
Good morning,
On Fri, Jul 12, 2024 at 04:34:54PM +0800, Peng Fan (OSS) wrote:
> From: Peng Fan
>
> The DDR Alias address should be 0x4000 according to RM, so correct
> it.
>
> Fixes: 4ab8f9607aad ("remoteproc: imx_rproc: support i.MX8MQ/M")
This commit was merged more than 3 years ago...
On 16.07.24 14:32, David Woodhouse wrote:
> On 16 July 2024 12:54:52 BST, Peter Hilber
> wrote:
>> On 11.07.24 09:50, David Woodhouse wrote:
>>> On Thu, 2024-07-11 at 09:25 +0200, Peter Hilber wrote:
IMHO this phrasing is better, since it directly refers to the state of the
structu
在2024年7月16日七月 下午7:13,Mike Rapoport写道:
> From: "Mike Rapoport (Microsoft)"
>
> Make definition of node_data match other architectures.
> This will allow pulling declaration of node_data to the generic mm code in
> the following commit.
>
> Signed-off-by: Mike Rapoport (Microsoft)
Reviewed-by:
Function kvm_arch_para_features() is to detect supported para features,
it can be used by device driver to detect and enable para features,
such as extioi irqchip driver to detect KVM_FEATURE_VIRT_EXTIOI.
Signed-off-by: Bibo Mao
---
arch/loongarch/include/asm/kvm_para.h | 10 ++
arch/loo
On 16 July 2024 12:54:52 BST, Peter Hilber wrote:
>On 11.07.24 09:50, David Woodhouse wrote:
>> On Thu, 2024-07-11 at 09:25 +0200, Peter Hilber wrote:
>>>
>>> IMHO this phrasing is better, since it directly refers to the state of the
>>> structure.
>>
>> Thanks. I'll update it.
>>
>>> AFAIU if t
On 08.07.24 11:27, David Woodhouse wrote:
> +
> + /*
> + * Time according to time_type field above.
> + */
> + uint64_t time_sec; /* Seconds since time_type epoch */
> + uint64_t time_frac_sec; /* (seconds >> 64) */
> + uint64_t time_esterror_picosec;
On 11.07.24 09:50, David Woodhouse wrote:
> On Thu, 2024-07-11 at 09:25 +0200, Peter Hilber wrote:
>>
>> IMHO this phrasing is better, since it directly refers to the state of the
>> structure.
>
> Thanks. I'll update it.
>
>> AFAIU if there would be abnormal delays in store buffers, causing some
Hi,
On 2024/7/13 8:44, Jakub Kicinski wrote:
> On Fri, 12 Jul 2024 17:43:21 -0700 Jakub Kicinski wrote:
>> CC: virtio_net maintainers and Jiri who added BQL
>
> Oh, sounds like the fix may be already posted:
> https://lore.kernel.org/all/20240712080329.197605-2-jean-phili...@linaro.org/
Thanks,
From: "Mike Rapoport (Microsoft)"
The x86 implementation of range-to-target_node lookup (i.e.
phys_to_target_node() and memory_add_physaddr_to_nid()) relies on
numa_memblks.
Since numa_memblks are now part of the generic code, move these
functions from x86 to mm/numa_memblks.c and select
CONFIG_
From: "Mike Rapoport (Microsoft)"
Until now arch_numa was directly translating firmware NUMA information
to memblock.
Using numa_memblks as an intermediate step has a few advantages:
* alignment with more battle tested x86 implementation
* availability of NUMA emulation
* maintaining node inform
From: "Mike Rapoport (Microsoft)"
Introduce numa_memblks_init() and move some code around to avoid several
global variables in numa_memblks.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/mm/numa.c | 53 -
include/linux/numa_memblks.h | 9 +
mm/num
From: "Mike Rapoport (Microsoft)"
Move numa_emulation codfrom arch/x86 to mm/numa_emulation.c
This code will be later reused by arch_numa.
No functional changes.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/Kconfig | 8
arch/x86/include/asm/numa.h | 12 ---
From: "Mike Rapoport (Microsoft)"
Move code dealing with numa_distance array from arch/x86 to
mm/numa_memblks.c
This code will be later reused by arch_numa.
No functional changes.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/mm/numa.c | 101
From: "Mike Rapoport (Microsoft)"
Move code dealing with numa_memblks from arch/x86 to mm/ and add Kconfig
options to let x86 select it in its Kconfig.
This code will be later reused by arch_numa.
No functional changes.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/Kconfig
From: "Mike Rapoport (Microsoft)"
CPU id cannot be negative.
Making it unsigned also aligns with declarations in
include/asm-generic/numa.h used by arm64 and riscv and allows sharing
numa emulation code with these architectures.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/include/as
From: "Mike Rapoport (Microsoft)"
This is required to make numa emulation code architecture independent s
that it can be moved to generic code in following commits.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/include/asm/numa.h | 1 +
arch/x86/mm/numa.c | 5 +
arch/x86
From: "Mike Rapoport (Microsoft)"
This is required to make numa emulation code architecture independent so
that it can be moved to generic code in following commits.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/include/asm/numa.h | 2 ++
arch/x86/mm/numa.c | 22 +++
From: "Mike Rapoport (Microsoft)"
By the time numa_emulation() is called, all physical memory is already
mapped in the direct map and there is no need to define limits for
memblock allocation.
Replace memblock_phys_alloc_range() with memblock_alloc().
Signed-off-by: Mike Rapoport (Microsoft)
-
From: "Mike Rapoport (Microsoft)"
The definitions of FAKE_NODE_MIN_SIZE and FAKE_NODE_MIN_HASH_MASK are
only used by numa emulation code, make them local to
arch/x86/mm/numa_emulation.c
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/x86/include/asm/numa.h | 2 --
arch/x86/mm/numa_emulation
From: "Mike Rapoport (Microsoft)"
Allocation of numa_distance uses memblock_phys_alloc_range() to limit
allocation to be below the last mapped page.
But NUMA initializaition runs after the direct map is populated and
there is also code in setup_arch() that adjusts memblock limit to
reflect how m
From: "Mike Rapoport (Microsoft)"
Architectures that support NUMA duplicate the code that allocates
NODE_DATA on the node-local memory with slight variations in reporting
of the addresses where the memory was allocated.
Use x86 version as the basis for the generic alloc_node_data() function
and
From: "Mike Rapoport (Microsoft)"
Every architecture that supports NUMA defines node_data in the same way:
struct pglist_data *node_data[MAX_NUMNODES];
No reason to keep multiple copies of this definition and its forward
declarations, especially when such forward declaration is the only
From: "Mike Rapoport (Microsoft)"
Make definition of node_data match other architectures.
This will allow pulling declaration of node_data to the generic mm code in
the following commit.
Signed-off-by: Mike Rapoport (Microsoft)
---
arch/mips/include/asm/mach-loongson64/mmzone.h | 4 ++--
arch/
From: "Mike Rapoport (Microsoft)"
sgi-ip27 is the only system that defines NODE_DATA() differently than
the rest of NUMA machines.
Add node_data array of struct pglist pointers that will point to
__node_data[node]->pglist and redefine NODE_DATA() to use node_data
array.
This will allow pulling
From: "Mike Rapoport (Microsoft)"
The stub functions in kernel/numa.c belong to mm/ rather than to kernel/
Signed-off-by: Mike Rapoport (Microsoft)
---
kernel/Makefile | 1 -
mm/Makefile | 1 +
{kernel => mm}/numa.c | 0
3 files changed, 1 insertion(+), 1 deletion(-)
rename {k
From: "Mike Rapoport (Microsoft)"
Hi,
Following the discussion about handling of CXL fixed memory windows on
arm64 [1] I decided to bite the bullet and move numa_memblks from x86 to
the generic code so they will be available on arm64/riscv and maybe on
loongarch sometime later.
While it could b
On Wed, 10 Jul 2024 07:42:46 -0400
"Michael S. Tsirkin" wrote:
> --- a/drivers/s390/virtio/virtio_ccw.c
> +++ b/drivers/s390/virtio/virtio_ccw.c
> @@ -694,7 +694,7 @@ static int virtio_ccw_find_vqs(struct virtio_device
> *vdev, unsigned nvqs,
> {
> struct virtio_ccw_device *vcdev = to_vc_
On 15.07.2024 16:47, Nikita Kiryushin wrote:
> As nonseekable_open() documentation states:
> "The function is not supposed to ever fail, the only
> reason it returns an 'int' and not 'void' is so that it can be plugged
> directly into file_operations structure."
>
> So it seems, that it will not f
On Mon, Jul 15, 2024 at 03:04:12PM -0400, Steven Rostedt wrote:
>
> [ Adding sched maintainers, as this is a scheduling trace event ]
>
> On Wed, 3 Jul 2024 11:33:53 +0800
> Tio Zhang wrote:
>
> > Switch the order of prev_comm and next_comm in sched_switch's code to
> > align with its printing
On Mon, 15 Jul 2024 19:21:52 +0200
Oleg Nesterov wrote:
> On 07/15, Masami Hiramatsu wrote:
> >
> > Hi Peter, Oleg,
> >
> > If this is OK for you, please give your Ack.
>
> Acked-by: Oleg Nesterov
>
Thanks for the Ack!
--
Masami Hiramatsu (Google)
On Mon, 15 Jul 2024 14:47:45 -0400
Steven Rostedt wrote:
> From: "Steven Rostedt (Google)"
>
> Gone but never forgotten.
>
> [ Also moved Daniel's name to be consistent with the alphabetical order ]
>
Reviewed-by: Masami Hiramatsu (Google)
Thank you,
> Signed-off-by: Steven Rostedt (Googl
On Thu, Jun 13, 2024 at 10:36 PM Zheng Yejian wrote:
>
> When a weak type function is overridden, its symbol will be removed
> from the symbol table, but its code will not be removed. Besides,
> due to lacking of size for kallsyms, kernel compute function size by
> substracting its symbol address
On Mon, Jul 15, 2024 at 08:39:59PM +, Sami Tolvanen wrote:
> If using unions here is acceptable to everyone, a simple solution
> would be to use a known name prefix for the reserved members and teach
> gendwarfksyms to only print out the original type for the replaced
> ones. For example:
>
>
46 matches
Mail list logo