On 1/16/24 20:21, Rob Herring wrote:
> On Mon, Jan 15, 2024 at 02:52:47PM +0100, Arnaud Pouliquen wrote:
>> The "st,stm32mp1-m4-tee" compatible is utilized in a system configuration
>> where the Cortex-M4 firmware is loaded by the Trusted execution Environment
>> (TEE).
>> This compatible is use
Hello.
We are Ubisectech Sirius Team, the vulnerability lab of China ValiantSec.
Recently, our team has discovered a issue in Linux kernel 6.7.0-g052d534373b7.
Attached to the email were a POC file of the issue.
Stack dump:
[ 185.664167][ T8332] BUG: unable to handle page fault for address:
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Signed-off-by: Kunwu Chan
---
net/netfilter/ipvs/ip_vs_conn.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/net/netfilter/ipvs/ip_vs_conn.c b/net/netfilter/ipvs/ip
There is a deadlock scenario in kprobe_optimizer():
pid A pid B pid C
kprobe_optimizer() do_exit() perf_kprobe_init()
mutex_lock(&kprobe_mutex) exit_tasks_rcu_start()
mutex_lock(&kprobe_mutex)
synchronize_rcu_tasks()
From: "Steven Rostedt (Google)"
The original eventfs code added a wrapper around the dcache_readdir open
callback and created all the dentries and inodes at open, and increment
their ref count. A wrapper was added around the dcache_readdir release
function to decrement all the ref counts of those
[ subject is still wrong, but is to match v2, see patch 2 for correct subject ]
Changes since v2:
https://lore.kernel.org/all/20240116211217.968123...@goodmis.org/
Implemented Linus's suggestion to just change the iterate_shared to
use the hard coded inodes.
Steven Rostedt (Google) (2):
From: "Steven Rostedt (Google)"
The dentries and inodes are created in the readdir for the sole purpose of
getting a consistent inode number. Linus stated that is unnecessary, and
that all inodes can have the same inode number. For a virtual file system
they are pretty meaningless.
Instead use a
On Wed, 17 Jan 2024, Jeff Layton wrote:
> Add a new struct file_lease and move the lease-specific fields from
> struct file_lock to it. Convert the appropriate API calls to take
> struct file_lease instead, and convert the callers to use them.
I think that splitting of struct lease_manager_operati
On Wed, 17 Jan 2024, Jeff Layton wrote:
> Have both __locks_insert_block and the deadlock and conflict checking
> functions take a struct file_lock_core pointer instead of a struct
> file_lock one. Also, change posix_locks_deadlock to return bool.
>
> Signed-off-by: Jeff Layton
> ---
> fs/locks.
On Wed, 17 Jan 2024, Jeff Layton wrote:
> Convert __locks_delete_block and __locks_wake_up_blocks to take a struct
> file_lock_core pointer. Note that to accomodate this, we need to add a
> new file_lock() wrapper to go from file_lock_core to file_lock.
Actually we don't need it see below.
>
On Wed, 17 Jan 2024, Jeff Layton wrote:
> I couldn't get them to work properly as macros, so convert them
> to static inlines instead (which is probably better for the type safety
> anyway).
>
> Signed-off-by: Jeff Layton
> ---
> fs/locks.c | 46 +-
>
On Wed, 17 Jan 2024, Jeff Layton wrote:
> In a future patch, we're going to split file leases into their own
> structure. Since a lot of the underlying machinery uses the same fields
> move those into a new file_lock_core, and embed that inside struct
> file_lock.
>
> Signed-off-by: Jeff Layton
>
On Tue, 16 Jan 2024 13:39:38 -0800
Linus Torvalds wrote:
> I don't understand why your still insist on this pointless open wrapper.
I just liked the consistency of it.
>
> Just do this all at iterate time. No open wrappers. No nothing. Just
> iterate over the days structures your have.
>
> IO
Am 16.01.24 um 09:05 schrieb Pavel Machek:
[If you have hints how to set-up pinephone for kernel development,
that would be welcome. Currently I have mobian with rather old 6.1
kernel on it, and lack of keyboard/ethernet makes things tricky.]
So far I'm mostly using "pmbootstrap build --src" [1
From: "Steven Rostedt (Google)"
The original eventfs code added a wrapper around the dcache_readdir open
callback and created all the dentries and inodes at open, and increment
their ref count. A wrapper was added around the dcache_readdir release
function to decrement all the ref counts of those
[ subject is wrong, but is to match v1, see patch 2 for correct subject ]
Fix reading dir again, this time without creating dentries and inodes.
Changes since v1:
https://lore.kernel.org/linux-trace-kernel/20240116114711.7e863...@gandalf.local.home
Steven Rostedt (Google) (2):
eventfs: H
From: "Steven Rostedt (Google)"
The dentries and inodes are created in the readdir for the sole purpose of
getting a consistent inode number. Linus stated that is unnecessary, and
that all inodes can have the same inode number. For a virtual file system
they are pretty meaningless.
Instead use a
On Mon, 15 Jan 2024 13:52:50 +0900 Honggyu Kim wrote:
> This patch introduces DAMOS_DEMOTE action, which is similar to
> DAMOS_PAGEOUT, but demote folios instead of swapping them out.
>
> Since there are some common routines with pageout, many functions have
> similar logics between pageout and
On Mon, 15 Jan 2024 13:52:49 +0900 Honggyu Kim wrote:
> Since we will introduce reclaim_pages like functions such as
> demote_pages and promote_pages, the most of the code can be shared.
>
> This is a preparation patch that introduces reclaim_or_migrate_folios()
> to cover all the logics, but it
Hello Pavel,
Isn't this simply the case of picking the gc2145 bits from Megis tree?
https://megous.com/git/linux/tree/arch/arm64/boot/dts/allwinner/sun50i-a64-pinephone.dtsi?h=orange-pi-5.10#n410
[For the pinephone kernel development there's the option of building the
kernel using envkernel.sh
On Mon, 15 Jan 2024 13:52:52 +0900 Honggyu Kim wrote:
> From: Hyeongtak Ji
>
> This patch introduces DAMOS_PROMOTE action for paddr mode.
>
> It includes renaming alloc_demote_folio to alloc_migrate_folio to use it
> for promotion as well.
>
> The execution sequence of DAMOS_DEMOTE and DAMOS_
On Mon, 15 Jan 2024 13:52:51 +0900 Honggyu Kim wrote:
> From: Hyeongtak Ji
>
> This patch adds next_promotion_node that can be used to identify the
> appropriate promotion target based on memory tiers. When multiple
> promotion target nodes are available, the nearest node is selected based
> o
Hello,
On Mon, 15 Jan 2024 13:52:48 +0900 Honggyu Kim wrote:
> There was an RFC IDEA "DAMOS-based Tiered-Memory Management" previously
> posted at [1].
>
> It says there is no implementation of the demote/promote DAMOS action
> are made. This RFC is about its implementation for physical addres
Add a new struct file_lease and move the lease-specific fields from
struct file_lock to it. Convert the appropriate API calls to take
struct file_lease instead, and convert the callers to use them.
Signed-off-by: Jeff Layton
---
fs/libfs.c | 2 +-
fs/locks.c
Have these functions take a file_lock_core pointer instead of a
file_lock.
Signed-off-by: Jeff Layton
---
fs/locks.c | 44 ++--
1 file changed, 22 insertions(+), 22 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 88c72eb4672e..6d24cf2525ec 100644
Have locks_wake_up_blocks take a file_lock_core pointer, and fix up the
callers to pass one in.
Signed-off-by: Jeff Layton
---
fs/locks.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 4a1e9457c430..88c72eb4672e 100644
--- a/fs/lo
Have assign_type take struct file_lock_core instead of file_lock.
Signed-off-by: Jeff Layton
---
fs/locks.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 27160dc65d63..4a1e9457c430 100644
--- a/fs/locks.c
+++ b/fs/locks.c
@@ -462,13
Rename the old __locks_delete_block to __locks_unlink_lock. Rename
change old locks_delete_block function to __locks_delete_block and
have it take a file_lock_core. Make locks_delete_block a simple wrapper
around __locks_delete_block.
Also, change __locks_insert_block to take struct file_lock_core
Rework the internals of locks_delete_block to use struct file_lock_core
(mostly just for clarity's sake). The prototype is not changed.
Signed-off-by: Jeff Layton
---
fs/locks.c | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 1bc6
Both locks and leases deal with fl_blocker. Switch the fl_blocker
pointer in struct file_lock_core to point to the file_lock_core of the
blocker instead of a file_lock structure.
Signed-off-by: Jeff Layton
---
fs/locks.c | 10 +-
include/linux/filelock.h| 2
Have both __locks_insert_block and the deadlock and conflict checking
functions take a struct file_lock_core pointer instead of a struct
file_lock one. Also, change posix_locks_deadlock to return bool.
Signed-off-by: Jeff Layton
---
fs/locks.c | 132 --
Convert __locks_delete_block and __locks_wake_up_blocks to take a struct
file_lock_core pointer. Note that to accomodate this, we need to add a
new file_lock() wrapper to go from file_lock_core to file_lock.
Signed-off-by: Jeff Layton
---
fs/locks.c | 43 ++---
I couldn't get them to work properly as macros, so convert them
to static inlines instead (which is probably better for the type safety
anyway).
Signed-off-by: Jeff Layton
---
fs/locks.c | 46 +-
1 file changed, 33 insertions(+), 13 deletions(-)
diff
Have locks_insert_global_blocked and locks_delete_global_blocked take a
struct file_lock_core pointer.
Signed-off-by: Jeff Layton
---
fs/locks.c | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 5fe54f48b9c1..770aaa5809ba 100644
--- a
Convert these functions to take a file_lock_core instead of a file_lock.
Signed-off-by: Jeff Layton
---
fs/locks.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 6432bcfb55a0..5fe54f48b9c1 100644
--- a/fs/locks.c
+++ b/fs/lock
Convert posix_owner_key to take struct file_lock_core pointer, and fix
up the callers to pass one in.
Signed-off-by: Jeff Layton
---
fs/locks.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index 0c47497eb1a4..6432bcfb55a0 100644
--- a/fs/loc
Change posix_same_owner to take struct file_lock_core pointers, and
convert the callers to pass those in.
Signed-off-by: Jeff Layton
---
fs/locks.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/fs/locks.c b/fs/locks.c
index e09920cc9da2..0c47497eb1a4 100644
Convert more internal fs/locks.c functions to take and deal with struct
file_lock_core instead of struct file_lock:
- locks_dump_ctx_list
- locks_check_ctx_file_list
- locks_release_private
- locks_owner_has_blockers
Signed-off-by: Jeff Layton
---
fs/locks.c | 51 +--
Convert some internal fs/locks.c function to take and deal with struct
file_lock_core instead of struct file_lock:
- locks_init_lock_heads
- locks_alloc_lock
- locks_init_lock
Signed-off-by: Jeff Layton
---
fs/locks.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff
The coccinelle script doesn't catch quite everythng (particularly with
embedded structs). These are some by-hand fixups after the split of
common fields into struct file_lock_core.
Signed-off-by: Jeff Layton
---
fs/ceph/locks.c | 8 ++---
fs/lockd/clnt4xdr.c | 8 ++-
This is the direct result of the changes generated by coccinelle. There
is still about 1/4 of the callsites that need to be touched by hand
here.
Signed-off-by: Jeff Layton
---
fs/9p/vfs_file.c| 38 ++---
fs/afs/flock.c | 55 +++---
fs/ceph/locks.c | 66 ++
Add some coccinelle scripts to handle the move of several fields from
struct file_lock to struct file_lock_core.
Signed-off-by: Jeff Layton
---
cocci/filelock.cocci | 81 +++
cocci/filelock2.cocci | 6
cocci/nlm.cocci | 81
In a future patch, we're going to split file leases into their own
structure. Since a lot of the underlying machinery uses the same fields
move those into a new file_lock_core, and embed that inside struct
file_lock.
Signed-off-by: Jeff Layton
---
include/linux/filelock.h | 9 +++--
1 file c
8 ++-
include/linux/fs.h | 5 +-
include/linux/lockd/lockd.h | 8 +-
include/trace/events/afs.h | 4 +-
include/trace/events/filelock.h | 54 +--
48 files changed, 1119 insertions(+), 825 deletions(-)
---
base-commit: 052d534373b7ed33712a63d5e17b2b6cdbce84fd
ch
On Mon, Jan 15, 2024 at 02:52:47PM +0100, Arnaud Pouliquen wrote:
> The "st,stm32mp1-m4-tee" compatible is utilized in a system configuration
> where the Cortex-M4 firmware is loaded by the Trusted execution Environment
> (TEE).
> This compatible is used in both the Linux and OP-TEE device-tree.
>
On Wed, Jan 10, 2024 at 9:40 PM Steve Sistare wrote:
>
> To pass ownership of a live vdpa device to a new process, the user
> suspends the device, calls VHOST_NEW_OWNER to change the mm, and calls
> VHOST_IOTLB_REMAP to change the user virtual addresses to match the new
> mm. Flush workers in sus
On Wed, Jan 10, 2024 at 9:40 PM Steve Sistare wrote:
>
> vdpasim_do_reset sets running to true, which is wrong, as it allows
> vdpasim_kick_vq to post work requests before the device has been
> configured. To fix, do not set running until VIRTIO_CONFIG_S_FEATURES_OK
> is set.
>
> Signed-off-by: S
On Wed, Jan 10, 2024 at 9:40 PM Steve Sistare wrote:
>
> When device ownership is passed to a new process via VHOST_NEW_OWNER,
> some devices need to know the new userland addresses of the dma mappings.
> Define the new iotlb message type VHOST_IOTLB_REMAP to update the uaddr
> of a mapping. The
On Tue, 16 Jan 2024 13:12:28 -0500
Steven Rostedt wrote:
> Maybe I can just use a hash to generate he inode numbers from the name?
> Hopefully there will be no collisions. Then I don't need the dentry
> creation at all.
Maybe I could use a hash of the address of the meta data to create the
inode
On Tue, 16 Jan 2024 09:55:15 -0800
Linus Torvalds wrote:
> [ html crud because I still don't have power or real Internet, just trying
> to keep an eye on things on my phone. Mailing lists removed to avoid
> bounces, please put them back in replies that don't have my horrible
> formatting ]
>
> N
Acked-by: Conor Dooley
signature.asc
Description: PGP signature
From: "Steven Rostedt (Google)"
The original eventfs code added a wrapper around the dcache_readdir open
callback and created all the dentries and inodes at open, and increment
their ref count. A wrapper was added around the dcache_readdir release
function to decrement all the ref counts of those
The following changes since commit b8e0792449928943c15d1af9f63816911d139267:
virtio_blk: fix snprintf truncation compiler warning (2023-12-04 09:43:53
-0500)
are available in the Git repository at:
https://git.kernel.org/pub/scm/linux/kernel/git/mst/vhost.git tags/for_linus
for you to fetc
On Mon, Jan 15, 2024 at 07:20:31PM +0100, Krzysztof Kozlowski wrote:
> dtschema package defines firmware-name as string-array, so individual
> bindings should not make it a string but instead just narrow the number
> of expected firmware file names.
>
> Signed-off-by: Krzysztof Kozlowski
> ---
>
On Mon, Jan 15, 2024 at 05:39:22PM +0300, Fedor Pchelkin wrote:
> Inside decrement_ttl() upon discovering that the packet ttl has exceeded,
> __IP_INC_STATS and __IP6_INC_STATS macros can be called from preemptible
> context having the following backtrace:
>
> check_preemption_disabled: 48 callbac
On Mon, Jan 15, 2024 at 09:35:50PM +0100, Christophe JAILLET wrote:
> ida_alloc() and ida_free() should be preferred to the deprecated
> ida_simple_get() and ida_simple_remove().
>
> Note that the upper limit of ida_simple_get() is exclusive, buInputt the one
> of
> ida_alloc_max() is inclusive.
Il 15/01/24 19:20, Krzysztof Kozlowski ha scritto:
dtschema package defines firmware-name as string-array, so individual
bindings should not make it a string but instead just narrow the number
of expected firmware file names.
Signed-off-by: Krzysztof Kozlowski
... a better commit description:
Hello,
On Mon, 15 Jan 2024, Fedor Pchelkin wrote:
> Inside decrement_ttl() upon discovering that the packet ttl has exceeded,
> __IP_INC_STATS and __IP6_INC_STATS macros can be called from preemptible
> context having the following backtrace:
>
> check_preemption_disabled: 48 callbacks
/linux.git
rproc-next
patch link:
https://lore.kernel.org/r/20240115135249.296822-5-arnaud.pouliquen%40foss.st.com
patch subject: [PATCH 4/4] remoteproc: stm32: Add support of an OP-TEE TA to
load the firmware
config: arm64-allyesconfig
(https://download.01.org/0day-ci/archiv
/linux.git
rproc-next
patch link:
https://lore.kernel.org/r/20240115135249.296822-5-arnaud.pouliquen%40foss.st.com
patch subject: [PATCH 4/4] remoteproc: stm32: Add support of an OP-TEE TA to
load the firmware
config: um-randconfig-r113-20240116
(https://download.01.org/0day-ci/archiv
Hi!
In 6.8-rc0, driver for gc2145 (front camera on pinephone) was merged,
but we don't have corresponding dts entries. Does anyone have setup
where they can fix it easily?
[If you have hints how to set-up pinephone for kernel development,
that would be welcome. Currently I have mobian with rather
61 matches
Mail list logo