[RFC PATCH] drivers: hv: Convert open-coded timeouts to msecs_to_jiffies()

2024-10-16 Thread Easwar Hariharan
We have several places where timeouts are open-coded as N (seconds) * HZ, but best practice is to use msecs_to_jiffies(). Convert the timeouts to make them HZ invariant. Signed-off-by: Easwar Hariharan --- drivers/hv/hv_balloon.c | 9 + drivers/hv/hv_kvp.c | 4 ++-- drivers/hv/hv_s

[PATCH net,v2] hv_netvsc: Fix VF namespace also in synthetic NIC NETDEV_REGISTER event

2024-10-16 Thread Haiyang Zhang
The existing code moves VF to the same namespace as the synthetic NIC during netvsc_register_vf(). But, if the synthetic device is moved to a new namespace after the VF registration, the VF won't be moved together. To make the behavior more consistent, add a namespace check for synthetic NIC's NET

[PATCH v1] tools: hv: change permissions of NetworkManager configuration file

2024-10-16 Thread Olaf Hering
Align permissions of the resulting .nmconnection file, instead of the input file from hv_kvp_daemon. To avoid the tiny time frame where the output file is world-readable, use umask instead of chmod. Fixes: 42999c90 ("Support for keyfile based connection profile") Signed-off-by: Olaf Hering ---

[PATCH] x86/mtrr: Rename mtrr_overwrite_state() to guest_force_mtrr_state()

2024-10-16 Thread Kirill A. Shutemov
Rename the helper to better reflect its function. Signed-off-by: Kirill A. Shutemov Suggested-by: Dave Hansen --- arch/x86/hyperv/ivm.c | 2 +- arch/x86/include/asm/mtrr.h| 10 +- arch/x86/kernel/cpu/mtrr/generic.c | 6 +++--- arch/x86/kernel/cpu/mtrr/mtrr.c|