Re: [PATCH] auxdisplay: panel: refactor deprecated strncpy

2023-09-29 Thread Miguel Ojeda
On Fri, Sep 29, 2023 at 8:42 PM Kees Cook wrote: > > Applied to for-next/hardening, thanks! Thanks for picking it up! Cheers, Miguel

Re: [PATCH 06/82] overflow: Reintroduce signed and unsigned overflow sanitizers

2024-01-22 Thread Miguel Ojeda
On Tue, Jan 23, 2024 at 1:28 AM Kees Cook wrote: > > Because the kernel is built with -fno-strict-overflow, signed and pointer > arithmetic is defined to always wrap around instead of "overflowing" > (which would either be elided due to being undefined behavior or would > wrap around, which led to

Re: [PATCH 06/82] overflow: Reintroduce signed and unsigned overflow sanitizers

2024-01-23 Thread Miguel Ojeda
On Tue, Jan 23, 2024 at 5:45 AM Kees Cook wrote: > > Yes. We removed this bad behavior by using -fno-strict-overflow, and we will > want to keep it enabled. Yeah, I only meant that the wording of the commit seems to say there is something special about the "overflowing behavior", i.e. I was expe

Re: [PATCH] refcount: Annotated intentional signed integer wrap-around

2024-02-21 Thread Miguel Ojeda
n is triggering on the few `old + i`s caused by the calls from `drivers/misc/lkdtm/refcount.c`, right?): Reviewed-by: Miguel Ojeda As usual, thanks Kees for keeping up on getting the kernel (un)signed UBSan-clean :) Cheers, Miguel

Re: [PATCH 2/2] rust: time: Use wrapping_sub() for Ktime::sub()

2024-04-24 Thread Miguel Ojeda
On Wed, Apr 24, 2024 at 1:37 AM Kees Cook wrote: > > While working on the signed (and unsigned) integer overflow sanitizer > support on the C side for the kernel, I've also run into timekeeping > being a questionable area[1]. I *think* from what I can tell, it's always > expected to have wrapping

Re: [PATCH] uapi: stddef.h: Provide UAPI macros for __counted_by_{le, be}

2024-05-06 Thread Miguel Ojeda
On Mon, May 6, 2024 at 7:42 PM Erick Archer wrote: > > Provide UAPI macros for UAPI structs that will gain annotations for > __counted_by_{le, be} attributes. > > Signed-off-by: Erick Archer I guess this is a mirror of the kernel one at https://lore.kernel.org/lkml/20240327142241.1745989-1-aleks

Re: [PATCH] string: Check for "nonstring" attribute on strscpy() arguments

2024-08-06 Thread Miguel Ojeda
ill always reply with the right answer... (if e.g. they copy-paste another use). Perhaps there is a more explicit name to let users recall that. Anyway, it looks sensible to me: more compile-time checking seldomly hurts (apart from complexity in these definitions :). So: Reviewed-by: Miguel Ojeda

Re: [RFC PATCH 01/11] kbuild: ignore .config rule for make --always-make

2024-11-02 Thread Miguel Ojeda
On Sat, Nov 2, 2024 at 10:08 PM Nicolas Schier wrote: > > As we still also support make v3.80 to v4.0, please use $(short-opts) > defined around line 27. We moved to 4.0 in 5f99665ee8f4 ("kbuild: raise the minimum GNU Make requirement to 4.0") -- or do you mean something else / am I missing somet

Re: [PATCH 0/3] string.h: Use ARRAY_SIZE() for memtostr*()/strtomem*()

2025-02-06 Thread Miguel Ojeda
On Thu, Feb 6, 2025 at 7:42 PM Andy Shevchenko wrote: > > What's the minimum Clang version we build kernel with? 12? 13.0.1 for most architectures according to `scripts/min-tool-version.sh`. Cheers, Miguel

Re: [PATCH 1/3] compiler.h: Move C string helpers into C-only kernel section

2025-02-06 Thread Miguel Ojeda
I assume that is intentional. (Perhaps mention ifndef instead of ifdef?) I checked that this is indeed a pure move, so: Reviewed-by: Miguel Ojeda Cheers, Miguel

Re: [PATCH] compiler_types: Introduce __nonstring_array

2025-03-11 Thread Miguel Ojeda
e) in the comment to clarify (it will also help to clarify what that "only supported since GCC >= 15" means). If you are going to use it in a series that has a use case: Acked-by: Miguel Ojeda Thanks! Cheers, Miguel