On Fri, 22 Sep 2023 10:53:23 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexi
On Fri, 22 Sep 2023 10:54:02 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexi
On Fri, Sep 29, 2023 at 12:14:59PM -0700, Kees Cook wrote:
> On Fri, 15 Sep 2023 13:09:11 -0600, Gustavo A. R. Silva wrote:
> > If, for any reason, the open-coded arithmetic causes a wraparound,
> > the protection that `struct_size()` adds against potential integer
> > overflows is defeated. Fix t
On Sun, Oct 01, 2023 at 01:37:04PM -0700, Kees Cook wrote:
> On Sun, Oct 01, 2023 at 11:25:59AM +0100, Mark Brown wrote:
> > Why is this bypassing the ASoC tree?
> Hi! Sorry, I can drop it if you want to take it? I tend to collect trivial
> hardening changes with reviews th
On Fri, 15 Sep 2023 13:09:11 -0600, Gustavo A. R. Silva wrote:
> If, for any reason, the open-coded arithmetic causes a wraparound,
> the protection that `struct_size()` adds against potential integer
> overflows is defeated. Fix this by hardening call to `struct_size()`
> with `size_add()`.
>
>
On Tue, 03 Oct 2023 16:28:53 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time via CONFIG_UBSAN_BOUNDS (for
> array indexing) and C
On Wed, Oct 04, 2023 at 12:34:45PM -0700, Kees Cook wrote:
> +++ b/MAINTAINERS
> @@ -20116,6 +20116,8 @@ F:Documentation/devicetree/bindings/sound/
> F: Documentation/sound/soc/
> F: include/dt-bindings/sound/
> F: include/sound/soc*
> +F: include/sound/sof/
> +F: include/uapi/sou
On Wed, Oct 04, 2023 at 12:41:14PM -0700, Kees Cook wrote:
> >The SOF header is also missing from the entry for SOF.
> Ah, right! Can you take this and tweak it with the missing entries, or should
> I send a v2?
Could you send an incremental patch please? It's already in my CI as
is.
signatu
On Wed, 04 Oct 2023 12:34:45 -0700, Kees Cook wrote:
> Make sure a few other paths are correctly sent to the ASoC maintainers.
>
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/1] MAINTAINERS: Include additional ASoC paths
commit: 21
On Wed, 04 Oct 2023 19:56:21 -0700, Kees Cook wrote:
> Add missing sof header files for ASoC.
>
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/1] MAINTAINERS: Include sof headers under ASoC
commit: 4b226f15421d160cc07ff497179547f559
On Fri, Oct 06, 2023 at 01:22:55PM -0700, Kees Cook wrote:
> On Fri, Sep 22, 2023 at 10:50:50AM -0700, Kees Cook wrote:
> > Prepare for the coming implementation by GCC and Clang of the __counted_by
> > attribute. Flexible array members annotated with __counted_by can have
> > their accesses bound
On Fri, Oct 06, 2023 at 01:40:08PM -0700, Kees Cook wrote:
> On Fri, Sep 22, 2023 at 10:52:07AM -0700, Kees Cook wrote:
> > Prepare for the coming implementation by GCC and Clang of the __counted_by
> > attribute. Flexible array members annotated with __counted_by can have
> > their accesses bound
On Fri, 22 Sep 2023 10:53:31 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexi
On Mon, Oct 09, 2023 at 10:17:33AM -0700, Kees Cook wrote:
> On Fri, Oct 06, 2023 at 09:53:49PM +0100, Mark Brown wrote:
> > Please don't send content free pings and please allow a reasonable time
> > for review. People get busy, go on holiday, attend conferences and so
&g
On Fri, 22 Sep 2023 10:50:50 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexi
On Fri, 22 Sep 2023 10:52:07 -0700, Kees Cook wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexi
On Mon, 09 Oct 2023 15:24:23 -0600, Gustavo A. R. Silva wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time via CONFIG_UBSAN_BOUNDS (for
> array index
On Thu, Nov 02, 2023 at 04:20:29PM +0100, Duje Mihanović wrote:
> The SSPA driver currently seems to generate ARM32 assembly, which causes
> build errors when building a kernel for an ARM64 ARCH_MMP platform.
>
> Fixes: fa375d42f0e5 ("ASoC: mmp: add sspa support")
> Reported-by: kernel test robot
On Fri, Nov 03, 2023 at 05:58:05PM +0100, Duje Mihanović wrote:
> I just looked at it again and it looks like no code in sound/soc/pxa/* or
> sound/arm/pxa* depends on AACI in any way. Therefore, I believe that to fix
> this correctly, I would have to remove "select SND_ARM" from sound/soc/pxa/
On Fri, Nov 10, 2023 at 08:28:56PM +0100, Duje Mihanović wrote:
> On Monday, November 6, 2023 11:58:46 AM CET Mark Brown wrote:
> > On Fri, Nov 03, 2023 at 05:58:05PM +0100, Duje Mihanović wrote:
> > > this correctly, I would have to remove "select SND_ARM" from sou
On Thu, Dec 21, 2023 at 10:21:04AM -0500, Paul Moore wrote:
> On Thu, Dec 21, 2023 at 8:01 AM Mark Brown wrote:
> > On Wed, Dec 20, 2023 at 08:40:24PM -0500, Paul Moore wrote:
> > > Suggestions on how to annotate the struct, or the code doing the
> > > memcpy() are w
The ctx in struct lsm_ctx is an array of size ctx_len, tell the compiler
about this using __counted_by() where supported to improve the ability to
detect overflow issues.
Reported-by: Aishwarya TCV
Signed-off-by: Mark Brown
---
include/uapi/linux/lsm.h | 2 +-
1 file changed, 1 insertion(+), 1
The ctx in struct lsm_ctx is an array of size ctx_len, tell the compiler
about this using __counted_by() where supported to improve the ability to
detect overflow issues.
Reported-by: Aishwarya TCV
Signed-off-by: Mark Brown
---
Changes in v2:
- Add explicit stddef.h inclusion in case
On Mon, Jan 08, 2024 at 02:41:14PM -0600, Ninad Palsule wrote:
> + regulator@60 {
> + compatible = "maxim,max8952";
> + reg = <0x60>;
> +
> + max8952,default-mode = <0>;
> + max8952,dvs-mode-microvolt = <125>, <120>,
> +
n CPU Oops nor things
> like KASAN, UBSAN, etc that called dump_stack(). Regularize this line
> so CI systems and other things (like LKDTM) that depend on parsing
> "Call trace:" out of dmesg will see it for ARM.
Reviewed-by: Mark Brown
signature.asc
Description: PGP signature
On Tue, 09 Jan 2024 19:11:01 +0100, Erick Archer wrote:
> Use 2-factor multiplication argument form devm_kcalloc() instead
> of devm_kzalloc().
>
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/1] ASoC: ti: j721e-evm: Use devm_kcalloc() in
On Sat, 06 Jan 2024 18:16:35 +0100, Erick Archer wrote:
> Use 2-factor multiplication argument form devm_kcalloc() instead
> of devm_kzalloc().
>
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/1] ASoC: qcom: Use devm_kcalloc() instead of
s. Make sure copy_from_kernel_nofault() does not attempt this
> any more.
This appears to fix the original issue:
https://lava.sirena.org.uk/scheduler/job/497571
(though so did your earlier patch) so:
Tested-by: Mark Brown
signature.asc
Description: PGP signature
On Mon, 12 Feb 2024 14:10:08 +0100, Konrad Dybcio wrote:
> DTS for the phone and some fly-by fixes
>
> Patch 1 for Mark/sound
> Rest for qcom
>
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next
Thanks!
[1/7] dt-bindings: ASoC: cs35l45: Add interrupts
On Wed, Feb 28, 2024 at 10:41:36PM +0200, Andy Shevchenko wrote:
> We have two new helpers struct_size_with_data() and struct_data_pointer()
> that we can utilize in __spi_alloc_controller(). Do it so.
Acked-by: Mark Brown
signature.asc
Description: PGP signature
On Mon, 04 Mar 2024 10:04:22 -0600, David Lechner wrote:
> This series contains a few small cleanups to the axi-spi-engine driver,
> mostly suggested from previous reviews.
>
Applied to
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/spi.git for-next
Thanks!
[1/3] spi: axi-spi-engin
eported for the
> memset() tests:
Reviewed-by: Mark Brown
signature.asc
Description: PGP signature
pper/lower
> testing looks like this:
Reviewed-by: Mark Brown
signature.asc
Description: PGP signature
On Mon, 05 Aug 2024 09:28:55 -0600, Gustavo A. R. Silva wrote:
> -Wflex-array-member-not-at-end was introduced in GCC-14, and we are
> getting ready to enable it, globally.
>
> Move the conflicting declaration to the end of the structure. Notice
> that `struct snd_sof_pcm` ends in a flexible-array
On Fri, Oct 18, 2024 at 12:32:37PM -0700, Jeff Xu wrote:
> On Fri, Oct 18, 2024 at 11:37 AM Mark Brown wrote:
> > On Fri, Oct 18, 2024 at 11:06:20AM -0700, Jeff Xu wrote:
> > Test 106 here is called "test_munmap_free_multiple_ranges_with_split:
> > line:2573" which
On Thu, Oct 17, 2024 at 12:49:40PM -0700, Jeff Xu wrote:
> So it is not a problem with the MACRO, but where is it used ?
> ret = sys_mseal(ptr, size);
> FAIL_TEST_IF_FALSE(!ret);
> Take this example, it would be
> assert(!ret)
The problem is that the macro name is confusing and
On Fri, Oct 18, 2024 at 11:06:20AM -0700, Jeff Xu wrote:
> On Fri, Oct 18, 2024 at 6:04 AM Mark Brown wrote:
> > The problem is that the macro name is confusing and not terribly
> > consistent with how the rest of the selftests work. The standard
> > kselftes
On Fri, Oct 18, 2024 at 05:10:01PM -0700, Jeff Xu wrote:
> On Fri, Oct 18, 2024 at 2:05 PM Mark Brown wrote:
> > That's not the entire issue - it is also a problem that the test name
> > is not the same between passes and failures so automated systems can't
> >
On Tue, Oct 29, 2024 at 01:37:05PM +, Aleksei Vetrov wrote:
> Sent v2.
That doesn't seem to have shown up here?
signature.asc
Description: PGP signature
On Mon, 28 Oct 2024 22:50:30 +, Aleksei Vetrov wrote:
> The widgets array in the snd_soc_dapm_widget_list has a __counted_by
> attribute attached to it, which points to the num_widgets variable. This
> attribute is used in bounds checking, and if it is not set before the
> array is filled, then
On Tue, Oct 29, 2024 at 03:14:53PM +, Aleksei Vetrov wrote:
> On Tue, Oct 29, 2024 at 02:08:32PM +0000, Mark Brown wrote:
> > For this fix I couldn't send v2, because it has been already applied by
> > Mark Brown. Guess I would need to send a separate message to the st
On Fri, Sep 13, 2024 at 03:50:00PM -0700, Jeff Xu wrote:
> Even though the number of lines is large in these patches, its main
> intention is to test Pedro's in-place change (from can_modify_mm to
> can_modify_vma). Before this patch, the test had a common pattern:
> setup memory layout, seal the
On Mon, Feb 10, 2025 at 11:08:27PM -0500, Ethan Carter Edwards wrote:
> There is a possibility for an uninitialized *ret* variable to be
> returned in some code paths.
>
> Setting to 0 prevents a random value from being returned.
That'll shut up the warning but is the warning trying to tell us th
On Sun, Feb 23, 2025 at 10:50:08AM +0100, Markus Elfring wrote:
> …
> > We are trying to get rid of all multiplications from allocation
> > functions to prevent integer overflows[1]. …
>
> Is an imperative wording more desirable for such a change description?
> https://git.kernel.org/pub/scm/linux
On Sat, 22 Feb 2025 14:55:20 -0500, Ethan Carter Edwards wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows[1]. Here the multiplication is
> obviously safe, but using kcalloc() is more appropriate and improves
> readability. This patch
45 matches
Mail list logo