On Fri, Feb 07, 2025 at 08:56:45PM +0100, Bartosz Golaszewski wrote:
> On Fri, Feb 7, 2025 at 4:42 PM Andy Shevchenko
> wrote:
> >
> > On Fri, Feb 07, 2025 at 05:17:14PM +0200, Andy Shevchenko wrote:
> > > We have a temporary variable to keep a pointer to struct device.
> > > Utilise it where it m
On Mon, Feb 3, 2025 at 1:18 PM Andy Shevchenko
wrote:
> Use macros defined in linux/cleanup.h to automate resource lifetime
> control in the driver.
>
> Signed-off-by: Andy Shevchenko
Clearly this is more readable and less prone to accidental bugs.
Reviewed-by: Linus Walleij
Yours,
Linus Wall
On Mon, Feb 3, 2025 at 1:18 PM Andy Shevchenko
wrote:
> Make use of BIT() and GENMASK() where it makes sense.
>
> Signed-off-by: Andy Shevchenko
Reviewed-by: Linus Walleij
Yours,
Linus Walleij
On Mon, Feb 10, 2025 at 10:12:52AM +0100, Linus Walleij wrote:
> On Mon, Feb 3, 2025 at 1:18 PM Andy Shevchenko
> wrote:
>
> > Make use of BIT() and GENMASK() where it makes sense.
> >
> > Signed-off-by: Andy Shevchenko
>
> Reviewed-by: Linus Walleij
Thanks, there is a v2 available.
--
With
On 2/8/25 02:47, GONG Ruiqi wrote:
> Move __kvmalloc_node_noprof (and also kvfree* for consistency) into
> mm/slub.c so that it can directly invoke __do_kmalloc_node, which is
> needed for the next patch. Move kmalloc_gfp_adjust to slab.h since now
> its two callers are in different .c files.
>
>
On 2/8/25 02:47, GONG Ruiqi wrote:
> As revealed by this writeup[1], due to the fact that __kmalloc_node (now
> renamed to __kmalloc_node_noprof) is an exported symbol and will never
> get inlined, using it in kvmalloc_node (now is __kvmalloc_node_noprof)
> would make the RET_IP inside always point
On 06/02/2025 23:41, Kees Cook wrote:
> On Mon, Feb 03, 2025 at 10:18:24AM +, Kevin Brodsky wrote:
>> This is a proposal to leverage protection keys (pkeys) to harden
>> critical kernel data, by making it mostly read-only. The series includes
>> a simple framework called "kpkeys" to manipulate
On Sun, Feb 09, 2025 at 11:47:24PM -0500, Ethan Carter Edwards wrote:
> Variable self assignment does not have any effect.
Hi Ethan
As a general rule, it would be good to explain in the comment message
what research you did to find out why there is a self assignment, and
why just deleting it is t
On 07/02/25 19:37, Frederic Weisbecker wrote:
> Le Fri, Feb 07, 2025 at 06:06:45PM +0100, Valentin Schneider a écrit :
>>
>> S I've been thinking...
>>
>> Isn't
>>
>> (context_tracking.state & CT_RCU_WATCHING)
>>
>> pretty much a proxy for knowing whether a CPU is executing in kernelspace,
>>
GCC can see that the value range for "order" is capped, but this leads
it to consider that it might be negative, leading to a false positive
warning (with GCC 15 with -Warray-bounds -fdiagnostics-details):
../drivers/net/ethernet/mellanox/mlx4/alloc.c:691:47: error: array subscript -1
is below ar
On Thu, Feb 06, 2025 at 06:37:27PM -0800, Kees Cook wrote:
> On Thu, Feb 06, 2025 at 05:12:11PM -0800, Dave Hansen wrote:
> > On 2/6/25 17:00, Kees Cook wrote:
> > > +++ b/arch/x86/coco/tdx/tdx.c
> > > @@ -170,7 +170,7 @@ static void __noreturn tdx_panic(const char *msg)
> > > /* Define r
On 17/01/25 16:52, Jann Horn wrote:
> On Fri, Jan 17, 2025 at 4:25 PM Valentin Schneider
> wrote:
>> On 14/01/25 19:16, Jann Horn wrote:
>> > On Tue, Jan 14, 2025 at 6:51 PM Valentin Schneider
>> > wrote:
>> >> vunmap()'s issued from housekeeping CPUs are a relatively common source of
>> >> int
Hi Lorenzo,
Gentle ping for my clarification questions.
I also tried the new ioctl PROCMAP_QUERY, please see below for details.
On Wed, Jan 15, 2025 at 12:47 PM Jeff Xu wrote:
>
> Hi Lorenzo,
>
> On Thu, Jan 2, 2025 at 9:30 AM Lorenzo Stoakes
> wrote:
> >
> > Sorry for delay, was super busy le
On 25/02/10 05:08PM, Jeff Johnson wrote:
> On 2/9/2025 8:36 PM, Ethan Carter Edwards wrote:
>
> commit subject should be as specific as possible.
> suggest you at least mention the function
Will change. Thanks!
>
> > There is a possibility for an uninitialized *ret* variable to be
> > returned i
There is a possibility for an uninitialized *ret* variable to be
returned in some code paths.
This explicitly returns 0 without an error. Also removes goto that
returned *ret* and simply returns in place.
Closes:
https://scan5.scan.coverity.com/#/project-view/63541/10063?selectedIssue=1642337
Fi
On Mon, Feb 10, 2025 at 09:45:05AM -0800, Kees Cook wrote:
> GCC can see that the value range for "order" is capped, but this leads
> it to consider that it might be negative, leading to a false positive
> warning (with GCC 15 with -Warray-bounds -fdiagnostics-details):
>
> ../drivers/net/ethernet
On 2/3/25 10:03 PM, Gustavo A. R. Silva wrote:
> -Wflex-array-member-not-at-end was introduced in GCC-14, and we are
> getting ready to enable it, globally.
>
> So, in order to avoid ending up with a flexible-array member in the
> middle of other structs, we use the `struct_group_tagged()` helper
On Thu, 23 Jan 2025 22:11:11 +, Mel Gorman wrote:
> Changelog since v2
> o Default on
> o Logic correction and simplification
>
> Changelog since v1
> o Menu section rename
> o Make static branch usage similar to init_on_alloc
> o Change ordering of menu options
>
> [...]
Applied to for-next
n");
- max_mtu = 1500;
}
return max_mtu;
}
---
base-commit: febbc555cf0fff895546ddb8ba2c9a523692fb55
change-id: 20250210-otx2_common-453132aa0a24
Best regards,
--
Ethan Carter Edwards
On Mon, Feb 10, 2025 at 05:11:24PM -0800, Andrew Morton wrote:
> On Mon, 10 Feb 2025 16:31:28 -0800 Kees Cook wrote:
>
> > This is rebased to v6.14-rc2. I'll carry it and folks can send me new
> > tests, etc, as needed to minimize future collisions.
>
> Actually seems designed to maximize collis
From: Luis Felipe Hernandez
This patch is a follow-up task from a discussion stemming from point 3
in a recent patch introducing the int_pow kunit test [1] and
documentation regarding kunit test style and nomenclature [2].
Colocate all kunit test suites in lib/math/tests/ and
follow recommended
Following from the recent KUnit file naming discussion[1], move all
KUnit tests in lib/ into lib/tests/.
Link: https://lore.kernel.org/lkml/20240720165441.it.320-k...@kernel.org/ [1]
Acked-by: Steven Rostedt (Google)
Acked-by: Jakub Kicinski
Acked-by: Masami Hiramatsu (Google)
Reviewed-by: Davi
Hi,
This is rebased to v6.14-rc2. I'll carry it and folks can send me new
tests, etc, as needed to minimize future collisions.
v1: https://lore.kernel.org/lkml/20241011072509.3068328-2-david...@google.com/
Thanks!
-Kees
Bruno Sobreira França (1):
lib/math: Add int_log test suite
Diego Viei
From: Diego Vieira
Add KUnit tests for the kfifo data structure.
They test the vast majority of macros defined in the kfifo
header (include/linux/kfifo.h).
These are inspired by the existing tests for the doubly
linked list in lib/tests/list-test.c (previously at lib/list-test.c) [1].
Note that
From: Gabriela Bittencourt
Refactoring 'test' functions into kunit tests, to test utf-8 support in
unicode subsystem.
This allows the utf8 tests to be run alongside the KUnit test suite
using kunit-tool, quickly compiling and running all desired tests as
part of the KUnit test suite, instead of
From: Gabriela Bittencourt
Change utf8 kunit test filename and path to follow the style
convention on Documentation/dev-tools/kunit/style.rst
Co-developed-by: Pedro Orlando
Signed-off-by: Pedro Orlando
Co-developed-by: Danilo Pereira
Signed-off-by: Danilo Pereira
Signed-off-by: Gabriela Bitt
From: Bruno Sobreira França
This commit introduces KUnit tests for the intlog2 and intlog10
functions, which compute logarithms in base 2 and base 10, respectively.
The tests cover a range of inputs to ensure the correctness of these
functions across common and edge cases.
Signed-off-by: Bruno S
On Mon, Feb 10, 2025 at 7:36 PM Valentin Schneider wrote:
> What if isolated CPUs unconditionally did a TLBi as late as possible in
> the stack right before returning to userspace? This would mean that upon
> re-entering the kernel, an isolated CPU's TLB wouldn't contain any kernel
> range transla
> > >
> > > Addresses-Coverity-ID: 1642337 ("Uninitialized scalar variable")
> >
> > Is that an official kernel tag? IMO the proper tag would be
> So, it isn't "official" as far as I can tell, but it is widely used in
> other commits, especially by Gustavo Silva.
>
> Also:
> https://git.kernel.org
@@ -576,11 +579,14 @@ int tty_insert_flip_string_and_push_buffer(struct
tty_port *port,
void tty_buffer_init(struct tty_port *port)
{
struct tty_bufhead *buf = &port->buf;
+ struct tty_buffer *buf_sentinel;
+
+ buf_sentinel = container_of(&buf->sentinel, struct tty_buffer,
On Tue, 11 Feb 2025 at 08:31, Kees Cook wrote:
>
> Hi,
>
> This is rebased to v6.14-rc2. I'll carry it and folks can send me new
> tests, etc, as needed to minimize future collisions.
>
> v1:
> https://lore.kernel.org/lkml/20241011072509.3068328-2-david...@google.com/
>
> Thanks!
>
> -Kees
Than
t; mutex_lock(&pfvf->mbox.lock);
> @@ -1948,7 +1948,6 @@ u16 otx2_get_max_mtu(struct otx2_nic *pfvf)
> if (rc) {
> dev_warn(pfvf->dev,
>"Failed to get MTU from hardware setting default
> value(1500)\n");
> -
ommit: febbc555cf0fff895546ddb8ba2c9a523692fb55
change-id: 20250210-soc_sdw_rt_amp-e9c703ebe4dc
Best regards,
--
Ethan Carter Edwards
On 2/9/2025 8:36 PM, Ethan Carter Edwards wrote:
commit subject should be as specific as possible.
suggest you at least mention the function
> There is a possibility for an uninitialized *ret* variable to be
> returned in some code paths.
>
> This moves *ret* inside the conditional and explicitl
On Mon, 10 Feb 2025 16:31:28 -0800 Kees Cook wrote:
> This is rebased to v6.14-rc2. I'll carry it and folks can send me new
> tests, etc, as needed to minimize future collisions.
Actually seems designed to maximize collisions.
I'll drop ("lib/math: add Kunit test suite for gcd()")
https://lore.
35 matches
Mail list logo