On Wed, 29 Mar 2023 19:54:02 -0600, Gustavo A. R. Silva wrote:
> GCC-13 (and Clang) does not like having a partially allocated object,
> since it cannot reason about it for bounds checking.
>
> Notice that the compiler is legitimately complaining about accessing
> an object (params, in this case)
On Tue, Dec 5, 2023 at 8:10 AM Kees Cook wrote:
>
> On Tue, Dec 05, 2023 at 01:46:27AM +1000, Ronald Monthero wrote:
> > Cheers Kees,
> > BR,
> > ronald
>
> Is this a "Tested-by"? :)
Oh sorry Kees I have somehow missed this conversation.
Yes ack the tests which were earlier causing oops, now pass
"Gustavo A. R. Silva" wrote:
> Transform zero-length arrays `rate`, `adm_stat` and `msdu_cnt` into
> proper flexible-array members in anonymous union in `struct
> mt7996_mcu_all_sta_info_event` via the DECLARE_FLEX_ARRAY()
> helper; and fix multiple -Warray-bounds warnings:
>
> drivers/net/wirel
Structure declarations in 8250_pci1.c have been moved above
the functions for code readability.
Signed-off-by: Rengarajan S
---
drivers/tty/serial/8250/8250_pci1.c | 26 -
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/tty/serial/8250/8250
This patch series improves the UART performance in PCI1 from C0 rev
using burst mode operation. Each transaction processes DWORDs at a time
and the remaining bytes are handled byte-by-byte. With burst mode access
the baud rate support is extended from 1.5 Mbps to 3.9 Mbps.
v1
Initial Submissio
pci1_handle_irq reads the burst status and checks if the FIFO
is empty and is ready to accept the incoming data. The handling is
done in pci1_tx_burst where each transaction processes data in
block of DWORDs, while any remaining bytes are processed individually,
one byte at a time.
Signed-
In PCI1 C0 endpoint, support for Burst mode is added.
pci1_handle_irq checks the burst status and based on that
incoming characters are received in DWORDs, RX handling is done
in pci1_rx_burst. While reading the burst status the RX error
is checked and the corresponding error statistics
Different Host drivers can attempt to access system registers
simultaneously from different memory spaces at the same time. The
syslock mechanism provides a safe option for reading UART system
registers and prevents conflicts by serializing access. Added
three padding bytes in the structure for mem
On Thu, Dec 14, 2023 at 09:06:12PM +, tanz...@google.com wrote:
> This patch includes linux/kernel.h in asm/word-at-a-time.h for the
> sh architecture. WORD_AT_A_TIME_CONSTANTS depends on kernel.h.
> Making this implicit dependancy explicit allows for later improvements
> in the lib/string.c in
On Thu, Dec 14, 2023 at 09:06:13PM +, tanz...@google.com wrote:
> This diff uses an open source tool include-what-you-use (IWYU) to modify
> the include list changing indirect includes to direct includes.
> IWYU is implemented using the IWYUScripts github repository which is a tool
> that is
>
On 2023-12-12 23:51:30-0800, Luis Chamberlain wrote:
> On Tue, Dec 12, 2023 at 10:09:30AM +0100, Joel Granados wrote:
> > My idea was to do something similar to your originl RFC, where you have
> > an temporary proc_handler something like proc_hdlr_const (we would need
> > to work on the name) and
On Thu, Dec 14, 2023 at 06:43:47PM +, Arnd Bergmann wrote:
> On Thu, Dec 14, 2023, at 17:08, Thierry Reding wrote:
> > On Tue, Oct 17, 2023 at 10:53:14AM +0530, Kartik wrote:
> >> This series of patches add ACPI support for Tegra194 and Tegra234 in
> >> Tegra fuse and apbmisc drivers. It also a
On Fri, 15 Dec 2023, Thomas Weißschuh wrote:
> On 2023-12-12 23:51:30-0800, Luis Chamberlain wrote:
> > On Tue, Dec 12, 2023 at 10:09:30AM +0100, Joel Granados wrote:
> > > My idea was to do something similar to your originl RFC, where you have
> > > an temporary proc_handler something like proc
On 12/15/23 07:29, Kalle Valo wrote:
"Gustavo A. R. Silva" wrote:
Transform zero-length arrays `rate`, `adm_stat` and `msdu_cnt` into
proper flexible-array members in anonymous union in `struct
mt7996_mcu_all_sta_info_event` via the DECLARE_FLEX_ARRAY()
helper; and fix multiple -Warray-boun
On Fri, Dec 15, 2023 at 8:31 PM Tanzir Hasan wrote:
> On Fri, Dec 15, 2023 at 8:04 AM Andy Shevchenko wrote:
>> On Thu, Dec 14, 2023 at 09:06:12PM +, tanz...@google.com wrote:
...
>> > +#include
>>
>> I highly discourage from doing that. Instead, split what is needed to
>> the separate (ne
On Thu, Dec 14, 2023 at 09:04:00PM +, Al Viro wrote:
> drivers/firmware/arm_scmi/shmem.c:13:#include
Should just use linux/bug.h and be done with that.
> drivers/platform/x86/hp/hp-bioscfg/passwdobj-attributes.c:10:#include
>
Completely pointless; not to mention that none of the types de
16 matches
Mail list logo