On 18/10/2019 05:21, Ganapatrao Kulkarni wrote:
Hi Will,
On Thu, Oct 17, 2019 at 9:17 PM Will Deacon wrote:
On Thu, Oct 17, 2019 at 12:38:51PM +0530, Ganapatrao Kulkarni wrote:
On Wed, Oct 16, 2019 at 7:01 PM John Garry wrote:
+TX2_EVENT_ATTR(req_pktsent, CCPI2_EVENT_REQ_PKT_SENT);
+TX2_EV
Changes since v3:
- Init schedutil governor earlier too
- Simplified changes to thermal_init() error path
- Collects Acks
Changes since v2:
- Missed one patch when posting v2. Respinning.
Changes since v1:
- Completely get rid of netlink support in the thermal framework.
- This changes the early
There are no users of netlink messages for thermal inside the kernel.
Remove the code and adjust the documentation.
Signed-off-by: Amit Kucheria
Acked-by: Viresh Kumar
---
.../driver-api/thermal/sysfs-api.rst | 26 ++---
drivers/thermal/thermal_core.c| 101 +---
On Fri, Oct 18, 2019 at 2:08 PM John Garry wrote:
>
> On 18/10/2019 05:21, Ganapatrao Kulkarni wrote:
> > Hi Will,
> >
> > On Thu, Oct 17, 2019 at 9:17 PM Will Deacon wrote:
> >>
> >> On Thu, Oct 17, 2019 at 12:38:51PM +0530, Ganapatrao Kulkarni wrote:
> >>> On Wed, Oct 16, 2019 at 7:01 PM John G
Added sections on all the bind flags, libbpf, all the setsockopts and
all the getsockopts. Also updated the document to reflect the latest
features and to correct some spelling errors.
v1 -> v2:
* Updated XDP program with latest BTF map format
* Added one more FAQ entry
* Some minor edits and corr
Currently, FADump sysfs files are present inside /sys/kernel directory.
But as the number of FADump sysfs file increases it is not a good idea to
push all of them in /sys/kernel directory. It is better to have separate
directory to keep all the FADump sysfs files.
The patch series reorganizes the
Add the missing ABI documentation for the already available FADump
sysfs files.
Signed-off-by: Sourabh Jain
---
Documentation/ABI/testing/sysfs-kernel-fadump_enabled | 7 +++
Documentation/ABI/testing/sysfs-kernel-fadump_registered | 8
Documentation/ABI/testing/sysfs-kernel-fa
The /sys/kernel/fadump_* sysfs files are replicated under
/sys/kernel/fadump/ directory. But we need to keep the old
sysfs files to maintain the backward compatibility.
The sysfs files are scheduled to remove by 2021.
Signed-off-by: Sourabh Jain
---
.../sysfs-kernel-fadump_enabled
Add a sys interface to allow querying the memory reserved by FADump for
saving the crash dump.
Also added Documentation/ABI for the new sysfs file.
Signed-off-by: Sourabh Jain
---
Documentation/ABI/testing/sysfs-kernel-fadump| 7 +++
Documentation/powerpc/firmware-assisted-dump.rst |
As the number of FADump sysfs files increases it is hard to manage all of
them inside /sys/kernel directory. It's better to have all the FADump
related sysfs files in a dedicated directory /sys/kernel/fadump. But in
order to maintain the backward compatibility the /sys/kernel/fadump_*
sysfs files a
On Mon, 14 Oct 2019 21:50:02 +0800
Shaokun Zhang wrote:
> blk_init_queue has been removed since commit
> ("block: remove dead elevator code"), Let's cleanup the description
> in the biodoc.rst document.
>
> Cc: Jonathan Corbet
> Cc: Jens Axboe
> Signed-off-by: Shaokun Zhang
So I applied thi
On Fri, 4 Oct 2019 19:01:19 +0200
Jonathan Neuschäfer wrote:
> This makes the code snippet more readable.
>
> Signed-off-by: Jonathan Neuschäfer
> ---
> Documentation/driver-api/pti_intel_mid.rst | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/Documentation/driver
On Sat, 5 Oct 2019 22:01:22 +0200
Jonathan Neuschäfer wrote:
> ReST directives are introduced with two dots.
>
> Signed-off-by: Jonathan Neuschäfer
I've applied both of these, thanks.
jon
On Wed, 16 Oct 2019 22:13:37 +0200
Albert Vaca Cintora wrote:
> revious docs mentioned 11 unsigned long fields, when the reality is that
> we have 15 fields with a mix of unsigned long and unsigned int.
>
> Signed-off-by: Albert Vaca Cintora
> ---
> Documentation/admin-guide/iostats.rst | 47 +
This file tells us all about how 2.4 reported I/O statistics, which is less
than fully useful. Put a note at the top advising of this fact and
requesting some kind soul to bring things up to date.
Signed-off-by: Jonathan Corbet
---
I'm thinking about beginning to sprinkle these around Documenta
On Tue, Oct 15, 2019 at 10:20:02PM +0100, Mike Leach wrote:
> Update document to include the new sysfs features added during this
> patchset.
>
> Updated to reflect the new sysfs component nameing schema.
In most cases describing different actions in a changelog is a good indication
that more tha
On Tue, Oct 15, 2019 at 10:20:03PM +0100, Mike Leach wrote:
> There are two files in the Documentation/trace directory relating to
> coresight, with more to follow, so create a Documentation/trace/coresight
> directory and move existing files there. Update MAINTAINERS to reference
> this sub-direct
The following commit has been merged into the x86/asm branch of tip:
Commit-ID: ffedeeb780dc554eff3d3b16e6a462a26a41d7ec
Gitweb:
https://git.kernel.org/tip/ffedeeb780dc554eff3d3b16e6a462a26a41d7ec
Author:Jiri Slaby
AuthorDate:Fri, 11 Oct 2019 13:50:41 +02:00
Committer:
On Tue, Oct 15, 2019 at 06:56:51PM +0100, Mark Rutland wrote:
> Hi Steven,
>
> On Fri, Oct 11, 2019 at 01:59:21PM +0100, Steven Price wrote:
> > Introduce a paravirtualization interface for KVM/arm64 based on the
> > "Arm Paravirtualized Time for Arm-Base Systems" specification DEN 0057A.
>
> I n
On Tue, Oct 15, 2019 at 10:20:04PM +0100, Mike Leach wrote:
> Add in detailed programmers reference for users wanting to program the
> CoreSight ETM 4.x driver using sysfs.
>
> Signed-off-by: Mike Leach
> ---
> .../coresight/coresight-etm4x-reference.rst | 798 ++
> 1 file chan
On Fri, 18 Oct 2019 at 10:20, Mathieu Poirier
wrote:
>
> On Tue, Oct 15, 2019 at 10:20:03PM +0100, Mike Leach wrote:
> > There are two files in the Documentation/trace directory relating to
> > coresight, with more to follow, so create a Documentation/trace/coresight
> > directory and move existin
From: Boris Ostrovsky
[ Upstream commit c6875f3aacf2a5a913205accddabf0bfb75cac76 ]
Currently execution of panic() continues until Xen's panic notifier
(xen_panic_event()) is called at which point we make a hypercall that
never returns.
This means that any notifier that is supposed to be called
From: Boris Ostrovsky
[ Upstream commit c6875f3aacf2a5a913205accddabf0bfb75cac76 ]
Currently execution of panic() continues until Xen's panic notifier
(xen_panic_event()) is called at which point we make a hypercall that
never returns.
This means that any notifier that is supposed to be called
From: Boris Ostrovsky
[ Upstream commit c6875f3aacf2a5a913205accddabf0bfb75cac76 ]
Currently execution of panic() continues until Xen's panic notifier
(xen_panic_event()) is called at which point we make a hypercall that
never returns.
This means that any notifier that is supposed to be called
On Fri, Oct 18, 2019 at 11:33:40AM +0200, Magnus Karlsson wrote:
> +
> + #include
> + #include "bpf_helpers.h"
> +
> + #define MAX_SOCKS 16
> +
> + struct {
> +__uint(type, BPF_MAP_TYPE_XSKMAP);
> +__uint(max_entries, MAX_SOCKS);
> +__uint(key_size, sizeof(int));
>
25 matches
Mail list logo