[PATCH 3/4] cpu_cooling: Keep only one of_cpufreq*cooling_register() helper

2017-11-15 Thread Viresh Kumar
of_cpufreq_cooling_register() isn't used by anyone and so can be removed, but then we would be left with two routines: cpufreq_cooling_register() and of_cpufreq_power_cooling_register() that would look odd because of strange names. Remove current implementation of of_cpufreq_cooling_register() and

[PATCH 2/4] cpu_cooling: Remove unused cpufreq_power_cooling_register()

2017-11-15 Thread Viresh Kumar
It isn't used by anyone, drop it. Signed-off-by: Viresh Kumar --- Documentation/thermal/cpu-cooling-api.txt | 24 +++- drivers/thermal/cpu_cooling.c | 30 -- include/linux/cpu_cooling.h | 10 -- 3 files changed, 3

[PATCH 1/4] cpu_cooling: Make of_cpufreq_power_cooling_register() parse DT

2017-11-15 Thread Viresh Kumar
All the callers of of_cpufreq_power_cooling_register() have almost identical code and it makes more sense to move that code into the helper as its all about reading DT properties. This got rid of lot of redundant code. Signed-off-by: Viresh Kumar --- Documentation/thermal/cpu-cooling-api.txt |

Re: [PATCH v2] sched/deadline: fix runtime accounting in documentation

2017-11-15 Thread Peter Zijlstra
On Tue, Nov 14, 2017 at 12:19:26PM +0100, Claudio Scordino wrote: > Signed-off-by: Claudio Scordino > Signed-off-by: Luca Abeni > Acked-by: Daniel Bristot de Oliveira > CC: Jonathan Corbet > CC: "Peter Zijlstra (Intel)" > CC: Ingo Molnar > CC: linux-doc@vger.kernel.org > Cc: Tommaso Cucinotta

Re: git pull

2017-11-15 Thread Michael Ellerman
Linus Torvalds writes: > On Tue, Nov 14, 2017 at 1:33 PM, Tobin C. Harding wrote: >> >> Linus do you care what protocol? I'm patching Documentation and since >> the point is creating pull requests for you 'some people' don't matter. > > I actually tend to prefer the regular git:// protocol and s

Re: [PATCH v8 0/7] Support RAS virtualization in KVM

2017-11-15 Thread gengdongjiu
Hi James, Thank you very much for your comments and review. On 2017/11/15 0:00, James Morse wrote: > Hi Dongjiu Geng, > > On 10/11/17 19:54, Dongjiu Geng wrote: >> This series patches mainly do below things: >> >> 1. Trap RAS ERR* registers Accesses to EL2 from Non-secure EL1, >>KVM will w

Re: [PATCH v8 7/7] arm64: kvm: handle SError Interrupt by categorization

2017-11-15 Thread gengdongjiu
Hi James, Thanks a lot for the review. On 2017/11/15 0:00, James Morse wrote: > Hi Dongjiu Geng, > > On 10/11/17 19:54, Dongjiu Geng wrote: >> If it is not RAS SError, directly inject virtual SError, >> which will keep the old way. If it is RAS SError, firstly >> let host ACPI module to handl

Hello Dear...

2017-11-15 Thread M,Shakour Rosarita
Hello Dear... I know that this message will come to you as a surprise. I hoped that you will not expose or betray this trust and confident that I am about to repose on you, my name is M, Shakour Rosarita. I am 19 years old Girl, female, from Tartu Syria, (never married) 61 kg, white in complexion,

Re: [PATCH RFC v3 3/6] sched/idle: Add a generic poll before enter real idle path

2017-11-15 Thread Peter Zijlstra
On Mon, Nov 13, 2017 at 06:06:02PM +0800, Quan Xu wrote: > From: Yang Zhang > > Implement a generic idle poll which resembles the functionality > found in arch/. Provide weak arch_cpu_idle_poll function which > can be overridden by the architecture code if needed. No, we want less of those magic

Re: [PATCH RFC v3 0/6] x86/idle: add halt poll support

2017-11-15 Thread Peter Zijlstra
On Mon, Nov 13, 2017 at 07:01:40PM +0800, Quan Xu wrote: > Documentation/sysctl/kernel.txt | 35 > arch/x86/include/asm/paravirt.h |5 ++ > arch/x86/include/asm/paravirt_types.h |6 +++ > arch/x86/kernel/kvm.c | 73 > +++

Re: [PATCH] docs: add submitting-pull-requests.rst

2017-11-15 Thread Jani Nikula
On Wed, 15 Nov 2017, "Tobin C. Harding" wrote: > On Tue, Nov 14, 2017 at 04:48:16PM -0700, Jonathan Corbet wrote: > > Awesome comments Jon, I knew there would be more to writing docs than > first met the eye. > >> On Wed, 15 Nov 2017 09:54:21 +1100 >> "Tobin C. Harding" wrote: >> >> > There is c

Re: [PATCH v3 4/6] PM / core: Add helpers for subsystem callback selection

2017-11-15 Thread Rafael J. Wysocki
On Wed, Nov 15, 2017 at 8:43 AM, Ulf Hansson wrote: > On 12 November 2017 at 01:42, Rafael J. Wysocki wrote: >> From: Rafael J. Wysocki >> >> Add helper routines to find and return a suitable subsystem callback >> during the "noirq" phases of system suspend/resume (or analogous) >> transitions a

Re: [Xen-devel] [PATCH RFC v3 0/6] x86/idle: add halt poll support

2017-11-15 Thread Konrad Rzeszutek Wilk
On Mon, Nov 13, 2017 at 06:05:59PM +0800, Quan Xu wrote: > From: Yang Zhang > > Some latency-intensive workload have seen obviously performance > drop when running inside VM. The main reason is that the overhead > is amplified when running inside VM. The most cost I have seen is > inside idle pat

Re: [PATCH RFC v3 3/6] sched/idle: Add a generic poll before enter real idle path

2017-11-15 Thread Thomas Gleixner
On Wed, 15 Nov 2017, Peter Zijlstra wrote: > On Mon, Nov 13, 2017 at 06:06:02PM +0800, Quan Xu wrote: > > From: Yang Zhang > > > > Implement a generic idle poll which resembles the functionality > > found in arch/. Provide weak arch_cpu_idle_poll function which > > can be overridden by the archi

[PATCH v10 00/10] Application Data Integrity feature introduced by SPARC M7

2017-11-15 Thread Khalid Aziz
SPARC M7 processor adds additional metadata for memory address space that can be used to secure access to regions of memory. This additional metadata is implemented as a 4-bit tag attached to each cacheline size block of memory. A task can set a tag on any number of such blocks. Access to such bloc

[PATCH v10 10/10] sparc64: Add support for ADI (Application Data Integrity)

2017-11-15 Thread Khalid Aziz
ADI is a new feature supported on SPARC M7 and newer processors to allow hardware to catch rogue accesses to memory. ADI is supported for data fetches only and not instruction fetches. An app can enable ADI on its data pages, set version tags on them and use versioned addresses to access the data p

Re: [PATCH] docs: dev-tools: coccinelle: delete out of date wiki reference

2017-11-15 Thread Masahiro Yamada
2017-11-14 1:50 GMT+09:00 Julia Lawall : > The wiki is no longer available. > > Signed-off-by: Julia Lawall > > --- > > diff --git a/Documentation/dev-tools/coccinelle.rst > b/Documentation/dev-tools/coccinelle.rst > index 37e474f..94f41c2 100644 > --- a/Documentation/dev-tools/coccinelle.rst > +

[PATCH 2/2] Documentation: add UUID/GUID section to kernel-api

2017-11-15 Thread Randy Dunlap
From: Randy Dunlap Update kernel-doc notation in lib/uuid.c and then add UUID/GUID function interfaces to kernel-api. Signed-off-by: Randy Dunlap --- Documentation/core-api/kernel-api.rst |6 lib/uuid.c| 34 2 files changed, 23 in

[PATCH 1/2] Documentation: add Sorting section to kernel-api

2017-11-15 Thread Randy Dunlap
From: Randy Dunlap Add sort() and list_sort() to the kernel API documentation in a new "Sorting" section. Signed-off-by: Randy Dunlap --- Documentation/core-api/kernel-api.rst |9 + 1 file changed, 9 insertions(+) --- lnx-414.orig/Documentation/core-api/kernel-api.rst +++ lnx-414/

Re: [PATCHv3 1/1] locking/qspinlock/x86: Avoid test-and-set when PV_DEDICATED is set

2017-11-15 Thread Eduardo Valentin
Hey Radim, On Thu, Nov 09, 2017 at 03:17:33PM +0100, Radim Krčmář wrote: > > This is what I'm doubting, because the patch is adding about two > thousand cycles to every spinlock-taken path. > Doesn't this patch yield better results? > > diff --git a/arch/x86/kernel/kvm.c b/arch/x86/kernel/kvm