On Mon, Oct 16, 2017 at 03:12:35AM +0200, Rafael J. Wysocki wrote:
> Hi All,
>
> Well, this took more time than expected, as I tried to cover everything I had
> in mind regarding PM flags for drivers.
>
> This work was triggered by attempts to fix and optimize PM in the
> i2c-designware-platdev d
On 13 October 2017 at 15:25, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki
>
> Fix the kerneldoc comments of __device_suspend_noirq(),
> __device_suspend_late() and __device_suspend() where the function
> names in kerneldoc don't match the actual names of the functions.
>
> Also fix the devi
From: Changbin Du
The first one introduce new interfaces, the second one kills naming confusion.
The aim is to remove duplicated code and simplify transparent huge page
allocation.
Changbin Du (2):
mm, thp: introduce dedicated transparent huge page allocation
interfaces
mm: rename page d
From: Changbin Du
This patch introduced 4 new interfaces to allocate a prepared
transparent huge page.
- alloc_transhuge_page_vma
- alloc_transhuge_page_nodemask
- alloc_transhuge_page_node
- alloc_transhuge_page
The aim is to remove duplicated code and simplify transparent
huge page all
From: Changbin Du
The current name free_{huge,transhuge}_page are paired with
alloc_{huge,transhuge}_page functions, but the actual page free
function is still free_page() which will indirectly call
free_{huge,transhuge}_page. So this patch removes this confusion
by renaming all the compound page
On Thu, Oct 12, 2017 at 10:24 PM, Tom Saeger wrote:
> Signed-off-by: Tom Saeger
Patch applied.
Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-doc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/major
On Sat, 14 Oct 2017, "gre...@linuxfoundation.org"
wrote:
> And really, all news one should be in correct markdown format, as it is
> almost identical to a "normal" text file. Heck, it really is just a
> "plain" textfile, you can read it as-such, right?
*cough* reStructuredText *cough*
BR,
Jani
Hi Jonathan and Paul,
Please include these fixes before 4.14 final.
Thanks.
On 09/17/17 12:49, Paul E. McKenney wrote:
> On Sun, Sep 17, 2017 at 10:57:42AM -0700, Randy Dunlap wrote:
>> On 09/17/17 10:47, Paul E. McKenney wrote:
>>> On Sat, Sep 16, 2017 at 09:41:45PM -0700, Paul E. McKenney wrot
On Mon, Oct 16, 2017 at 12:58:28PM -0700, Randy Dunlap wrote:
> Hi Jonathan and Paul,
>
> Please include these fixes before 4.14 final.
Hello, Randy,
I currently have them queued up for the 4.15 merge window. Will that
work for you?
Thanx
On Mon, 16 Oct 2017, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki
>
> The motivation for this change is to provide a way to work around
> a problem with the direct-complete mechanism used for avoiding
> system suspend/resume handling for devices in runtime suspend.
>
> The problem is that
On 10/16/17 13:07, Paul E. McKenney wrote:
> On Mon, Oct 16, 2017 at 12:58:28PM -0700, Randy Dunlap wrote:
>> Hi Jonathan and Paul,
>>
>> Please include these fixes before 4.14 final.
>
> Hello, Randy,
>
> I currently have them queued up for the 4.15 merge window. Will that
> work for you?
They
On Mon, Oct 16, 2017 at 01:18:14PM -0700, Randy Dunlap wrote:
> On 10/16/17 13:07, Paul E. McKenney wrote:
> > On Mon, Oct 16, 2017 at 12:58:28PM -0700, Randy Dunlap wrote:
> >> Hi Jonathan and Paul,
> >>
> >> Please include these fixes before 4.14 final.
> >
> > Hello, Randy,
> >
> > I currently
On 10/16/17 13:26, Paul E. McKenney wrote:
> On Mon, Oct 16, 2017 at 01:18:14PM -0700, Randy Dunlap wrote:
>> On 10/16/17 13:07, Paul E. McKenney wrote:
>>> On Mon, Oct 16, 2017 at 12:58:28PM -0700, Randy Dunlap wrote:
Hi Jonathan and Paul,
Please include these fixes before 4.14 fina
On Mon, Oct 16, 2017 at 9:08 AM, Greg Kroah-Hartman
wrote:
> On Mon, Oct 16, 2017 at 03:12:35AM +0200, Rafael J. Wysocki wrote:
>> Hi All,
>>
>> Well, this took more time than expected, as I tried to cover everything I had
>> in mind regarding PM flags for drivers.
>>
>> This work was triggered by
On Monday, October 16, 2017 7:34:52 AM CEST Lukas Wunner wrote:
> On Mon, Oct 16, 2017 at 03:29:02AM +0200, Rafael J. Wysocki wrote:
> > + :c:func:`dev_pm_set_driver_flags` helper function.] If the first of
> > + tese flags is set, the PM core will not apply the direct-complete
> ^
>
On Monday, October 16, 2017 8:28:52 AM CEST Greg Kroah-Hartman wrote:
> On Mon, Oct 16, 2017 at 03:29:02AM +0200, Rafael J. Wysocki wrote:
> > struct dev_pm_info {
> > pm_message_tpower_state;
> > unsigned intcan_wakeup:1;
> > @@ -561,6 +580,7 @@ struct dev_pm_info
On Monday, October 16, 2017 8:31:22 AM CEST Greg Kroah-Hartman wrote:
> On Mon, Oct 16, 2017 at 03:29:02AM +0200, Rafael J. Wysocki wrote:
> > +static inline void dev_pm_set_driver_flags(struct device *dev, unsigned
> > int flags)
> > +{
> > + dev->power.driver_flags = flags;
> > +}
>
> Should
On Monday, October 16, 2017 10:16:15 PM CEST Alan Stern wrote:
> On Mon, 16 Oct 2017, Rafael J. Wysocki wrote:
>
> > From: Rafael J. Wysocki
> >
> > The motivation for this change is to provide a way to work around
> > a problem with the direct-complete mechanism used for avoiding
> > system sus
drivers/media/platform/rockchip/rga/rga-hw.c:383:6: warning: no previous
prototype for 'rga_cmd_set' [-Wmissing-prototypes]
void rga_cmd_set(struct rga_ctx *ctx)
^~~
drivers/media/platform/rockchip/rga/rga.c:359:17: warning: no previous
prototype for 'rga_fmt_find' [-Wmissing-proto
From: Randy Dunlap
There are some good comments about bitmap operations in lib/bitmap.c
and include/linux/bitmap.h, so format them for document generation and
pull them into core-api/kernel-api.rst.
I converted the "tables" of functions from using tabs to using spaces
so that they are more reada
On Mon, Oct 16, 2017 at 02:46:15PM -0700, Randy Dunlap wrote:
> On 10/16/17 13:26, Paul E. McKenney wrote:
> > On Mon, Oct 16, 2017 at 01:18:14PM -0700, Randy Dunlap wrote:
> >> On 10/16/17 13:07, Paul E. McKenney wrote:
> >>> On Mon, Oct 16, 2017 at 12:58:28PM -0700, Randy Dunlap wrote:
> Hi
21 matches
Mail list logo