gt;
> Signed-off-by: Mauro Carvalho Chehab
> Signed-off-by: Hans Verkuil
Same typo in my email.
> Reviewed-by: Ricardo Ribalda
> ---
> Documentation/driver-api/media/index.rst | 1 +
> .../media/maintainer-entry-profile.rst| 8 +
> .../driver
On 02/12/2024 10:26, Mauro Carvalho Chehab wrote:
> The media subsystem used to have a multi-commiter's model in the
> past, but things didn't go well on that time, and we had to move to
> a centralized model.
>
> As the community has evolved, and as there are now new policies in
> place like CoC,
gt;
>> Signed-off-by: Mauro Carvalho Chehab
>> Signed-off-by: Hans Verkuil
>> ---
>> Documentation/driver-api/media/index.rst | 1 +
>> .../media/maintainer-entry-profile.rst| 193 ++
>> .../driver-api/media/media-committer.rst
On 6/13/19 4:18 PM, Luca Ceresoli wrote:
> This sentence renders as:
>
>> Since such compound controls need to expose more information about
>> themselves than is possible with ioctls VIDIOC_QUERYCTRL,
>> VIDIOC_QUERY_EXT_CTRL and VIDIOC_QUERYMENU the VIDIOC_QUERY_EXT_CTRL
>
A quick follow-up:
On 01/08/2018 02:54 PM, Hans Verkuil wrote:
>> +/*
>> + * Videobuf operations
>> + */
>> +int dvb_vb2_init(struct dvb_vb2_ctx *ctx, const char *name, int nonblocking)
>> +{
>> +struct vb2_queue *q = &ctx->vb_q;
>> +i
Hi Mauro,
Thanks for this patch series, nice to see this moving forward.
Some comments below (note the wrong queue_setup code in particular since that
relates to my comment about the '[PATCH v3] media: videobuf2-core: don't go out
of the buffer range' patch).
On 12/21/2017 05:18 PM, Mauro Carval
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> Currently, there's no way to document #define foo
> with kernel-doc. So, convert it to an enum, and document.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Thanks,
Hans
> ---
> include/
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> This enum is already documented, but it is not using a kernel-doc
> format. Convert its format, in order to produce documentation.
>
> Signed-off-by: Mauro Carvalho Chehab
No, this does not belong in the kernel API doc. It is really just an inter
Nice! I have some small fixes and one little rewrite for the replace/merge
documentation:
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> Both v4l2-event.rst and v4l2-event.h have an overview of
> events, but there are some inconsistencies there:
>
> - at v4l2-event, the event's ringbuffer is c
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> The can_reduce_fps() is already documented, but it is not
> using the kernel-doc markup. Convert it, in order to generate
> documentation from it.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
> ---
>
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> There are several widely macros that aren't documented using kernel-docs
> markups.
>
> Add it.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards,
Hans
> ---
> incl
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> There are several ancillary functions that aren't documented.
s/ancillary/helper/g
>
> Document them.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> drivers/media/v4l2-core/v4l2-common.c | 14 -
> include/media/v4l2-common.h |
num_sizes;
> -};
> -
> -const struct v4l2_frmsize_discrete *v4l2_find_nearest_format(
> - const struct v4l2_discrete_probe *probe,
> - s32 width, s32 height);
> +const struct v4l2_frmsize_discrete
> +*v4l2_find_nea
On 09/27/17 23:46, Mauro Carvalho Chehab wrote:
> This struct is not used anymore. Get rid of it and update
> the documentation about what should still be converted.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
> ---
> include/media/v4l2-common.h | 14 +
More word-smithing...
On 10/10/2017 01:45 PM, Mauro Carvalho Chehab wrote:
> When we added support for omap3, back in 2010, we added a new
> type of V4L2 devices that aren't fully controlled via the V4L2
> device node.
>
> Yet, we have never clearly documented in the V4L2 specification
> the diff
More (mostly) small stuff:
On 10/10/2017 01:45 PM, Mauro Carvalho Chehab wrote:
> Add a glossary of terms for V4L2, as several concepts are complex
> enough to cause misunderstandings.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> Documentation/media/uapi/v4l/glossary.rst | 167
> ++
On 10/10/2017 10:20 AM, Mauro Carvalho Chehab wrote:
> Em Tue, 10 Oct 2017 09:47:13 +0200
> Hans Verkuil escreveu:
>
>> On 09/28/2017 12:23 AM, Mauro Carvalho Chehab wrote:
>>> Add a glossary of terms for V4L2, as several concepts are complex
>>> enough to cause
-specific
> controls.
Just to note that there is a pull request pending from me that
removes this from the cobalt driver. So once that's merged there
are only two drivers that do this.
Anyway:
Acked-by: Hans Verkuil
Regards,
Hans
>
> Signed-off-by: Mauro Carvalho Chehab
ces' configuration
> can be controlled via the :ref:`sub-device API `, which creates one
> device node per sub-device.
>
> +.. attention::
> +
> + Devices that require **MC-centric** media hardware control should
should -> shall
After that change you can add my:
On 09/28/2017 12:23 AM, Mauro Carvalho Chehab wrote:
> Add a glossary of terms for V4L2, as several concepts are complex
> enough to cause misunderstandings.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> Documentation/media/uapi/v4l/glossary.rst | 136
> ++
> Docu
On 09/10/17 12:19, Mauro Carvalho Chehab wrote:
> Convert #defines to enums and add kernel-doc markups for V4L2
> video_device flags.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards,
Hans
> ---
> include/media/v4l2-dev.h | 25
driver or at tvtuner.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Huh, I thought this header was nuked a long time ago...
Regards,
Hans
> ---
> drivers/media/i2c/tda7432.c | 1 -
> drivers/media/i2c/tvaudio.c | 2 --
> driver
On 09/10/17 12:19, Mauro Carvalho Chehab wrote:
> The V4L_DIR_* direction flags document the direction for a
> V4L2 device node. Convert them to enum and document.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards,
Hans
> ---
> include/med
On 09/10/17 12:19, Mauro Carvalho Chehab wrote:
> Some of the previously used I2C addresses there aren't used
> anymore. So, get rid of them.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards,
Hans
> ---
> include/media/i2c-addr.h | 7 --
On 09/10/17 12:19, Mauro Carvalho Chehab wrote:
> Using enums makes easier to document, as it can use kernel-doc
> markups. It also allows cross-referencing, with increases the
> kAPI readability.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards
ers
> are obsolete and in the process of cleanings, I opted to just
> keep the behavior, using an unsigned int inside those two
> drivers.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Nice cleanup.
Regards,
Hans
--
To unsubscribe from this l
On 09/10/17 12:23, Mauro Carvalho Chehab wrote:
> Despite the struct says "color16", it was actually using 32 bits
> for each color. Fix it.
>
> Suggested-by: Hans Verkuil
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Thanks!
Hans
> ---
omewhat public header!
>
> So rename them to:
> color -> tpg_rbg_color8
> color16 -> tpg_rbg_color16
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Thanks!
Hans
> ---
> drivers/media/common/v4l2-tpg/v4l2-tpg-colors.
gether. So, merge them.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Thanks!
Hans
> ---
> drivers/media/common/v4l2-tpg/v4l2-tpg-colors.c | 2 +-
> drivers/media/common/v4l2-tpg/v4l2-tpg-core.c | 2 +-
> drivers/media/platform/vimc/vimc-sensor.c
On 29/08/17 15:17, Mauro Carvalho Chehab wrote:
> Add a glossary of terms for V4L2, as several concepts are complex
> enough to cause misunderstandings.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> Documentation/media/uapi/v4l/glossary.rst | 150
> ++
> Documenta
On 29/08/17 10:31, Ramesh Shanmugasundaram wrote:
> Hi Hans,
>
>> On 28/08/17 12:30, Mauro Carvalho Chehab wrote:
>>> Em Mon, 28 Aug 2017 12:05:06 +0200
>>> Hans Verkuil escreveu:
>>>
>>>> On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
>
On 28/08/17 12:30, Mauro Carvalho Chehab wrote:
> Em Mon, 28 Aug 2017 12:05:06 +0200
> Hans Verkuil escreveu:
>
>> On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
>>> The documentation doesn't mention if vdev-centric hardware
>>> control would have subdev
On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
> The documentation doesn't mention if vdev-centric hardware
> control would have subdev API or not.
>
> Add a notice about that, reflecting the current status, where
> three drivers use it, in order to support some subdev-specific
> controls.
I pos
On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
> As both vdev-centric and MC-centric devices may implement the
> same APIs, we need a flag to allow userspace to distinguish
> between them.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> Documentation/media/uapi/v4l/open.rst| 7
On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
> As we now have a glossary, some terms used on open.rst
> require adjustments.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
Regards,
Hans
> ---
> Documentation/media/uapi/v4l/open.rst | 12
On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
> When we added support for omap3, back in 2010, we added a new
> type of V4L2 devices that aren't fully controlled via the V4L2
> device node.
>
> Yet, we have never clearly documented in the V4L2 specification
> the differences between the two type
gt; this is not relevant, as udev will take care of it.
>
> So, remove this useless misinformation.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by: Hans Verkuil
> ---
> Documentation/media/uapi/v4l/open.rst | 9 -
> 1 file changed, 4 insertions(+), 5 deletion
This is a partial review. I think I need to review the other patches first
before continuing this review. But it doesn't hurt to post this now.
On 26/08/17 13:53, Mauro Carvalho Chehab wrote:
> Add a glossary of terms for V4L2, as several concepts are complex
> enough to cause misunderstandings.
>
On 25/08/17 15:11, Laurent Pinchart wrote:
> Hi Mauro,
>
> Thank you for the patch.
>
> On Friday, 25 August 2017 12:40:05 EEST Mauro Carvalho Chehab wrote:
>> From: "mche...@s-opensource.com"
>>
>> When we added support for omap3, back in 2010, we added a new
>> type of V4L2 devices that aren't
On 25/08/17 14:52, Mauro Carvalho Chehab wrote:
> From: "mche...@s-opensource.com"
>
> When we added support for omap3, back in 2010, we added a new
> type of V4L2 devices that aren't fully controlled via the V4L2
> device node. Yet, we never made it clear, at the V4L2 spec,
> about the differenc
b-OmniVision._USB_Camera-B4.04.27.1-video-index0 ->
> ../../video0
> + └── by-path
> + └── pci-:00:14.0-usb-0:2:1.0-video-index0 -> ../../video0
> +
>
> Many drivers support "video_nr", "radio_nr" or "vbi_nr" module
>
On 25/08/17 13:35, Mauro Carvalho Chehab wrote:
> Em Fri, 25 Aug 2017 08:30:37 -0300
> Mauro Carvalho Chehab escreveu:
>
>> Em Fri, 25 Aug 2017 08:15:03 -0300
>> Mauro Carvalho Chehab escreveu:
>>
>>> Em Fri, 25 Aug 2017 12:56:30 +0200
>>> Hans
On 25/08/17 12:50, Mauro Carvalho Chehab wrote:
> Em Fri, 25 Aug 2017 12:42:51 +0200
> Hans Verkuil escreveu:
>
>> On 08/25/2017 12:35 PM, Mauro Carvalho Chehab wrote:
>>> Em Fri, 25 Aug 2017 12:13:53 +0200
>>> Hans Verkuil escreveu:
>>>
>>
On 08/25/2017 12:35 PM, Mauro Carvalho Chehab wrote:
> Em Fri, 25 Aug 2017 12:13:53 +0200
> Hans Verkuil escreveu:
>
>> On 08/25/2017 12:06 PM, Mauro Carvalho Chehab wrote:
>>> Em Fri, 25 Aug 2017 11:44:27 +0200
>>> Hans Verkuil escreveu:
>>>
&
On 25/08/17 11:40, Mauro Carvalho Chehab wrote:
> From: "mche...@s-opensource.com"
>
> When we added support for omap3, back in 2010, we added a new
> type of V4L2 devices that aren't fully controlled via the V4L2
> device node. Yet, we never made it clear, at the V4L2 spec,
> about the differenc
On 08/25/2017 12:06 PM, Mauro Carvalho Chehab wrote:
> Em Fri, 25 Aug 2017 11:44:27 +0200
> Hans Verkuil escreveu:
>
>> On 08/25/2017 11:40 AM, Mauro Carvalho Chehab wrote:
>>> From: Mauro Carvalho Chehab
>>>
>>> As both vdev-centric and mc-centric d
On 08/25/2017 11:40 AM, Mauro Carvalho Chehab wrote:
> From: Mauro Carvalho Chehab
>
> As both vdev-centric and mc-centric devices may implement the
> same APIs, we need a flag to allow userspace to distinguish
> between them.
>
> Signed-off-by: Mauro Carvalho Chehab
> Signed-off-by: Mauro Carv
On 24/08/17 14:07, Mauro Carvalho Chehab wrote:
> From: "mche...@s-opensource.com"
>
> When we added support for omap3, back in 2010, we added a new
> type of V4L2 devices that aren't fully controlled via the V4L2
> device node. Yet, we never made it clear, at the V4L2 spec,
> about the differenc
On 04/09/2017 12:56 PM, Mauro Carvalho Chehab wrote:
> The documentation incorrectly mentions MENU and INTEGER_MENU
> at struct v4l2_querymenu table as if they were flags. They're
> not: they're types.
>
> Signed-off-by: Mauro Carvalho Chehab
Reviewed-by: Hans Verkui
sferred per bus
sample), 1, 1.5 (encoded as 1_5) and 2.
With that additional change you can add my:
Acked-by: Hans Verkuil
Regards,
Hans
--
To unsubscribe from this list: send the line "unsubscribe linux-doc" in
the body of a message to majord...@vger.kernel.org
More majordo
On 03/17/2017 05:11 PM, Neil Armstrong wrote:
> On 03/16/2017 06:01 PM, Archit Taneja wrote:
>>
>>
>> On 3/7/2017 10:12 PM, Neil Armstrong wrote:
>>> Add documentation for added Bus Formats to describe RGB and YUS formats used
>>
>> s/YUS/YUV
>
> Thanks again
>
>>
>>> as input to the Synopsys
On 03/07/2017 05:42 PM, Neil Armstrong wrote:
> Add documentation for added Bus Formats to describe RGB and YUS formats used
> as input to the Synopsys DesignWare HDMI TX Controller.
>
> Signed-off-by: Neil Armstrong
> ---
> Documentation/media/uapi/v4l/subdev-formats.rst | 4992
> +
On 09/03/17 21:17, Mauro Carvalho Chehab wrote:
> drivers/media/platform/coda/coda-common.c: In function ‘coda_alloc_aux_buf’:
> ./include/linux/kern_levels.h:4:18: warning: format ‘%u’ expects argument of
> type ‘unsigned int’, but argument 4 has type ‘size_t {aka long unsigned int}’
> [-Wformat
On 03/09/2017 09:08 PM, Mauro Carvalho Chehab wrote:
> Currently, IMX_VDOA and VIDEO_CODA only builds on ARCH_MXC.
>
> That prevented me to build-test the driver, causing a bad patch
> to be applied, and to see other warnings on this driver.
Huh, must be the time of year. I just made a similar pa
ust precede a
> section header)
> Documentation/output/videodev2.h.rst:6: WARNING: undefined label:
> v4l2-in-st-no-std-lock (if the link has no caption the label must precede a
> section header)
>
> Fixes: ab6343956f9c ("[media] V4L2: Add documentation for SDI timings
On 08/19/2016 03:05 PM, Mauro Carvalho Chehab wrote:
There are some things there that aren't ok for ReST format.
Fix them.
Signed-off-by: Mauro Carvalho Chehab
OK, so I posted a similar patch for this:
https://patchwork.linuxtv.org/patch/36376/
It's part of one of my pull requests, but I g
On 07/18/2016 02:42 PM, Ricardo Ribalda Delgado wrote:
> Some hardware maps the Hue between 0 and 255 instead of 0-179. Support
> this format with a new field hsv_enc.
>
> Signed-off-by: Ricardo Ribalda Delgado
> ---
> include/uapi/linux/videodev2.h | 21 +++--
> 1 file changed,
On 07/18/2016 02:42 PM, Ricardo Ribalda Delgado wrote:
> Describe the hsv_enc field and its use.
>
> Signed-off-by: Ricardo Ribalda Delgado
> ---
> Documentation/media/uapi/v4l/pixfmt-002.rst| 12 ++-
> Documentation/media/uapi/v4l/pixfmt-003.rst| 14 ++--
> Documentation
On 08/05/2016 11:19 AM, Markus Heiser wrote:
> From: Markus Heiser
>
> Remove the distracting (left/right) padding of inline literals. (HTML
> ). Requested and discussed in [1].
>
> [1] http://www.spinics.net/lists/linux-media/msg103991.html
>
> Signed-off-by: Markus
On 07/27/2016 11:32 AM, Mauro Carvalho Chehab wrote:
> Now that all media documentation was converted to Sphinx, we
> should get rid of the old DocBook one, as we don't want people
> to submit patches against the old stuff.
>
> Signed-off-by: Mauro Carvalho Chehab
Acked-by
On 07/22/2016 04:07 PM, Ricardo Ribalda Delgado wrote:
> V4L2_CTRL_FLAG_VOLATILE behaviour when V4L2_CTRL_FLAG_EXECUTE_ON_WRITE
> is set was not properly explained.
>
> Reported-by: Dimitrios Katsaros
> Credit-to: Hans Verkuil
> Signed-off-by: Ricardo Ribalda Delgado
>
On 07/16/2016 12:41 PM, Ricardo Ribalda Delgado wrote:
> precalculate_color() had a optimization that avoided duplicated
> conversion for YUV formats. This optimization did not take into
> consideration YUV444, YUV555, YUV565 or limited range quantization.
>
> This patch keeps the optimization, bu
On 07/16/2016 12:41 PM, Ricardo Ribalda Delgado wrote:
> Replace is_yuv with color_enc Which can be used by other
> color encodings such us HSV.
>
> This change should ease the review of the following patches.
>
> Signed-off-by: Ricardo Ribalda Delgado
> ---
> drivers/media/common/v4l2-tpg/v4l2
On 07/08/2016 03:34 PM, Mauro Carvalho Chehab wrote:
> As commented on the patch series I just submitted, we finished the conversion
> of the Media uAPI book from DocBook to ReST.
>
> For now, I'm placing the new documentation, after parsed by Sphinx, at this
> place:
> https://mchehab.fedor
On 07/08/2016 03:02 PM, Mauro Carvalho Chehab wrote:
> That's the second series of patches related to DocBook to ReST
> conversion. With this patch series, we're ready to merge it
> upstream.
>
> There are still one thing to do: there are some new updates at
> the DocBook pages on two topic branch
Arnd
>>
>> [PATCH v2 1/2] samples: connector: from Documentation to samples
>> [PATCH v2 2/2] samples: v4l: from Documentation to samples directory
>
> I can take them through the docs tree.
>
> Hans [added], are you OK with moving v4l2-pci-skeleton.c over to
> t
Hi Markus,
On 04/08/16 17:12, Markus Heiser wrote:
> Hi kernel-doc authors,
>
> motivated by this MT, I implemented a toolchain to migrate the kernel’s
> DocBook XML documentation to reST markup.
>
> It converts 99% of the docs well ... to gain an impression how
> kernel-docs could benefit fr
On 02/18/16 13:04, Mauro Carvalho Chehab wrote:
> Em Thu, 18 Feb 2016 13:23:37 +0200
> Jani Nikula escreveu:
>
>> On Thu, 18 Feb 2016, Mauro Carvalho Chehab wrote:
>>> For simple documents like the one produced by kernel-doc, I guess
>>> all markup languages would work equally.
>>>
>>> The probl
On 02/18/16 11:19, Jani Nikula wrote:
> On Thu, 18 Feb 2016, Hans Verkuil wrote:
>> I looked at ReStructuredText and it looks like it will be a pain to convert
>> the media DocBook code to that, and the main reason is the poor table
>> support.
>> The syntax for that
Hi Jon,
On 02/17/2016 10:52 PM, Jonathan Corbet wrote:
> Hey, Mauro,
>
> There's been a conversation going on that I keep meaning to bring you
> into. In short, there's a fair amount of interest in improving our
> formatted kernel documentation, and, in particular, making it easier to
> write; I
70 matches
Mail list logo