[RFC PATCH 1/6] net: ethernet: ti: cpsw: use cpdma channels in backward order for txq

2018-05-18 Thread Ivan Khoronzhuk
The cpdma channel highest priority is from hi to lo number. The driver has limited number of descriptors that are shared between number of cpdma channels. Number of queues can be tuned with ethtool, that allows to not spend descriptors on not needed cpdma channels. In AVB usually only 2 tx queues c

[RFC PATCH 4/6] net: ethernet: ti: cpsw: add CBS Qdisc offload

2018-05-18 Thread Ivan Khoronzhuk
The cpsw has up to 4 FIFOs per port and upper 3 FIFOs can feed rate limited queue with shaping. In order to set and enable shaping for those 3 FIFOs queues the network device with CBS qdisc attached is needed. The CBS configuration is added for dual-emac/single port mode only, but potentially can b

[RFC PATCH 3/6] net: ethernet: ti: cpsw: add MQPRIO Qdisc offload

2018-05-18 Thread Ivan Khoronzhuk
That's possible to offload vlan to tc priority mapping with assumption sk_prio == L2 prio. Example: $ ethtool -L eth0 rx 1 tx 4 $ qdisc replace dev eth0 handle 100: parent root mqprio num_tc 3 \ map 2 2 1 0 2 2 2 2 2 2 2 2 2 2 2 2 queues 1@0 1@1 2@2 hw 1 $ tc -g class show dev eth0 +---(100:ffe2

[RFC PATCH 2/6] net: ethernet: ti: cpdma: fit rated channels in backward order

2018-05-18 Thread Ivan Khoronzhuk
According to TRM tx rated channels should be in 7..0 order, so correct it. Signed-off-by: Ivan Khoronzhuk --- drivers/net/ethernet/ti/davinci_cpdma.c | 31 - 1 file changed, 15 insertions(+), 16 deletions(-) diff --git a/drivers/net/ethernet/ti/davinci_cpdma.c b/drivers

[RFC PATCH 0/6] net: ethernet: ti: cpsw: add MQPRIO and CBS Qdisc offload

2018-05-18 Thread Ivan Khoronzhuk
This series adds MQPRIO and CBS Qdisc offload for TI cpsw driver. It potentially can be used in audio video bridging (AVB) and time sensitive networking (TSN). Patchset was tested on AM572x EVM and BBB boards. Last patch from this series adds detailed description of configuration with examples. Fo

[RFC PATCH 5/6] net: ethernet: ti: cpsw: restore shaper configuration while down/up

2018-05-18 Thread Ivan Khoronzhuk
Need to restore shapers configuration after interface was down/up. This is needed as appropriate configuration is still replicated in kernel settings. This only shapers context restore, so vlan configuration should be restored by user if needed, especially for devices with one port where vlan frame

[RFC PATCH 6/6] Documentation: networking: cpsw: add MQPRIO & CBS offload examples

2018-05-18 Thread Ivan Khoronzhuk
This document describes MQPRIO and CBS Qdisc offload configuration for cpsw driver based on examples. It potentially can be used in audio video bridging (AVB) and time sensitive networking (TSN). Signed-off-by: Ivan Khoronzhuk --- Documentation/networking/cpsw.txt | 540 +

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Eduardo Habkost
On Fri, May 18, 2018 at 07:18:57PM +0200, Paolo Bonzini wrote: > On 18/05/2018 19:13, Eduardo Habkost wrote: > >> As much as we'd like to be helpful and validate input, you need a real > >> time host too. I'm not sure how we'd find out - I suggest we do not > >> bother for now. > > I'm worried that

Re: [PATCH v2 3/7] memcg: use compound_order rather than hpage_nr_pages

2018-05-18 Thread Punit Agrawal
Punit Agrawal writes: > Tsukada-san, > > I am not familiar with memcg so can't comment about whether the patchset > is the right way to solve the problem outlined in the cover letter but > had a couple of comments about this patch. > > TSUKADA Koutaro writes: > >> The current memcg implementatio

Re: [PATCH v2 3/7] memcg: use compound_order rather than hpage_nr_pages

2018-05-18 Thread Punit Agrawal
Tsukada-san, I am not familiar with memcg so can't comment about whether the patchset is the right way to solve the problem outlined in the cover letter but had a couple of comments about this patch. TSUKADA Koutaro writes: > The current memcg implementation assumes that the compound page is TH

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Paolo Bonzini
On 18/05/2018 19:13, Eduardo Habkost wrote: >> As much as we'd like to be helpful and validate input, you need a real >> time host too. I'm not sure how we'd find out - I suggest we do not >> bother for now. > I'm worried that people will start enabling the flag in all kinds > of scenarios where th

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Paolo Bonzini
On 18/05/2018 18:04, Eduardo Habkost wrote: >> Without mlock you should always use pv spinlocks. >> >> Otherwise you risk blocking on a lock taken by >> a VCPU that is in turn blocked on IO, where the IO >> is not completing because CPU is being used up >> spinning. > > So the stronger guarantee se

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Eduardo Habkost
On Fri, May 18, 2018 at 08:01:49PM +0300, Michael S. Tsirkin wrote: > On Fri, May 18, 2018 at 01:04:31PM -0300, Eduardo Habkost wrote: > > CCing qemu-devel, as I'm now discussing userspace. > > > > On Thu, May 17, 2018 at 10:55:33PM +0300, Michael S. Tsirkin wrote: > > > On Thu, May 17, 2018 at 03

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Eduardo Habkost
CCing qemu-devel, as I'm now discussing userspace. On Thu, May 17, 2018 at 10:55:33PM +0300, Michael S. Tsirkin wrote: > On Thu, May 17, 2018 at 03:46:58PM -0300, Eduardo Habkost wrote: > > On Thu, May 17, 2018 at 05:54:24PM +0300, Michael S. Tsirkin wrote: > > > HINTS_DEDICATED seems to be somewh

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Michael S. Tsirkin
On Fri, May 18, 2018 at 01:04:31PM -0300, Eduardo Habkost wrote: > CCing qemu-devel, as I'm now discussing userspace. > > On Thu, May 17, 2018 at 10:55:33PM +0300, Michael S. Tsirkin wrote: > > On Thu, May 17, 2018 at 03:46:58PM -0300, Eduardo Habkost wrote: > > > On Thu, May 17, 2018 at 05:54:24P

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Michael S. Tsirkin
On Fri, May 18, 2018 at 11:41:23AM +0200, Paolo Bonzini wrote: > On 17/05/2018 20:46, Eduardo Habkost wrote: > > My understanding of the original patch is that the intention is > > to tell the guest that it is very unlikely to be preempted, so it > > can choose a more appropriate spinlock implement

Re: [PATCH v5 2/2] ThunderX2: Add Cavium ThunderX2 SoC UNCORE PMU driver

2018-05-18 Thread Ganapatrao Kulkarni
On Thu, May 17, 2018 at 4:42 PM, John Garry wrote: > On 16/05/2018 05:55, Ganapatrao Kulkarni wrote: >> >> This patch adds a perf driver for the PMU UNCORE devices DDR4 Memory >> Controller(DMC) and Level 3 Cache(L3C). >> > > Hi, > > Just some coding comments below: > >> ThunderX2 has 8 independen

Re: [PATCH] kvm: rename HINTS_DEDICATED to KVM_HINTS_REALTIME

2018-05-18 Thread Paolo Bonzini
On 17/05/2018 20:46, Eduardo Habkost wrote: > My understanding of the original patch is that the intention is > to tell the guest that it is very unlikely to be preempted, so it > can choose a more appropriate spinlock implementation. This > description implies that the guest will never be preempt