On Wed, 14 Feb 2018, Jonathan Corbet wrote:
> It can be useful to put code snippets into kerneldoc comments; that can be
> done with the "::" operator at the end of a line like this::
>
>if (desperate)
>run_in_circles();
>
> The ".. code-block::" directive can also be used to this end.
On Wed, 14 Feb 2018, Jonathan Corbet wrote:
> XML escaping is a worry that came with DocBook, which we no longer have any
> dealings with. So get rid of the useless xml_escape()/xml_unescape()
> functions. No change to the generated output.
>
> Signed-off-by: Jonathan Corbet
Reviewed-by: Jani
Begin the process of splitting up the nearly 500-line process_file()
function by moving STATE_NORMAL processing to a separate function.
Reviewed-by: Jani Nikula
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 21 -
1 file changed, 16 insertions(+), 5 deletions(-)
di
XML escaping is a worry that came with DocBook, which we no longer have any
dealings with. So get rid of the useless xml_escape()/xml_unescape()
functions. No change to the generated output.
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 65
STATE_FIELD describes a parser state that can handle any part of a
kerneldoc comment body; rename it to STATE_BODY to reflect that.
The $in_purpose variable was a hidden substate of STATE_FIELD; get rid of
it and make a proper state (STATE_BODY_MAYBE) instead. This will make the
subsequent proces
Move this code out of process_file() in the name of readability and
maintainability.
Reviewed-by: Jani Nikula
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 137 -
1 file changed, 72 insertions(+), 65 deletions(-)
diff --git a/script
Also group the pseudo-global $leading_space variable with its peers.
Reviewed-by: Jani Nikula
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 193 -
1 file changed, 101 insertions(+), 92 deletions(-)
diff --git a/scripts/kernel-doc b/
Move the top-level prototype-processing code out of process_file().
Reviewed-by: Jani Nikula
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 46 --
1 file changed, 28 insertions(+), 18 deletions(-)
diff --git a/scripts/kernel-doc b/scripts/ke
It can be useful to put code snippets into kerneldoc comments; that can be
done with the "::" operator at the end of a line like this::
if (desperate)
run_in_circles();
The ".. code-block::" directive can also be used to this end. kernel-doc
currently fails to understand these literal
Move STATE_INLINE and STATE_DOCBLOCK code out of process_file(), which now
actually fits on a single screen. Delete an unused variable and add a
couple of comments while I'm at it.
Reviewed-by: Jani Nikula
Signed-off-by: Jonathan Corbet
---
scripts/kernel-doc | 139
So once upon a time I set out to fix the problem reported by Tobin wherein
a literal block within a kerneldoc comment would be corrupted in
processing. On the way, though, I got annoyed at the way I have to learn
how kernel-doc works from the beginning every time I tear into it.
As a result, seve
On Wed, 14 Feb 2018, Mauro Carvalho Chehab wrote:
> There is a simple fix, though. Make inline comments to accept a dot:
>
> diff --git a/scripts/kernel-doc b/scripts/kernel-doc
> index fee8952037b1..06d7f3f2c094 100755
> --- a/scripts/kernel-doc
> +++ b/scripts/kernel-doc
> @@ -363,7 +363,7 @@ my
Em Wed, 14 Feb 2018 18:07:03 +0200
Jani Nikula escreveu:
> On Mon, 18 Dec 2017, Mauro Carvalho Chehab wrote:
> > It is possible to use nested structs like:
> >
> > struct {
> > struct {
> > void *arg1;
> > } st1, st2, *st3, st4;
> > };
> >
> > Handling it requires to split ea
In the description of data dependency barriers the words 'before' is
used erroneously. Since such barrier order dependent loads one after
the other. So substitute 'before' with 'after'.
Signed-off-by: Nikolay Borisov
---
Resent due to missing out the various mailing lists doh ...
Documentati
> Am 07.02.2018 um 18:26 schrieb Jonathan Corbet :
>
> It can be useful to put code snippets into kerneldoc comments; that can be
> done with the "::" operator at the end of a line like this::
>
> if (desperate)
> run_in_circles();
>
> kernel-doc currently fails to understand these litera
On Mon, 18 Dec 2017, Mauro Carvalho Chehab wrote:
> It is possible to use nested structs like:
>
> struct {
> struct {
> void *arg1;
> } st1, st2, *st3, st4;
> };
>
> Handling it requires to split each parameter. Change the logic
> to allow such definitions.
>
> In order
On Fri, Jan 26, 2018 at 08:15:32PM +0100, Corentin Labbe wrote:
> This patch convert the driver to the new crypto engine API.
>
> Signed-off-by: Corentin Labbe
Acked-by: Michael S. Tsirkin
Pls queue when/if rest of changes go in.
> ---
> drivers/crypto/virtio/virtio_crypto_algs.c | 16
Adding my tested-by for the AEAD part which is new in v2
On 26/01/18 20:15, Corentin Labbe wrote:
> The crypto engine could actually only enqueue hash and ablkcipher request.
> This patch permit it to enqueue any type of crypto_async_request.
>
> Signed-off-by: Corentin Labbe
> Tested-by: Fabien
On Sat, Jan 13, 2018 at 6:35 AM, Karthikeyan Ramasubramanian
wrote:
> This driver manages the Generic Interface (GENI) firmware based Qualcomm
> Universal Peripheral (QUP) Wrapper. GENI based QUP is the next generation
> programmable module composed of multiple Serial Engines (SE) and supports
> a
On Sat, Jan 13, 2018 at 6:35 AM, Karthikeyan Ramasubramanian
wrote:
> This driver supports GENI based UART Controller in the Qualcomm SOCs. The
> Qualcomm Generic Interface (GENI) is a programmable module supporting a
> wide range of serial interfaces including UART. This driver support console
>
On Wed, 14 Feb 2018, Michal Hocko wrote:
> I do not have any objections regarding the extension. What I am more
> interested in is _why_ people are still using this command line
> parameter at all these days. Why would anybody want to introduce lowmem
> issues from 32b days. I can see the CMA/Hotp
On Mon 12-02-18 16:24:25, David Rientjes wrote:
> Both kernelcore= and movablecore= can be used to define the amount of
> ZONE_NORMAL and ZONE_MOVABLE on a system, respectively. This requires
> the system memory capacity to be known when specifying the command line,
> however.
>
> This introduces
On Wed, Feb 14, 2018 at 10:17 AM, Bhupesh SHARMA
wrote:
> On Wed, Feb 14, 2018 at 2:32 PM, Gi-Oh Kim wrote:
>> On Wed, Feb 14, 2018 at 2:43 AM, Dave Young wrote:
>>> Hi,
>>> On 02/13/18 at 04:22pm, Gioh Kim wrote:
Jumping between the system kernel and the dump-capture kernel
has been s
On Tue, Feb 13, 2018 at 07:55:17PM +0100, Juri Lelli wrote:
> Hi,
>
> a couple of patches to lockdep docs.
>
> First one is a small fix for that fact that Peter made documentation
> stale (as usual :P).
>
> Second one is an RFC. I thought that adding some info about lockdep
> asserts might help
On Wed, Feb 14, 2018 at 2:32 PM, Gi-Oh Kim wrote:
> On Wed, Feb 14, 2018 at 2:43 AM, Dave Young wrote:
>> Hi,
>> On 02/13/18 at 04:22pm, Gioh Kim wrote:
>>> Jumping between the system kernel and the dump-capture kernel
>>> has been supported for long time but there is no description
>>> how to us
On Wed, Feb 14, 2018 at 2:43 AM, Dave Young wrote:
> Hi,
> On 02/13/18 at 04:22pm, Gioh Kim wrote:
>> Jumping between the system kernel and the dump-capture kernel
>> has been supported for long time but there is no description
>> how to use it. This patch adds the description how to use kexec too
26 matches
Mail list logo