Re: [PATCH] docs: Remove "could not extract kernel version" warning

2017-12-11 Thread Jani Nikula
On Mon, 11 Dec 2017, Randy Dunlap wrote: > On 12/11/2017 02:24 PM, Jonathan Corbet wrote: >> This warning will happen for every normal kernel docs build and doesn't >> carry any useful information. Should anybody actually depend on this >> "version" variable (which isn't clear to me), the "unknow

[PATCH v2] arm64: v8.4: Support for new floating point multiplication instructions

2017-12-11 Thread Dongjiu Geng
ARM v8.4 extensions add new neon instructions for performing a multiplication of each FP16 element of one vector with the corresponding FP16 element of a second vector, and to add or subtract this without an intermediate rounding to the corresponding FP32 element in a third vector. This patch dete

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread gengdongjiu
On 2017/12/12 2:58, Suzuki K Poulose wrote: > Hi gengdongjiu > > Sorry for the late response. I have a similar patch to add the support for > "FHM", which I was about to post it this week. Suzuki, you are welcome. May be you can not post again to avoid the duplicate review, thanks! > > On 11/12

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread gengdongjiu
On 2017/12/11 21:29, Dave Martin wrote: >> Thanks for the point out. >> In fact, this feature only adds two instructions: >> FP16 * FP16 + FP32 >> FP16 * FP16 - FP32 >> >> The spec call this bit to ID_AA64ISAR0_EL1.FHM, I do not know why it >> will call "FHM", I think call it "FMLXL" may be bette

[PATCH v10 00/13] Introduce framework for SLIMbus device driver

2017-12-11 Thread srinivas . kandagatla
From: Srinivas Kandagatla SLIMbus (Serial Low Power Interchip Media Bus) is a specification developed by MIPI (Mobile Industry Processor Interface) alliance. SLIMbus is a 2-wire implementation, which is used to communicate with peripheral components like audio-codec. SLIMbus uses Time-Division-Mu

[PATCH v10 02/13] dt-bindings: Add SLIMbus bindings

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia SLIMbus (Serial Low Power Interchip Media Bus) is a specification developed by MIPI (Mobile Industry Processor Interface) alliance. SLIMbus is a 2-wire implementation, which is used to communicate with peripheral components like audio-codec. This patch adds device tree binding

[PATCH v10 08/13] regmap: add SLIMbus support

2017-12-11 Thread srinivas . kandagatla
From: Srinivas Kandagatla This patch adds support to read/write SLIMbus value elements. Currently it only supports byte read/write. Adding this support in regmap would give codec drivers more flexibility when there are more than 2 control interfaces like SLIMbus, i2c. Without this patch each cod

[PATCH v10 01/13] Documentation: Add SLIMbus summary

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia SLIMbus (Serial Low Power Interchip Media Bus) is a specification developed by MIPI (Mobile Industry Processor Interface) alliance. SLIMbus is a 2-wire implementation, which is used to communicate with peripheral components like audio-codec. The summary of SLIMbus and API is d

[PATCH v10 06/13] slimbus: Add messaging APIs to slimbus framework

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia SLIMbus devices use value-element, and information elements to control device parameters (e.g. value element is used to represent gain for codec, information element is used to represent interrupt status for codec when codec interrupt fires). Messaging APIs are used to set/get

[PATCH v10 07/13] slimbus: Add support for 'clock-pause' feature

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia Per SLIMbus specification, a reconfiguration sequence known as 'clock pause' needs to be broadcast over the bus while entering low- power mode. Clock-pause is initiated by the controller driver. To exit clock-pause, controller typically wakes up the framer device. Since wakeup

[PATCH v10 10/13] dt-bindings: Add qcom slimbus controller bindings

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia This patch add device tree bindings for Qualcomm slimbus controller. Signed-off-by: Sagar Dharia Signed-off-by: Srinivas Kandagatla Reviewed-by: Rob Herring --- .../devicetree/bindings/slimbus/slim-qcom-ctrl.txt | 39 ++ 1 file changed, 39 insertions(+)

[PATCH v10 04/13] slimbus: core: Add slim controllers support

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia This patch adds support to slim controllers in the slim core, including some utility functions invoked by the controller and slim device drivers. Signed-off-by: Srinivas Kandagatla --- drivers/slimbus/core.c| 306 ++ drivers/sl

[PATCH v10 05/13] slimbus: core: add support to device tree helper

2017-12-11 Thread srinivas . kandagatla
From: Srinivas Kandagatla This patch adds support to parse slim devices from device tree. Signed-off-by: Srinivas Kandagatla --- drivers/slimbus/core.c | 50 ++ 1 file changed, 50 insertions(+) diff --git a/drivers/slimbus/core.c b/drivers/slimb

[PATCH v10 09/13] slimbus: core: add common defines required for controllers

2017-12-11 Thread srinivas . kandagatla
From: Srinivas Kandagatla This patch adds some common constant defines which are required for qcom slim controller driver. Signed-off-by: Srinivas Kandagatla --- drivers/slimbus/slimbus.h | 33 + 1 file changed, 33 insertions(+) diff --git a/drivers/slimbus/sli

[PATCH v10 11/13] slimbus: qcom: Add Qualcomm Slimbus controller driver

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia This controller driver programs manager, interface, and framer devices for Qualcomm's slimbus HW block. Manager component currently implements logical address setting, and messaging interface. Interface device reports bus synchronization information, and framer device clocks th

[PATCH v10 03/13] slimbus: Add SLIMbus bus type

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia SLIMbus (Serial Low Power Interchip Media Bus) is a specification developed by MIPI (Mobile Industry Processor Interface) alliance. SLIMbus is a 2-wire implementation, which is used to communicate with peripheral components like audio-codec. SLIMbus uses Time-Division-Multiplex

[PATCH v10 13/13] MAINTAINERS: Add SLIMbus maintainer

2017-12-11 Thread srinivas . kandagatla
From: Srinivas Kandagatla Add myself as maintainer for slimbus. Signed-off-by: Srinivas Kandagatla Acked-by: Bjorn Andersson --- MAINTAINERS | 8 1 file changed, 8 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index aa71ab52fd76..f26bf2707709 100644 --- a/MAINTAINERS +++ b/MA

[PATCH v10 12/13] slimbus: qcom: Add runtime-pm support using clock-pause

2017-12-11 Thread srinivas . kandagatla
From: Sagar Dharia Slimbus HW mandates that clock-pause sequence has to be executed before disabling relevant interface and core clocks. Runtime-PM's autosuspend feature is used here to enter/exit low power mode for Qualcomm's Slimbus controller. Autosuspend feature enables driver to avoid changi

Re: [PATCH v9 01/13] Documentation: Add SLIMbus summary

2017-12-11 Thread Jonathan Corbet
On Thu, 7 Dec 2017 23:22:51 + Srinivas Kandagatla wrote: > > It seems you have kerneldoc comments for your data structures and at least > > some of your exported symbols. If you really want to document this stuff > > well, I'd suggest finishing out those comments, then pulling them into the

Re: [PATCH] i2c: update i2c-dev.h warning in documentation

2017-12-11 Thread Jonathan Corbet
On Sat, 9 Dec 2017 23:10:58 +0300 Cengiz Can wrote: > `dev-interface` document gives examples for accessing i2c from > userspace. > > There's a note warning developers about the different `i2c-dev.h` header > files which were shipped with the kernel and i2c-tools separately. > > However, these

Re: [PATCH] docs: Remove "could not extract kernel version" warning

2017-12-11 Thread Randy Dunlap
On 12/11/2017 02:24 PM, Jonathan Corbet wrote: > This warning will happen for every normal kernel docs build and doesn't > carry any useful information. Should anybody actually depend on this > "version" variable (which isn't clear to me), the "unknown version" value > will be clue enough. Yay.

[PATCH] docs: Remove "could not extract kernel version" warning

2017-12-11 Thread Jonathan Corbet
This warning will happen for every normal kernel docs build and doesn't carry any useful information. Should anybody actually depend on this "version" variable (which isn't clear to me), the "unknown version" value will be clue enough. Signed-off-by: Jonathan Corbet --- Documentation/conf.py |

Re: [PATCH] docs: refcount_t documentation

2017-12-11 Thread Kees Cook
On Mon, Dec 11, 2017 at 1:42 PM, Jonathan Corbet wrote: > On Tue, 5 Dec 2017 12:46:35 +0200 > Elena Reshetova wrote: > >> Some functions from refcount_t API provide different >> memory ordering guarantees that their atomic counterparts. >> This adds a document outlining these differences ( >> Do

Re: [PATCH 0/2] Documentation: Add guidance on CONFIG default value

2017-12-11 Thread Jonathan Corbet
On Mon, 20 Nov 2017 14:39:32 -0800 Darren Hart wrote: > Document the preference for "default n" in kconfig-language.txt, and reference > that in the submit-checklist.rst. I've (finally) applied the pair to the docs tree, thanks. jon -- To unsubscribe from this list: send the line "unsubscribe l

Re: [PATCH 2/2 v2] Documentation: add UUID/GUID to kernel-api

2017-12-11 Thread Jonathan Corbet
On Wed, 29 Nov 2017 12:32:42 -0800 Randy Dunlap wrote: > From: Randy Dunlap > > Update kernel-doc notation in lib/uuid.c and then add UUID/GUID > function interfaces to kernel-api. > > Signed-off-by: Randy Dunlap Applied to the docs tree. While I was at it... > + * uuid_is_valid - checks i

Re: [PATCH 1/2 v2] Documentation: add Sorting section to kernel-api

2017-12-11 Thread Jonathan Corbet
On Wed, 29 Nov 2017 12:32:38 -0800 Randy Dunlap wrote: > Add sort() and list_sort() to the kernel API documentation in a > new "Sorting" section. > > Signed-off-by: Randy Dunlap Applied to the docs tree, thanks. jon -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in th

Re: [PATCH 0/2] mux: add overview and add to driver-api docs

2017-12-11 Thread Jonathan Corbet
On Mon, 11 Dec 2017 09:29:41 +0100 Peter Rosin wrote: > Don't know if this is worth adding, but it might answer at least a few > questions. > > It looks ok when I view the htmldocs output, but I'm not all that certain > this is good to go? Almost, but I have one request: the new mux.rst file is

Re: [PATCH] docs: refcount_t documentation

2017-12-11 Thread Jonathan Corbet
On Tue, 5 Dec 2017 12:46:35 +0200 Elena Reshetova wrote: > Some functions from refcount_t API provide different > memory ordering guarantees that their atomic counterparts. > This adds a document outlining these differences ( > Documentation/core-api/refcount-vs-atomic.rst) as well as > some oth

Re: [PATCH] Documentation/driver-api/usb: Replace dead link

2017-12-11 Thread Jonathan Corbet
On Fri, 8 Dec 2017 01:12:09 +0100 Stefan Tatschner wrote: > This link is dead: > > $ curl -vI http://usb.cs.tum.edu/usbdoc > * Could not resolve host: usb.cs.tum.edu > * Closing connection 0 > curl: (6) Could not resolve host: usb.cs.tum.edu > > I found the document somewhere e

Re: [PATCH v2] kernel-doc: parse DECLARE_KFIFO and DECLARE_KFIFO_PTR()

2017-12-11 Thread Jonathan Corbet
On Fri, 8 Dec 2017 09:05:12 -0500 Mauro Carvalho Chehab wrote: > So, teach kernel-doc how to parse DECLARE_KFIFO() and DECLARE_KFIFO_PTR(). > > While here, relax at the past DECLARE_foo() macros, accepting a random > number of spaces after comma. Applied, thanks. jon -- To unsubscribe from th

Re: [PATCH] Documentation: kernel-hacking: corrected a typo

2017-12-11 Thread Jonathan Corbet
On Fri, 8 Dec 2017 19:10:54 +0100 Marco Donato Torsello wrote: > Corrected a typo. > > Signed-off-by: Marco Donato Torsello > --- > Documentation/kernel-hacking/hacking.rst | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied to the docs tree, thanks. jon -- To unsubscribe from t

Re: [PATCH] Documentation: mono: Update links and s/CVS/Git/

2017-12-11 Thread Jonathan Corbet
On Sat, 9 Dec 2017 17:21:04 +0100 Jonathan Neuschäfer wrote: > The URLs in mono.rst redirect to pages on www.mono-project.com, so let's > update them. I took the liberty to update the compilation instructions > to the Linux-specific version, because readers of the kernel > documentation will mos

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread Suzuki K Poulose
Hi gengdongjiu Sorry for the late response. I have a similar patch to add the support for "FHM", which I was about to post it this week. On 11/12/17 13:29, Dave Martin wrote: On Mon, Dec 11, 2017 at 08:47:00PM +0800, gengdongjiu wrote: On 2017/12/11 19:59, Dave P Martin wrote: On Sat, Dec

Re: [PATCH] doc: convert printk-formats.txt to rst

2017-12-11 Thread Laura Abbott
On 12/08/2017 10:33 PM, Tobin C. Harding wrote: [Adding Laura] On Fri, Dec 08, 2017 at 06:18:45PM -0800, Joe Perches wrote: On Sat, 2017-12-09 at 12:27 +1100, Tobin C. Harding wrote: On Fri, Dec 08, 2017 at 01:22:37PM -0800, Joe Perches wrote: Outside of the documentation, what could be use

[PATCH v2 2/2] acpi, x86: Use SPCR table for earlycon on x86

2017-12-11 Thread Prarit Bhargava
The ACPI SPCR code has been used to define an earlycon console for ARM64 and can be used for x86. Modify the ACPI SPCR parsing code to account for console behaviour differences between ARM64 and x86. Initialize the SPCR code from x86 ACPI initialization code. Signed-off-by: Prarit Bhargava Cc:

[PATCH v2 0/2] acpi, x86: Add SPCR table support

2017-12-11 Thread Prarit Bhargava
The SPCR (Serial Port Console Redirection) Table provides information about the configuration of the serial port. This information can be used to configure the early console. SPCR support was added for ARM64 and is made available across all arches in this patchset. The first patch adds a weak pe

[PATCH v2 1/2] acpi, spcr: Make SPCR avialable to other architectures

2017-12-11 Thread Prarit Bhargava
Other architectures can use SPCR to setup an early console or console but the current code is ARM64 specific. Change the name of parse_spcr() to acpi_parse_spcr(). Add a weak function acpi_arch_setup_console() that can be used for arch-specific setup. Move flags into ACPI code. Update the Docum

Re: [PATCH 0/2] acpi, x86: Add SPCR table support

2017-12-11 Thread Ingo Molnar
* Prarit Bhargava wrote: > If I disable "Serial Port Console Debug" in my BIOS I still see the SPCR > configured: > > [root@prarit-lab ~]# dmesg | grep SPCR > [0.00] ACPI: SPCR 0x69031000 50 (v01 > ) > > AFAICT the SPCR is always enabled on some syste

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread Dave Martin
On Mon, Dec 11, 2017 at 08:47:00PM +0800, gengdongjiu wrote: > > On 2017/12/11 19:59, Dave P Martin wrote: > > On Sat, Dec 09, 2017 at 03:28:42PM +, Dongjiu Geng wrote: > >> ARM v8.4 extensions include support for new floating point > >> multiplication variant instructions to the AArch64 SIMD

Re: [PATCH v8 00/20] ILP32 for ARM64

2017-12-11 Thread Yury Norov
On Mon, Dec 11, 2017 at 10:32:30AM +, Catalin Marinas wrote: > Hi Yury, > > On Thu, Nov 16, 2017 at 02:11:30PM +0300, Yury Norov wrote: > > This is ILP32 patches on top of 4.14 kernel: > > https://github.com/norov/linux/commits/ilp32-4.14 > > > > I tested the series with LTP lite built by Lin

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread gengdongjiu
On 2017/12/11 19:59, Dave P Martin wrote: > On Sat, Dec 09, 2017 at 03:28:42PM +, Dongjiu Geng wrote: >> ARM v8.4 extensions include support for new floating point >> multiplication variant instructions to the AArch64 SIMD > > Do we have any human-readable description of what the new instruct

Re: [RESEND PATCH] arm64: v8.4: Support for new floating point multiplication variant

2017-12-11 Thread Dave P Martin
On Sat, Dec 09, 2017 at 03:28:42PM +, Dongjiu Geng wrote: > ARM v8.4 extensions include support for new floating point > multiplication variant instructions to the AArch64 SIMD Do we have any human-readable description of what the new instructions do? Since the v8.4 spec itself only describes

Re: [PATCH v8 00/20] ILP32 for ARM64

2017-12-11 Thread Catalin Marinas
Hi Yury, On Thu, Nov 16, 2017 at 02:11:30PM +0300, Yury Norov wrote: > This is ILP32 patches on top of 4.14 kernel: > https://github.com/norov/linux/commits/ilp32-4.14 > > I tested the series with LTP lite built by Linaro toolchain, and no > regressions found. Thanks. I gave it a try as well wit

[PATCH 1/2] mux: core: add a brief overview of the subsystem

2017-12-11 Thread Peter Rosin
Preparation for adding the mux subsystem to the driver-api documenation. Signed-off-by: Peter Rosin --- drivers/mux/core.c | 37 + 1 file changed, 37 insertions(+) diff --git a/drivers/mux/core.c b/drivers/mux/core.c index d1271c1ee23c..ccb5479f8a39 100644 --

[PATCH 2/2] docs: add mux docs to the driver-api docs

2017-12-11 Thread Peter Rosin
Include both the overview and the more detailed api docs. Signed-off-by: Peter Rosin --- Documentation/driver-api/index.rst | 1 + Documentation/driver-api/mux.rst | 17 + 2 files changed, 18 insertions(+) create mode 100644 Documentation/driver-api/mux.rst diff --git a/Docu

[PATCH 0/2] mux: add overview and add to driver-api docs

2017-12-11 Thread Peter Rosin
Hi! Don't know if this is worth adding, but it might answer at least a few questions. It looks ok when I view the htmldocs output, but I'm not all that certain this is good to go? Cheers, Peter Peter Rosin (2): mux: core: add a brief overview of the subsystem docs: add mux docs to the drive