On Friday, October 20, 2017 10:46:07 PM CEST Bjorn Helgaas wrote:
> On Mon, Oct 16, 2017 at 03:12:35AM +0200, Rafael J. Wysocki wrote:
> > Hi All,
> >
> > Well, this took more time than expected, as I tried to cover everything I
> > had
> > in mind regarding PM flags for drivers.
>
> For the par
On Mon, Oct 16, 2017 at 03:12:35AM +0200, Rafael J. Wysocki wrote:
> Hi All,
>
> Well, this took more time than expected, as I tried to cover everything I had
> in mind regarding PM flags for drivers.
For the parts that touch PCI,
Acked-by: Bjorn Helgaas
I doubt there'll be conflicts with chan
- Use the same file name in the explanation and in the example (conex.c vs
sonixj.c)
- Add a missing ':' in a :ref: tag which leads to incorrect Shpinx output
- Add some missing ',' and ';'
Signed-off-by: Christophe JAILLET
---
Documentation/admin-guide/bug-hunting.rst | 8
1 file chang
WMI is the bus inside kernel, so, we may access the GUID via
/sys/bus/wmi instead of doing this through /sys/devices path.
Signed-off-by: Andy Shevchenko
---
Documentation/admin-guide/thunderbolt.rst | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/admin-guide/th
The device will not appear until we rescan the bus.
Signed-off-by: Andy Shevchenko
---
Documentation/admin-guide/thunderbolt.rst | 5 +
1 file changed, 5 insertions(+)
diff --git a/Documentation/admin-guide/thunderbolt.rst
b/Documentation/admin-guide/thunderbolt.rst
index 9b55952039a6..869
On 10/20/2017 01:05 AM, Petr Mladek wrote:
On Thu 2017-10-19 16:40:45, Calvin Owens wrote:
On 09/28/2017 05:43 PM, Calvin Owens wrote:
Not all consoles are created equal: depending on the actual hardware,
the latency of a printk() call can vary dramatically. The worst examples
are serial consol
ADI is a new feature supported on SPARC M7 and newer processors to allow
hardware to catch rogue accesses to memory. ADI is supported for data
fetches only and not instruction fetches. An app can enable ADI on its
data pages, set version tags on them and use versioned addresses to
access the data p
SPARC M7 processor adds additional metadata for memory address space
that can be used to secure access to regions of memory. This additional
metadata is implemented as a 4-bit tag attached to each cacheline size
block of memory. A task can set a tag on any number of such blocks.
Access to such bloc
On Thu, Oct 12, 2017 at 03:24:10PM -0500, Tom Saeger wrote:
> Make refs to selftests files valid including:
> - watchdog-test.c
> - dnotify_test.c
>
> Signed-off-by: Tom Saeger
> ---
> Documentation/filesystems/dnotify.txt| 2 +-
> Documentation/watchdog/hpwdt.txt | 2 +-
> Docum
On 10/20/17 09:42, Paul E. McKenney wrote:
> On Wed, Oct 18, 2017 at 10:36:47AM -0600, Jonathan Corbet wrote:
>> On Wed, 18 Oct 2017 09:27:01 -0700
>> "Paul E. McKenney" wrote:
>>
>>> On a related topic... Is there anything that test-builds docbook prior
>>> to patches hitting mainline? My exper
On Wed, Oct 18, 2017 at 10:36:47AM -0600, Jonathan Corbet wrote:
> On Wed, 18 Oct 2017 09:27:01 -0700
> "Paul E. McKenney" wrote:
>
> > On a related topic... Is there anything that test-builds docbook prior
> > to patches hitting mainline? My experience indicates that the answer is
> > "no".
>
Hi james,
Thanks for the mail and sorry for my late response.
2017-10-19 1:21 GMT+08:00, James Morse :
> Hi Dongjiu Geng,
>
> On 17/10/17 15:14, Dongjiu Geng wrote:
>> ARMv8.2 adds a new bit HCR_EL2.TEA which controls to
>> route synchronous external aborts to EL2, and adds a
>> trap control bi
On Fri, 20 Oct 2017, changbin...@intel.com wrote:
> diff --git a/mm/huge_memory.c b/mm/huge_memory.c
> index 269b5df..2a960fc 100644
> --- a/mm/huge_memory.c
> +++ b/mm/huge_memory.c
> @@ -501,6 +501,43 @@ void prep_transhuge_page(struct page *page)
> set_compound_page_dtor(page, TRANSHUGE_P
On Friday, October 20, 2017 1:35:27 PM CEST Greg Kroah-Hartman wrote:
> On Fri, Oct 20, 2017 at 01:11:22PM +0200, Rafael J. Wysocki wrote:
> > On Thursday, October 19, 2017 9:33:15 AM CEST Greg Kroah-Hartman wrote:
> > > On Thu, Oct 19, 2017 at 01:17:31AM +0200, Rafael J. Wysocki wrote:
> > > > Fro
On Fri, Oct 20, 2017 at 01:11:22PM +0200, Rafael J. Wysocki wrote:
> On Thursday, October 19, 2017 9:33:15 AM CEST Greg Kroah-Hartman wrote:
> > On Thu, Oct 19, 2017 at 01:17:31AM +0200, Rafael J. Wysocki wrote:
> > > From: Rafael J. Wysocki
> > >
> > > The motivation for this change is to provid
On Thursday, October 19, 2017 9:33:15 AM CEST Greg Kroah-Hartman wrote:
> On Thu, Oct 19, 2017 at 01:17:31AM +0200, Rafael J. Wysocki wrote:
> > From: Rafael J. Wysocki
> >
> > The motivation for this change is to provide a way to work around
> > a problem with the direct-complete mechanism used
Hi Phillip,
Thank you for your fast reply.
On Fri, Oct 20, 2017 at 2:18 PM, Phillip Lougher
wrote:
> On Thu, Oct 19, 2017 at 12:50 AM, Qixuan Wu wrote:
>> Hi All,
>>
>> Currently, squashfs fragments' cache size is only determined by
>> config option CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE. Use
On Fri, 2017-10-20 at 09:27 +0200, Linus Walleij wrote:
> I paged Bartosz and Michael on this, they are experts on the use cases for
> the character device and their opinions are likely more valuable than mine.
>
> > On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> > Similar to devicetree
From: Changbin Du
This patch introduced 4 new interfaces to allocate a prepared
transparent huge page. The aim is to remove duplicated code and
simplify transparent huge page allocation. These are similar to
alloc_hugepage_xxx which are for hugetlbfs pages.
- alloc_transhuge_page_vma
- alloc_
From: Changbin Du
The first one introduce new interfaces, the second one kills naming confusion.
The aim is to simplify transparent huge page allocation and remove duplicated
code.
V2:
- Coding improvment.
- Fix build error if thp is disabled.
Changbin Du (2):
mm, thp: introduce dedicated
From: Changbin Du
The current name free_{huge,transhuge}_page are paired with
alloc_{huge,transhuge}_page functions, but the actual page free
function is still free_page() which will indirectly call
free_{huge,transhuge}_page.
So this patch removes this confusion by renaming all the
compound pag
Hi Hocko,
On Thu, Oct 19, 2017 at 02:49:31PM +0200, Michal Hocko wrote:
> On Wed 18-10-17 19:00:26, Du, Changbin wrote:
> > Hi Hocko,
> >
> > On Tue, Oct 17, 2017 at 12:20:52PM +0200, Michal Hocko wrote:
> > > [CC Kirill]
> > >
> > > On Mon 16-10-17 17:19:16, changbin...@intel.com wrote:
> > > >
On Fri, 2017-10-20 at 09:43 +0200, Linus Walleij wrote:
> On Fri, Oct 20, 2017 at 9:17 AM, Linus Walleij
> wrote:
> > > > On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> >
> > > GPIO state reset tolerance is implemented in gpiolib through the
> > > addition of a new pinconf parameter.
On Fri, 2017-10-20 at 09:17 +0200, Linus Walleij wrote:
> > On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
>
> > GPIO state reset tolerance is implemented in gpiolib through the
> > addition of a new pinconf parameter. With that, some renaming of helpers
> > is done to clarify the scope o
On Thu 2017-10-19 16:40:45, Calvin Owens wrote:
> On 09/28/2017 05:43 PM, Calvin Owens wrote:
> >Not all consoles are created equal: depending on the actual hardware,
> >the latency of a printk() call can vary dramatically. The worst examples
> >are serial consoles, where it can spin for tens of mi
On Fri, Oct 20, 2017 at 9:17 AM, Linus Walleij wrote:
> On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
>
>> GPIO state reset tolerance is implemented in gpiolib through the
>> addition of a new pinconf parameter. With that, some renaming of helpers
>> is done to clarify the scope of the a
On Fri, 2017-10-20 at 09:29 +0200, Linus Walleij wrote:
> On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery
> wrote:
>
> > Expose a new 'maintain' sysfs attribute to control both suspend and
> > reset tolerance.
> >
> > Signed-off-by: Andrew Jeffery
>
> NAK. You will find the actual ABI document
On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> Expose a new 'maintain' sysfs attribute to control both suspend and
> reset tolerance.
>
> Signed-off-by: Andrew Jeffery
NAK. You will find the actual ABI documentation in
Documentation/ABI/obsolete/sysfs-gpio
that's why. This is being ph
On Fri, 2017-10-20 at 09:18 +0200, Linus Walleij wrote:
> On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery
> wrote:
>
> > @@ -32,6 +32,7 @@ enum of_gpio_flags {
> > OF_GPIO_SINGLE_ENDED = 0x2,
> > OF_GPIO_OPEN_DRAIN = 0x4,
> > OF_GPIO_SLEEP_MAY_LOSE_VALUE = 0x8,
> > +
I paged Bartosz and Michael on this, they are experts on the use cases for
the character device and their opinions are likely more valuable than mine.
On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> Similar to devicetree support, add flags and mappings to expose reset
> tolerance configu
On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> @@ -32,6 +32,7 @@ enum of_gpio_flags {
> OF_GPIO_SINGLE_ENDED = 0x2,
> OF_GPIO_OPEN_DRAIN = 0x4,
> OF_GPIO_SLEEP_MAY_LOSE_VALUE = 0x8,
> + OF_GPIO_RESET_TOLERANT = 0x16,
Now you're mixing up decimal and hex.
On Fri, Oct 20, 2017 at 5:37 AM, Andrew Jeffery wrote:
> GPIO state reset tolerance is implemented in gpiolib through the
> addition of a new pinconf parameter. With that, some renaming of helpers
> is done to clarify the scope of the already existing
> gpiochip_line_is_persistent(), as it's now
32 matches
Mail list logo