Re: [PATCH] dma-mapping: clear mark DMA ops as an architecture feature

2024-08-25 Thread Thomas Gleixner
hree drivers overriding it depend on that. They should > probably also be marked broken, but we can give them a bit of a grace > period for that. One week :) > Signed-off-by: Christoph Hellwig Reviewed-by: Thomas Gleixner

Re: [v2 PATCH 0/3] arch: mm, vdso: consolidate PAGE_SIZE definition

2024-03-06 Thread Thomas Gleixner
On Wed, Mar 06 2024 at 15:14, Arnd Bergmann wrote: > From: Arnd Bergmann > > Naresh noticed that the newly added usage of the PAGE_SIZE macro in > include/vdso/datapage.h introduced a build regression. I had an older > patch that I revived to have this defined through Kconfig rather than > through

Re: [PATCH v2 3/3] arch: define CONFIG_PAGE_SIZE_*KB on all architectures

2024-03-06 Thread Thomas Gleixner
n one and allow > only the hardware page size to be selected. > > Acked-by: Guo Ren > Acked-by: Heiko Carstens > Acked-by: Stafford Horne > Acked-by: Johannes Berg > Signed-off-by: Arnd Bergmann Reviewed-by: Thomas Gleixner

Re: [PATCH v2 2/3] arch: simplify architecture specific page size configuration

2024-03-06 Thread Thomas Gleixner
e > leaving the arhcitecture specific ones as the user visible > place for configuring it, to avoid breaking user configs. > > Reviewed-by: Christophe Leroy (powerpc32) > Acked-by: Catalin Marinas > Acked-by: Helge Deller # parisc > Signed-off-by: Arnd Bergmann Reviewed-by: Thomas Gleixner

Re: [PATCH v2 1/3] arch: consolidate existing CONFIG_PAGE_SIZE_*KB definitions

2024-03-06 Thread Thomas Gleixner
off-by: Arnd Bergmann Reviewed-by: Thomas Gleixner

Re: [PATCH 08/21] x86: clean up ioremap

2019-10-21 Thread Thomas Gleixner
On Thu, 17 Oct 2019, Christoph Hellwig wrote: Please change the subject to: x86/mm: Cleanup ioremap() > Use ioremap as the main implemented function, and defined ioremap() please s/defined/define/ > ioremap_nocache to it as a deprecated alias. ioremap_nocache() as a deprecated alias o

Re: [PATCH] Drop unused isa_page_to_bus

2019-06-14 Thread Thomas Gleixner
On Thu, 13 Jun 2019, Stephen Kitt wrote: > isa_page_to_bus is deprecated and no longer used anywhere, this patch > removes it entirely. > > Signed-off-by: Stephen Kitt Acked-by: Thomas Gleixner

Re: [PATCH v2] time: Make sure jiffies_to_msecs() preserves non-zero time periods

2018-06-22 Thread Thomas Gleixner
On Fri, 22 Jun 2018, Geert Uytterhoeven wrote: > On Fri, Jun 22, 2018 at 2:49 PM Thomas Gleixner wrote: > > On Fri, 22 Jun 2018, Geert Uytterhoeven wrote: > > > For the common cases where 1000 is a multiple of HZ, or HZ is a multiple > > > of 1000, jiffies_to_msec

Re: [PATCH 1/4] PCI: Remove redundant pcibios_set_master() declarations

2017-10-05 Thread Thomas Gleixner
On Thu, 5 Oct 2017, Bjorn Helgaas wrote: > From: Bjorn Helgaas > > All users of pcibios_set_master() include , which already has > a declaration. Remove the unnecessary declarations from the > files. > > Signed-off-by: Bjorn Helgaas Reviewed-by: Thomas Gleixner -- To

Re: [PATCH 3/4] PCI: Remove unused declarations

2017-10-05 Thread Thomas Gleixner
# only defined by x86 > pcibios_set_irq_routing() # only defined by x86 > > Signed-off-by: Bjorn Helgaas Reviewed-by: Thomas Gleixner -- To unsubscribe from this list: send the line "unsubscribe linux-alpha" in the body of a message to majord...@vger.kernel.org More m

Re: [PATCH v2 1/1] futex: remove duplicated code and fix UB

2017-08-25 Thread Thomas Gleixner
On Thu, 24 Aug 2017, Will Deacon wrote: > On Thu, Aug 24, 2017 at 09:31:05AM +0200, Jiri Slaby wrote: > > +static int futex_atomic_op_inuser(unsigned int encoded_op, u32 __user > > *uaddr) > > +{ > > + unsigned int op = (encoded_op & 0x7000) >> 28; > > + unsigned int cmp =(

Re: [PATCH 1/1] futex: remove duplicated code and fix UB

2017-07-03 Thread Thomas Gleixner
On Mon, 26 Jun 2017, Jiri Slaby wrote: > On 06/23/2017, 09:51 AM, Thomas Gleixner wrote: > > On Wed, 21 Jun 2017, Jiri Slaby wrote: > >> diff --git a/arch/arm64/include/asm/futex.h > >> b/arch/arm64/include/asm/futex.h > >> index f32b42e8725d..5bb2fd4674e7 1006

Re: [PATCH 1/1] futex: remove duplicated code and fix UB

2017-06-23 Thread Thomas Gleixner
On Wed, 21 Jun 2017, Jiri Slaby wrote: > diff --git a/arch/arm64/include/asm/futex.h b/arch/arm64/include/asm/futex.h > index f32b42e8725d..5bb2fd4674e7 100644 > --- a/arch/arm64/include/asm/futex.h > +++ b/arch/arm64/include/asm/futex.h > @@ -48,20 +48,10 @@ do {

Re: [PATCH 1/1] futex: remove duplicated code

2017-05-25 Thread Thomas Gleixner
On Thu, 25 May 2017, Will Deacon wrote: > On Mon, May 22, 2017 at 11:11:33PM +0200, Thomas Gleixner wrote: > > On Mon, 15 May 2017, Will Deacon wrote: > > > On Mon, May 15, 2017 at 03:07:42PM +0200, Jiri Slaby wrote: > > > > There is code duplicated over

Re: [PATCH 1/1] futex: remove duplicated code

2017-05-22 Thread Thomas Gleixner
On Mon, 15 May 2017, Will Deacon wrote: > Hi Jiri, > > On Mon, May 15, 2017 at 03:07:42PM +0200, Jiri Slaby wrote: > > There is code duplicated over all architecture's headers for > > futex_atomic_op_inuser. Namely op decoding, access_ok check for uaddr, > > and comparison of the result. > > > >

Re: [PATCH 2/8] char/rtc: legacy RTC is no longer supported on x86

2016-04-27 Thread Thomas Gleixner
at contain a two older implementations of > the CONFIG_RTC_DRV_CMOS driver. > > This removes x86 from the list. > > Signed-off-by: Arnd Bergmann Reviewed-by: Thomas Gleixner -- To unsubscribe from this list: send the line "unsubscribe linux-alpha" in the body of a mess