null
+++ b/arch/arm/mach-ux500/cpuidle.c
@@ -0,0 +1,171 @@
+/*
+ * Copyright (c) 2012 Linaro : Daniel Lezcano (IBM)
+ *
+ * Based on the work of Rickard Andersson
+ * and Jonas Aaberg.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU
On 02/09/2012 12:25 PM, Daniel Lezcano wrote:
On 02/09/2012 11:52 AM, Rickard Andersson wrote:
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W
advised us not to move stuff around at this stage.
The pm.c file does not exists for
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W
advised us not to move stuff around at this stage.
BR
Rickard
This patch allows to decouple and recouple the gic from the PRCMU.
This is needed to put the A9 core in retention mode
On 02/07/2012 10:22 AM, Daniel Lezcano wrote:
On 02/07/2012 09:39 AM, Rickard Andersson wrote:
On 02/06/2012 03:10 PM, Daniel Lezcano wrote:
On 02/06/2012 10:19 AM, Rickard Andersson wrote:
Hi!
Our comments:
Thanks Rickard and Jonas for your comments.
- function names don't match c
On 02/06/2012 03:10 PM, Daniel Lezcano wrote:
On 02/06/2012 10:19 AM, Rickard Andersson wrote:
Hi!
Our comments:
Thanks Rickard and Jonas for your comments.
- function names don't match commit comment disable/enable vs
recouple/decouple. Decouple is a better name than disable, becaus
t bus */
void ux500_pm_gic_recouple(void)
{
prcmu_write_masked(PRCM_A9_MASK_REQ,
PRCM_A9_MASK_REQ_PRCM_A9_MASK_REQ,
0);
}
BR
Rickard Andersson& Jonas Aberg
This patch allows to decouple and recouple the gic from the PRCMU.
This is