Re: 3.3 kernel from TI landing teams and powervr problems.

2012-04-16 Thread Martin Ertsås
On 04/17/12 01:17, Clark, Rob wrote: On Mon, Apr 16, 2012 at 10:07 AM, Martin Ertsås wrote: True, I renamed that file, since I got the message that it couldn't find module omap. First I renamed it to omap_drv.so, which gave me the same error, then I tried pvr_drm.so which is the attatched logfi

Re: [PATCH 13/13] clk: basic: improve parent_names & return errors

2012-04-16 Thread Turquette, Mike
On Mon, Apr 16, 2012 at 6:46 PM, Shawn Guo wrote: > On 17 April 2012 07:10, Turquette, Mike wrote: > ... >> Yes, this was a braindead change on my part.  I'll remove the kstrdup >> in my next series (the rest of this patch will stay in). >> > Do you have an ETA on that?  A few platform porting ar

Re: [PATCH][PM-QA] add cpuidle_02 and cpuidle_03 tests

2012-04-16 Thread Hongbo Zhang
Hello Daniel, I cannot apply your patch in this mail, 3 .rej files are created after applying your patch, and it is difficult to apply your patch manually. so could you tell me which version is your patch based on? did you upload your work to your own git? Thanks. On 17 April 2012 09:44, Hongbo Z

Re: [PATCH 13/13] clk: basic: improve parent_names & return errors

2012-04-16 Thread Shawn Guo
On 17 April 2012 07:10, Turquette, Mike wrote: ... > Yes, this was a braindead change on my part.  I'll remove the kstrdup > in my next series (the rest of this patch will stay in). > Do you have an ETA on that? A few platform porting are waiting for a stable branch with all necessary fixup/clean

Re: [PATCH][PM-QA] add cpuidle_02 and cpuidle_03 tests

2012-04-16 Thread Hongbo Zhang
Daniel and Amit, I am so sorry for not response this quickly, because I am busy with the thermal driver now. Anyway I will try to test and merge this work today. On 16 April 2012 23:17, Daniel Lezcano wrote: > On 04/16/2012 02:00 PM, Amit Kucheria wrote: > >> On Mon, Apr 16, 2012 at 2:05 PM, D

Re: [PATCH 1/3] ARM: imx: Add common imx cpuidle init functionality.

2012-04-16 Thread Jesper Juhl
On Mon, 16 Apr 2012, Robert Lee wrote: > Add common cpuidle init functionality that can be used by various > imx platforms. > > Signed-off-by: Robert Lee > --- > arch/arm/plat-mxc/Makefile |2 + > arch/arm/plat-mxc/cpuidle.c | 89 > +

[PATCH 2/3] ARM: imx: Add imx5 cpuidle driver

2012-04-16 Thread Robert Lee
Add imx5 cpuidle driver. Signed-off-by: Robert Lee --- arch/arm/mach-imx/Makefile |2 +- arch/arm/mach-imx/cpuidle-imx5.c| 55 +++ arch/arm/mach-imx/mm-imx5.c | 16 ++--- arch/arm/plat-mxc/include/mach/common.h |1 + 4

[PATCH 3/3] ARM: imx: Add imx6q cpuidle driver

2012-04-16 Thread Robert Lee
Add basic imx6q cpuidle driver. For now, only basic WFI state is supported. Deeper idle states will be added in the future. Signed-off-by: Robert Lee --- arch/arm/mach-imx/Makefile|2 +- arch/arm/mach-imx/cpuidle-imx6q.c | 33 + arch/arm/mach-imx/m

[PATCH 0/3] Add imx cpuidle

2012-04-16 Thread Robert Lee
Add common imx cpuidle initialization functionality and add a i.MX5 and i.MX6 platform cpuidle implementation. Robert Lee (3): ARM: imx: Add common imx cpuidle init functionality. ARM: imx: Add imx5 cpuidle driver ARM: imx: Add imx6q cpuidle driver arch/arm/mach-imx/Makefile

[PATCH 1/3] ARM: imx: Add common imx cpuidle init functionality.

2012-04-16 Thread Robert Lee
Add common cpuidle init functionality that can be used by various imx platforms. Signed-off-by: Robert Lee --- arch/arm/plat-mxc/Makefile |2 + arch/arm/plat-mxc/cpuidle.c | 89 ++ arch/arm/plat-mxc/include/mach/cpuidle.h | 26 ++

[PATCH] ARM: imx: Fix imx5 idle logic bug

2012-04-16 Thread Robert Lee
The imx5_idle() check of the tzic_eanble_wake() return value uses incorrect (inverted) logic causing all attempt to idle to fail. Signed-off-by: Robert Lee --- arch/arm/mach-imx/mm-imx5.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/arm/mach-imx/mm-imx5.c b/arch/ar

Re: 3.3 kernel from TI landing teams and powervr problems.

2012-04-16 Thread Clark, Rob
On Mon, Apr 16, 2012 at 10:07 AM, Martin Ertsås wrote: > > True, I renamed that file, since I got the message that it couldn't find > module omap. First I renamed it to omap_drv.so, which gave me the same > error, then I tried pvr_drm.so which is the attatched logfile. Both of them > are the omap_

Re: [PATCH 13/13] clk: basic: improve parent_names & return errors

2012-04-16 Thread Turquette, Mike
On Mon, Apr 16, 2012 at 1:52 PM, Sascha Hauer wrote: > On Wed, Apr 11, 2012 at 06:02:51PM -0700, Mike Turquette wrote: >> This patch is the basic clk version of 'clk: core: copy parent_names & >> return error codes'. >> >> The registration functions are changed to allow the core code to copy >> th

Re: [PATCH 13/13] clk: basic: improve parent_names & return errors

2012-04-16 Thread Turquette, Mike
On Wed, Apr 11, 2012 at 11:49 PM, Shawn Guo wrote: > On Wed, Apr 11, 2012 at 06:02:51PM -0700, Mike Turquette wrote: > ... >> @@ -175,23 +188,32 @@ struct clk *clk_register_divider(struct device *dev, >> const char *name, >>       div->flags = clk_divider_flags; >>       div->lock = lock; >> >> +

Re: [PATCH v2] rtc: add support for Freescale SNVS RTC

2012-04-16 Thread Kim Phillips
On Sat, 14 Apr 2012 15:07:17 +0800 "Ying-Chun Liu (PaulLiu)" wrote: > +++ b/Documentation/devicetree/bindings/rtc/snvs-rtc.txt this conflicts with the "Secure Non-Volatile Storage (SNVS) Node" section published in: Documentation/devicetree/bindings/crypto/fsl-sec4.txt please use that instead.

Re: [PATCH 12/13] clk: core: copy parent_names & return error codes

2012-04-16 Thread Turquette, Mike
On Mon, Apr 16, 2012 at 1:30 PM, Sascha Hauer wrote: > On Wed, Apr 11, 2012 at 06:02:50PM -0700, Mike Turquette wrote: >>  struct clk *clk_register(struct device *dev, const char *name, >>               const struct clk_ops *ops, struct clk_hw *hw, >>               const char **parent_names, u8 nu

Re: [PATCH 13/13] clk: basic: improve parent_names & return errors

2012-04-16 Thread Sascha Hauer
On Wed, Apr 11, 2012 at 06:02:51PM -0700, Mike Turquette wrote: > This patch is the basic clk version of 'clk: core: copy parent_names & > return error codes'. > > The registration functions are changed to allow the core code to copy > the array of strings and allow platforms to declare those arra

Re: [PATCH 12/13] clk: core: copy parent_names & return error codes

2012-04-16 Thread Sascha Hauer
On Wed, Apr 11, 2012 at 06:02:50PM -0700, Mike Turquette wrote: > This patch cleans up clk_register and solves a few bugs by teaching > clk_register and __clk_init to return error codes (instead of just NULL) > to better align with the existing clk.h api. > > Along with that change this patch also

Re: Getting from a CI report to a hardware pack

2012-04-16 Thread Fathi Boudra
On 16 April 2012 22:22, Christian Robottom Reis wrote: > On Sat, Apr 14, 2012 at 06:59:53PM +0300, Fathi Boudra wrote: >> On 14 April 2012 18:02, Christian Robottom Reis wrote: >> > On Sat, Apr 14, 2012 at 04:29:26PM +0200, Alexander Sack wrote: >> >> > http://snapshots.linaro.org/kernel-hwpack/T

Re: Getting from a CI report to a hardware pack

2012-04-16 Thread Christian Robottom Reis
On Mon, Apr 16, 2012 at 12:52:22PM +0530, Deepti Kalakeri wrote: > > We don't export the .deb package itself. What we export is the complete > > hwpack for such "pure" upstream CI jobs: > > http://ci.linaro.org/kernel_hwpack/ (in this case: > > http://ci.linaro.org/kernel_hwpack/TI-working-tree/TI-

Re: Getting from a CI report to a hardware pack

2012-04-16 Thread Christian Robottom Reis
On Sat, Apr 14, 2012 at 06:59:53PM +0300, Fathi Boudra wrote: > On 14 April 2012 18:02, Christian Robottom Reis wrote: > > On Sat, Apr 14, 2012 at 04:29:26PM +0200, Alexander Sack wrote: > >> > http://snapshots.linaro.org/kernel-hwpack/TI-working-tree/TI-working-tree_tilt-linux-linaro-3.1_panda-om

Re: [PATCH v4] mfd: da9052: add device-tree support for i2c driver

2012-04-16 Thread Samuel Ortiz
Hi Paul, On Mon, Apr 16, 2012 at 12:01:50AM +0800, Ying-Chun Liu (PaulLiu) wrote: > From: "Ying-Chun Liu (PaulLiu)" > > This patch adds device-tree support for dialog MFD and the binding > documentations. > > Signed-off-by: Ying-Chun Liu (PaulLiu) > Cc: Samuel Ortiz > Cc: Mark Brown > Cc: Sh

Re: [PATCH][PM-QA] add cpuidle_02 and cpuidle_03 tests

2012-04-16 Thread Daniel Lezcano
On 04/16/2012 02:00 PM, Amit Kucheria wrote: On Mon, Apr 16, 2012 at 2:05 PM, Daniel Lezcano wrote: On 04/05/2012 02:03 PM, Daniel Lezcano wrote: This patch provides a couple of tests for cpuidle in addition with a small program which behaves to sollicitate the cpuidle drivers especially whe

Re: 3.3 kernel from TI landing teams and powervr problems.

2012-04-16 Thread Martin Ertsås
True, I renamed that file, since I got the message that it couldn't find module omap. First I renamed it to omap_drv.so, which gave me the same error, then I tried pvr_drm.so which is the attatched logfile. Both of them are the omap_pvr_drv.so file. Should there be a omap_drv.so file in the sa

Re: 3.3 kernel from TI landing teams and powervr problems.

2012-04-16 Thread Clark, Rob
There is an omap_drv.so which should be the xorg driver to load.. it will attempt to load (if present) omap_pvr_drv.so as a submodule for EXA accel. I'm not entirely sure why it is named pvr_drv.so in your filesystem, but from list of symbols it seems to match what I would expect to be omap_pvr_dr

Re: Thermal release for this month.

2012-04-16 Thread Andrey Konovalov
On 04/14/2012 09:29 PM, Amit Kucheria wrote: On Sat, Apr 14, 2012 at 3:49 AM, Christian Robottom Reis mailto:k...@linaro.org>> wrote: On Sat, Apr 14, 2012 at 01:02:59AM +0400, Andrey Konovalov wrote: > 2) So the new thermal_exynos4_imx6_work obsoletes the old > exynos_thermal_fra

Re: [PATCH][PM-QA] add cpuidle_02 and cpuidle_03 tests

2012-04-16 Thread Amit Kucheria
On Mon, Apr 16, 2012 at 2:05 PM, Daniel Lezcano wrote: > On 04/05/2012 02:03 PM, Daniel Lezcano wrote: >> >> This patch provides a couple of tests for cpuidle in addition with >> a small program which behaves to sollicitate the cpuidle drivers >> especially when both cores needs to reach the same

Re: [PATCH][PM-QA] add cpuidle_02 and cpuidle_03 tests

2012-04-16 Thread Daniel Lezcano
On 04/05/2012 02:03 PM, Daniel Lezcano wrote: This patch provides a couple of tests for cpuidle in addition with a small program which behaves to sollicitate the cpuidle drivers especially when both cores needs to reach the same C-states. The program forks as many online processors present on th

Re: Getting from a CI report to a hardware pack

2012-04-16 Thread Deepti Kalakeri
On Sat, Apr 14, 2012 at 8:13 PM, Alexander Sack wrote: > > > On Sat, Apr 14, 2012 at 4:29 PM, Alexander Sack wrote: > >> >> >> On Sat, Apr 14, 2012 at 2:41 PM, Christian Robottom Reis > > wrote: >> >>> I think there's a standard link missing from CI pages such as >>> >>> >>> https://ci.linaro.or

Re: Getting from a CI report to a hardware pack

2012-04-16 Thread Deepti Kalakeri
Hello Alexander, Thanks a lot for helping with ci queries in my absence. On Sat, Apr 14, 2012 at 7:59 PM, Alexander Sack wrote: > > > On Sat, Apr 14, 2012 at 2:41 PM, Christian Robottom Reis > wrote: > >> I think there's a standard link missing from CI pages such as >> >> >> https://ci.linaro.