Re: Chord Semantics Patch

2017-11-02 Thread Charles Winston
> On Nov 2, 2017, at 11:40 AM, David Kastrup wrote: > > Charles Winston writes: > >> Hi developers, >> >> I posted a new patch on Reitveld that captures the semantics entered >> in chordmode in order to produce more accurate chord names. The way it >&

Re: Chord Semantics Patch

2017-11-02 Thread Charles Winston
here’s the url: https://codereview.appspot.com/332090043 > On Nov 2, 2017, at 10:08 AM, Charles Winston wrote: > > Hi developers, > > I posted a new patch on Reitveld that captures the semantics entered in > chordmode in order to produce more accurate chord names. The way it

Chord Semantics Patch

2017-11-02 Thread Charles Winston
the chord_name_engraver, which uses a new naming function to produce chord names based on the semantics list. Let me know what you think, Charles Winston ___ lilypond-devel mailing list lilypond-devel@gnu.org https://lists.gnu.org/mailman/listinfo

Re: Passing music objects into scheme functions

2017-08-14 Thread Charles Winston
> On Aug 14, 2017, at 1:34 PM, David Kastrup wrote: > > David Kastrup writes: > >> Charles Winston writes: >> >>>> On Aug 14, 2017, at 1:20 PM, David Kastrup wrote: >>>> >>>> Charles Winston writes: >>>> >>&

Re: Passing music objects into scheme functions

2017-08-14 Thread Charles Winston
> On Aug 14, 2017, at 1:20 PM, David Kastrup wrote: > > Charles Winston writes: > >> Here is the function inside chord-name.scm >> >> >> ;; chordmode-to-exceptions >> (define-safe-public (chordmode-to-exceptions chord markup) >> "

Re: Passing music objects into scheme functions

2017-08-14 Thread Charles Winston
list)) (list (cons (get-semantics chord) markup))) And here is my branch which has added chord semantics and new naming capabilities based on these semantics: https://github.com/charlesrwinston/lilypond_chords/tree/dev/crw_chordsemantics > On Aug 14, 2017, at 12:46 PM, Charles Winston wrote:

Passing music objects into scheme functions

2017-08-14 Thread Charles Winston
Hi developers, I’m working on chord semantics and creating a new way to input chord name exceptions. I want the chord exceptions to be an alist whose keys are the chord's semantics list and values are the exception markups. I wrote a function that takes an event chord and a markup as parameters

Chord Semantics Review

2017-07-06 Thread Charles Winston
the link https://codereview.appspot.com/321250043 <https://codereview.appspot.com/321250043> Thanks, Charles Winston ___ lilypond-devel mailing list lilypond-devel@gnu.org https://lists.gnu.org/mailman/listinfo/lilypond-devel

Re: Making LilyPond quickly

2017-06-28 Thread Charles Winston
Thanks for the help! The -j option is what I need. Charles > On Jun 27, 2017, at 11:31 AM, David Kastrup wrote: > > Charles Winston writes: > >> Hi developers, >> >> So far for my chords project, I’ve only been editing Scheme files, so >> I haven’t nee

Making LilyPond quickly

2017-06-27 Thread Charles Winston
Hi developers, So far for my chords project, I’ve only been editing Scheme files, so I haven’t needed to build lilypond at all to test. Now I’m working on C++ files, so I need to compile in order to test my changes. It’s frustrating that compiling takes such a long time. I’m just using the “mak

Plan for GSoC Chords project

2017-06-01 Thread Charles Winston
Hi developers, I want to run my project plan for by you all for updating the structure of EventChord to include semantic information. I believe the better way to do it now (rather than adding a new ‘semantics entry to EventChord) is to add a new property, chord-degree, to the NoteEvents, which

Scheme in LilyPond

2017-06-01 Thread Charles Winston
Hi, I’m fooling around with using Scheme in lilypond files, making some way on my GSoC chords project. I’m trying to call the make-note-ev procedure found in scm/chord-entry.scm on line 196. I’ve written something simple: #(begin (define root (ly:make-pitch 0 0 0)) (display (mak

Re: Definition of make-music

2017-05-30 Thread Charles Winston
> On May 30, 2017, at 2:41 PM, Carl Sorensen wrote: > > On 5/30/17 12:18 PM, "lilypond-devel on behalf of Charles Winston" > chazwi...@gmail.com> wrote: > >> Could someone tell me where the make-music function is defined? I¹m >> trying to understand the

Definition of make-music

2017-05-30 Thread Charles Winston
Could someone tell me where the make-music function is defined? I’m trying to understand the internals, and since make-music is used so frequently to create music expressions I want to concretely understand what it does. Also, any helpful explanation of what the function does would be great, too

Re: Case of 'c' in partcombine

2017-05-29 Thread Charles Winston
> On May 29, 2017, at 1:40 PM, David Kastrup wrote: > > Charles Winston writes: > >> Could you explain the following line which appears all over convert rules.py: >> >> str = re.sub (r“str1”, r“str2”, str) >> >> I want to change all instances of “

Re: Case of 'c' in partcombine

2017-05-29 Thread Charles Winston
> On May 29, 2017, at 12:28 PM, David Kastrup wrote: > > Charles Winston writes: > >> Hi all, >> >> This is a pretty simple question but for some reason I can’t find a >> definitive answer. I’m adding a rule to convertrules.py, but I need to >> know the

Re: Case of 'c' in partcombine

2017-05-29 Thread Charles Winston
sen wrote: > > On 5/25/17 11:22 AM, "Charles Winston" wrote: > >> >>>> >> >> Am I correct in understanding that the convert-ly rules are defined in >> python/convertrules.py? So I would have to write rules in this file that >> convert

Re: Case of 'c' in partcombine

2017-05-25 Thread Charles Winston
> On May 25, 2017, at 11:54 AM, Charles Winston wrote: > > >> On May 25, 2017, at 11:48 AM, Carl Sorensen wrote: >> >> On 5/25/17 8:40 AM, "lilypond-devel on behalf of Charles Winston" >> > chazwi...@gmail.com> wrote: >> >>&g

Re: Case of 'c' in partcombine

2017-05-25 Thread Charles Winston
> On May 25, 2017, at 11:48 AM, Carl Sorensen wrote: > > On 5/25/17 8:40 AM, "lilypond-devel on behalf of Charles Winston" > chazwi...@gmail.com> wrote: > >> Hey developers, >> >> I am working on my first patch‹it is resolving a very simple iss

Re: Case of 'c' in partcombine

2017-05-25 Thread Charles Winston
> On May 25, 2017, at 11:42 AM, Charles Winston wrote: > >> >> On May 25, 2017, at 11:29 AM, Phil Holmes wrote: >> >> - Original Message - From: "Charles Winston" >> To: >> Sent: Thursday, May 25, 2017 3:40 PM >> Subj

Re: Case of 'c' in partcombine

2017-05-25 Thread Charles Winston
> On May 25, 2017, at 11:29 AM, Phil Holmes wrote: > > - Original Message - From: "Charles Winston" > To: > Sent: Thursday, May 25, 2017 3:40 PM > Subject: Case of 'c' in partcombine > > >> Hey developers, >> >> I am

Case of 'c' in partcombine

2017-05-25 Thread Charles Winston
this function, but I believe that I need to make changes in the parsing process where the parser reads the string “partcombine” input by the user as the command. However I’m not completely clear on where to find this in the source code. Would love some preliminary help! Thanks, Charles Wi