A good performance improvement. As I have not tested this, I'm keeping the
Qualcomm default to no.
Original commit below:
From: Ben Menchaca
Date: Fri, 7 Jun 2013 15:25:00 -0500
Subject: [ag71xx] support for descriptors in SRAM
Adds support to the ag71xx to use SRAM for descriptors for a limite
Seems to remove a few instructions. Original message below:
From: Ben Menchaca
Date: Tue, 11 Jun 2013 15:50:17 -0500
Subject: [ag71xx] optimize iomapped register access
Add register accessors that remove the per-register range check that
was done previously. Additionally, we separate the write
Less verbose code. Should help when porting some of the other patches.
Signed-off-by: Rosen Penev
---
.../drivers/net/ethernet/atheros/ag71xx/ag71xx.h | 1 +
.../net/ethernet/atheros/ag71xx/ag71xx_main.c | 40 +-
2 files changed, 17 insertions(+), 24 deletions(-)
dif
Tightens up the ag71xx_ring_alloc function and makes it easier to read.
Signed-off-by: Rosen Penev
---
.../drivers/net/ethernet/atheros/ag71xx/ag71xx_main.c | 17 -
1 file changed, 4 insertions(+), 13 deletions(-)
diff --git
a/target/linux/ar71xx/files/drivers/net/ethernet/at
This patch is preparation for ag71xx usage of external, on-die
resources. Since these resources are limited, we need to track how
many instances we have probed.
Signed-off-by: Ben Menchaca
Signed-off-by: Rosen Penev dev = dev;
ag->msg_enable = netif_msg_init(ag71xx_msg_level,
Moves the code more in line with QCA code. Also reduces variable to a u16
instead of s32.
QCA code has the roundup component behind a Makefile config. Not sure if
enabled by default so I opted to keep current behavior.
Signed-off-by: Rosen Penev
---
.../files/drivers/net/ethernet/atheros/ag71
Should help slightly.
Signed-off-by: Rosen Penev
---
.../ar71xx/files/drivers/net/ethernet/atheros/ag71xx/ag71xx.h | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git
a/target/linux/ar71xx/files/drivers/net/ethernet/atheros/ag71xx/ag71xx.h
b/target/linux/ar71xx/files/
Ack from me for PKG_HASH=none. Much easier to use.
/ted
-Original Message-
From: Jo-Philipp Wich
Sent: Thursday, December 07, 2017 9:56 AM
To: lede-dev@lists.infradead.org
Subject: Re: [LEDE-DEV] [PATCH 2/2] download.mk: introduce a new variable SKIPHASH
Hi Baptiste,
we've been d
On 07-12-17 15:56, Jo-Philipp Wich wrote:
> Hi Baptiste,
>
> we've been discussing this patch again on IRC today and I came up with
> an alternate suggestion that does not require a new variable.
>
> -- 8< --
> diff --git a/scripts/download.pl b/scripts/download.pl
> index 775408934a..ad9c480c67 10
Hi Baptiste,
we've been discussing this patch again on IRC today and I came up with
an alternate suggestion that does not require a new variable.
-- 8< --
diff --git a/scripts/download.pl b/scripts/download.pl
index 775408934a..ad9c480c67 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
Hi,
Are there any remaining concerns about those 'OpenWrt merge' patches
that have been sitting in my staging tree for a while now?
If not, I plan on pushing them to master this weekend.
- Felix
___
Lede-dev mailing list
Lede-dev@lists.infradead.org
h
Hi Stijn,
Stijn Tintel schrieb am 07.12.2017 12:05:
> On 07-12-17 12:04, Timo Sigurdsson wrote:
>> Hi,
>>
>> Stijn Tintel schrieb am 07.12.2017 01:35:
>>
>>> On 14-11-17 21:41, Timo Sigurdsson wrote:
Increase PKG_RELEASE after latest changes to hostapd, so downstream
users can fetch upd
On 07-12-17 12:04, Timo Sigurdsson wrote:
> Hi,
>
> Stijn Tintel schrieb am 07.12.2017 01:35:
>
>> On 14-11-17 21:41, Timo Sigurdsson wrote:
>>> Increase PKG_RELEASE after latest changes to hostapd, so downstream
>>> users can fetch updates via opkg.
>>>
>> You should have bumped PKG_RELEASE in the
Hi,
Stijn Tintel schrieb am 07.12.2017 01:35:
> On 14-11-17 21:41, Timo Sigurdsson wrote:
>> Increase PKG_RELEASE after latest changes to hostapd, so downstream
>> users can fetch updates via opkg.
>>
> You should have bumped PKG_RELEASE in the previous commit. I've done
> that in my staging tree
14 matches
Mail list logo