On Wed, 13 Sep 2017 21:57:50 +0200
Ondrej Pokorny via Lazarus wrote:
>[...]
> > uses unitdots.unit1, unitdots;
> > type
> >TPrgBright = unitdots.tbright;
> >TPrgColor = unitdots.unit1.tcolor; <--
> > ...
>
> I don't get it :)
> from left to right: is unitdots a namespace? -> yes -> is un
On Wed, 13 Sep 2017 22:18:06 +0200
Sven Barth via Lazarus wrote:
>[...]
> The compiler always searches units in this order:
> - as written in uses clause
> - all lowercase
> - all uppercase
> (and this whole block for extensions .pp, .pas and .p)
Note that uppercase also uppercase the extension.
On 13.09.2017 22:23, Michael Van Canneyt via Lazarus wrote:
create table customer (
C_ID INT Primary key,
C_FIRSTNAME VARCHAR(30),
C_LASTNAME VARCHAR(50)
);
CREATE table invoice (
I_ID INT PRIMARY KEY,
I_CUSTOMER_FK INT,
I_DATE DATE
);
ALTER TABLE INVOICE ADD CONSTRAINT R_INVOICE_CU
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
On 13.09.2017 20:33, Graeme Geldenhuys via Lazarus wrote:
On 2017-09-13 19:17, Michael Van Canneyt via Lazarus wrote:
Similarly, every field in a database I create is always uniquely named.
So if I ask "where is field TX_ID' I get exactl
On 13.09.2017 20:19, Graeme Geldenhuys via Lazarus wrote:
> On 2017-09-13 10:30, Michael Van Canneyt via Lazarus wrote:
>> When using CamelCase properly, you don't need _ or . at all.
>
> That would be my preference too. I love CamelCase - though personally I
> lowercase my unit names (files), but
On 13.09.2017 20:24, Graeme Geldenhuys via Lazarus wrote:
> On 2017-09-13 14:33, Mattias Gaertner via Lazarus wrote:
>> Try "org.|" with the
>> Delphi code insight.
>
> Don't get me started on that again. The Delphi IDE is horribly horribly
> broken in comparison to Lazarus IDE. It two weeks of wo
On 13.09.2017 20:33, Graeme Geldenhuys via Lazarus wrote:
On 2017-09-13 19:17, Michael Van Canneyt via Lazarus wrote:
Similarly, every field in a database I create is always uniquely named.
So if I ask "where is field TX_ID' I get exactly 1 field, in 1 table.
Graeme Geldenhuys can testify that I
On 13.09.2017 21:17, Mattias Gaertner via Lazarus wrote:
Everything looks like the compiler uses the same algorithm -> it first
resolves a then b then c and so on, it doesn't need to go backwards.
It's not so simple. See my example for Sven:
...
uses unitdots.unit1, unitdots;
type
TPrgBright
On Wed, 13 Sep 2017 18:09:40 +0200
Ondrej Pokorny via Lazarus wrote:
>[...]
> I think you are wrong.
Partly. I just didn't tell the whole story.
> I didn't study how the compiler resolves the
> identifiers internally, but when I developed dotted unit support for
> CodeTools I did it so: I reg
Hi,
in fact, it is called PascalCase, see https://en.wikipedia.org/wiki/PascalCase
V.
__
Od: Graeme Geldenhuys via Lazarus
Komu: lazarus@lists.lazarus-ide.org
Datum: 13.09.2017 20:19
Předmět: Re: [Lazarus] FPReport file names
On 2
On 2017-09-13 10:40, Ondrej Pokorny via Lazarus wrote:
Furthermore code tools can handle dotted units (I added the support:) )
and namespaces will be handled as well once FPC supports them.
Excellent!!! The development tools are waiting for the underlying
compiler to catch up. Only in the ope
On 2017-09-13 19:17, Michael Van Canneyt via Lazarus wrote:
Similarly, every field in a database I create is always uniquely named.
So if I ask "where is field TX_ID' I get exactly 1 field, in 1 table.
Graeme Geldenhuys can testify that I use this practice even in very big
databases.
I can con
On 2017-09-13 14:33, Mattias Gaertner via Lazarus wrote:
Try "org.|" with the
Delphi code insight.
Don't get me started on that again. The Delphi IDE is horribly horribly
broken in comparison to Lazarus IDE. It two weeks of working with Delphi
XE the other week I managed to find 13 bugs in th
On 2017-09-13 10:30, Michael Van Canneyt via Lazarus wrote:
When using CamelCase properly, you don't need _ or . at all.
That would be my preference too. I love CamelCase - though personally I
lowercase my unit names (files), but CamelCase the "unit xxx" line
inside the unit.
Now the next q
On Wed, 13 Sep 2017, Ondrej Pokorny wrote:
Of course there can be collisions - if it happens you have to resolve them
with explicit namespaces.
Making the whole point moot.
You can understand namespaces and subnamespaces as a concept for folder
structure within code.
Of course you can
On 13.09.2017 12:28, Michael Van Canneyt wrote:
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
On 13.09.2017 12:03, Michael Van Canneyt via Lazarus wrote:
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
The benefit of writing fpreport.exporthtml versus
fpreportexporthtml is zero
On 13.09.2017 15:33, Mattias Gaertner via Lazarus wrote:
Also were is there an ambiguity anyway (given all units are used with their
full name)? The compiler reads (in my above example) the token sequence ID
Point ID and thus can find the unit without any backtracking just as for
ordinary methods
On Wed, 13 Sep 2017, Graeme Geldenhuys via Lazarus wrote:
On 2017-09-13 09:44, Michael Van Canneyt via Lazarus wrote:
As long as there are no command-line switch and directive for setting
namespaces, they are completely useless.
Like I said, FPC still needs a bit more work before namespaces
Hi all,
The annual PasCon for Lazarus conference is this time on 14th Oct:
http://www.blaisepascal.eu/agenda/lazarus_conference.php
The conference is organized by Blaise Pascal Magazine and takes place in
IJsselstein, Netherland.
Mattias
--
___
Laza
On 2017-09-13 09:44, Michael Van Canneyt via Lazarus wrote:
As long as there are no command-line switch and directive for setting
namespaces, they are completely useless.
Like I said, FPC still needs a bit more work before namespaces become
more useful (or workable like Delphi intended).
>
Am 13.09.2017 15:33 schrieb "Mattias Gaertner via Lazarus" <
lazarus@lists.lazarus-ide.org>:
>
> On Wed, 13 Sep 2017 14:38:55 +0200
> Sven Barth via Lazarus wrote:
>
> >[...]
> > I'm not talking about ambiguity, I'm talking about aesthetics:
FooBar.Blubb
> > is easier to discern visually than FooB
On Wed, 13 Sep 2017 14:38:55 +0200
Sven Barth via Lazarus wrote:
>[...]
> I'm not talking about ambiguity, I'm talking about aesthetics: FooBar.Blubb
> is easier to discern visually than FooBarBlubb.
Well, aesthetics often goes together with "used to".
I'm used to a point separates a sub identif
Am 13.09.2017 11:59 schrieb "Mattias Gaertner via Lazarus" <
lazarus@lists.lazarus-ide.org>:
>
> On Wed, 13 Sep 2017 11:40:23 +0200
> Mattias Gaertner via Lazarus wrote:
>
> > On Wed, 13 Sep 2017 11:19:58 +0200
> > Sven Barth via Lazarus wrote:
> >
> > >[...]
> > > The "." allows for a nicer disa
On 09/13/2017 10:51 AM, Gabor Boros via Lazarus wrote:
Hi All,
https://bugs.freepascal.org/view.php?id=26971
~3 years later. Any idea?
No
zeljko
--
___
Lazarus mailing list
Lazarus@lists.lazarus-ide.org
https://lists.lazarus-ide.org/listinfo/lazaru
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
On 13.09.2017 12:03, Michael Van Canneyt via Lazarus wrote:
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
The benefit of writing fpreport.exporthtml versus fpreportexporthtml
is zero.
You forgot one thing: third-party libr
On 13.09.2017 12:03, Michael Van Canneyt via Lazarus wrote:
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
The benefit of writing fpreport.exporthtml versus fpreportexporthtml
is zero.
You forgot one thing: third-party libraries. E.g. your fpReport could
use the "fprep" namespace.
On Wed, 13 Sep 2017, Mattias Gaertner wrote:
On Wed, 13 Sep 2017 11:28:55 +0200 (CEST)
Michael Van Canneyt wrote:
[...]
The benefit of writing fpreport.exporthtml versus fpreportexporthtml is zero.
It's a little bit better than zero. For example shorter uses clause.
Without using a swi
On Wed, 13 Sep 2017, Ondrej Pokorny via Lazarus wrote:
The benefit of writing fpreport.exporthtml versus fpreportexporthtml is
zero.
You forgot one thing: third-party libraries. E.g. your fpReport could use the
"fprep" namespace. In the fpReport package you then define to use the fprep
na
On Wed, 13 Sep 2017 11:40:23 +0200
Mattias Gaertner via Lazarus wrote:
> On Wed, 13 Sep 2017 11:19:58 +0200
> Sven Barth via Lazarus wrote:
>
> >[...]
> > The "." allows for a nicer disambiguation between what's the prefix and
> > what's the remainder. Granted, that can be done with "_" as well
On 13.09.2017 10:44, Michael Van Canneyt via Lazarus wrote:
On Wed, 13 Sep 2017, Graeme Geldenhuys via Lazarus wrote:
On 2017-09-12 19:01, Alexey via Lazarus wrote:
It is new. Please rename (it's easy for new component) all files:
usually its good with one prefix. E.g. fprep_*.*.
hahaha...
On Wed, 13 Sep 2017 11:19:58 +0200
Sven Barth via Lazarus wrote:
>[...]
> The "." allows for a nicer disambiguation between what's the prefix and
> what's the remainder. Granted, that can be done with "_" as well, but in my
> personal opinion a "." simply looks nicer. :)
I don't get why disambig
On 13/09/17 10:19, Sven Barth via Lazarus wrote:
> Am 13.09.2017 10:45 schrieb "Michael Van Canneyt via Lazarus"
>> The benefit of writing fpreport.exporthtml versus
>> fpreportexporthtml is zero.
>>
>
> The "." allows for a nicer disambiguation between what's the prefix
> and what's the remaind
On Wed, 13 Sep 2017, Sven Barth via Lazarus wrote:
As long as there are no command-line switch and directive for setting
namespaces, they are completely useless. And even with them, the benefit is
doubtful.
The benefit of writing fpreport.exporthtml versus fpreportexporthtml is
zero.
On Wed, 13 Sep 2017, Mattias Gaertner via Lazarus wrote:
On Wed, 13 Sep 2017 10:44:23 +0200 (CEST)
Michael Van Canneyt via Lazarus wrote:
[...]
As long as there are no command-line switch and directive for setting
namespaces, they are completely useless. And even with them, the benefit is
On 09/13/2017 05:13 AM, Mattias Gaertner via Lazarus wrote:
On Wed, 13 Sep 2017 10:44:23 +0200 (CEST)
Michael Van Canneyt via Lazarus wrote:
[...]
I tested in Delphi:
c:\Temp>dcc32 /NSos /NSweb testns.dpr
Embarcadero Delphi for Win32 compiler version 30.0
Copyright (c) 1983,2015 Embarcadero Te
Am 13.09.2017 10:45 schrieb "Michael Van Canneyt via Lazarus" <
lazarus@lists.lazarus-ide.org>:
>
>
>
> On Wed, 13 Sep 2017, Graeme Geldenhuys via Lazarus wrote:
>
>> On 2017-09-12 19:01, Alexey via Lazarus wrote:
>>>
>>> It is new. Please rename (it's easy for new component) all files:
>>> usually
On Wed, 13 Sep 2017 10:44:23 +0200 (CEST)
Michael Van Canneyt via Lazarus wrote:
>[...]
> As long as there are no command-line switch and directive for setting
> namespaces, they are completely useless. And even with them, the benefit is
> doubtful.
>
> The benefit of writing fpreport.exporthtm
Hi All,
https://bugs.freepascal.org/view.php?id=26971
~3 years later. Any idea?
https://bugs.freepascal.org/view.php?id=30466
The KeepChild feature is very important from my POV. Please review the
patch. (I have not tried yet.)
Gabor
--
___
Lazaru
On Wed, 13 Sep 2017, Graeme Geldenhuys via Lazarus wrote:
On 2017-09-12 19:01, Alexey via Lazarus wrote:
It is new. Please rename (it's easy for new component) all files:
usually its good with one prefix. E.g. fprep_*.*.
hahaha... I had the units like that, using underscores. eg:
fpreport_
On 2017-09-12 19:01, Alexey via Lazarus wrote:
It is new. Please rename (it's easy for new component) all files:
usually its good with one prefix. E.g. fprep_*.*.
hahaha... I had the units like that, using underscores. eg:
fpreport_export_aggpas.pas, fpreport_export_fpimage.pas etc. Michael
40 matches
Mail list logo