WARN() takes a condition and a format string. The condition was
omitted. So I added it.
Signed-off-by: Geliang Tang
---
drivers/vfio/vfio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/vfio/vfio.c b/drivers/vfio/vfio.c
index de632da..9da0703 100644
--- a/drivers
Use dev_to_virtio() instead of open-coding it.
Signed-off-by: Geliang Tang
---
drivers/s390/virtio/virtio_ccw.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/s390/virtio/virtio_ccw.c b/drivers/s390/virtio/virtio_ccw.c
index 1b83159..97231e1 100644
--- a/drivers
Use list_for_each_entry*() instead of list_for_each*() to simplify
the code.
Signed-off-by: Geliang Tang
---
arch/x86/kvm/assigned-dev.c | 14 --
1 file changed, 4 insertions(+), 10 deletions(-)
diff --git a/arch/x86/kvm/assigned-dev.c b/arch/x86/kvm/assigned-dev.c
index 9dc091a
Use list_for_each_entry_safe() instead of list_for_each_safe() to
simplify the code.
Signed-off-by: Geliang Tang
---
virt/kvm/kvm_main.c | 9 +++--
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
index 484079e..5b6df4f 100644
--- a
To make the intention clearer, use list_last_entry instead of
list_entry.
Signed-off-by: Geliang Tang
---
arch/x86/kvm/mmu.c | 4 ++--
arch/x86/kvm/vmx.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c
index e7c2c14..5041ef0
To make the intention clearer, use list_first_entry instead of
list_entry.
Signed-off-by: Geliang Tang
---
virt/kvm/async_pf.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/virt/kvm/async_pf.c b/virt/kvm/async_pf.c
index 77d42be..62c4857 100644
--- a/virt/kvm
Fixes the following sparse warning:
arch/x86/kvm/x86.c:4492:5: warning: symbol 'kvm_emulate_wbinvd_noskip'
was not declared. Should it be static?
Signed-off-by: Geliang Tang
---
arch/x86/kvm/x86.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/kvm/x86.c