Re: [PATCH 15/31] mips/kvm: Exception handling to leave and reenter guest mode.

2013-06-15 Thread Ralf Baechle
On Fri, Jun 07, 2013 at 04:03:19PM -0700, David Daney wrote: > Currently this is a little complex, here are the facts about how it works: I'm not so much worried about the intrinic complexity of the job your code is trying to do rather than stackframe.h getting every more complex. We're reaching

Re: [PATCH 16/31] mips/kvm: Add exception handler for MIPSVZ Guest exceptions.

2013-06-15 Thread Ralf Baechle
On Fri, Jun 07, 2013 at 04:03:20PM -0700, David Daney wrote: Acked-by: Ralf Baechle -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 18/31] mips/kvm: Add pt_regs slots for BadInstr and BadInstrP

2013-06-15 Thread Ralf Baechle
Acked-by: Ralf Baechle -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 2/2] armv7 initial device passthrough support

2013-06-15 Thread Paolo Bonzini
Il 13/06/2013 11:19, Mario Smarduch ha scritto: > Updated Device Passthrough Patch. > - optimized IRQ->CPU->vCPU binding, irq is installed once > - added dynamic IRQ affinity on schedule in > - added documentation and few other coding recommendations. > > Per earlier discussion VFIO is our target

[PATCH] intel-iommu: Fix leaks in pagetable freeing

2013-06-15 Thread Alex Williamson
At best the current code only seems to free the leaf pagetables and the root. If you're unlucky enough to have a large gap (like any QEMU guest with more than 3G of memory), only the first chunk of leaf pagetables are freed (plus the root). This is a massive memory leak. This patch re-writes the

Re: [PATCH 17/31] MIPS: Quit exposing Kconfig symbols in uapi headers.

2013-06-15 Thread Paolo Bonzini
Il 07/06/2013 19:03, David Daney ha scritto: > From: David Daney > > The kernel's struct pt_regs has many fields conditional on various > Kconfig variables, we cannot be exporting this garbage to user-space. > > Move the kernel's definition to asm/ptrace.h, and put a uapi only > version in uapi/

[Bug 59521] KVM linux guest reads uninitialized pvclock values before executing rdmsr MSR_KVM_WALL_CLOCK

2013-06-15 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=59521 --- Comment #2 from Eugene Batalov 2013-06-15 17:17:18 --- KVM pv_clock initialization for SMP CPU is called very early on SMP CPU boot stage: arch/x86/kernel/smpboot.c: __cpuinit start_secondary(void *unused) ... cpu_init(); x86_cpu

[PATCHv1] kvm guest: fix uninitialized kvmclock read by KVM guest

2013-06-15 Thread Eugene Batalov
Due to unintialized kvmclock read KVM guest is hanging on SMP boot stage. If unintialized memory contains fatal garbage then hang reproduction is 100%. Unintialized memory is allocated by memblock_alloc. So the garbage values depend on many many things. See the detailed description of the bug and

Re: Bug#707257: linux-image-3.8-1-686-pae: KVM crashes with "entry failed, hardware error 0x80000021"

2013-06-15 Thread Stefan Pietsch
On 13.06.2013 16:59, Stefan Pietsch wrote: > On 13.06.2013 15:42, Paolo Bonzini wrote: >> Il 13/06/2013 07:57, Stefan Pietsch ha scritto: >>> git bisect tells me: >>> 79fd50c67f91136add9726fb7719b57a66c6f763 is the first bad commit >> >> This is an s390 commit, so the bisect somehow went wrong. Ca

Re: [PATCH 1/4] KVM: PPC: Add support for multiple-TCE hcalls

2013-06-15 Thread Benjamin Herrenschmidt
On Wed, 2013-06-05 at 16:11 +1000, Alexey Kardashevskiy wrote: > This adds real mode handlers for the H_PUT_TCE_INDIRECT and > H_STUFF_TCE hypercalls for QEMU emulated devices such as IBMVIO > devices or emulated PCI. These calls allow adding multiple entries > (up to 512) into the TCE table in on

Re: [PATCH 2/4] powerpc: Prepare to support kernel handling of IOMMU map/unmap

2013-06-15 Thread Benjamin Herrenschmidt
> +#if defined(CONFIG_SPARSEMEM_VMEMMAP) || defined(CONFIG_FLATMEM) > +int realmode_get_page(struct page *page) > +{ > + if (PageCompound(page)) > + return -EAGAIN; > + > + get_page(page); > + > + return 0; > +} > +EXPORT_SYMBOL_GPL(realmode_get_page); > + > +int realmode_pu

Re: [PATCH 2/4] powerpc: Prepare to support kernel handling of IOMMU map/unmap

2013-06-15 Thread Benjamin Herrenschmidt
On Sun, 2013-06-16 at 14:26 +1000, Benjamin Herrenschmidt wrote: > > +int realmode_get_page(struct page *page) > > +{ > > + if (PageCompound(page)) > > + return -EAGAIN; > > + > > + get_page(page); > > + > > + return 0; > > +} Shouldn't it be get_page_unless_zero ? Cheers,

Re: [PATCH 3/4] KVM: PPC: Add support for IOMMU in-kernel handling

2013-06-15 Thread Benjamin Herrenschmidt
> static pte_t kvmppc_lookup_pte(pgd_t *pgdir, unsigned long hva, bool writing, > - unsigned long *pte_sizep) > + unsigned long *pte_sizep, bool do_get_page) > { > pte_t *ptep; > unsigned int shift = 0; > @@ -135,6 +136,14 @@ static pte_t kvmppc

Re: [PATCH 4/4] KVM: PPC: Add hugepage support for IOMMU in-kernel handling

2013-06-15 Thread Benjamin Herrenschmidt
On Wed, 2013-06-05 at 16:11 +1000, Alexey Kardashevskiy wrote: > @@ -185,7 +186,31 @@ static unsigned long kvmppc_realmode_gpa_to_hpa(struct > kvm_vcpu *vcpu, > unsigned long hva, hpa, pg_size = 0, offset; > unsigned long gfn = gpa >> PAGE_SHIFT; > bool writing = gpa & TCE_PCI_W

Re: mod filenames != modnames? (inconsistent name changing)

2013-06-15 Thread Rusty Russell
Linda Walsh writes: > Should we have any expectation that a module name and it's filename > should be equivalent? > > I was writing an auto-complete script for modprobe so it wouldn't give > me the option to double load a module (I'd have to manually type it in if > I really wanted it). > > Troubl

Re: Commit f9afbd45b0d0 broke mips r4k.

2013-06-15 Thread Rob Landley
On 06/13/2013 04:00:02 AM, Ralf Baechle wrote: On Wed, Jun 12, 2013 at 09:35:16PM -0500, Rob Landley wrote: > My aboriginal linux project builds tiny linux systems to run under > qemu, producing as close to the same system as possible across a > bunch of different architectures. The above change