This revision was automatically updated to reflect the committed changes.
Closed by commit R241:5f7e892cb79f: Refactor and remove duplicate code in
kfileplacesview (authored by mlaurent).
Restricted Application added a project: Frameworks.
CHANGED PRIOR TO COMMIT
https://phabricator.kde.org/D86
dfaure accepted this revision.
This revision is now accepted and ready to land.
REVISION DETAIL
https://phabricator.kde.org/D8619
To: mlaurent, #frameworks, ervin, dfaure
Cc: dfaure, ngraham
mlaurent updated this revision to Diff 23071.
mlaurent marked 3 inline comments as done.
mlaurent added a comment.
Fix comment from David
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D8619?vs=21828&id=23071
REVISION DETAIL
https://phabricator.kde.org/D8619
AFFECTED FILES
src/f
dfaure requested changes to this revision.
dfaure added inline comments.
This revision now requires changes to proceed.
INLINE COMMENTS
> kfileplacesview.cpp:66
> +QSize sizeHint(const QStyleOptionViewItem &option,
> const QModelIndex &index) const Q_DECL_OVERRIDE;
cfeck set the repository for this revision to R241 KIO.
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D8619
To: mlaurent, #frameworks, ervin
Cc: ngraham
ngraham edited the summary of this revision.
ngraham added a dependency: D8450: User can now hide an entire places group
from KFilePlacesView.
REVISION DETAIL
https://phabricator.kde.org/D8619
To: mlaurent, #frameworks, ervin
Cc: ngraham
mlaurent edited the summary of this revision.
REVISION DETAIL
https://phabricator.kde.org/D8619
To: mlaurent, #frameworks, ervin
Cc: ngraham
mlaurent updated this revision to Diff 21828.
mlaurent added a comment.
Don't disconnect a model without check if not null.
Const'ify some variables
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D8619?vs=21779&id=21828
REVISION DETAIL
https://phabricator.kde.org/D8619
AFFECTED
mlaurent updated this revision to Diff 21779.
mlaurent added a comment.
Remove virtual keyword when we have override
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D8619?vs=21778&id=21779
REVISION DETAIL
https://phabricator.kde.org/D8619
AFFECTED FILES
src/filewidgets/kfileplace
mlaurent updated this revision to Diff 21778.
mlaurent added a comment.
Const'ify + use more static_cast
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D8619?vs=21776&id=21778
REVISION DETAIL
https://phabricator.kde.org/D8619
AFFECTED FILES
src/filewidgets/kfileplacesview.cpp
T
mlaurent created this revision.
mlaurent added reviewers: Frameworks, ervin.
REVISION SUMMARY
Remove duplicate code.
Use static_cast when we don't test result from dynamic_cast
Remove unused variable
TEST PLAN
compile/test
REPOSITORY
R342 KIO AudioCD
REVISION DETAIL
https://phabric
11 matches
Mail list logo