When do pci remove/rescan on system that have more iommus, got
[ 894.089745] Set context mapping for c4:00.0
[ 894.110890] mpt2sas3: Allocated physical memory: size(4293 kB)
[ 894.112556] mpt2sas3: Current Controller Queue Depth(1883), Max Controller
Queue Depth(2144)
[ 894.127278] mpt2sas3:
Should check dmar_disabled just after tboot_force_iommu.
Otherwise when tboot is not used, and intel_iommu=off, and nointrmap
still get dmar_table_init() called. that will cause some get_device
calling, and it will have some device refcount leaking.
Signed-off-by: Yinghai Lu
Cc: David Woodhouse
IOMMU ops should be working at a group level rather than a device
level as we cannot arbitrarily assign devices from the same group
to different domains. For now this is just a simple wrapper that
makes use of the dma_dev within a group.
Signed-off-by: Alex Williamson
---
drivers/iommu/iommu.c
IOMMU groups define the minimum granularity of the IOMMU. We therefore
create groups using a dma_dev which is the effective requestor ID for
the entire group. Additional devices can be added to groups based on
system topology, IOMMU limitations, or device quirks.
This implementation also include
This series attempts to make IOMMU device grouping a slightly more
integral part of the device model. iommu_device_groups were originally
introduced to support the VFIO user space driver interface which needs
to understand the granularity of device isolation in order to ensure
security of devices
IOMMUs often do not have visibility of individual devices in the
system. Due to IOMMU design, bus topology, or device quirks, we
can often only identify groups of devices. Examples include
Intel VT-d & AMD-Vi which often have function level visibility
compared to POWER partitionable endpoints whi
* Yinghai Lu wrote:
> On Sat, Mar 31, 2012 at 1:14 AM, Ingo Molnar wrote:
> >
> > * Suresh Siddha wrote:
> >
> >> Ingo,
> >>
> >> Here is the Joerg's irq_remap_ops patchset updated for the latest -tip.
> >> Simplified some of the naming conventions to follow the irq_remapping
> >> terminology.
This patch is being submitted to handle the case where a pci device is
placed into the si domain, when booting in iommu passthrough mode, then
removed. The RMRR information for such devices need to be re-processed
to avoid DMA Read errors due to the Present Bit being cleared in the
device's context
* Suresh Siddha wrote:
> Ingo,
>
> Here is the Joerg's irq_remap_ops patchset updated for the latest -tip.
> Simplified some of the naming conventions to follow the irq_remapping
> terminology. There are still some "if (irq_remapping_enabled)" checks in
> io_apic.c that I would like to roll int