I do this exact thing all the time, and have never encountered any
difficulties.
-Jason
On Sat, 2003-07-05 at 09:55, Sascha Schumann wrote:
> On Sat, 5 Jul 2003, Marcus [x-unknown] Börger wrote:
>
> > Hello Andi,
> >
> > there was nothing in this thread that was against adding it besides Sascha
>
> The problem isn't the ending. The problem is that according
> to our naming conventions it should be array_foobar() whereas the
other
> array functions were invented before our conventions and are short
names such
> as next(). Now on one hand we wouldn't want to pollute the PHP
function
>
The problem isn't the ending. The problem is that according to our naming
conventions it should be array_foobar() whereas the other array functions
were invented before our conventions and are short names such as next().
Now on one hand we wouldn't want to pollute the PHP function space with new
Hi,
How about array_has_next() to reference the php function?
Greg
Marcus BöRger wrote:
Anyway you said that you don't like the name really. Do you have a better
name? If not i'll go with 'array_has_more'.
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://ww
On Sat, 5 Jul 2003, Marcus [x-unknown] Börger wrote:
> Hello Andi,
>
> there was nothing in this thread that was against adding it besides Sascha
> suggestion that following code would do the trick:
There was also nothing in favor of it. Beside the cludgy
name, array loops can simply be
Just a note that I'd prefer a different name as well. I really don't
see the use for this function though. If you need to see the next
element in the iteration use next(), and then rewind it with prev().
-Sterling
On Sat, 2003-07-05 at 06:57, Marcus Börger wrote:
> Hello Andi,
>
> there was no
Hello Andi,
there was nothing in this thread that was against adding it besides Sascha
suggestion that following code would do the trick:
function array_has_more($ar) {
if (!is_array($ar)) {
trigger_error("Argument to array_has_more is no array", E_WARNING);
return NULL;
}
Hello Andi,
Friday, July 4, 2003, 10:18:41 PM, you wrote:
AG> At 07:00 PM 4/7/2003 +0200, Marcus Börger wrote:
>>Hello Andi,
>>
>>damn, yeah, it was already to early in the morning when i sent the mail, i
>>somehow didn't notice that i was trying to send a '.tx' file :-(
AG> What you are saying
You forgot to attach the diff :)
Andi
At 03:56 AM 4/7/2003 +0200, Marcus Börger wrote:
Hello internals,
during my todays work i was again reminded that still one array function is
missing namely array_has_more. This function will return true if there are
more elements in an array and false if