> On 15 May 2016, at 20:29, Dan Ackroyd wrote:
> Hello,
>
> I've opened the voting for the Closure from callable RFC -
> https://wiki.php.net/rfc/closurefromcallable
Voting was closed, the RFC has passed 40-0.
Thanks again to Bob, for helping with (aka doing most of) the code.
cheers
Dan
--
P
On 16 May 2016 at 09:31, Dmitry Stogov wrote:
> I'm sorry, I didn't follow the RFC discussion.
> In general I like the idea, but why not to use Closure constructor?
>
Hi Dmitry,
Several small to medium sized reasons that make me think it's the best way.
As Marco said, constructors cannot be pas
On Mon, 16 May 2016 03:56:38 +0300, Sara Golemon wrote:
On Sun, May 15, 2016 at 11:20 AM, Nikita Nefedov
wrote:
why would you need to support a $this->fieldName case though?
Because to not support it would be to deliberately design in a new
flavor of inconsistency into the language. $obj->
On 16 May 2016 at 10:31, Dmitry Stogov wrote:
> I'm sorry, I didn't follow the RFC discussion.
> In general I like the idea, but why not to use Closure constructor?
>
> $f = new Closure("some_func");
>
> would look more readable than
>
> $f = Closure::fromCallable("some_func");
>
> Sorry, if this
cussed before.
Thanks. Dmitry.
From: Dan Ackroyd
Sent: Sunday, May 15, 2016 8:29:22 PM
To: internals@lists.php.net
Subject: [PHP-DEV] [RFC][VOTE] Closure from callable
Hello,
I've opened the voting for the Closure from callable RFC -
https://wiki.php.net/rfc/clos
On Sun, May 15, 2016 at 11:20 AM, Nikita Nefedov wrote:
> why would you need to support a $this->fieldName case though?
>
Because to not support it would be to deliberately design in a new
flavor of inconsistency into the language. $obj->memb is a property
access in PHP. Making it suddenly mean "
> On 15 May 2016, at 20:29, Dan Ackroyd wrote:
>
> Hello,
>
> I've opened the voting for the Closure from callable RFC -
> https://wiki.php.net/rfc/closurefromcallable
>
> Just to note, some people I've spoken to have expressed a desire to
> have a more powerful syntax where 'bare' function na
Hello,
I've opened the voting for the Closure from callable RFC -
https://wiki.php.net/rfc/closurefromcallable
Just to note, some people I've spoken to have expressed a desire to
have a more powerful syntax where 'bare' function names are used,
like:
callable(someFunctionName)
callable($this->me