On Tue, Oct 7, 2014 at 9:05 AM, Mathias Grimm
wrote:
> Hi,
> I would like to suggest something for php like a class I am using
>
> https://github.com/mathiasgrimm/arraypath
>
> The reason is to access arrays like this:
>
> $idx3 = ArrayPath::get('idx1/idx2/idx3', $_POST, 'myDefaultValue');
>
>
>
Hi Andrea,
This is great -- thanks to you and Nikita for the work here.
Syntax wise, I would prefer a function-like syntax, e.g. coalesce($a, $b,
'c') or ifsetor() instead of $a ?? $b ?? 'c'. I find this more readable,
and it avoids any possible confusion about precedence within the
expressions.
On Wed, Aug 13, 2014 at 3:24 AM, Peter Cowburn
wrote:
>
> My thoughts on the topic? I think we're in danger of letting "process" get
> in our way here. It's a bug fix which IMHO should even be thrown into 5.6
> (this is a bug fix!). Going through the RFC process, being forced to wait
> for 5.7 or
On Thu, Dec 6, 2012 at 4:34 PM, Kris Craig wrote:
> Hey guys,
>
> Please forgive me if this has already been addressed, but could somebody
> tell me why all the methods for the Exception class are in camelCase? I
> don't want to wade too deeply into the "consistency vs. BC" rabbit hole
> here, b
On Tue, Jan 24, 2012 at 3:16 PM, Paul Dragoonis wrote:
> On Tue, Jan 24, 2012 at 11:12 PM, Christopher Jones
> wrote:
>>
>>
>> On 01/24/2012 03:11 PM, Justin Martin wrote:
>>>
>>> Hello,
>>>
>>> With some frequency, I find bugs which are not "bogus", so much as they
>>> are reported based on a mi
On Fri, Jan 14, 2011 at 10:21 AM, Marc Easen wrote:
> Hello everyone,
>
> I would like to open the discussion around the support of negative indexes,
> as I feel a lot of developers will benefit from this syntactical sugar.
It would be convenient, but PHP already allows arrays to have negative
i
On Wed, Nov 10, 2010 at 2:51 PM, Gustavo Lopes wrote:
> On Wed, 10 Nov 2010 21:31:19 -, Jonah H. Harris
> wrote:
>
>> Hey all,
>>
>> I was recently working on some code which made use of bit arrays and I
>> came across feature request 50648: Format for binary numbers. While it's
>> just
>> m
On Thu, Jul 29, 2010 at 8:18 AM, Kalle Sommer Nielsen wrote:
>
> Hello Zeev
>
> 2010/7/29 Zeev Suraski :
> > With the revived interest in the neighbourhood of type hints in the last few
> > days I'm resending this email from a few weeks ago.
> >
> > In a nutshell, use auto-conversion for scalar ty
Hi All,
I came across a situation where I had to make the first character of an
arrays keys uppercase, and found the array_change_key_case function, but
noticed it only supported CASE_UPPER and CASE_LOWER. Attached is a patch to
also add support for CASE_LCFIRST and CASE_UCFIRST.
The patch is aga
On Monday, July 6, 2009, Ilia Alshanetsky wrote:
> Last week or so there was a fairly detailed discussion on the internals list
> regarding type hinting based on my original patch. Since then the patch has
> been revised to address the major concerns that were identified (breakage of
> binary c
Hi,
The arg info for array_map appears to be incorrect. It lists 3 arguments as
required, when in fact there are only 2 required. Attached is a small patch
to fix it.
Regards,
Matthew
Index: basic_functions.c
===
RCS file: /repositor
Option [a] seems like the most logical thing to do, would probably work the
best. It might be nice to note on php.net somewhere right now before this is
fixed that PEAR will not install.
The options we have, as far as I can tell, are:
[a] Re-release 5.0.4 with that file
[b] Release 5.0.5 with th
I would like to help with documentation and contribute anything else possible, and
also I was told to request a CVS account by [EMAIL PROTECTED]
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
13 matches
Mail list logo