I like the naming convention of are_*. For me personally it isn't directly
intuitive that the multiple parameters of is_* would be compared with an &&
and not an ||.
On Wed, Sep 18, 2013 at 7:50 AM, Sean Coates wrote:
> > i.e. is_null($a, $b, $c) would be the same as is_null($a) && is_null($b)
I hear Perl 6 supports Str decrementing
On Jul 18, 2013 5:11 PM, "Sara Golemon" wrote:
> > My question is, why specifically doesn't it?
> >
> > Because Perl.
>
gt;
> My proposal:
>
>
> 1) Support decrementing letters
>
> - or -
>
> 2) Throw a notice explaining that decrementing is not supported so
>
> developers quickly know they can't do that
>
>
> One hiccup. I imagine maybe the reason we don't suppo
ort decrementing letters
>
> - or -
>
> 2) Throw a notice explaining that decrementing is not supported so
>
> developers quickly know they can't do that
>
>
> One hiccup. I imagine maybe the reason we don't support decrementing is
>
> because what would happen if y
a notice explaining that decrementing is not supported so
developers quickly know they can't do that
One hiccup. I imagine maybe the reason we don't support decrementing is
because what would happen if you tried to decrement 'A'. In that case I
would suggest either returning NULL or throwing a notice.
Thanks for the input
Chris London
eed the value. I would like to
allow the following syntax:
foreach ($array as $key => ) {
}
Please let me know your thoughts.
Thanks
Chris London