On 28.08.2008, at 16:18, Matt Wilmas wrote:
Well, it's been awhile since Alpha 1 :-), so I wanted to finally
resend this
before Alpha 2! I agree that the additional optimization probably
wouldn't
happen often, as there won't be that much namespace usage right
away, I
assume. But I think
Hi again,
> A few weeks ago I wrote quite a long posting to internals@ that tried to
> clarify the situation on the round() function in PHP. I was asked to
> write it up as an RFC in the wiki, which I have done:
>
> http://wiki.php.net/rfc/rounding
Since there has been no reaction so far to my p
Hi!
I'm really sorry, but I have to ask.
Since you can detect that this is a nested namespace, why can't we allow it?
Because that's not how model was designed and it creates all kind of
trouble with name resolution. Basically, you get potentially infinite
resolution path. You don't want to
On Thu, 2008-08-28 at 16:09 +0530, KishoreKumar Bairi wrote:
> PHP_FUNCTION(test_func)
>
> *{*
These additional asterisks (*) make the code hard to read.
> but when I hit http://localhost/test.php Instead of showing the string, my
> browser is offering *test.php* for download. If I click save, i
Hi Dmitry,
Well, it's been awhile since Alpha 1 :-), so I wanted to finally resend this
before Alpha 2! I agree that the additional optimization probably wouldn't
happen often, as there won't be that much namespace usage right away, I
assume. But I think it makes sense to handle :: prefix consta
Hi Johannes,
- Original Message -
From: "Johannes Schlüter"
Sent: Thursday, July 31, 2008
> Matt,
>
> On Thu, 2008-07-31 at 20:06 +0200, Johannes Schlüter wrote:
> > On Thu, 2008-07-31 at 11:48 -0500, Matt Wilmas wrote:
> > > Ugh, I hate that reference/recursion stuff! I have a hard time
Hey guys..
This is the code of a
string test_func(resource $handle) which is supposed to return the size of
resource as a string.
PHP_FUNCTION(test_func)
*{*
zval *arg1;
php_stream_statbuf stat_ssb;
*char* *input_stream_len_str;
php_stream *input_stream;