On 13/06/2024 8:17, Sasha Neftin wrote:
Since the kernel's 'ethtool_keee' structure is in use, the internal
'eee_advert' field becomes pointless and can be removed.
This patch comes to clean up this redundant code.
Signed-off-by: Sasha Neftin
---
v2: Fixed grammar in the commit message
---
d
On 6/25/24 20:49, Aleksandr Loktionov wrote:
Remove wrong EIO to EGAIN conversion and pass all errors as is.
After commit 230f3d53a547 ("i40e: remove i40e_status"), which should only
replace F/W specific error codes with Linux kernel generic, all EIO errors
suddenly started to be converted into
This series replaces multiple aux buses and devices used in
the PTP support code with struct ice_adapter holding the necessary
shared data
Patches 1,2 add convenience wrappers
Patch 3 does the main refactoring
Patch 4 finalizes the refactoring
Sergey Temerkhanov (4):
ice: Introduce ice_get_phy_
Introduce ice_get_phy_model() to improve code readability
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice.h| 5 +
drivers/net/ethernet/intel/ice/ice_ptp.c| 18 -
drivers/net/ethernet/intel/ice/ice_ptp_hw.c |
Add ice_get_ctrl_ptp() wrapper to simplify the PTP support code
in the functions that do not use ctrl_pf directly
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice_ptp.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers
- Use struct ice_adapter to hold shared PTP data and control PTP
related actions instead of auxbus. This allows significant code
simplification and faster access to the container fields used in
the PTP support code.
- Move the PTP port list to the ice_adapter container to simplify
the code and avo
Drop unused auxbus/auxdev support from the PTP code due to
move to the ice_adapter.
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice_ptp.c | 265 ---
1 file changed, 265 deletions(-)
diff --git a/drivers/net/ethernet/inte
After vsi setup refactor commit 6624e780a577 ("ice: split ice_vsi_setup
into smaller functions") ice_cfg_sw_lldp function which removes rx rule
directing LLDP packets to vsi is moved from ice_vsi_release to
ice_vsi_decfg function. ice_vsi_decfg is used in more cases than just in
vsi_release resulti
On 6/26/24 12:03, Sergey Temerkhanov wrote:
Add ice_get_ctrl_ptp() wrapper to simplify the PTP support code
in the functions that do not use ctrl_pf directly
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice_ptp.c | 12
1 file
On Mon, Jun 24, 2024 at 05:12:13PM +0200, Michal Kubiak wrote:
> The commit 6533e558c650 ("i40e: Fix reset path while removing
> the driver") introduced a new PF state "__I40E_IN_REMOVE" to block
> modifying the XDP program while the driver is being removed.
> Unfortunately, such a change is useful
On Tue, Jun 04, 2024 at 03:21:52PM +0200, Maciej Fijalkowski wrote:
> This so we prevent Tx timeout issues. One of conditions checked on
> running in the background dev_watchdog() is netif_carrier_ok(), so let
> us turn it off when we disable the queues that belong to a q_vector
> where XSK pool is
This series replaces multiple aux buses and devices used in the PTP support
code with struct ice_adapter holding the necessary shared data
Patches 1,2 add convenience wrappers
Patch 3 does the main refactoring
Patch 4 finalizes the refactoring
Previous discussion:
https://lists.osuosl.org/piperm
Introduce ice_get_phy_model() to improve code readability
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice.h| 5 +
drivers/net/ethernet/intel/ice/ice_ptp.c| 18 -
drivers/net/ethernet/intel/ice/ice_ptp_hw.c |
Add ice_get_ctrl_ptp() wrapper to simplify the PTP support code
in the functions that do not use ctrl_pf directly.
Add the control PF pointer to struct ice_adapter
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice_adapter.h | 4
drivers/
Use struct ice_adapter to hold shared PTP data and control PTP
related actions instead of auxbus. This allows significant code
simplification and faster access to the container fields used in
the PTP support code.
Move the PTP port list to the ice_adapter container to simplify
the code and avoid r
Drop unused auxbus/auxdev support from the PTP code due to
move to the ice_adapter.
Reviewed-by: Przemek Kitszel
Signed-off-by: Sergey Temerkhanov
---
drivers/net/ethernet/intel/ice/ice_ptp.c | 252 ---
drivers/net/ethernet/intel/ice/ice_ptp.h | 23 ---
2 files changed, 275
On Wed, Jun 26, 2024 at 02:21:39PM +0200, Michal Kubiak wrote:
> On Tue, Jun 04, 2024 at 03:21:52PM +0200, Maciej Fijalkowski wrote:
> > This so we prevent Tx timeout issues. One of conditions checked on
> > running in the background dev_watchdog() is netif_carrier_ok(), so let
> > us turn it off w
Faizal Rahim writes:
> Following the implementation of "igc: Add TransmissionOverrun counter"
> patch, when a taprio command is triggered by user, igc processes two
> commands: TAPRIO_CMD_REPLACE followed by TAPRIO_CMD_STATS. However, both
> commands unconditionally pass through igc_tsn_offload_a
Kurt Kanzenbach writes:
> Add support for offloading MQPRIO. The hardware has four priorities as well
> as four queues. Each queue must be a assigned with a unique priority.
>
> However, the priorities are only considered in TSN Tx mode. There are two
> TSN Tx modes. In case of MQPRIO the Qbv cap
19 matches
Mail list logo