counterpart. However the feedback received from Masahiro Yamada was that
> it is too ugly, not providing much value. And just wrapping in a boolean
> context is too dumb - we could simply open code it.
>
> As detailed in commit babaab2f4738 ("drm/i915: Encapsulate kconfig
> c
, even in the i915 driver.
For a few sources of the warnings,
replacing it with != 0 or > 0 is just fine.
Of course, such an ugly macro is not worth being moved to
--
Best Regards
Masahiro Yamada
On Fri, Oct 1, 2021 at 12:55 AM Lucas De Marchi
wrote:
>
> On Thu, Sep 30, 2021 at 11:01:36PM +0900, Masahiro Yamada wrote:
> >On Thu, Sep 30, 2021 at 3:34 AM Lucas De Marchi
> > wrote:
> >>
> >> The check for config value doesn't really belong to i915_
On Mon, Sep 6, 2021 at 4:34 PM Daniel Vetter wrote:
>
> On Mon, Sep 6, 2021 at 12:49 AM Stephen Rothwell
> wrote:
> > Hi all,
> >
> > On Thu, 2 Sep 2021 07:50:38 +1000 Stephen Rothwell
> > wrote:
> > >
> > > On Fri, 20 Aug 2021 15:23:34 +090
consistent, and finally get rid of the gross hacks.
Having whitespaces after -I does not matter since commit 48f6e3cf5bc6
("kbuild: do not drop -I without parameter").
[1]: https://patchwork.kernel.org/patch/9632347/
Signed-off-by: Masahiro Yamada
---
I put all gpu/drm changes into a si
The top level Makefile adds -Wall globally:
KBUILD_CFLAGS := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs \
I see two "-Wall" added for compiling under drivers/gpu/drm/i915/.
Signed-off-by: Masahiro Yamada
---
BTW, I have a question in the comment:
"Note the
On Wed, May 15, 2019 at 3:25 PM Chris Wilson wrote:
>
> Quoting Masahiro Yamada (2019-05-15 05:37:53)
> > The top level Makefile adds -Wall globally:
> >
> > KBUILD_CFLAGS := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs
> > \
> >
> > I
d special target header-test-y where individual Makefiles can add
> headers to be tested if CONFIG_HEADER_TEST is enabled. This will
> generate a dummy C file per header that gets built as part of extra-y.
>
> Cc: Chris Wilson
> Cc: Masahiro Yamada
> Cc: Michal Marek
> Signed
'clean-files-y +='
If Kbuild supports this in the core Makefiles,
we can add "-o -name '*.header_test.c'"
to the top Makefile.
> And it should also be put into the global gitignore I think.
Documentation/dontdiff too.
> -Chris
--
Best Regards
M
Hi.
On Fri, Mar 29, 2019 at 8:37 PM Masahiro Yamada
wrote:
>
> Currently, the Kbuild core manipulates header search paths in a crazy
> way [1].
>
> To fix this mess, I want all Makefiles to add explicit $(srctree)/ to
> the search paths in the srctree. Some Makefiles are
On Thu, Jan 31, 2019 at 1:01 PM Masahiro Yamada
wrote:
>
> Currently, the Kbuild core manipulates header search paths in a crazy
> way [1].
>
> To fix this mess, I want all Makefiles to add explicit $(srctree)/ to
> the search paths in the srctree. Some Makefiles are already wri
consistent, and finally get rid of the gross hacks.
Having whitespaces after -I does not matter since commit 48f6e3cf5bc6
("kbuild: do not drop -I without parameter").
[1]: https://patchwork.kernel.org/patch/9632347/
Signed-off-by: Masahiro Yamada
Reviewed-by: Sam Ravnborg
---
I put a
thanks.
> I have cooked up something ad-hoc a couple of times but having it as a
> standard feature in the build system is much better.
> The we can let some of our infrastructure pick up an issues
> automatically.
>
> >
> > Cc: Chris Wilson
> > Cc: Masahiro
regeneration of *.hdrtest.c
quiet_cmd_header_test = HDRTEST $@
cmd_header_test = echo "\#include \"$*.h\"" > $@
$(obj)/%.hdrtest.c:
$(call cmd,header_test)
[3] Please add '*.hdrtest.c' to .gitignore, Documentation/dontdiff
[4] Please add '*.
quot;header-test-y" hurts the eye a little with
> two '-', and all other variables uses only one '-' as is today.
> (generic-y, obj-y etc).
>
> This is bikeshedding but is was itcing me a little.
I do not have a strong opinion.
I leave it to Jani. Either is fine with me
On Thu, Jun 6, 2019 at 4:57 PM Jani Nikula wrote:
>
> You're totally right, it needs to be fixed in your tree. For that, I
> think the best option is your fixup patch #2.
OK, I will squash patch #2.
--
Best Regards
Masahiro Yamada
___
hanging the standard used, this patch explciitly
enales the warnings with `-Wdeclaration-after-statement`, which takes
effect regardless of which version of the C standard is in use."
modpost is already built with -std=gnu89.
If Wdeclaration-after-statement is implied by gnu89,
why did nobody notice this before?
--
Best Regards
Masahiro Yamada
building with -Wextra, ...
> 'make W=1' option, as well as for three drivers in the kernel that always
> enable -Werror, but it was only observed with the i915 driver so far.
Same here.
enable -Werror, but ...
->
enable -Wextra, but ...
Otherwise,
Acked-by: Ma
The headers in the gem/selftests/, gt/selftests, gvt/, selftests/
directories have never been compile-tested, but it would be possible
to make them self-contained.
This commit only addresses missing and forward
struct declarations.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/gem
Since this function is defined in a header file, it should be
'static inline' instead of 'static'.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/dr
On Fri, Nov 8, 2019 at 2:15 PM Masahiro Yamada
wrote:
>
> The headers in the gem/selftests/, gt/selftests, gvt/, selftests/
> directories have never been compile-tested, but it would be possible
> to make them self-contained.
>
> This commit only addresses missing an
The headers in the gem/selftests/, gt/selftests, gvt/, selftests/
directories have never been compile-tested, but it would be possible
to make them self-contained.
This commit only addresses missing and forward
struct declarations.
Signed-off-by: Masahiro Yamada
---
Rebase on git
version to 2.21").
I confirmed the code in $(call as-instr,...) can be assembled by the
binutils 2.21 assembler and also by Clang's integrated assembler.
Remove CONFIG_AS_MOVNTDQA, which is always defined.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/Makefile | 3
Hi i915 maintainers,
On Mon, Mar 23, 2020 at 11:12 AM Masahiro Yamada wrote:
>
> CONFIG_AS_MOVNTDQA was introduced by commit 0b1de5d58e19 ("drm/i915:
> Use SSE4.1 movntdqa to accelerate reads from WC memory").
>
> We raise the minimal supported binutils version from
rypto: curve25519 - do not pollute dispatcher based on assembler
x86: update AS_* macros to binutils >=2.23, supporting ADX and AVX2
Masahiro Yamada (11):
lib/raid6/test: fix build on distros whose /bin/sh is not bash
x86: remove unneeded defined(__ASSEMBLY__) check from asm/dwarf2.h
x86
Hi Ingo,
On Wed, Mar 25, 2020 at 1:59 PM Ingo Molnar wrote:
>
>
> * Masahiro Yamada wrote:
>
> > This series of cleanups was prompted by Linus:
> > https://lkml.org/lkml/2020/3/12/726
> >
> > First, this series drop always-on CONFIG_AS_* options.
> > So
version to 2.21").
I confirmed the code in $(call as-instr,...) can be assembled by the
binutils 2.21 assembler and also by LLVM integrated assembler.
Remove CONFIG_AS_MOVNTDQA, which is always defined.
Signed-off-by: Masahiro Yamada
Reviewed-by: Nick Desaulniers
---
drivers/gpu/drm/i9
):
x86: probe assembler capabilities via kconfig instead of makefile
crypto: x86 - rework configuration based on Kconfig
crypto: curve25519 - do not pollute dispatcher based on assembler
x86: update AS_* macros to binutils >=2.23, supporting ADX and AVX2
Masahiro Yamada (11):
lib/raid6/t
version to 2.21").
I confirmed the code in $(call as-instr,...) can be assembled by the
binutils 2.21 assembler and also by LLVM integrated assembler.
Remove CONFIG_AS_MOVNTDQA, which is always defined.
Signed-off-by: Masahiro Yamada
Reviewed-by: Nick Desaulniers
---
Changes in v2: None
On Fri, Mar 27, 2020 at 5:46 AM Jason A. Donenfeld wrote:
>
> On Thu, Mar 26, 2020 at 2:44 PM Masahiro Yamada wrote:
> > I collected more Reviewed-by and Acked-by,
> > then pushed this series to
> >
> > git://git.kernel.org/pub/scm/linux/kernel/git/masahiroy/linux
et it into -next ASAP, today would be ideal for test
> coverage ...
I collected more Reviewed-by and Acked-by,
then pushed this series to
git://git.kernel.org/pub/scm/linux/kernel/git/masahiroy/linux-kbuild.git
kbuild-asinstr
It will show up in -next soon.
--
Best Regards
Masahiro Yamada
__
(src)/$(GVT_DIR)/' is added to allow
include/trace/define_trace.h to find the gvt/trace.h
By setting the correct relative path to TRACE_INCLUDE_PATH, this -I
is also unneeded.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/gvt/Makefile | 1 -
drivers/gpu/drm/i915/gvt/trace.h | 2 +-
Including subdirectory Makefile from the driver main Makefile does not
buy us much because this is not real isolation.
Having a single Makefile at the top of the module is clearer, and
it is what this driver almost does.
Move all gvt objects to the i915 main Makefile.
Signed-off-by: Masahiro
Currently, Kbuild treats an object as multi-used when any of
$(foo-objs), $(foo-y), $(foo-m) is set. It makes more sense to
check $(foo-) as well.
In the context of foo-$(CONFIG_FOO_FEATURE1), CONFIG_FOO_FEATURE1
could be unset.
Signed-off-by: Masahiro Yamada
---
scripts/Makefile.lib | 10
limitation is getting more and more painful.
This commit allows modules to recurse into sub-directories. The
child Makefiles inherit composite object names from the parent.
TODO:
Add documentation for this syntax.
Signed-off-by: Masahiro Yamada
---
scripts/Makefile.build | 27
In the next commit, I will re-use this for thin-archives of objects
liked into modules.
Rename cmd_ar_builtin to a more generic cmd_ar_no_sym.
(cmd_ar is already defined in scripts/Makefile.lib)
I removed unneeded ifdef builtin-target.
No functional change intended.
Signed-off-by: Masahiro
'multi-used' is used for computing the modname. Improve the code
readability by removing the .o suffix before the foreach loop.
I renamed multi-used-m to modules-multi.
No functional change intended.
Signed-off-by: Masahiro Yamada
---
scripts/Makefile.build | 6 +++---
scripts/Ma
y does not work.
The single targets directly descend into the directory of
that file resides.
It missed subdir-ccflags-y if it is specifies in parent
Makefiles.
Perhaps, I will have to manage correct implementation of single targets.
Masahiro Yamada (5):
kbuild: treat an objec
You can use the -y syntax in sub-directory Makefiles
of modules.
Demonstrate how it works.
PLEASE DO NOT APPLY FOR NOW: this is only for comments.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/Makefile | 126 ++--
drivers/gpu/drm/i915/display/Makefile
On Tue, Aug 6, 2019 at 3:40 PM Masahiro Yamada
wrote:
>
> Currently, Kbuild treats an object as multi-used when any of
> $(foo-objs), $(foo-y), $(foo-m) is set. It makes more sense to
> check $(foo-) as well.
>
> In the context of foo-$(CONFIG_FOO_FEATURE1), CONFIG_FOO_FEATURE
As commit d0e628cd817f ("kbuild: doc: clarify the difference between
extra-y and always-y") explained, extra-y should be used for listing
the prerequsites of vmlinux. always-y is a better fix here.
Signed-off-by: Masahiro Yamada
---
Documentation/devicetree/bindings/Mak
On Thu, Jan 21, 2021 at 6:39 AM Rob Herring wrote:
>
> On Wed, Jan 20, 2021 at 03:23:51PM +0900, Masahiro Yamada wrote:
> > As commit d0e628cd817f ("kbuild: doc: clarify the difference between
> > extra-y and always-y") explained, extra-y should be used for listing
>
On Sat, Feb 22, 2020 at 1:43 PM Masahiro Yamada wrote:
>
> Hi Jani,
>
> On Fri, Feb 21, 2020 at 7:54 PM Jani Nikula wrote:
> >
> > $(CC) with $(CFLAGS_GCOV) assumes the output filename with .gcno suffix
> > appended is writable. This is not the case when the ou
On Sat, Feb 22, 2020 at 2:25 PM Randy Dunlap wrote:
>
> On 2/21/20 8:53 PM, Masahiro Yamada wrote:
> > On Sat, Feb 22, 2020 at 1:43 PM Masahiro Yamada
> > wrote:
> >>
> >> Hi Jani,
> >>
> >> On Fri, Feb 21, 2020 at 7:54 PM Jani Nikula wr
dead.org
> Reported-by: Randy Dunlap
> Fixes: c6d4a099a240 ("drm/i915: reimplement header test feature")
> Cc: Masahiro Yamada
> Signed-off-by: Jani Nikula
> ---
> drivers/gpu/drm/i915/Makefile | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
Remove unneeded variables and assignments.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 6 +-
drivers/gpu/drm/amd/amdgpu/sdma_v2_4.c| 6 +-
drivers/gpu/drm/amd/amdgpu/sdma_v3_0.c| 6 +-
drivers/gpu/drm/bridge
Hi Jani,
2016-09-07 17:34 GMT+09:00 Jani Nikula :
> On Wed, 07 Sep 2016, Masahiro Yamada wrote:
>> Remove unneeded variables and assignments.
>>
>> Signed-off-by: Masahiro Yamada
>
> ...
>
>> diff --git a/drivers/gpu/drm/i915/i915_drv.c
>> b/driver
Changes in v2:
- Split per-driver
- Remove i915_driver_open()
- Fix dce_virtual_hw_init() as well
Masahiro Yamada (5):
drm/amdgpu: squash lines for simple wrapper functions
drm/radeon: squash lines for simple wrapper functions
drm/bridge: squash lines for simple wrapper functions
i915_driver_open() is equivalent to i915_gem_open(). Replace the
i915_driver_open with the direct use of i915_gem_open().
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/i915_drv.c | 13 +
1 file changed, 1 insertion(+), 12 deletions(-)
diff --git a/drivers/gpu/drm/i915
2016-09-15 18:46 GMT+09:00 Jani Nikula :
> On Wed, 14 Sep 2016, Masahiro Yamada wrote:
>> i915_driver_open() is equivalent to i915_gem_open(). Replace the
>> i915_driver_open with the direct use of i915_gem_open().
>
> Sorry I know I asked for this, but there was oppos
Remove unneeded variables and assignments.
Signed-off-by: Masahiro Yamada
---
Changes in v3:
- Keep the wrapper function.
Cleanup of variables and assignments only.
- Fix intel_engine_init_common() as well.
drivers/gpu/drm/i915/i915_drv.c| 8 +---
drivers/gpu/drm/i915
Hi Chris,
2016-09-16 15:15 GMT+09:00 Chris Wilson :
> On Fri, Sep 16, 2016 at 10:40:23AM +0900, Masahiro Yamada wrote:
>> Remove unneeded variables and assignments.
>>
>> Signed-off-by: Masahiro Yamada
>> ---
>>
>> Changes in v3:
>> - Keep the wrap
the series.
Perhaps, the first two for v4.15. Then, rest of series
will be sent per-subsystem for v4.16?
Or, can somebody take care of the whole series?
I checked allmodconfig for x86 and arm64.
I am expecting 0 day testing will check it too.
Masahiro Yamada (12):
radix-tree: replace wit
tree accessors are used.
Signed-off-by: Masahiro Yamada
---
drivers/gpu/drm/i915/i915_gem.c| 1 +
drivers/gpu/drm/i915/i915_gem_context.c| 1 +
drivers/gpu/drm/i915/i915_gem_context.h| 2 +-
drivers/gpu/drm/i915/i915_gem_execbuffer.c | 1 +
drivers/gpu/drm/i915/i915_gem_object.h
2017-10-09 3:52 GMT+09:00 Leon Romanovsky :
> On Mon, Oct 09, 2017 at 01:10:01AM +0900, Masahiro Yamada wrote:
>
> <...>
>>
>> By splitting out the radix_tree_root definition,
>> we can reduce the header file dependency.
>>
>> Reducing the header
2017-10-10 21:18 GMT+09:00 Matthew Wilcox :
> On Mon, Oct 09, 2017 at 01:10:01AM +0900, Masahiro Yamada wrote:
>> Reducing the header dependency will help for speeding the kernel
>> build, suppressing unnecessary recompile of objects during
>> git-bisect'ing, etc.
>
in our local subdir-ccflags-y and can be dropped.
>
> Cc: Arnd Bergmann
> Cc: Nick Desaulniers
> Cc: Nathan Chancellor
> Cc: Masahiro Yamada
> Signed-off-by: Jani Nikula
I made a similar suggestion in the past
https://lore.kernel.org/dri-devel/20190515043753.9853-1-yamada.
in our local subdir-ccflags-y and can be dropped.
>
> Cc: Arnd Bergmann
> Cc: Nick Desaulniers
> Cc: Nathan Chancellor
> Cc: Masahiro Yamada
> Reviewed-by: Nathan Chancellor
> Acked-by: Nick Desaulniers
> Signed-off-by: Jani Nikula
> ---
Reviewed-by: Masahiro Yamada
--
Best Regards
Masahiro Yamada
W=2 or W=3
> builds, depending on the warning.
>
> v2: Add back some -Wextra warning disables (Nathan)
>
> Cc: Arnd Bergmann
> Cc: Nick Desaulniers
> Cc: Nathan Chancellor
> Cc: Masahiro Yamada
> Reviewed-by: Nathan Chancellor
> Signed-off-by: Jani Nikula
Reviewed-by: Masahiro Yamada
--
Best Regards
Masahiro Yamada
rror to kernel-doc
> locally, and fail the build when there are kernel-doc warnings in i915.
>
> Cc: Masahiro Yamada
> Signed-off-by: Jani Nikula
>
> ---
>
> Masahiro, is this an awful hack to do in our local Makefile?
>
> Note that we do try to
; > Cc: Maarten Lankhorst
> > Cc: Maxime Ripard
> > Cc: Thomas Zimmermann
> > Cc: Masahiro Yamada
> > Acked-by: Thomas Zimmermann
> > Signed-off-by: Jani Nikula
>
> Masahiro, ack for merging this?
Sorry, I did not notice that I was
n Lankhorst
> Cc: Maxime Ripard
> Cc: Thomas Zimmermann
> Cc: Masahiro Yamada
> Acked-by: Thomas Zimmermann
> Signed-off-by: Jani Nikula
> ---
> Kbuild | 1 +
> drivers/gpu/drm/Kconfig | 11 +++
> drivers/gpu/drm/Makefile | 18 ++
On Mon, Mar 3, 2025 at 7:02 PM Jani Nikula wrote:
>
> On Mon, 03 Mar 2025, Masahiro Yamada wrote:
> > +CC: Linus
> >
> > On Wed, Jan 22, 2025 at 11:41 PM Jani Nikula wrote:
> >>
> >> Ensure drm headers build, are self-contained, have header guards,
On Wed, Mar 5, 2025 at 10:59 PM Maxime Ripard wrote:
>
> On Wed, Mar 05, 2025 at 03:05:25AM +0900, Masahiro Yamada wrote:
> > > IMO headers should almost invariably be self-contained, instead of
> > > putting the burden on their users to include other headers to make it
&g
On Mon, Mar 3, 2025 at 10:53 PM Jani Nikula wrote:
>
> On Mon, 03 Mar 2025, Masahiro Yamada wrote:
> > On Mon, Mar 3, 2025 at 7:02 PM Jani Nikula wrote:
> >>
> >> On Mon, 03 Mar 2025, Masahiro Yamada wrote:
> >> And one of the underlying goals is to mak
65 matches
Mail list logo