Change the backlight device names from intel_backlight to
card%d-%s-backlight format, for example card0-eDP-1-backlight, to make
them unique. Otherwise, registering multiple backlight devices with
intel_backlight name will fail, regardless of whether they're two
connectors in the same device or two
On 4/6/2021 3:44 PM, Anshuman Gupta wrote:
Fix static analysis tool uninitialized symbol error.
Reported-by: kernel test robot
Reported-by: Dan Carpenter
Signed-off-by: Anshuman Gupta
---
drivers/gpu/drm/i915/display/intel_dp_hdcp.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
di
== Series Details ==
Series: drm/i915/backlight: switch to unique backlight device names
URL : https://patchwork.freedesktop.org/series/88798/
State : warning
== Summary ==
$ make htmldocs 2>&1 > /dev/null | grep i915
./drivers/gpu/drm/i915/gem/i915_gem_shrinker.c:102: warning: Function parame
== Series Details ==
Series: drm/i915/backlight: switch to unique backlight device names
URL : https://patchwork.freedesktop.org/series/88798/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_9931 -> Patchwork_19897
Summary
--
On Wed, 07 Apr 2021, Patchwork wrote:
> == Series Details ==
>
> Series: drm/i915/backlight: switch to unique backlight device names
> URL : https://patchwork.freedesktop.org/series/88798/
> State : failure
>
> == Summary ==
>
> CI Bug Log - changes from CI_DRM_9931 -> Patchwork_19897
>
The kobj here is a type-erased version of mdev_type, which is already
stored in the struct mdev_device being passed in. It was only ever used to
compute the type_group_id, which is now extracted directly from the mdev.
Reviewed-by: Kevin Tian
Reviewed-by: Cornelia Huck
Reviewed-by: Christoph Hel
The ascii85.h is user of exactly two headers, i.e. math.h and types.h.
There is no need to carry on entire kernel.h.
Signed-off-by: Andy Shevchenko
---
include/linux/ascii85.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/include/linux/ascii85.h b/include/linux/ascii85.h
On Tue, Apr 06, 2021 at 03:57:32PM +0200, Hans de Goede wrote:
> Hi,
>
> On 3/25/21 12:48 PM, Hans de Goede wrote:
> > After the recently added commit fe0f1e3bfdfe ("drm/i915: Shut down
> > displays gracefully on reboot"), the DSI panel on a Cherry Trail based
> > Predia Basic tablet would no long
== Series Details ==
Series: series starting with [v1,1/1] drm/i915: Include only needed headers in
ascii85.h
URL : https://patchwork.freedesktop.org/series/88803/
State : warning
== Summary ==
$ make htmldocs 2>&1 > /dev/null | grep i915
./drivers/gpu/drm/i915/gem/i915_gem_shrinker.c:102: wa
On Wed, 07 Apr 2021, Andy Shevchenko wrote:
> The ascii85.h is user of exactly two headers, i.e. math.h and types.h.
> There is no need to carry on entire kernel.h.
>
> Signed-off-by: Andy Shevchenko
That's hardly drm/i915 specific!
Reviewed-by: Jani Nikula
But who's going to pick it up and,
On Thu, 25 Mar 2021, Matt Roper wrote:
> From: Vandita Kulkarni
>
> Add the qp table for 444 formats, for 8bpc, 10bpc and 12bpc, as given by
> the VESA C model for DSC 1.1
>
> v2:
> - Add include guard to header (Jani)
> - Move the big tables to a .c file (Chris, Jani, Lucas)
I was kind of hop
== Series Details ==
Series: series starting with [v1,1/1] drm/i915: Include only needed headers in
ascii85.h
URL : https://patchwork.freedesktop.org/series/88803/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_9931 -> Patchwork_19898
==
On Wed, Apr 07, 2021 at 03:46:37PM +0300, Jani Nikula wrote:
> On Wed, 07 Apr 2021, Andy Shevchenko
> wrote:
> > The ascii85.h is user of exactly two headers, i.e. math.h and types.h.
> > There is no need to carry on entire kernel.h.
> >
> > Signed-off-by: Andy Shevchenko
>
> That's hardly drm/
On Wed, Apr 07, 2021 at 04:40:10PM +0300, Andy Shevchenko wrote:
> On Wed, Apr 07, 2021 at 03:46:37PM +0300, Jani Nikula wrote:
> > On Wed, 07 Apr 2021, Andy Shevchenko
> > wrote:
> > > The ascii85.h is user of exactly two headers, i.e. math.h and types.h.
> > > There is no need to carry on entir
Hi,
On 4/7/21 2:34 PM, Ville Syrjälä wrote:
> On Tue, Apr 06, 2021 at 03:57:32PM +0200, Hans de Goede wrote:
>> Hi,
>>
>> On 3/25/21 12:48 PM, Hans de Goede wrote:
>>> After the recently added commit fe0f1e3bfdfe ("drm/i915: Shut down
>>> displays gracefully on reboot"), the DSI panel on a Cherry
On Wed, Apr 07, 2021 at 03:50:35PM +0200, Hans de Goede wrote:
> Hi,
>
> On 4/7/21 2:34 PM, Ville Syrjälä wrote:
> > On Tue, Apr 06, 2021 at 03:57:32PM +0200, Hans de Goede wrote:
> >> Hi,
> >>
> >> On 3/25/21 12:48 PM, Hans de Goede wrote:
> >>> After the recently added commit fe0f1e3bfdfe ("drm/
== Series Details ==
Series: series starting with [v1,1/1] drm/i915: Include only needed headers in
ascii85.h
URL : https://patchwork.freedesktop.org/series/88803/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_9931_full -> Patchwork_19898_full
On Tue, Oct 13, 2020 at 02:15:32PM +0300, Ville Syrjälä wrote:
> On Tue, Oct 13, 2020 at 01:20:35PM +0800, Kai-Heng Feng wrote:
> >
> >
> > > On Sep 3, 2020, at 14:26, Kai-Heng Feng
> > > wrote:
> > >
> > >
> > >
> > >> On Aug 26, 2020, at 21:05, Ville Syrjälä
> > >> wrote:
> > >>
> > >>
On Wed, Apr 07, 2021 at 09:18:51AM -0400, Rodrigo Vivi wrote:
> On Thu, Jun 04, 2020 at 12:11:07PM +0200, Peter Zijlstra wrote:
> > On Tue, Jun 02, 2020 at 08:27:10PM +0200, Peter Zijlstra wrote:
> > > On Tue, Jun 02, 2020 at 06:08:03PM +, Souza, Jose wrote:
> > > > Hi Peter
> > > > Please file
> -Original Message-
> From: Intel-gfx On Behalf Of Lucas
> De Marchi
> Sent: Friday, March 19, 2021 10:36 AM
> To: intel-gfx@lists.freedesktop.org
> Subject: [Intel-gfx] [PATCH v2 3/3] drm/i915/display: remove strap checks
> from gen 9
>
> Direction on gen9+ was to stop reading the st
On Fri, Apr 02, 2021 at 10:23:17AM +0200, Takashi Iwai wrote:
> intel_dsm_platform_mux_info() tries to parse the ACPI package data
> from _DSM for the debug information, but it assumes the fixed format
> without checking what values are stored in the elements actually.
> When an unexpected value is
On Wed, 07 Apr 2021 18:34:46 +0200,
Ville Syrjälä wrote:
>
> On Fri, Apr 02, 2021 at 10:23:17AM +0200, Takashi Iwai wrote:
> > intel_dsm_platform_mux_info() tries to parse the ACPI package data
> > from _DSM for the debug information, but it assumes the fixed format
> > without checking what value
On Tue, Apr 6, 2021 at 11:17 PM Hans de Goede wrote:
>
> Add a getter for the acpi_gbl_reduced_hardware variable so that modules
> can check if they are running on an ACPI reduced-hw platform or not.
>
> Signed-off-by: Hans de Goede
> ---
> drivers/acpi/utils.c| 11 +++
> include/acp
Hi,
On 4/7/21 7:13 PM, Rafael J. Wysocki wrote:
> On Tue, Apr 6, 2021 at 11:17 PM Hans de Goede wrote:
>>
>> Add a getter for the acpi_gbl_reduced_hardware variable so that modules
>> can check if they are running on an ACPI reduced-hw platform or not.
>>
>> Signed-off-by: Hans de Goede
>> ---
>
On Wed, Apr 7, 2021 at 7:43 PM Hans de Goede wrote:
>
> Hi,
>
> On 4/7/21 7:13 PM, Rafael J. Wysocki wrote:
> > On Tue, Apr 6, 2021 at 11:17 PM Hans de Goede wrote:
> >>
> >> Add a getter for the acpi_gbl_reduced_hardware variable so that modules
> >> can check if they are running on an ACPI redu
Add a getter for the acpi_gbl_reduced_hardware variable so that modules
can check if they are running on an ACPI reduced-hw platform or not.
Signed-off-by: Hans de Goede
---
Changes in v2:
- Use EXPORT_SYMBOL_GPL instead of EXPORT_SYMBOL
---
drivers/acpi/utils.c| 11 +++
include/acpi
Hi,
On 4/7/21 7:50 PM, Rafael J. Wysocki wrote:
> On Wed, Apr 7, 2021 at 7:43 PM Hans de Goede wrote:
>>
>> Hi,
>>
>> On 4/7/21 7:13 PM, Rafael J. Wysocki wrote:
>>> On Tue, Apr 6, 2021 at 11:17 PM Hans de Goede wrote:
Add a getter for the acpi_gbl_reduced_hardware variable so that mod
> -Original Message-
> From: Intel-gfx On Behalf Of Matt
> Roper
> Sent: Monday, March 29, 2021 11:54 AM
> To: intel-gfx@lists.freedesktop.org
> Cc: De Marchi, Lucas
> Subject: [Intel-gfx] [PATCH v2] drm/i915/display: Eliminate IS_GEN9_{BC, LP}
>
> Now that we've eliminated INTEL_GEN(),
Now that we've eliminated INTEL_GEN(), IS_GEN_RANGE(), etc. from the
display code, we should also kill off our use of the IS_GEN9_* macros
too. We'll do the conversion manually this time instead of using
Coccinelle since the most logical substitution can depend heavily on the
code context, and som
On Wed, Apr 07, 2021 at 12:08:12PM +0300, Jani Nikula wrote:
> Change the backlight device names from intel_backlight to
> card%d-%s-backlight format, for example card0-eDP-1-backlight, to make
> them unique. Otherwise, registering multiple backlight devices with
> intel_backlight name will fail, r
== Series Details ==
Series: drm/i915/display: Eliminate IS_GEN9_{BC,LP} (rev3)
URL : https://patchwork.freedesktop.org/series/88466/
State : warning
== Summary ==
$ make htmldocs 2>&1 > /dev/null | grep i915
./drivers/gpu/drm/i915/gem/i915_gem_shrinker.c:102: warning: Function parameter
or m
== Series Details ==
Series: drm/i915/display: Eliminate IS_GEN9_{BC,LP} (rev3)
URL : https://patchwork.freedesktop.org/series/88466/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_9931 -> Patchwork_19899
Summary
---
On Wed, Apr 07, 2021 at 06:56:15PM +0200, Takashi Iwai wrote:
> On Wed, 07 Apr 2021 18:34:46 +0200,
> Ville Syrjälä wrote:
> >
> > On Fri, Apr 02, 2021 at 10:23:17AM +0200, Takashi Iwai wrote:
> > > intel_dsm_platform_mux_info() tries to parse the ACPI package data
> > > from _DSM for the debug in
== Series Details ==
Series: drm/i915/display: Eliminate IS_GEN9_{BC,LP} (rev3)
URL : https://patchwork.freedesktop.org/series/88466/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_9931_full -> Patchwork_19899_full
Summary
-
On Wed, Apr 07, 2021 at 01:13:35PM -0700, Sripada, Radhakrishna wrote:
> > -Original Message-
> > From: Intel-gfx On Behalf Of Matt
> > Roper
> > Sent: Monday, March 29, 2021 11:54 AM
> > To: intel-gfx@lists.freedesktop.org
> > Cc: De Marchi, Lucas
> > Subject: [Intel-gfx] [PATCH v2] drm/
The macro we use to check is called DISPLAY_VER(). While using this
macro and the new ones being added in following changes I made the
mistake multiple times when mixing both "ver" and "version". Although
it's usually better to prefer the complete name, the shorhand
DISPLAY_VER() / GRAPHICS_VER / M
Since its introduction 2 years ago, we never used the mask to span more
than one gen. Replace gen_mask a single number and start using the new
GRAPHICS_VER().
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/gt/selftest_workarounds.c | 10 +-
1 file changed, 5 insertions(+), 5 del
Like it was done in
commit 01eb15c9165e ("drm/i915: Add DISPLAY_VER() and related macros")
add the correspondent macros for graphics and media. Going forward we
will prefer checking the versions for the specific IPs (graphics, media
and display) rather than grouping everything under a "gen" version
Replace gen with the new graphics_ver value and use GRAPHICS_VER()
in those places.
Signed-off-by: Lucas De Marchi
---
.../gpu/drm/i915/gem/i915_gem_execbuffer.c| 22 +--
drivers/gpu/drm/i915/i915_drv.c | 2 +-
drivers/gpu/drm/i915/intel_device_info.c | 2
Now that it's not being used anymore, finish its removal. Like for
gen_mask, we replace INTEL_GEN() and IS_GEN() macros to use the new
field.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/i915_drv.h | 10 +-
drivers/gpu/drm/i915/i915_pci.c |
Commit 989634fb49ad ("drm/i915/audio: set HDA link parameters in driver")
added INTEL_GEN() in the display code, where it should actually be using
DISPLAY_VER(). Switch to the new macro.
Cc: Kai Vehmanen
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/display/intel_audio.c | 2 +-
1 fil
Now that it's not used anywhere, remove it from struct
intel_device_info. To allow a period in which code will be converted to
the new macro, keep IS_GEN_RANGE() around, just redefining it to use
the new fields. The size advantage from IS_GEN_RANGE() using a mask is
not that big as it has pretty li
Like was done for the display part that parted ways with INTEL_GEN(),
replacing with DISPLAY_VER(), do a similar conversion for the rest of
the driver.
Lucas De Marchi (12):
drm/i915: rename display.version to display.ver
drm/i915: add macros for graphics and media versions
drm/i915/gt: repl
Remove the remaining uses of INTEL_GEN_MASK() and the correspondent
gen_mask in struct intel_device_info. This will allow the removal of
gen_mask later since it's incompatible with the new per-IP versioning
scheme.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/intel_uncore.c
Since we are now converting from a single gen version to graphics_ver,
media_ver and display_ver, add the last 2 when printing the device info.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/intel_device_info.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/i915/i
Start using the new fields graphics_version for the previous gen checks.
Here we rename the "gen" field and replace the comparisons using it to
start using the new GRAPHICS_VER(). Other uses of INTEL_GEN() were left
as is for automatic conversion later.
Signed-off-by: Lucas De Marchi
---
drivers
Make them independent so we can use DGFX_FEATURES more generically.
For future platforms that do not use the GEN nomenclature we will define
graphics, media and display separately, so we avoid setting graphics_ver
with the GEN() macro.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/i915
On Wed, Apr 7, 2021 at 5:42 PM Lucas De Marchi wrote:
>
> Like was done for the display part that parted ways with INTEL_GEN(),
> replacing with DISPLAY_VER(), do a similar conversion for the rest of
> the driver.
>
> Lucas De Marchi (12):
> drm/i915: rename display.version to display.ver
> dr
Like was done for the display part that parted ways with INTEL_GEN(),
replacing with DISPLAY_VER(), do a similar conversion for the rest of
the driver.
v2: Remove .ko that was incorrectly added as part of patch 11, making it
very big and not going through the mailing list. Sorry for those in CC
wh
Since its introduction 2 years ago, we never used the mask to span more
than one gen. Replace gen_mask a single number and start using the new
GRAPHICS_VER().
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/gt/selftest_workarounds.c | 10 +-
1 file changed, 5 insertions(+), 5 del
Like it was done in
commit 01eb15c9165e ("drm/i915: Add DISPLAY_VER() and related macros")
add the correspondent macros for graphics and media. Going forward we
will prefer checking the versions for the specific IPs (graphics, media
and display) rather than grouping everything under a "gen" version
Start using the new fields graphics_version for the previous gen checks.
Here we rename the "gen" field and replace the comparisons using it to
start using the new GRAPHICS_VER(). Other uses of INTEL_GEN() were left
as is for automatic conversion later.
Signed-off-by: Lucas De Marchi
---
drivers
Now that it's not used anywhere, remove it from struct
intel_device_info. To allow a period in which code will be converted to
the new macro, keep IS_GEN_RANGE() around, just redefining it to use
the new fields. The size advantage from IS_GEN_RANGE() using a mask is
not that big as it has pretty li
Remove the remaining uses of INTEL_GEN_MASK() and the correspondent
gen_mask in struct intel_device_info. This will allow the removal of
gen_mask later since it's incompatible with the new per-IP versioning
scheme.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/intel_uncore.c
Now that it's not being used anymore, finish its removal. Like for
gen_mask, we replace INTEL_GEN() and IS_GEN() macros to use the new
field.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/i915_drv.h | 10 +-
drivers/gpu/drm/i915/i915_pci.c |
Commit 989634fb49ad ("drm/i915/audio: set HDA link parameters in driver")
added INTEL_GEN() in the display code, where it should actually be using
DISPLAY_VER(). Switch to the new macro.
Cc: Kai Vehmanen
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/display/intel_audio.c | 2 +-
1 fil
Make them independent so we can use DGFX_FEATURES more generically.
For future platforms that do not use the GEN nomenclature we will define
graphics, media and display separately, so we avoid setting graphics_ver
with the GEN() macro.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/i915
Since we are now converting from a single gen version to graphics_ver,
media_ver and display_ver, add the last 2 when printing the device info.
Signed-off-by: Lucas De Marchi
---
drivers/gpu/drm/i915/intel_device_info.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/i915/i
Replace gen with the new graphics_ver value and use GRAPHICS_VER()
in those places.
Signed-off-by: Lucas De Marchi
---
.../gpu/drm/i915/gem/i915_gem_execbuffer.c| 22 +--
drivers/gpu/drm/i915/i915_drv.c | 2 +-
drivers/gpu/drm/i915/intel_device_info.c | 2
The macro we use to check is called DISPLAY_VER(). While using this
macro and the new ones being added in following changes I made the
mistake multiple times when mixing both "ver" and "version". Although
it's usually better to prefer the complete name, the shorhand
DISPLAY_VER() / GRAPHICS_VER / M
== Series Details ==
Series: drm/i915: Extend GEN renames to the rest of the driver (rev2)
URL : https://patchwork.freedesktop.org/series/88825/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
80f2d9b2707c drm/i915: rename display.version to display.ver
-:46: CHECK:MACRO_ARG_REUS
== Series Details ==
Series: drm/i915: Extend GEN renames to the rest of the driver (rev2)
URL : https://patchwork.freedesktop.org/series/88825/
State : warning
== Summary ==
$ dim sparse --fast origin/drm-tip
Sparse version: v0.6.2
Fast mode used, each commit won't be checked separately.
-
+d
== Series Details ==
Series: drm/i915: Extend GEN renames to the rest of the driver (rev2)
URL : https://patchwork.freedesktop.org/series/88825/
State : warning
== Summary ==
$ make htmldocs 2>&1 > /dev/null | grep i915
./drivers/gpu/drm/i915/gem/i915_gem_shrinker.c:102: warning: Function para
== Series Details ==
Series: drm/i915: Extend GEN renames to the rest of the driver (rev2)
URL : https://patchwork.freedesktop.org/series/88825/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_9934 -> Patchwork_19900
Summary
64 matches
Mail list logo