[Intel-gfx] [PATCH xf86-video-intel] intel: replace direct ioctl use with drm{Set, Drop}Master

2013-06-30 Thread Jonathan Gray
Use drmSetMaster/drmDropMaster instead of calling the ioctls directly. Fixes compilation on OpenBSD where these ioctls aren't defined. Signed-off-by: Jonathan Gray --- src/intel_device.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git src/intel_device.c src/intel_device.

Re: [Intel-gfx] [PATCH xf86-video-intel] intel: replace direct ioctl use with drm{Set, Drop}Master

2013-06-30 Thread Chris Wilson
On Sun, Jun 30, 2013 at 07:37:45PM +1000, Jonathan Gray wrote: > Use drmSetMaster/drmDropMaster instead of calling the ioctls > directly. Fixes compilation on OpenBSD where these ioctls > aren't defined. > > Signed-off-by: Jonathan Gray Sigh. Thanks for the patch, pushed. -Chris -- Chris Wils

Re: [Intel-gfx] [PATCH 57/66] drm/i915: Disallow pin with full ppgtt

2013-06-30 Thread Daniel Vetter
On Sat, Jun 29, 2013 at 11:56:53PM -0700, Ben Widawsky wrote: > On Sat, Jun 29, 2013 at 04:34:07PM +0200, Daniel Vetter wrote: > > On Sat, Jun 29, 2013 at 8:44 AM, Chris Wilson > > wrote: > > > On Fri, Jun 28, 2013 at 10:43:30PM -0700, Ben Widawsky wrote: > > >> On Fri, Jun 28, 2013 at 09:55:27AM

[Intel-gfx] Updated drm-intel-testing

2013-06-30 Thread Daniel Vetter
Hi all, New testing tree. I still need to split it up into fixes for 3.11, but the new features here most likely will all go into 3.12. Highlights: - fixup the unwind paths for "ghost eDP" on haswell (Paulo) - fix pch detection on virtual machines - fix sdvo hpd on i965g/gm (Bspec was wrong!) - mo

Re: [Intel-gfx] [PATCH 57/66] drm/i915: Disallow pin with full ppgtt

2013-06-30 Thread Chris Wilson
On Sun, Jun 30, 2013 at 01:06:47PM +0200, Daniel Vetter wrote: > On Sat, Jun 29, 2013 at 11:56:53PM -0700, Ben Widawsky wrote: > > On Sat, Jun 29, 2013 at 04:34:07PM +0200, Daniel Vetter wrote: > > > On Sat, Jun 29, 2013 at 8:44 AM, Chris Wilson > > > wrote: > > > > On Fri, Jun 28, 2013 at 10:43:

Re: [Intel-gfx] [PATCH 57/66] drm/i915: Disallow pin with full ppgtt

2013-06-30 Thread Daniel Vetter
On Sun, Jun 30, 2013 at 1:31 PM, Chris Wilson wrote: > I respectfully disagree. The semantics of the pin ioctl remain useful > even with the ggtt/ppgtt split, and I think barring its use forever more > is unwise. Not that pinning is a good solution, just in some cases it > may be the only solution

Re: [Intel-gfx] [PATCH 04/66] drm: Optionally create mm blocks from top-to-bottom

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:05PM -0700, Ben Widawsky wrote: > From: Chris Wilson > > Clients like i915 needs to segregate cache domains within the GTT which > can lead to small amounts of fragmentation. By allocating the uncached > buffers from the bottom and the cacheable buffers from the top,

Re: [Intel-gfx] [PATCH 29/66] drm: pre allocate node for create_block

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:30PM -0700, Ben Widawsky wrote: > For an upcoming patch where we introduce the i915 VMA, it's ideal to > have the drm_mm_node as part of the VMA struct (ie. it's pre-allocated). > Part of the conversion to VMAs is to kill off obj->gtt_space. Doing this > will break a b

Re: [Intel-gfx] [PATCH 04/66] drm: Optionally create mm blocks from top-to-bottom

2013-06-30 Thread Daniel Vetter
On Sun, Jun 30, 2013 at 2:30 PM, Daniel Vetter wrote: > On Thu, Jun 27, 2013 at 04:30:05PM -0700, Ben Widawsky wrote: >> From: Chris Wilson >> >> Clients like i915 needs to segregate cache domains within the GTT which >> can lead to small amounts of fragmentation. By allocating the uncached >> bu

Re: [Intel-gfx] [PATCH 30/66] drm/i915: Getter/setter for object attributes

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:31PM -0700, Ben Widawsky wrote: > This will be handy when we add VMs. It's not strictly, necessary, but it > will make the code much cleaner. > > Signed-off-by: Ben Widawsky You're going to hate, but this is patch ordering fail. Imo this should be one of the very fi

Re: [Intel-gfx] [PATCH 20/66] drm/i915: Move fbc members out of line

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:21PM -0700, Ben Widawsky wrote: > Signed-off-by: Ben Widawsky Merged patches 16-20, thanks. -Daniel > --- > drivers/gpu/drm/i915/i915_debugfs.c| 2 +- > drivers/gpu/drm/i915/i915_drv.h| 48 +++-- > drivers/gpu/drm/i915/i915_

Re: [Intel-gfx] [PATCH 21/66] drm/i915: Move gtt and ppgtt under address space umbrella

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:22PM -0700, Ben Widawsky wrote: > The GTT and PPGTT can be thought of more generally as GPU address > spaces. Many of their actions (insert entries), state (LRU lists) and > many of their characteristics (size), can be shared. Do that. > > Created a i915_gtt_vm helper

Re: [Intel-gfx] [PATCH 23/66] drm/i915: Move stolen stuff to i915_gtt

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:24PM -0700, Ben Widawsky wrote: > It doesn't apply to generic VMA, so it belongs with the gtt. > > for file in `ls drivers/gpu/drm/i915/*.c` ; do > sed -i "s/mm.stolen_base/gtt.stolen_base/" $file; > done > > for file in `ls drivers/gpu/drm/i915/*.c` ; do >

Re: [Intel-gfx] [PATCH 24/66] drm/i915: Move aliasing_ppgtt

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:25PM -0700, Ben Widawsky wrote: > for file in `ls drivers/gpu/drm/i915/*.c` ; do > sed -i "s/mm.aliasing/gtt.aliasing/" $file; > done Commit message should explain _why_ we do something. Again I'm asking since I'm unclear about how things fit all together and wh

Re: [Intel-gfx] [PATCH 40/66] drm/i915: Track all VMAs per VM

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:41PM -0700, Ben Widawsky wrote: > This allows us to be aware of all the VMAs leftover and teardown, and is > useful for debug. I suspect it will prove even more useful later. > > Signed-off-by: Ben Widawsky > --- > drivers/gpu/drm/i915/i915_drv.h | 2 ++ > drivers/g

Re: [Intel-gfx] [PATCH 26/66] drm/i915: Move active/inactive lists to new mm

2013-06-30 Thread Daniel Vetter
On Thu, Jun 27, 2013 at 04:30:27PM -0700, Ben Widawsky wrote: > for file in `ls drivers/gpu/drm/i915/*.c` ; do sed -i > "s/dev_priv->mm.inactive_list/i915_gtt_mm-\>inactive_list/" $file; done > for file in `ls drivers/gpu/drm/i915/*.c` ; do sed -i > "s/dev_priv->mm.active_list/i915_gtt_mm-\>activ

Re: [Intel-gfx] [PATCH] drm/i915: pixel multiplier readout support for pch ports

2013-06-30 Thread Daniel Vetter
On Fri, Jun 28, 2013 at 10:20:35AM -0700, Jesse Barnes wrote: > On Thu, 27 Jun 2013 19:47:19 +0200 > Daniel Vetter wrote: > > > Now that we painstakingly track the shared pch dplls we can finally > > implement pixel mutliplier readout support for pch ports, too. > > > > v2: Undo the temporary ha

Re: [Intel-gfx] [PATCH 5/5] drm/i915: flip on a no fb -> fb transition if crtc is active v3

2013-06-30 Thread Daniel Vetter
On Wed, Jun 26, 2013 at 01:38:19AM +0300, Jesse Barnes wrote: > If the crtc is active, we can simply flip a new fb onto it, provided the > other mode setting reqs are met. Otherwise, we'll need to do a full > mode set to re-enable the crtc. > > v2: check for crtc active and set mode_changed accor

[Intel-gfx] [ANNOUNCE] xf86-video-intel 2.21.11

2013-06-30 Thread Chris Wilson
Release 2.21.11 (2013-06-30) An eventful week. What started with a regression with some builds of firefox on some machines lead ultimately to the discovery of an older kernel bug. Aside from the work to fix the image bug and a few other older bugs that were reported and

Re: [Intel-gfx] [PATCH 3/3] drm/i915: Allow contexts to be specified for unsupported rings

2013-06-30 Thread Ben Widawsky
On Tue, Jun 25, 2013 at 05:10:42PM +0100, Chris Wilson wrote: > On Tue, Jun 25, 2013 at 06:47:02PM +0300, Mika Kuoppala wrote: > > From: Chris Wilson > > > > As our contexts are more general than the logical contexts supported by > > the hardware, for instance they allow per context hangcheck tra

Re: [Intel-gfx] [PATCH 2/3] drm/i915: Replace open-coding of DEFAULT_CONTEXT_ID

2013-06-30 Thread Ben Widawsky
On Tue, Jun 25, 2013 at 06:47:01PM +0300, Mika Kuoppala wrote: > From: Chris Wilson > > The intent of the check is made more clear if we use the proper name for > 0 here. > > Signed-off-by: Chris Wilson Reviewed-by: Ben Widawsky [snip] -- Ben Widawsky, Intel Open Source Technology Center

Re: [Intel-gfx] [PATCH 1/3] drm/i915: Fix retrieval of hangcheck stats

2013-06-30 Thread Ben Widawsky
On Tue, Jun 25, 2013 at 06:47:00PM +0300, Mika Kuoppala wrote: > From: Chris Wilson > > The default context is always supported (as it contains the global > hangcheck stats) and the contexts for hangcheck are not limited > to any ring. > > References: https://bugs.freedesktop.org/show_bug.cgi?id

Re: [Intel-gfx] [PATCH i-g-t 1/3] quick_dump: Add automagic DPIO register support

2013-06-30 Thread Ben Widawsky
On Wed, Jun 26, 2013 at 08:57:32PM +0300, ville.syrj...@linux.intel.com wrote: > From: Ville Syrjälä > > Repurpose the (currently unused) third element in the register > definition tuple to indicate the type of the register. 'DPIO' > is the only special register type for now. > > Signed-off-by:

Re: [Intel-gfx] [PATCH 2/3] drm/i915: no hangcheck when reset is in progress

2013-06-30 Thread Ben Widawsky
On Tue, Jun 25, 2013 at 06:26:40PM +0300, Mika Kuoppala wrote: > The timer for hangchecking can run again before the previous > reset it has triggered has been handled. This can corrupt > the hangcheck state as reset handling will access and write to > the hangcheck data. To prevent this, avoid run

Re: [Intel-gfx] [PATCH] drm/i915: Don't wait for vblank for sprite plane flips

2013-06-30 Thread Vijay Purushothaman
On 6/28/2013 7:54 PM, Ville Syrjälä wrote: On Fri, Jun 28, 2013 at 07:45:31PM +0530, Vijay Purushothaman wrote: Since the sprite planes are using synchronized MMIO based flip, no need to wait for vblank. Removing this wait allows us to get a nice performance boost to both 3D & media workloads ba

Re: [Intel-gfx] [PATCH] drm/i915: Don't wait for vblank for sprite plane flips

2013-06-30 Thread Vijay Purushothaman
On 6/28/2013 9:35 PM, Chris Wilson wrote: On Fri, Jun 28, 2013 at 05:24:50PM +0300, Ville Syrjälä wrote: On Fri, Jun 28, 2013 at 07:45:31PM +0530, Vijay Purushothaman wrote: Since the sprite planes are using synchronized MMIO based flip, no need to wait for vblank. Removing this wait allows us