On 25/04/2018 15:09, Chris Wilson wrote:
Quoting Tvrtko Ursulin (2018-04-25 15:00:43)
On 25/04/2018 13:37, Chris Wilson wrote:
When filling the ring to align the emit pointer to the next cacheline,
use memset64() rather than open-coding it. As we know that we always
have an even number of dwo
Quoting Tvrtko Ursulin (2018-04-25 15:00:43)
>
> On 25/04/2018 13:37, Chris Wilson wrote:
> > When filling the ring to align the emit pointer to the next cacheline,
> > use memset64() rather than open-coding it. As we know that we always
> > have an even number of dwords, we can replace the dword
On 25/04/2018 13:37, Chris Wilson wrote:
When filling the ring to align the emit pointer to the next cacheline,
use memset64() rather than open-coding it. As we know that we always
have an even number of dwords, we can replace the dword loop with the
qword equivalent.
Signed-off-by: Chris Wilso
When filling the ring to align the emit pointer to the next cacheline,
use memset64() rather than open-coding it. As we know that we always
have an even number of dwords, we can replace the dword loop with the
qword equivalent.
Signed-off-by: Chris Wilson
---
drivers/gpu/drm/i915/intel_ringbuffe