When we switched to always using a timeout in conjunction with
wait_seqno, we lost the ability to detect missed interrupts. Since, we
have had issues with interrupts on a number of generations, and they are
required to be delivered in a timely fashion for a smooth UX, it is
important that we do log
On Fri, Aug 23, 2013 at 10:06 AM, Chris Wilson wrote:
>> Yeah, I think this approach should work. A few comments:
>> - I think we need a debugfs file to shut the safety quirk off - when
>> testing on a machine where we actually miss interrupts it might be
>> usful to get the warning output every t
On Fri, Aug 23, 2013 at 09:27:42AM +0200, Daniel Vetter wrote:
> On Fri, Aug 23, 2013 at 3:05 AM, Chris Wilson
> wrote:
> > Rather than continue to fix up the timeouts to work around the interface
> > impedence in wait_event_*(), open code the combination of
> > wait_event[_interruptible][_timeou
On Fri, Aug 23, 2013 at 3:05 AM, Chris Wilson wrote:
> Rather than continue to fix up the timeouts to work around the interface
> impedence in wait_event_*(), open code the combination of
> wait_event[_interruptible][_timeout]. And note the code size reduction,
> and dare say readability?, in doin
Rather than continue to fix up the timeouts to work around the interface
impedence in wait_event_*(), open code the combination of
wait_event[_interruptible][_timeout]. And note the code size reduction,
and dare say readability?, in doing so..
v2: In order to satisfy the debug requirement of loggi
On Tue, Aug 13, 2013 at 02:39:55PM +0100, Chris Wilson wrote:
> On Tue, Aug 13, 2013 at 10:36:04AM -0300, Rodrigo Vivi wrote:
> > applied to experimental drm-intel-collector.
> >
> > drivers/gpu/drm/i915/i915_gem.c: In function ‘__wait_seqno’:
> > drivers/gpu/drm/i915/i915_gem.c:1033:20: warning:
On Tue, Aug 13, 2013 at 10:36:04AM -0300, Rodrigo Vivi wrote:
> applied to experimental drm-intel-collector.
>
> drivers/gpu/drm/i915/i915_gem.c: In function ‘__wait_seqno’:
> drivers/gpu/drm/i915/i915_gem.c:1033:20: warning: ‘timeout_jiffies’ may be
> used
> +uninitialized in this function
Dumb
applied to experimental drm-intel-collector.
drivers/gpu/drm/i915/i915_gem.c: In function ‘__wait_seqno’:
drivers/gpu/drm/i915/i915_gem.c:1033:20: warning: ‘timeout_jiffies’ may be used
+uninitialized in this function
On Tue, Aug 6, 2013 at 10:03 PM, Chris Wilson wrote:
> Rather than continue
Rather than continue to fix up the timeouts to work around the interface
impedence in wait_event_*(), open code the combination of
wait_event[_interruptible][_timeout]. And note the code size reduction,
and dare say readability?, in doing so..
Food for thought.
---
drivers/gpu/drm/i915/i915_gem.c