On Mon, 18 Apr 2016, Chris Wilson wrote:
> [ text/plain ]
> On Mon, Apr 18, 2016 at 06:09:28PM +0300, Joonas Lahtinen wrote:
>> @@ -251,7 +245,7 @@ static int swsci(struct drm_device *dev, u32 function,
>> u32 parm, u32 *parm_out)
>> struct drm_i915_private *dev_priv = dev->dev_private;
>>
On Mon, Apr 18, 2016 at 06:09:28PM +0300, Joonas Lahtinen wrote:
> @@ -251,7 +245,7 @@ static int swsci(struct drm_device *dev, u32 function,
> u32 parm, u32 *parm_out)
> struct drm_i915_private *dev_priv = dev->dev_private;
> struct opregion_swsci *swsci = dev_priv->opregion.swsci;
>
Do not use magic numbers, do not prefix stuff with "PCI_", do not
declare registers in implementation files. Also move the PCI
registers under correct comment in i915_reg.h.
v2:
- Consistently use BSM (not BDSM or other variants from PRM) (Chris)
- Also include register address to help identify th
On Fri, Apr 15, 2016 at 12:17:18PM +0300, Joonas Lahtinen wrote:
> Do not use magic numbers, do not prefix stuff with "PCI_", do not
> declare registers in implementation files. Also move the PCI
> registers under correct comment in i915_reg.h.
>
> Cc: Jani Nikula
> Cc: Chris Wilson
> Cc: Ville
Do not use magic numbers, do not prefix stuff with "PCI_", do not
declare registers in implementation files. Also move the PCI
registers under correct comment in i915_reg.h.
Cc: Jani Nikula
Cc: Chris Wilson
Cc: Ville Syrjälä
Signed-off-by: Joonas Lahtinen
---
drivers/gpu/drm/i915/i915_dma.c