Quoting Qing Wang (2022-02-14 17:55:39)
> From: Wang Qing
>
> Use the helper function time_is_{before,after}_jiffies() to improve
> code readability.
>
> Signed-off-by: Wang Qing
> ---
Applied to clk-next
Quoting Sean Paul (2021-11-04 20:04:31)
> From: Sean Paul
>
> This patch adds HDCP 1.x support to msm DP connectors using the new HDCP
$ git grep "This patch" -- Documentation/process/
> helpers.
>
> Cc: Stephen Boyd
> Cc: Abhinav Kumar
> Signed-o
(Sorry for the slow reply)
Quoting Hans de Goede (2021-09-16 06:17:56)
> Hi,
>
> On 9/16/21 5:20 AM, Stephen Boyd wrote:
> > Quoting Hans de Goede (2021-08-17 14:52:01)
> >> diff --git a/drivers/usb/typec/altmodes/displayport.c
> >> b/drivers/usb/typec/
Quoting Sean Paul (2021-09-15 13:38:32)
> diff --git a/arch/arm64/boot/dts/qcom/sc7180.dtsi
> b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> index c8921e2d6480..3ae6fc7a2c01 100644
> --- a/arch/arm64/boot/dts/qcom/sc7180.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> @@ -3088,7 +3088,9 @@ mdss_dp:
Quoting Sean Paul (2021-09-15 13:38:27)
> From: Sean Paul
>
> Make includes alphabetical in dpu_kms.c
>
> Signed-off-by: Sean Paul
> Link:
> https://patchwork.freedesktop.org/patch/msgid/20210913175747.47456-9-s...@poorly.run
> #v1
>
> Changes in v2:
> -None
> ---
Reviewed-by: Stephen Boyd
v2:
> -None
> ---
Reviewed-by: Stephen Boyd
t
> serves no purpose any longer. So remove the indirection.
When did it become false? Just curious when this became obsolete.
>
> Signed-off-by: Sean Paul
> Link:
> https://patchwork.freedesktop.org/patch/msgid/20210913175747.47456-11-s...@poorly.run
> #v1
>
> Changes in
Signed-off-by: Sean Paul
> Link:
> https://patchwork.freedesktop.org/patch/msgid/20210913175747.47456-12-s...@poorly.run
> #v1
>
> Changes in v2:
> -None
> ---
Reviewed-by: Stephen Boyd
Quoting Hans de Goede (2021-08-17 14:52:01)
> diff --git a/drivers/usb/typec/altmodes/displayport.c
> b/drivers/usb/typec/altmodes/displayport.c
> index aa669b9cf70e..c1d8c23baa39 100644
> --- a/drivers/usb/typec/altmodes/displayport.c
> +++ b/drivers/usb/typec/altmodes/displayport.c
> @@ -125,6 +
Quoting Sean Paul (2021-09-13 10:57:44)
> From: Sean Paul
>
> This patch adds the register ranges required for HDCP to the sc7180
> device tree. These registers will be used to inject HDCP key as well as
> toggle HDCP on and off.
It doesn't look to do any of that?
>
> Signed-off-by: Sean Paul
>
Quoting Sean Paul (2021-09-13 10:57:43)
> diff --git a/Documentation/devicetree/bindings/display/msm/dp-controller.yaml
> b/Documentation/devicetree/bindings/display/msm/dp-controller.yaml
> index 64d8d9e5e47a..984301442653 100644
> --- a/Documentation/devicetree/bindings/display/msm/dp-controller
().
>
> v2: Use is_power_of_2() from log2.h (Chris)
>
> References:
> 20181015203410.155997-1-swboyd@chromium.org">http://mid.mail-archive.com/20181015203410.155997-1-swboyd@chromium.org
> Reported-by: Stephen Boyd
Tested-by: Stephen Boyd
___
is similar to
what's being checked here so this might work well enough.
Cc: Masahiro Yamada
Cc: Michal Marek
Cc: Andrey Ryabinin
Signed-off-by: Stephen Boyd
---
drivers/gpu/drm/i915/intel_engine_cs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/i
gt; config and not the current state.
>
> This is part of the rework allowing the PWM framework to support
> hardware readout and expose real PWM state even when the PWM has
> just been requested (before the user calls pwm_config/enable/disable()).
>
> Signed-off-by: Boris Brez
On 03/30, Boris Brezillon wrote:
> diff --git a/drivers/clk/clk-pwm.c b/drivers/clk/clk-pwm.c
> index ebcd738..49ec5b1 100644
> --- a/drivers/clk/clk-pwm.c
> +++ b/drivers/clk/clk-pwm.c
> @@ -28,15 +28,29 @@ static inline struct clk_pwm *to_clk_pwm(struct clk_hw
> *hw)
> static int clk_pwm_prepar
On 03/30, Boris Brezillon wrote:
> @@ -74,6 +74,23 @@ enum pwm_polarity {
> PWM_POLARITY_INVERSED,
> };
>
> +/**
> + * struct pwm_args - PWM arguments
> + * @period: reference period
> + * @polarity: reference polarity
> + *
> + * This structure describe board-dependent arguments attached
16 matches
Mail list logo