Re: [PATCH v6 1/4] pwm: rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-09 Thread Dmitry Torokhov
On Wed, Nov 29, 2023 at 09:13:34AM +, Sean Young wrote: > drivers/input/misc/da7280.c | 4 +-- > drivers/input/misc/pwm-beeper.c | 4 +-- > drivers/input/misc/pwm-vibra.c| 8 +++--- Acked-by: Dmitry Torokhov # for input Thanks. -- Dmitry

Re: [Intel-gfx] [PATCH] drm/i915/quirk: Add quirk for devices with incorrect PWM frequency

2023-11-09 Thread Dmitry Torokhov
Hi Allen, On Tue, Oct 17, 2023 at 06:01:39PM +, Allen Ballway wrote: > Cyernet T10C has a bad default PWM frequency causing the display to > strobe when the brightness is less than 100%. Create a new quirk to use > the value from the BIOS rather than the default register value. > > Signed-off

Re: [Intel-gfx] [PATCH V3 6/13] input: serio: use time_is_before_jiffies() instead of open coding it

2022-02-15 Thread Dmitry Torokhov
Hi Wang, On Mon, Feb 14, 2022 at 05:55:43PM -0800, Qing Wang wrote: > From: Wang Qing > > Use the helper function time_is_{before,after}_jiffies() to improve > code readability. I applied changes by Danilo Krummrich converting the driver to use ktime_t (see https://lore.kernel.org/r/2022021516

Re: [Intel-gfx] [PATCH] input/psmouse: Don't hold the mutex while calling ->disconnect

2018-04-30 Thread Dmitry Torokhov
x40 > serio_driver_remove+0xc/0x10 > device_release_driver_internal+0x15b/0x230 > serio_handle_event+0x1c8/0x260 > process_one_work+0x215/0x620 > worker_thread+0x48/0x3a0 > ? _raw_spin_unlock_irqrestore+0x4c/0x60 > kthread+0xfb/0x130 > ? process_one_work+0x620/0x620

Re: [Intel-gfx] [PATCH v5 13/24] input: misc: max8997: explicitly apply PWM config extracted from pwm_args

2016-04-17 Thread Dmitry Torokhov
On Thu, Apr 14, 2016 at 09:17:33PM +0200, Boris Brezillon wrote: > Call pwm_apply_args() just after requesting the PWM device so that the > polarity and period are initialized according to the information provided > in pwm_args. > > This is an intermediate state, and pwm_apply_args() should be dro

Re: [Intel-gfx] [PATCH v5 36/46] input: misc: max77693: switch to the atomic API

2016-03-31 Thread Dmitry Torokhov
Hi Boris, On Wed, Mar 30, 2016 at 10:03:59PM +0200, Boris Brezillon wrote: > pwm_config/enable/disable() have been deprecated and should be replaced > by pwm_apply_state(). > > Signed-off-by: Boris Brezillon > --- > drivers/input/misc/max77693-haptic.c | 23 +-- > 1 file cha

Re: [Intel-gfx] [PATCH v5 32/46] pwm: deprecate pwm_config(), pwm_enable() and pwm_disable()

2016-03-31 Thread Dmitry Torokhov
Hi Boris, On Wed, Mar 30, 2016 at 10:03:55PM +0200, Boris Brezillon wrote: > Prefix those function as deprecated to encourage all existing users to > switch to pwm_apply_state(). Why not keep at least some of them as wrappers where we do not need to chnage several parameters at once? It is much e

[Intel-gfx] [PATCH v2] drm/i915: cope with large i2c transfers

2015-04-21 Thread Dmitry Torokhov
g Reviewed-by: Chris Wilson Signed-off-by: Dmitry Torokhov --- V2: reduced the limit from 511 to 256, added stable designation. drivers/gpu/drm/i915/i915_reg.h | 1 + drivers/gpu/drm/i915/intel_i2c.c | 66 ++-- 2 files changed, 57 insertions(+), 10 deletions(-)

[Intel-gfx] [PATCH] drm/i915: cope with large i2c transfers

2015-04-20 Thread Dmitry Torokhov
er on Pixel 1 function properly (it hasn't since commit 9d8dc3e529a19e427fd379118acd132520935c5d "Input: atmel_mxt_ts - implement T44 message handling" which tries to consume multiple touchscreen/touchpad reports in a single transaction). Signed-off-by: Dmitry Torokhov --- I th