== Series Details ==
Series: drm/i915/vrr: Fix DSB+VRR usage for PTL+ (rev3)
URL : https://patchwork.freedesktop.org/series/144153/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked separately.
+./arch/x86/include/asm/bit
== Series Details ==
Series: drm/i915: Fix scanline_offset for LNL+/BMG+
URL : https://patchwork.freedesktop.org/series/144526/
State : warning
== Summary ==
Error: dim checkpatch failed
2489090b60c3 drm/i915: Fix scanline_offset for LNL+ and BMG+
-:31: WARNING:MISSING_FIXES_TAG: The commit me
On Fri, Feb 07, 2025 at 11:54:03PM +0200, Ville Syrjälä wrote:
From: Ville Syrjälä
Something has changed in the hardware on LNL/BMG because
HDMI outputs no longer have the extra scanline offset.
I confirmed that MTL still has the old behaviour, which
is a bit weird since both MTL and BMG have
From: Ville Syrjälä
We don't really want legacy cursor updates to trigger
VRR pushes because these can happen willy nilly and we
generally want more precise control over the pushes.
The fastpath in intel_legacy_cursor_update() doesn't
send pushes, but if we punt to the full commit path
(with the
From: Ville Syrjälä
Currently we trigger the push send first, then follow it with
a "wait for safe window". That approach no longer works on
PTL+ because triggering the push send immediately ends the safe
window. On prior hardware the safe window extended past the
push being sent (presumably all
From: Ville Syrjälä
When we send a push during vblank the TRANS_PUSH write happens
at some point during a scanline, and the hardware picks it up
on the next scanline. Thus there is up to one extra scanline
of delay between the TRANS_PUSH write and the delayed vblank
triggering. Account for that d
From: Ville Syrjälä
Apparently PTL (or I suppose it could have already happened
in either MTL or LNL, didn't have either one to check) changes
the way the VRR hardwre works by ending the safe window as
soon as the push send is triggered. Reorder our DSB programming
sequence to account for that, a
From: Ville Syrjälä
Since we don't do mailbox updates the push send bit
should alwyas clear by the time the delay vblank fires
and the flip completes. Check for that to make sure we
haven't screwed up the sequencing/vblank evasion/etc.
On the DSB path we should be able to guarantee this
since we
From: Ville Syrjälä
The "wait usec" DSB command doesn't quite seem to able to
guarantee that it always waits at least the specified
amount of usecs. Some of that could be just because it
supposedly just does some kind of dumb timestamp comparison
internally. But I also see cases where two hardwar
From: Ville Syrjälä
Decode the DSB error interrupts into human readable
form for easier debugging.
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/display/intel_dsb.c | 15 ---
1 file changed, 12 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/i915/display/intel_d
From: Ville Syrjälä
Skip all the commit completion interrupt stuff on the
chained DSB when we don't take the full DSB path (ie. when
the plane/pipe programming is done via MMIO). The commit
completion will be done via the CPU side vblank interrupt.
Currently this is just a redundant interrupt, s
From: Ville Syrjälä
Add a function for emitting a DSB poll instruction. We'll allow
the caller to specify the poll parameters.
v2: s/wait/wait_us/ (Ankit)
Reviewed-by: Ankit Nautiyal
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/display/intel_dsb.c | 19 +++
drivers/g
From: Ville Syrjälä
Make intel_crtc_scanline_offset() a bit less confusing by
fully reordering the if ladder to use the new->old platform
order.
Signed-off-by: Ville Syrjälä
---
drivers/gpu/drm/i915/display/intel_vblank.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git
From: Ville Syrjälä
Something has changed in the hardware on LNL/BMG because
HDMI outputs no longer have the extra scanline offset.
I confirmed that MTL still has the old behaviour, which
is a bit weird since both MTL and BMG have display ver 14
vs. LNL is version 20. But can't argue with actual
From: Ville Syrjälä
The HDMI vs. not scanline offset stuff no longer applies to the
latest platforms, so using HAS_DDI() is a bit confusing. Replace
with a more specific set of conditions.
Also let's just deal with the platform types in the if ladder
itself, and handle the HDMI vs. not within th
From: Ville Syrjälä
Turns out LNL+ and BMG+ no longer have the weird extra scanline
offset for HDMI outputs. Fix intel_crtc_scanline_offset()
accordingly so that scanline evasion/etc. works correctly on
HDMI outputs on these new platforms.
Cc: sta...@vger.kernel.org
Signed-off-by: Ville Syrjälä
On Fri, Feb 07, 2025 at 08:57:34PM +0200, Povilas Kanapickas wrote:
> Hi,
>
> xf86-video-intel driver is currently cannot be compiled with released
> versions of X server. Simple reproduction steps: create Debian Bookworm
> container, download module sources and all required dependencies and try
>
== Series Details ==
Series: drm/i915: i915_reg.h display split
URL : https://patchwork.freedesktop.org/series/144505/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_16084 -> Patchwork_144505v1
Summary
---
**FAILURE**
== Series Details ==
Series: drm/i915/hdcp: move hdcp debugfs to intel_hdcp.c, cleanups
URL : https://patchwork.freedesktop.org/series/144491/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16084 -> Patchwork_144491v1
Summar
== Series Details ==
Series: drm/i915/pch: small cleanups, refactors
URL : https://patchwork.freedesktop.org/series/144489/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16084 -> Patchwork_144489v1
Summary
---
**SUCC
== Series Details ==
Series: drm/i915/hdcp: Create force_hdcp14 debug fs entry
URL : https://patchwork.freedesktop.org/series/144461/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16084 -> Patchwork_144461v1
Summary
---
Quoting Gustavo Sousa (2025-02-06 16:21:29-03:00)
>Add one step further into making intel_bw.c xe/i915 agnostic by using
>display-specific platform checks.
>
>Signed-off-by: Gustavo Sousa
>---
> drivers/gpu/drm/i915/display/intel_bw.c | 77 ++---
> 1 file changed, 43 insertions(
== Series Details ==
Series: drm/i915: i915_reg.h display split
URL : https://patchwork.freedesktop.org/series/144505/
State : warning
== Summary ==
Error: dim checkpatch failed
dc241ad94e8c drm/i915/reg: use REG_BIT and friends to define DP registers
adfada3efcca drm/i915/reg: Remove some ext
== Series Details ==
Series: drm/i915/xe3lpd: Update bandwidth parameters
URL : https://patchwork.freedesktop.org/series/11/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_16082 -> Patchwork_11v1
Summary
---
*
> -Original Message-
> From: Nikula, Jani
> Sent: Friday, February 7, 2025 4:29 PM
> To: Nikula, Jani ; intel-gfx@lists.freedesktop.org;
> intel...@lists.freedesktop.org
> Cc: Kandpal, Suraj
> Subject: [PATCH 4/3] drm/i915/hdcp: Make some functions static
What happened here wrong seri
> -Original Message-
> From: Nikula, Jani
> Sent: Friday, February 7, 2025 4:11 PM
> To: intel-gfx@lists.freedesktop.org; intel...@lists.freedesktop.org
> Cc: Nikula, Jani ; Kandpal, Suraj
>
> Subject: [PATCH 3/3] drm/i915/hdcp: Convert platform checks to use display-
> >platform
>
>
> -Original Message-
> From: Nikula, Jani
> Sent: Friday, February 7, 2025 4:11 PM
> To: intel-gfx@lists.freedesktop.org; intel...@lists.freedesktop.org
> Cc: Nikula, Jani ; Kandpal, Suraj
>
> Subject: [PATCH 1/3] drm/i915/hdcp: Move HDCP debugfs to intel_hdcp.c
>
> Continue with plac
> -Original Message-
> From: Nikula, Jani
> Sent: Friday, February 7, 2025 4:11 PM
> To: intel-gfx@lists.freedesktop.org; intel...@lists.freedesktop.org
> Cc: Nikula, Jani ; Kandpal, Suraj
>
> Subject: [PATCH 2/3] drm/i915/hdcp: rename intel_connector to connector
>
> Follow the curre
== Series Details ==
Series: drm/i915: intel_display conversions and some debug improvements (rev2)
URL : https://patchwork.freedesktop.org/series/143942/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_16082 -> Patchwork_143942v2
== Series Details ==
Series: drm/i915/pch: small cleanups, refactors
URL : https://patchwork.freedesktop.org/series/144489/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked separately.
== Series Details ==
Series: drm/i915/pch: small cleanups, refactors
URL : https://patchwork.freedesktop.org/series/144489/
State : warning
== Summary ==
Error: dim checkpatch failed
7bc5fca8d7b8 drm/i915/pch: Make LPT LP a dedicated PCH type
-:92: CHECK:MACRO_ARG_REUSE: Macro argument reuse '
== Series Details ==
Series: drm/i915: Fix harmfull driver register/unregister assymetry
URL : https://patchwork.freedesktop.org/series/144436/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_16081 -> Patchwork_144436v1
Summa
Jani Nikula (3):
drm/i915/reg: use REG_BIT and friends to define DP registers
drm/i915/reg: Remove some extra blank lines
drm/i915: split out display register macros to a separate file
drivers/gpu/drm/i915/display/g4x_dp.c | 24 +-
drivers/gpu/drm/i915/display/g4x_hdmi.c |
Remove some blank lines from i915_reg.h primarily to help the scripted
refactoring coming up, keeping the comments together.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/i915_reg.h | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/gpu/drm/i915/i915_reg.h b/drivers/gpu/drm/i9
Define the DP register contents using the REG_BIT, REG_GENMASK,
etc. macros. Ditch the unhelpful comments. Rename eDP related register
content macros to have EDP_ prefix.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/g4x_dp.c | 23 +++--
drivers/gpu/drm/i915/i915_reg.h | 124
On Fri, Feb 07, 2025 at 12:21:26PM +, Patchwork wrote:
> == Series Details ==
>
> Series: drm/i915/dp_mst: Fix disabling the minimum HBlank time
> URL : https://patchwork.freedesktop.org/series/144432/
> State : success
Thanks for the review, patch is pushed to drm-intel-next with the Bspec
> > - if (!folio)
> > + if (IS_ERR(folio))
>
> I don't see this patch yet in -next yet (and of course not in
> drm-tip), which branch is it based on?
To be precise, not this patch, but the patch(*) that this is fixing :-)
Andi
(*) "drm/i915/gem: Convert __shmem_writeback() t
== Series Details ==
Series: drm/i915/dp_mst: Fix disabling the minimum HBlank time
URL : https://patchwork.freedesktop.org/series/144432/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16080 -> Patchwork_144432v1
Summary
--
On Fri, Feb 07, 2025 at 12:02:43PM +0100, Andi Shyti wrote:
> Hi Dan,
>
> On Thu, Feb 06, 2025 at 11:17:02AM +0300, Dan Carpenter wrote:
> > The filemap_lock_folio() function doesn't return NULL, it returns error
> > pointers.
> >
> > Fixes: 25dd342f0cc8 ("drm/i915/gem: convert __shmem_writeback(
Hi Dan,
On Thu, Feb 06, 2025 at 11:17:02AM +0300, Dan Carpenter wrote:
> The filemap_lock_folio() function doesn't return NULL, it returns error
> pointers.
>
> Fixes: 25dd342f0cc8 ("drm/i915/gem: convert __shmem_writeback() to folios")
> Signed-off-by: Dan Carpenter
> ---
> drivers/gpu/drm/i91
On Thu, 06 Feb 2025, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> Now that intel_scanout_needs_vtd_wa() is no longer used from
> the gem code we can convert it to take struct intel_display.
> which will help with converting the low level plane code over
> as well.
>
> Cc: Jani Nikula
> Signed-
With the debugfs implementation moved next to the implementation, we no
longer need to expose some of the functions. Make them static.
Cc: Suraj Kandpal
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_hdcp.c | 10 +-
drivers/gpu/drm/i915/display/intel_hdcp.h | 6 -
On Fri, 07 Feb 2025, Suraj Kandpal wrote:
> Testing HDCP 1.4 becomes tough since the only way our code comes to
> HDCP 1.4 pathway is if the monitor only supports HDCP 1.4 which
> becomes tough to find sometimes.
> Setting this debug_fs entry will force use to use the HDCP 1.4 path
> so that more
Prefer display->platform. over IS_(i915), and
reducate struct drm_i915_private usages while at it.
Cc: Suraj Kandpal
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_hdcp.c | 22 ++
1 file changed, 10 insertions(+), 12 deletions(-)
diff --git a/drivers/gpu/
Jani Nikula (3):
drm/i915/hdcp: Move HDCP debugfs to intel_hdcp.c
drm/i915/hdcp: rename intel_connector to connector
drm/i915/hdcp: Convert platform checks to use display->platform
.../drm/i915/display/intel_display_debugfs.c | 74 +-
drivers/gpu/drm/i915/display/intel_hdcp.c
Follow the current convention of naming struct intel_connector pointers
connector.
Cc: Suraj Kandpal
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_hdcp.c | 12 +---
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.
Continue with placing debugfs next to the implementation.
intel_connector_info() still needs intel_hdcp_info(), so we'll need to
expose that too.
Cc: Suraj Kandpal
Signed-off-by: Jani Nikula
---
.../drm/i915/display/intel_display_debugfs.c | 74 +
drivers/gpu/drm/i915/display/i
With the PCH checks based on PCH types instead of IDs, the i915->pch_id
member has become unused. Remove it.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/i915_drv.h | 1 -
drivers/gpu/drm/i915/soc/intel_pch.c | 4
drivers/gpu/drm/xe/xe_device_types.h | 1 -
3 files changed, 6 de
Add PCH type PCH_LPT_LP and rename PCH_LPT to PCH_LPT_H for
consistency. Keep the existing HAS_PCH_LPT*() macros, but express them
in terms of the PCH types instead of looking at the device IDs
directly. This makes the PCH checks independent of the PCH device IDs.
Signed-off-by: Jani Nikula
---
Only the PCH identification code needs the PCH device IDs, as all the
PCH checks are now based on PCH type. Hide the PCH device IDs inside
intel_pch.c. Remove the unused INTEL_PCH_ID() macro while at it.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/soc/intel_pch.c | 30 +++
The PCH detection code is a bit problematic in terms of making it
independent of i915 core code. I don't have a solution yet, but while
looking I came up with these small improvements.
BR,
Jani.
Jani Nikula (3):
drm/i915/pch: Make LPT LP a dedicated PCH type
drm/i915/pch: Hide PCH device IDs
== Series Details ==
Series: Enable Aux based Nits brightness control for eDP (rev3)
URL : https://patchwork.freedesktop.org/series/143909/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16077_full -> Patchwork_143909v3_full
== Series Details ==
Series: Enable Aux based Nits brightness control for eDP (rev3)
URL : https://patchwork.freedesktop.org/series/143909/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_16077 -> Patchwork_143909v3
Summary
-
53 matches
Mail list logo