== Series Details ==
Series: drm/i915/uc: Include requested frequency in slow firmware load messages
URL : https://patchwork.freedesktop.org/series/142901/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15882 -> Patchwork_142901v1
===
== Series Details ==
Series: drm/i915: Add debug print about hw config table size
URL : https://patchwork.freedesktop.org/series/142898/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15882 -> Patchwork_142898v1
Summary
From: John Harrison
To aid debug of sporadic issues, include the requested frequency in
the debug message as well as the actual frequency. That way we know
for certain that the clamping is not because the driver forgot to ask.
Signed-off-by: John Harrison
Reviewed-by: Vinay Belgaumkar
---
dri
Hi Suraj,
kernel test robot noticed the following build warnings:
[auto build test WARNING on linus/master]
[also build test WARNING on drm-intel/for-linux-next
drm-intel/for-linux-next-fixes drm-tip/drm-tip v6.13-rc3 next-20241220]
[If your patch is applied to the wrong git tree, kindly drop
From: John Harrison
Add debug info to help investigate a very rare bug:
https://gitlab.freedesktop.org/drm/i915/kernel/-/issues/13385
Signed-off-by: John Harrison
---
drivers/gpu/drm/i915/gt/uc/intel_guc_hwconfig.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/i915/g
Hi Suraj,
kernel test robot noticed the following build errors:
[auto build test ERROR on linus/master]
[also build test ERROR on v6.13-rc3 next-20241220]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as
== Series Details ==
Series: drm/i915/gt: Log reason for setting TAINT_WARN at reset (rev4)
URL : https://patchwork.freedesktop.org/series/142882/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_15881 -> Patchwork_142882v4
Su
Hi Janusz,
> > > > > > +
> > > > > > cond_resched();
> > > > > >
> > > > > > - if (intel_gt_wait_for_idle(gt, HZ * 3) == -ETIME) {
> > > > > > + if (intel_gt_wait_for_idle(gt, HZ * timeout_ms / 500)
> > > > > > == -ETIME) {
> > > > >
> > > > > where is this 500
== Series Details ==
Series: drm/i915/gt: Log reason for setting TAINT_WARN at reset (rev3)
URL : https://patchwork.freedesktop.org/series/142882/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15881 -> Patchwork_142882v3
Su
-Original Message-
From: Intel-gfx On Behalf Of Ravi
Kumar Vodapalli
Sent: Friday, December 20, 2024 11:57 AM
To: intel-gfx@lists.freedesktop.org
Cc: Vivekanandan, Balasubramani ; Roper,
Matthew D ; De Marchi, Lucas
; Sousa, Gustavo ; Taylor,
Clinton A ; Atwood, Matthew S
; Bhadane, D
== Series Details ==
Series: drm/i915/gt: Log reason for setting TAINT_WARN at reset (rev2)
URL : https://patchwork.freedesktop.org/series/142882/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15881 -> Patchwork_142882v2
Su
== Series Details ==
Series: drm/i915/display: Don't update DBUF_TRACKER_STATE_SERVICE
URL : https://patchwork.freedesktop.org/series/142892/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_15881 -> Patchwork_142892v1
Summary
While display initialization along with MBUS credits programming
DBUF_CTL register is also programmed, as a part of it the
DBUF_TRACKER_STATE_SERVICE is updated to 0x8 value when default
value is other than 0x8 for platforms
1. display version 12
2. DG2.
Other platforms unless stated should use the
On Fri, Dec 20, 2024 at 02:13:26PM -0500, Rodrigo Vivi wrote:
On Fri, Dec 20, 2024 at 10:15:04AM +, Tvrtko Ursulin wrote:
On 20/12/2024 00:37, Vinay Belgaumkar wrote:
> Use the PMU support being added in
> https://patchwork.freedesktop.org/series/139121/ to add freq/c6 stats.
Brace yoursel
On Fri, Dec 20, 2024 at 10:15:04AM +, Tvrtko Ursulin wrote:
>
> On 20/12/2024 00:37, Vinay Belgaumkar wrote:
> > Use the PMU support being added in
> > https://patchwork.freedesktop.org/series/139121/ to add freq/c6 stats.
>
> Brace yourself for the customary "why". So yes, why?
>
> Gputop s
Hi Suraj,
kernel test robot noticed the following build errors:
[auto build test ERROR on linus/master]
[also build test ERROR on drm-intel/for-linux-next
drm-intel/for-linux-next-fixes drm-tip/drm-tip v6.13-rc3 next-20241220]
[If your patch is applied to the wrong git tree, kindly drop us a
On Wed, Dec 11, 2024 at 03:38:46PM -0500, Rodrigo Vivi wrote:
> Hi Dave and Sima,
>
> Here goes our first drm-intel-next round targeting 6.14.
>
> One drm/print change coming from here. The rest is mostly
> display changes and one GSC FW update for ARL platforms.
>
> Thanks,
> Rodrigo.
>
> drm-
Quoting Cavitt, Jonathan (2024-12-19 19:45:15-03:00)
>-Original Message-
>From: Intel-gfx On Behalf Of Gustavo
>Sousa
>Sent: Thursday, December 19, 2024 1:49 PM
>To: intel-gfx@lists.freedesktop.org; intel...@lists.freedesktop.org
>Cc: Ville Syrj�l� ; Nikula, Jani
>
>Subject: [PATCH 3/3]
== Series Details ==
Series: drm/i915/gt: Log reason for setting TAINT_WARN at reset
URL : https://patchwork.freedesktop.org/series/142882/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15880 -> Patchwork_142882v1
Summary
-
Hi André,
kernel test robot noticed the following build errors:
[auto build test ERROR on linus/master]
[also build test ERROR on drm-intel/for-linux-next
drm-intel/for-linux-next-fixes drm-tip/drm-tip v6.13-rc3 next-20241220]
[If your patch is applied to the wrong git tree, kindly drop us a
Hi Janusz,
> > > > > +
> > > > > cond_resched();
> > > > >
> > > > > - if (intel_gt_wait_for_idle(gt, HZ * 3) == -ETIME) {
> > > > > + if (intel_gt_wait_for_idle(gt, HZ * timeout_ms / 500)
> > > > > == -
> > > ETIME) {
> > > >
> > > > where is this 500 com
Quoting Ville Syrjälä (2024-12-20 06:23:24-03:00)
>On Thu, Dec 19, 2024 at 06:48:37PM -0300, Gustavo Sousa wrote:
>> If we look at how the members of struct intel_global_state_funcs, we see
>> a common pattern repeating itself. Let's add the necessary
>> infra-structure to allow reducing the boiler
Quoting Jani Nikula (2024-12-20 05:51:51-03:00)
>On Thu, 19 Dec 2024, Gustavo Sousa wrote:
>> diff --git a/drivers/gpu/drm/i915/display/intel_global_state.h
>> b/drivers/gpu/drm/i915/display/intel_global_state.h
>> index 6506a8e32972..e47e007225cc 100644
>> --- a/drivers/gpu/drm/i915/display/inte
Quoting Jani Nikula (2024-12-20 05:50:05-03:00)
>On Thu, 19 Dec 2024, Gustavo Sousa wrote:
>> If we look at how the members of struct intel_global_state_funcs, we see
>> a common pattern repeating itself. Let's add the necessary
>> infra-structure to allow reducing the boilerplate. We do that by
>
Quoting Cavitt, Jonathan (2024-12-19 19:44:12-03:00)
>-Original Message-
>From: Intel-gfx On Behalf Of Gustavo
>Sousa
>Sent: Thursday, December 19, 2024 1:49 PM
>To: intel-gfx@lists.freedesktop.org; intel...@lists.freedesktop.org
>Cc: Ville Syrj�l� ; Nikula, Jani
>
>Subject: [PATCH 2/3]
Quoting Ville Syrjälä (2024-12-20 06:11:57-03:00)
>On Thu, Dec 19, 2024 at 06:48:36PM -0300, Gustavo Sousa wrote:
>> The current intel_*_duplicate_state() functions assume the offset for
>> the base member of their state structures is zero when calling
>> kmemdup(). While that is true today, such a
On Fri, Dec 20, 2024 at 02:17:14PM +0100, Andi Shyti wrote:
> From: Sebastian Brzezinka
>
> TAINT_WARN is used to notify CI about non-recoverable failures, which
> require device to be restarted. In some cases, there is no sufficient
> information about the reason for the restart. The test runner
Hi André,
kernel test robot noticed the following build errors:
[auto build test ERROR on linus/master]
[also build test ERROR on v6.13-rc3 next-20241220]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as
From: Sebastian Brzezinka
TAINT_WARN is used to notify CI about non-recoverable failures, which
require device to be restarted. In some cases, there is no sufficient
information about the reason for the restart. The test runner is just
killed, and DUT is rebooted, logging only 'probe with driver
Hi Andi,
On Tuesday, 17 December 2024 19:00:40 CET Janusz Krzysztofik wrote:
> Hi Andi,
>
> On Tuesday, 17 December 2024 18:12:08 CET Andi Shyti wrote:
> > Hi Janusz,
> >
> > ...
> >
> > > > > +
> > > > > cond_resched();
> > > > >
> > > > > - if (intel_gt_wait_for_id
Hi Nitin,
On Tue, Dec 17, 2024 at 03:30:58PM +0530, Nitin Gote wrote:
> Instead of drm_err(), prefer gt_err() and ENGINE_TRACE()
> for GEM tracing in i915. So, it will be good to use ENGINE_TRACE()
> over drm_err() drm_device based logging for engine debug log.
>
> v2: Bit more specific in commit
== Series Details ==
Series: drm/i915/display: handle hdmi connector init failures, and no HDMI/DP
cases (rev3)
URL : https://patchwork.freedesktop.org/series/142119/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15879 -> Patchwork_142119v3
===
== Series Details ==
Series: drm/i915/display: handle hdmi connector init failures, and no HDMI/DP
cases (rev3)
URL : https://patchwork.freedesktop.org/series/142119/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked sep
On 20/12/2024 00:37, Vinay Belgaumkar wrote:
Use the PMU support being added in
https://patchwork.freedesktop.org/series/139121/ to add freq/c6 stats.
Brace yourself for the customary "why". So yes, why?
Gputop so far was a reference showcase for DRM fdinfo, nothing more. Why
add a _subset_
== Series Details ==
Series: drm/i915/gvt: store virtual_dp_monitor_edid in rodata (rev3)
URL : https://patchwork.freedesktop.org/series/142793/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_15879 -> Patchwork_142793v3
Summ
On Fri, Dec 13, 2024 at 08:35:22AM +0200, Jouni Högander wrote:
> Add register definitions for SFF_CTL and CFF_CTL registers. Name them as
> LNL_SFF_CTL and LNL_CFF_CTL.
>
> Signed-off-by: Jouni Högander
> ---
> drivers/gpu/drm/i915/display/intel_psr_regs.h | 8
> 1 file changed, 8 inse
On Fri, Dec 13, 2024 at 08:35:23AM +0200, Jouni Högander wrote:
> Bspec says this for SFF/CFF:
>
> "Hardware samples this bit on the start of every V. Blank Guardband
> region. For deterministic behavior, Software should ensure it is not
> changing this bit around the sample point."
>
> This can
On Thu, Dec 19, 2024 at 06:48:37PM -0300, Gustavo Sousa wrote:
> If we look at how the members of struct intel_global_state_funcs, we see
> a common pattern repeating itself. Let's add the necessary
> infra-structure to allow reducing the boilerplate. We do that by
> adding common generic implement
On 12/20/2024 2:49 AM, Cavitt, Jonathan wrote:
-Original Message-
From: Roper, Matthew D
Sent: Thursday, December 19, 2024 12:50 PM
To: Cavitt, Jonathan
Cc: Vodapalli, Ravi Kumar;intel-gfx@lists.freedesktop.org; Vivekanandan,
Balasubramani; De Marchi, Lucas; Sousa,
Gustavo; Taylor,
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> Add some tracpoints around skl+ scaler programming to help with
> debugging.
>
> Signed-off-by: Ville Syrjälä
> ---
> .../drm/i915/display/intel_display_trace.h| 99 +++
> drivers/gpu/drm/i915
On Thu, Dec 19, 2024 at 06:48:36PM -0300, Gustavo Sousa wrote:
> The current intel_*_duplicate_state() functions assume the offset for
> the base member of their state structures is zero when calling
> kmemdup(). While that is true today, such assumption should not be made
> and proper offset must
On Thu, Dec 19, 2024 at 06:02:25PM +0200, Ville Syrjälä wrote:
> On Thu, Dec 12, 2024 at 08:03:28PM +0530, Nemesa Garg wrote:
> > In panel fitter/pipe scaler scenario the pch_pfit configuration
> > currently takes place before accounting for pipe_src width for
> > joiner. This causes issue when pch
On Thu, 19 Dec 2024, Gustavo Sousa wrote:
> diff --git a/drivers/gpu/drm/i915/display/intel_global_state.h
> b/drivers/gpu/drm/i915/display/intel_global_state.h
> index 6506a8e32972..e47e007225cc 100644
> --- a/drivers/gpu/drm/i915/display/intel_global_state.h
> +++ b/drivers/gpu/drm/i915/display
On Wed, 18 Dec 2024, Gustavo Sousa wrote:
> Quoting Jani Nikula (2024-12-18 11:17:34-03:00)
>>Add const to register range arrays to store them in rodata. They don't
>>need to be modified.
>>
>>Cc: Gustavo Sousa
>>Signed-off-by: Jani Nikula
>
> Good idea.
>
> Reviewed-by: Gustavo Sousa
Thanks f
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> Fix typo s/excdeed/exceed/
>
> Signed-off-by: Ville Syrjälä
> ---
> drivers/gpu/drm/i915/display/skl_scaler.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/i915/display
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> Include the standard "[CRTC:...]" information in the scaler debugs
> to make life easier.
>
> Signed-off-by: Ville Syrjälä
> ---
> drivers/gpu/drm/i915/display/skl_scaler.c | 25 +++
> 1 file
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> The SKL_MAX_DST_* defines just make things hard to read.
> Get rid of them and introduce an easy to read function
> in their place.
>
> Signed-off-by: Ville Syrjälä
> ---
> drivers/gpu/drm/i915/display/skl_scaler
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> The tgl+ and mtl+ numbers in skl_scaler_max_dst_size() are
> identical. Combine them to a single piece of code.
>
> Signed-off-by: Ville Syrjälä
> ---
> drivers/gpu/drm/i915/display/skl_scaler.c | 5 +
> 1 fi
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> The SKL_MIN_DST_* defines just make things hard to read.
> Get rid of them and introduce an easy to read function
> in their place.
>
> Signed-off-by: Ville Syrjälä
> ---
> drivers/gpu/drm/i915/display/skl_scaler
On Thu, 19 Dec 2024, Gustavo Sousa wrote:
> If we look at how the members of struct intel_global_state_funcs, we see
> a common pattern repeating itself. Let's add the necessary
> infra-structure to allow reducing the boilerplate. We do that by
> adding common generic implementations for each memb
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> The SKL_MAX_SRC_* defines just make things hard to read.
> Get rid of them and introduce an easy to read function
> in their place.
>
> Signed-off-by: Ville Syrjälä
> ---
Reviewed-by: Luca Coelho
--
Cheers,
Luc
On Thu, 2024-12-19 at 15:08 +0200, Ville Syrjala wrote:
> From: Ville Syrjälä
>
> The SKL_MIN_*SRC_* defines just make things hard to read.
> Get rid of them and introduce an easy to read function
> in their place.
>
> Signed-off-by: Ville Syrjälä
> ---
Looks good, but a small nitpick: maybe y
52 matches
Mail list logo