On 5/15/24 07:25, Jani Nikula wrote:
> No reply from Bjorn, Cc: the x86 maintainers and list, could I get an
> ack from you please?
x86 is just a consumer of the drm/i915_pciids.h macros. The name change
is perfectly fine with me. No objections. But I really don't think you
need our acks to mov
== Series Details ==
Series: series starting with [1/2] drm/i915/pciids: switch to xe driver style
PCI ID macros
URL : https://patchwork.freedesktop.org/series/133664/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked se
== Series Details ==
Series: series starting with [1/2] drm/i915/pciids: switch to xe driver style
PCI ID macros
URL : https://patchwork.freedesktop.org/series/133664/
State : warning
== Summary ==
Error: dim checkpatch failed
527339fb7437 drm/i915/pciids: switch to xe driver style PCI ID mac
== Series Details ==
Series: series starting with [1/2] drm/i915/pciids: switch to xe driver style
PCI ID macros
URL : https://patchwork.freedesktop.org/series/133664/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_14768 -> Patchwork_133664v1
==
Now that the PCI ID macros allow us to pass in the macro to use, stop
redefining INTEL_VGA_DEVICE.
Cc: Lucas De Marchi
Cc: Rodrigo Vivi
Signed-off-by: Jani Nikula
---
.../drm/i915/display/intel_display_device.c | 87 +-
drivers/gpu/drm/i915/intel_device_info.c | 91 +
The PCI ID macros in xe_pciids.h allow passing in the macro to operate
on each PCI ID, making it more flexible. Convert i915_pciids.h to the
same pattern.
INTEL_IVB_Q_IDS() for Quanta transcode remains a special case, and
unconditionally uses INTEL_QUANTA_VGA_DEVICE().
Cc: Bjorn Helgaas
Cc: linu
On Wed, 15 May 2024, Bjorn Helgaas wrote:
> Sorry, I had ignored this because I didn't think it affected any PCI
> stuff. This is fine with me:
>
> Acked-by: Bjorn Helgaas
Thanks, pushed to drm-intel-next.
> But since you asked :), I'll gripe again about the fact that this
> intel_early_ids[]
On Fri, May 10, 2024 at 04:55:07PM +0300, Jani Nikula wrote:
> On Fri, 10 May 2024, Jani Nikula wrote:
> > This is a spin-off from [1], including just the PCI ID macro cleanups,
> > as well as adding a bunch more cleanups.
> >
> > BR,
> > Jani.
> >
> > [1] https://lore.kernel.org/all/cover.1715086
== Series Details ==
Series: series starting with [1/2] drm/i915/display: Move port clock calculation
URL : https://patchwork.freedesktop.org/series/133640/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_14764_full -> Patchwork_133640v1_full
Quoting Jani Nikula (2024-05-15 10:59:11-03:00)
>On Wed, 15 May 2024, Gustavo Sousa wrote:
>> Quoting Gustavo Sousa (2024-05-15 10:23:54-03:00)
>>>Quoting Mika Kahola (2024-05-15 03:45:23-03:00)
As a preparation to remove .clock member from pll state
structure, let's move the port clock ca
On Fri, 10 May 2024, Jani Nikula wrote:
> On Fri, 10 May 2024, Jani Nikula wrote:
>> This is a spin-off from [1], including just the PCI ID macro cleanups,
>> as well as adding a bunch more cleanups.
>>
>> BR,
>> Jani.
>>
>> [1] https://lore.kernel.org/all/cover.1715086509.git.jani.nik...@intel.c
On Wed, 15 May 2024, Gustavo Sousa wrote:
> Quoting Gustavo Sousa (2024-05-15 10:23:54-03:00)
>>Quoting Mika Kahola (2024-05-15 03:45:23-03:00)
>>>As a preparation to remove .clock member from pll state
>>>structure, let's move the port clock calculation on better
>>>location
>
> Ah... Also, I not
== Series Details ==
Series: Regression on linux-next (next-20240506)
URL : https://patchwork.freedesktop.org/series/133656/
State : failure
== Summary ==
Error: patch
https://patchwork.freedesktop.org/api/1.0/series/133656/revisions/1/mbox/ not
applied
Patch is empty.
When you have resolved
Quoting Gustavo Sousa (2024-05-15 10:23:54-03:00)
>Quoting Mika Kahola (2024-05-15 03:45:23-03:00)
>>As a preparation to remove .clock member from pll state
>>structure, let's move the port clock calculation on better
>>location
Ah... Also, I noticed that we are not simply moving the implementatio
Quoting Mika Kahola (2024-05-15 03:45:24-03:00)
>.clock is not necessarily required to have in pll state
>structure as it can always recalculated with the *_calc_port_clock()
>function. Hence, let's remove this struct member complitely.
>
>Signed-off-by: Mika Kahola
>---
> drivers/gpu/drm/i915/dis
On Wed, May 15, 2024 at 03:52:33PM +0300, Jani Nikula wrote:
> On Tue, 14 May 2024, Imre Deak wrote:
> > For clarity move the link training parameters updated during link
> > training based on the pass/fail LT result under a substruct in intel_dp.
> > This prepares for later patches in this patchs
Quoting Mika Kahola (2024-05-15 03:45:23-03:00)
>As a preparation to remove .clock member from pll state
>structure, let's move the port clock calculation on better
>location
>
>Signed-off-by: Mika Kahola
>---
> drivers/gpu/drm/i915/display/intel_cx0_phy.c | 176 ++-
> 1 file change
On Wed, May 15, 2024 at 04:09:23PM +0300, Jani Nikula wrote:
> On Tue, 14 May 2024, Imre Deak wrote:
> > Add connector debugfs entries to set a target link rate/lane count to be
> > used by a link training afterwards. After setting a target link
> > rate/lane count reset the link training paramete
On Wed, May 15, 2024 at 04:05:32PM +0300, Jani Nikula wrote:
> On Tue, 14 May 2024, Imre Deak wrote:
> > Reduce the indentation in intel_dp_get_link_train_fallback_values() by
> > adding separate helpers to reduce the link rate and lane count. Also
> > simplify things by passing crtc_state to the
== Series Details ==
Series: drm/i915: pass dev_priv explicitly to CUR* registers
URL : https://patchwork.freedesktop.org/series/133652/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_14766 -> Patchwork_133652v1
Summary
On Tue, 14 May 2024, Imre Deak wrote:
> Add connector debugfs entries to set a target link rate/lane count to be
> used by a link training afterwards. After setting a target link
> rate/lane count reset the link training parameters and for a non-auto
> target disable reducing the link parameters v
On Tue, 14 May 2024, Imre Deak wrote:
> Reduce the indentation in intel_dp_get_link_train_fallback_values() by
> adding separate helpers to reduce the link rate and lane count. Also
> simplify things by passing crtc_state to the function.
>
> This also prepares for later patches in the patchset ad
On Tue, 14 May 2024, Imre Deak wrote:
> For clarity move the link training parameters updated during link
> training based on the pass/fail LT result under a substruct in intel_dp.
> This prepares for later patches in this patchset adding similar params
> here. Rename intel_dp_reset_max_link_param
Hi
Am 15.05.24 um 13:38 schrieb Borah, Chaitanya Kumar:
[...]
Sorry, I didn't notice the report before. The commit is not related to ACPI.
There's now asm/video.h and acpi/video.h. Maybe there's a conflict among
included files.
Do you have a kernel config to build with?
~Sorry my email client
On Wed, May 15, 2024 at 02:56:40PM +0300, Jani Nikula wrote:
> Update all the register macros in the intel_cursor_regs.h file.
>
> Jani Nikula (8):
> drm/i915: pass dev_priv explicitly to CURCNTR
> drm/i915: pass dev_priv explicitly to CURBASE
> drm/i915: pass dev_priv explicitly to CURPOS
>
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURSURFLIVE register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
drivers/gpu/drm/i915/display/intel_psr.c | 13 +
2 files changed, 10 insert
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CUR_CHICKEN register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/display/intel_c
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CUR_FBC_CTL register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 3 ++-
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
drivers/gpu/drm/i915/intel_gvt_mmio_ta
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURSIZE register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 2 +-
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
2 files changed, 2 insertions(+), 2 deletio
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURPOS_ERLY_TPT register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 4 +++-
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
2 files changed, 4 insertions(+),
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURPOS register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 8
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
drivers/gpu/drm/i915/gvt/fb_decoder.c
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURBASE register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 6 +++---
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
drivers/gpu/drm/i915/gvt/fb_decoder.c
Avoid the implicit dev_priv local variable use, and pass dev_priv
explicitly to the CURCNTR register macro.
Signed-off-by: Jani Nikula
---
drivers/gpu/drm/i915/display/intel_cursor.c | 10 +-
drivers/gpu/drm/i915/display/intel_cursor_regs.h | 2 +-
drivers/gpu/drm/i915/display/inte
Update all the register macros in the intel_cursor_regs.h file.
Jani Nikula (8):
drm/i915: pass dev_priv explicitly to CURCNTR
drm/i915: pass dev_priv explicitly to CURBASE
drm/i915: pass dev_priv explicitly to CURPOS
drm/i915: pass dev_priv explicitly to CURPOS_ERLY_TPT
drm/i915: pass d
Hello
> -Original Message-
> From: Thomas Zimmermann
> Sent: Wednesday, May 15, 2024 2:25 PM
> To: Borah, Chaitanya Kumar
> Cc: intel-gfx@lists.freedesktop.org; Kurmi, Suresh Kumar
> ; Saarinen, Jani ;
> Nikula, Jani
> Subject: Re: Regression on linux-next (next-20240506)
>
> Hi
>
> A
Hi,
On 5/15/2024 2:24 PM, Thomas Zimmermann wrote:
Hi
Am 15.05.24 um 10:16 schrieb Borah, Chaitanya Kumar:
-Original Message-
From: Borah, Chaitanya Kumar
Sent: Wednesday, May 8, 2024 3:05 PM
To: tzimmerm...@suse.de
Cc: intel-gfx@lists.freedesktop.org; Kurmi, Suresh Kumar
; Saarinen,
On Mon, May 13, 2024 at 11:52:08PM +0300, Jani Nikula wrote:
> On Fri, 10 May 2024, Ville Syrjala wrote:
> > From: Ville Syrjälä
> >
> > Having the plane WM/DDB regitster write functions in skl_watermarks.c
> > is rather annoying when trying to implement DSB based plane updates.
> > Move them int
== Series Details ==
Series: Panel Replay Fixes
URL : https://patchwork.freedesktop.org/series/133648/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_14765 -> Patchwork_133648v1
Summary
---
**SUCCESS**
No regressio
== Series Details ==
Series: Panel Replay Fixes
URL : https://patchwork.freedesktop.org/series/133648/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked separately.
+./arch/x86/include/asm/bitops.h:116:1: warning: unrepla
Currently AUX Less Wake lines are not written into ALPM_CTL. Fix this.
Fixes: 1ccbf135862b ("drm/i915/psr: Enable ALPM on source side for eDP Panel
replay")
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_psr.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff -
Panel Replay is not enabled if there are no active planes. Do not compare
it on pipe comparison. Otherwise we get pipe mismatch.
Fixes: ac9ef327327b ("drm/i915/psr: Panel replay has to be enabled before link
training")
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_display
Currently setting I915_PSR_DEBUG_SU_REGION_ET_DISABLE (0x20) via psr_debug
debugfs interface is not allowed. This patch allows it.
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_psr.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915
Currently intel_dp_vsc_sdp_unpack is not taking into account Panel Replay
vsc sdp. Fix this by adding vsc sdp revision 0x6 and length 0x10 into
intel_dp_vsc_sdp_unpack
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_dp.c | 5 -
1 file changed, 4 insertions(+), 1 deletion
When enabling Early Transport use
intel_crtc_state->enable_psr2_su_region_et instead of
psr2_su_region_et_valid.
Fixes: 467e4e061c44 ("drm/i915/psr: Enable psr2 early transport as possible")
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_psr.c | 2 +-
1 file changed, 1 inse
Currently we are purely relying on psr2_su_region_et_valid. Add new boolean
value into intel_psr struct indicating whether Early Transport is enabled
or not and use it instead of psr2_su_region_et_valid for getting Early
Transport status information.
Signed-off-by: Jouni Högander
---
drivers/gpu
We are currently not getting Early Transport status information in
intel_psr_pipe_get_config. Fix this.
Fixes: 467e4e061c44 ("drm/i915/psr: Enable psr2 early transport as possible")
Signed-off-by: Jouni Högander
---
drivers/gpu/drm/i915/display/intel_psr.c | 2 ++
1 file changed, 2 insertions(+)
We want to have own variables for fast wake lines and aux less wake
time. It might be needed to choose if we can enable Panel Replay Selective
Update or PSR2.
Also currently aux less wake time is overwritten by calculated fast wake
time.
Fixes: da6a9836ac09 ("drm/i915/psr: Calculate aux less wake
This patch set contains fixes found when debugging Panel Replay and
Early Transport and ALPM using eDP panel supporting all these features.
Jouni Högander (8):
drm/i915/psr: Do not use fast_wake_lines for aux less wake time
drm/i915/psr: Add Early Transport status boolean into intel_psr
drm
Hi
Am 15.05.24 um 10:16 schrieb Borah, Chaitanya Kumar:
-Original Message-
From: Borah, Chaitanya Kumar
Sent: Wednesday, May 8, 2024 3:05 PM
To: tzimmerm...@suse.de
Cc: intel-gfx@lists.freedesktop.org; Kurmi, Suresh Kumar
; Saarinen, Jani
Subject: Regression on linux-next (next-202405
== Series Details ==
Series: drm/i915: Use for_each_child instead of manual for-loop (rev2)
URL : https://patchwork.freedesktop.org/series/133600/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_14764 -> Patchwork_133600v2
Su
== Series Details ==
Series: drm/i915: Use for_each_child instead of manual for-loop (rev2)
URL : https://patchwork.freedesktop.org/series/133600/
State : warning
== Summary ==
Error: dim checkpatch failed
01a8fa52159b drm/i915: Use for_each_child instead of manual for-loop
-:45: WARNING:AVOID
On Fri, 2024-05-10 at 12:38 +0300, Jouni Högander wrote:
> This patch set is implementing panel replay selective update support
> for Intel hardware.
These are now merged into drm-intel-next including "drm/panelreplay:
dpcd register definition for panelreplay SU".
Thank you Animesh and Maarten fo
> -Original Message-
> From: Borah, Chaitanya Kumar
> Sent: Wednesday, May 8, 2024 3:05 PM
> To: tzimmerm...@suse.de
> Cc: intel-gfx@lists.freedesktop.org; Kurmi, Suresh Kumar
> ; Saarinen, Jani
> Subject: Regression on linux-next (next-20240506)
>
> Hello Thomas,
>
> Hope you are doin
== Series Details ==
Series: series starting with [1/2] drm/i915/display: Move port clock calculation
URL : https://patchwork.freedesktop.org/series/133640/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_14764 -> Patchwork_133640v1
==
== Series Details ==
Series: series starting with [1/2] drm/i915/display: Move port clock calculation
URL : https://patchwork.freedesktop.org/series/133640/
State : warning
== Summary ==
Error: dim sparse failed
Sparse version: v0.6.2
Fast mode used, each commit won't be checked separately.
== Series Details ==
Series: series starting with [1/2] drm/i915/display: Move port clock calculation
URL : https://patchwork.freedesktop.org/series/133640/
State : warning
== Summary ==
Error: dim checkpatch failed
a7f08368e5a3 drm/i915/display: Move port clock calculation
-:107: WARNING:LINE
56 matches
Mail list logo