On Wed, 2019-04-17 at 15:37 -0700, José Roberto de Souza wrote:
> A new macro that is going to be added in a further patch will need to
> adjust the offset returned by _MMIO_TRANS2(), so here adding
> _TRANS2() and moving most of the implementation of _MMIO_TRANS2() to
> it and while at it taking t
== Series Details ==
Series: series starting with [v5,1/3] drm/i915/bdw+: Move misc display IRQ
handling to it own function
URL : https://patchwork.freedesktop.org/series/59787/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5964_full -> Patchwork_12853_full
==
== Series Details ==
Series: series starting with [v5,1/3] drm/i915/bdw+: Move misc display IRQ
handling to it own function
URL : https://patchwork.freedesktop.org/series/59787/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5964 -> Patchwork_12853
== Series Details ==
Series: series starting with [v5,1/3] drm/i915/bdw+: Move misc display IRQ
handling to it own function
URL : https://patchwork.freedesktop.org/series/59787/
State : warning
== Summary ==
$ dim sparse origin/drm-tip
Sparse version: v0.5.2
Commit: drm/i915/bdw+: Move misc d
== Series Details ==
Series: series starting with [v5,1/3] drm/i915/bdw+: Move misc display IRQ
handling to it own function
URL : https://patchwork.freedesktop.org/series/59787/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
c17cacf29b8b drm/i915/bdw+: Move misc display IRQ han
A new macro that is going to be added in a further patch will need to
adjust the offset returned by _MMIO_TRANS2(), so here adding
_TRANS2() and moving most of the implementation of _MMIO_TRANS2() to
it and while at it taking the opportunity to rename pipe to trans.
Cc: Rodrigo Vivi
Cc: Dhinakara
PSR registers are a mess, some have the full address while others just
have the additional offset from psr_mmio_base.
For BDW+ psr_mmio_base is nothing more than TRANSCODER_EDP_OFFSET +
0x800 and using it makes more difficult for people with an PSR
register address or PSR register name from from B
Just moving it to reduce the tabs and avoid break code lines.
No behavior changes intended here.
v2:
- Reading misc display IRQ outside of gen8_de_misc_irq_handler() as
other irq handlers (Dhinakaran)
Cc: Dhinakaran Pandiyan
Reviewed-by: Dhinakaran Pandiyan
Reviewed-by: Rodrigo Vivi
Signed-off
On Thu, Apr 18, 2019 at 1:54 PM Thomas Gleixner wrote:
>
> On Thu, 18 Apr 2019, Alexander Potapenko wrote:
> > On Thu, Apr 18, 2019 at 11:06 AM Thomas Gleixner wrote:
> > > - save_stack_trace(&b->stack_trace);
> > > + b->stack_len = stack_trace_save(b->stack_entries, MAX_STACK, 2);
>
On Thu, Apr 18, 2019 at 10:41:27AM +0200, Thomas Gleixner wrote:
> Replace the indirection through struct stack_trace by using the storage
> array based interfaces.
>
> Signed-off-by: Thomas Gleixner
> Cc: Catalin Marinas
> Cc: linux...@kvack.org
Acked-by: Catalin Marinas
_
On Thu, Apr 18, 2019 at 10:41:47AM +0200, Thomas Gleixner wrote:
> All architectures which support stacktrace carry duplicated code and
> do the stack storage and filtering at the architecture side.
>
> Provide a consolidated interface with a callback function for consuming the
> stack entries pro
On Thu, Apr 18, 2019 at 11:06 AM Thomas Gleixner wrote:
>
> Replace the indirection through struct stack_trace with an invocation of
> the storage array based interface.
>
> Signed-off-by: Thomas Gleixner
> Cc: dm-de...@redhat.com
> Cc: Mike Snitzer
> Cc: Alasdair Kergon
> ---
> drivers/md/dm-
On Thu, Apr 18, 2019 at 10:41:22AM +0200, Thomas Gleixner wrote:
> The struct stack_trace indirection in the stack depot functions is a truly
> pointless excercise which requires horrible code at the callsites.
>
> Provide interfaces based on plain storage arrays.
>
> Signed-off-by: Thomas Gleixn
On 2019/04/17, Emil Velikov wrote:
> On 2019/04/17, Christian König wrote:
> > This is to work around problems with libva and vainfo.
> >
> This part reverts a commit from 2013. Something I would wager that will cause
> multiple problems across the board.
>
> If we look at the intel libva driver
On 2019/04/17, Christian König wrote:
> This is to work around problems with libva and vainfo.
>
This part reverts a commit from 2013. Something I would wager that will cause
multiple problems across the board.
If we look at the intel libva driver in particular, as-is this will cause all
get para
Hi William,
Sorry for the late reply.
> > Currently, there are 3 different macros, namely sizeof_field, SIZEOF_FIELD
> > and FIELD_SIZEOF which are used to calculate the size of a member of
> > structure, so to bring uniformity in entire kernel source tree lets use
> > FIELD_SIZEOF and replace al
On 4/18/2019 4:36 PM, Colin King wrote:
From: Colin Ian King
There is a spelling mistake in a gvt_dbg_core debug message. Fix it.
Signed-off-by: Colin Ian King
Reviewed-by: Mukesh Ojha
Cheers,
-Mukesh
---
drivers/gpu/drm/i915/gvt/vgpu.c | 2 +-
1 file changed, 1 insertion(+), 1 del
Den 20.04.2019 12.45, skrev Noralf Trønnes:
> This moves the modesetting code from drm_fb_helper to drm_client so it
> can be shared by all internal clients.
>
> Changes this time:
> - Use full drm_client_init/release for the modesets (Daniel Vetter)
> - drm_client_for_each_modeset: use lockdep_
tree: git://anongit.freedesktop.org/drm/drm-tip drm-tip
head: c5fdcd8bd5c596bfc70b6be93e6f04d910c51308
commit: c5fdcd8bd5c596bfc70b6be93e6f04d910c51308 [9/9] drm-tip:
2019y-04m-19d-20h-56m-16s UTC integration manifest
config: ia64-allmodconfig (attached as .config)
compiler: ia64-linux-gcc (GC
== Series Details ==
Series: drm: Fire off KMS hotplug events if probe detect says the connector is
connected (rev3)
URL : https://patchwork.freedesktop.org/series/59691/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_5964 -> Patchwork_12852
===
== Series Details ==
Series: drm: Fire off KMS hotplug events if probe detect says the connector is
connected (rev3)
URL : https://patchwork.freedesktop.org/series/59691/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
56fec13ce383 drm: Fire off KMS hotplug events if probe detec
The hotplug detection routine of drm_helper_hpd_irq_event() can detect
changing of status of connector, but it can not detect changing of
properties of the connector.
e.g. changing of edid while suspend/resume, changing of dp lanes in dp aux.
Following scenario explains one of them; A detection of
On Thu, Apr 18, 2019 at 7:33 PM Jani Nikula wrote:
>
> On Thu, 18 Apr 2019, Gwan-gyeong Mun wrote:
> > The hotplug detection routine of drm_helper_hpd_irq_event() can detect
> > changing of status of connector, but it can not detect changing of
> > properties of the connector.
> > e.g. changing o
== Series Details ==
Series: drm/i915: Start writeback from the shrinker (rev2)
URL : https://patchwork.freedesktop.org/series/25332/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5963_full -> Patchwork_12851_full
Summary
-
== Series Details ==
Series: drm/i915: Start writeback from the shrinker (rev2)
URL : https://patchwork.freedesktop.org/series/25332/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5963 -> Patchwork_12851
Summary
---
== Series Details ==
Series: drm/fb-helper: Move modesetting code to drm_client (rev3)
URL : https://patchwork.freedesktop.org/series/58597/
State : failure
== Summary ==
CI Bug Log - changes from CI_DRM_5963_full -> Patchwork_12850_full
Su
== Series Details ==
Series: drm/i915: Start writeback from the shrinker (rev2)
URL : https://patchwork.freedesktop.org/series/25332/
State : warning
== Summary ==
$ dim sparse origin/drm-tip
Sparse version: v0.5.2
Commit: drm/i915: Start writeback from the shrinker
-drivers/gpu/drm/i915/selft
When we are called to relieve mempressue via the shrinker, the only way
we can make progress is either by discarding unwanted pages (those
objects that userspace has marked MADV_DONTNEED) or by reclaiming the
dirty objects via swap. As we know that is the only way to make further
progress, we can i
== Series Details ==
Series: drm/fb-helper: Move modesetting code to drm_client (rev3)
URL : https://patchwork.freedesktop.org/series/58597/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5963 -> Patchwork_12850
Summary
== Series Details ==
Series: drm/fb-helper: Move modesetting code to drm_client (rev3)
URL : https://patchwork.freedesktop.org/series/58597/
State : warning
== Summary ==
$ dim sparse origin/drm-tip
Sparse version: v0.5.2
Commit: drm/atomic: Move __drm_atomic_helper_disable_plane/set_config()
== Series Details ==
Series: drm/fb-helper: Move modesetting code to drm_client (rev3)
URL : https://patchwork.freedesktop.org/series/58597/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
caf4eff8b046 drm/atomic: Move __drm_atomic_helper_disable_plane/set_config()
3f7a665802ce d
No functional changes, just moving code as-is and fixing includes.
Signed-off-by: Noralf Trønnes
Reviewed-by: Maxime Ripard
---
drivers/gpu/drm/drm_client_modeset.c | 706 ++-
drivers/gpu/drm/drm_fb_helper.c | 691 --
include/drm/drm_client.h
An example to showcase the client API.
TODO:
A bootsplash client needs a way to tell drm_fb_helper to stay away,
otherwise it will chime in on setup and hotplug.
Most DRM drivers register fbdev before calling drm_dev_register() (the
generic emulation is an exception). This have to be reversed for
This moves the modesetting code from drm_fb_helper to drm_client so it
can be shared by all internal clients.
Changes this time:
- Use full drm_client_init/release for the modesets (Daniel Vetter)
- drm_client_for_each_modeset: use lockdep_assert_held (Daniel Vetter)
- Hook up to Documentation/gpu
The values are already present in the modeset.
This is done in preparation for the removal of struct drm_fb_helper_crtc.
Signed-off-by: Noralf Trønnes
Reviewed-by: Daniel Vetter
Reviewed-by: Maxime Ripard
---
drivers/gpu/drm/drm_fb_helper.c | 12
include/drm/drm_fb_helper.h |
Prepare for moving drm_fb_helper modesetting code to drm_client.
drm_client will be linked to drm.ko, so move
__drm_atomic_helper_disable_plane() and __drm_atomic_helper_set_config()
out of drm_kms_helper.ko.
While at it, fix two checkpatch complaints:
- WARNING: Block comments use a trailing */ o
Move the modeset commit code to drm_client_modeset.
No changes except exporting API.
v2: Move to drm_client_modeset.c instead of drm_client.c
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_client_modeset.c | 287 +++
drivers/gpu/drm/drm_fb_helper.c | 282
This makes the necessary changes so the commit code can be moved out to
drm_client as-is in the next patch. It's split up to ease review.
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_fb_helper.c | 122 +---
1 file changed, 81 insertions(+), 41 deletions(-)
d
Getting rotation info is cheap so we can do it on demand.
This is done in preparation for the removal of struct drm_fb_helper_crtc.
Cc: Hans de Goede
Signed-off-by: Noralf Trønnes
Acked-by: Daniel Vetter
Reviewed-by: Maxime Ripard
---
drivers/gpu/drm/drm_fb_helper.c | 131 ---
All drivers add all their connectors so there's no need to keep around an
array of available connectors.
Rename functions which signature is changed since they will be moved to
drm_client in a later patch.
Signed-off-by: Noralf Trønnes
---
Documentation/gpu/todo.rst | 3 +
drivers/gpu/dr
drm_fb_helper_is_bound() is used to check if DRM userspace is in control.
This is done by looking at the fb on the primary plane. By the time
fb-helper gets around to committing, it's possible that the facts have
changed.
Avoid this race by holding the drm_device->master_mutex lock while
committin
It now only contains the modeset so use that directly instead and attach
a modeset array to drm_client_dev. drm_fb_helper will use this array.
Code will later be moved to drm_client, so add code there in a new file
drm_client_modeset.c with MIT license to match drm_fb_helper.c.
The modeset connect
This prepares the modeset code so it can be moved out as-is in the next
patch.
v3: Remove stray newline
Signed-off-by: Noralf Trønnes
Reviewed-by: Maxime Ripard
---
drivers/gpu/drm/drm_fb_helper.c | 62 +++--
include/drm/drm_fb_helper.h | 4 ---
2 files changed
43 matches
Mail list logo