== Series Details ==
Series: drm/i915/cfl: Adding another PCI Device ID. (rev2)
URL : https://patchwork.freedesktop.org/series/56075/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5526_full -> Patchwork_12121_full
Summary
-
== Series Details ==
Series: drm/i915/cfl: Adding another PCI Device ID. (rev2)
URL : https://patchwork.freedesktop.org/series/56075/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5526 -> Patchwork_12121
Summary
---
This fixes the extra issues I discovered upstream after the introduction
of my rework of the atomic VCPI helpers that occur during
suspend/resume.
This time around, we use a slightly different but much less complicated
approach for fixing said issues.
Cc: Daniel Vetter
Lyude Paul (4):
drm/dp_
Since we now have an easy way of refcounting drm_dp_mst_port structs and
safely accessing their contents, there isn't any good reason to keep
validating ports here. It doesn't prevent us from performing modesets on
branch devices that have been removed either, and we already disallow
enabling new d
On Fri, 2019-02-01 at 15:50 -0800, Rodrigo Vivi wrote:
> While cross checking PCI IDs from Intel Media SDK
> and kernel Dmitry noticed this gap. So we checked the
> spec and this new ID had been recently added.
>
> v2: Adding new H_GT1 entry to i915_pci.c (Jose)
>
Reviewed-by: José Roberto de So
== Series Details ==
Series: drm/i915/cfl: Adding another PCI Device ID. (rev2)
URL : https://patchwork.freedesktop.org/series/56075/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
d78761758c42 drm/i915/cfl: Adding another PCI Device ID.
-:15: WARNING:BAD_SIGN_OFF: email address
While cross checking PCI IDs from Intel Media SDK
and kernel Dmitry noticed this gap. So we checked the
spec and this new ID had been recently added.
v2: Adding new H_GT1 entry to i915_pci.c (Jose)
Reported-by: Dmitry Rogozhkin
Cc: Dmitry Rogozhkin
Cc: José Roberto de Souza
Signed-off-by: Rodrig
Ville Syrjälä wrote:
> > @@ -1774,6 +1776,45 @@ static const u32 skl_planar_formats[] = {
> >DRM_FORMAT_NV12,
> > };
> >
> > +static const uint32_t icl_hdr_plane_formats[] = {
>
> Please switch to u32 & co. We recently had a mass conversion in the
> driver.
Will do. Looks like the CI caug
:
https://github.com/0day-ci/linux/commits/Chris-Wilson/drm-i915-Revoke-mmaps-and-prevent-access-to-fence-registers-across-reset/20190201-043323
base: git://anongit.freedesktop.org/drm-intel for-linux-next
reproduce:
# apt-get install sparse
make ARCH=x86_64 allmodconfig
On Fri, Feb 01, 2019 at 09:43:40AM -0800, Kevin Strasser wrote:
> 64 bpp half float formats are supported on hdr planes only and are subject
> to the following restrictions:
> * 90/270 rotation not supported
> * Yf Tiling not supported
> * Frame Buffer Compression not supported
> * Color Ke
On Fri, Feb 01, 2019 at 09:43:39AM -0800, Kevin Strasser wrote:
> Add 64 bpp 16:16:16:16 half float pixel formats. Each 16 bit component is
> formatted in IEEE-754 half-precision float (binary16) 1:5:10
> MSb-sign:exponent:fraction form.
>
> This patch attempts to address the feedback provided whe
== Series Details ==
Series: Support 64 bpp half float formats (rev3)
URL : https://patchwork.freedesktop.org/series/53212/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5526_full -> Patchwork_12120_full
Summary
---
On Wed, Jan 30, 2019 at 06:24:25PM +0530, Uma Shankar wrote:
> This patch adds a DP colorspace property, enabling
> userspace to switch to various supported colorspaces.
> This will help enable BT2020 along with other colorspaces.
>
> v2: Addressed Maarten and Ville's review comments. Enhanced
>
On 01/31/2019 05:42 PM, Chris Wilson wrote:
When first enabling preemption, we hesitated from making it a free-for-all
where every higher priority client would force a preempt-to-idle cycle
and take over from all lower priority clients. We hesitated because we
were uncertain just how well preem
On Wed, Jan 30, 2019 at 06:24:26PM +0530, Uma Shankar wrote:
> This patch attaches the colorspace connector property to the
> hdmi connector. Based on colorspace change, modeset will be
> triggered to switch to new colorspace.
>
> Based on colorspace property value create an infoframe
> with appro
On Wed, Jan 30, 2019 at 06:24:24PM +0530, Uma Shankar wrote:
> Create a new connector property to program colorspace to sink
> devices. Modern sink devices support more than 1 type of
> colorspace like 601, 709, BT2020 etc. This helps to switch
> based on content type which is to be displayed. The
== Series Details ==
Series: Support 64 bpp half float formats (rev3)
URL : https://patchwork.freedesktop.org/series/53212/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5526 -> Patchwork_12120
Summary
---
**SUCCESS*
On Thu, 2019-01-31 at 21:38 -0800, Rodrigo Vivi wrote:
> While cross checking PCI IDs from Intel Media SDK
> and kernel Dmitry noticed this gap. So we checked the
> spec and this new ID had been recently added.
>
> Reported-by: Dmitry Rogozhkin
> Cc: Dmitry Rogozhkin
> Cc: José Roberto de Souza
>
== Series Details ==
Series: Support 64 bpp half float formats (rev3)
URL : https://patchwork.freedesktop.org/series/53212/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
bb513dd0a6fe drm/fourcc: Add 64 bpp half float formats
-:39: WARNING:LONG_LINE: line over 100 characters
#39
On Fri, Feb 01, 2019 at 06:13:48PM +0100, Daniel Vetter wrote:
> On Wed, Jan 30, 2019 at 03:48:50PM -0800, Matt Roper wrote:
> > On Wed, Jan 30, 2019 at 09:57:10PM +0100, Daniel Vetter wrote:
> > > On Wed, Jan 30, 2019 at 10:56:26AM -0800, Matt Roper wrote:
> > > > On Wed, Jan 30, 2019 at 10:51:19A
On Thu, Jan 31, 2019 at 08:14:49PM -0500, Lyude Paul wrote:
> Since we now have an easy way of refcounting drm_dp_mst_port structs and
> safely accessing their contents, there isn't any good reason to keep
> validating ports here. It doesn't prevent us from performing modesets on
> branch devices t
== Series Details ==
Series: DC states igt tests patch series
URL : https://patchwork.freedesktop.org/series/56093/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5525_full -> IGTPW_2335_full
Summary
---
**SUCCESS**
On Fri, Feb 01, 2019 at 06:37:49PM +0100, Daniel Vetter wrote:
> On Sat, Jan 26, 2019 at 01:25:23PM +0100, Sam Ravnborg wrote:
> > The use of drmP.h is discouraged and removal of it from
> > drm_modeset_helper.h caused vboxvideo to fail to build.
> >
> > This patch introduce the necessary fixes to
Add 64 bpp 16:16:16:16 half float pixel formats. Each 16 bit component is
formatted in IEEE-754 half-precision float (binary16) 1:5:10
MSb-sign:exponent:fraction form.
This patch attempts to address the feedback provided when 2 of these
formats were previosly proposed:
https://patchwork.kernel.o
64 bpp half float formats are supported on hdr planes only and are subject
to the following restrictions:
* 90/270 rotation not supported
* Yf Tiling not supported
* Frame Buffer Compression not supported
* Color Keying not supported
v2:
- Drop handling pixel normalize register
- Don't use
This series defines new formats and adds implementation to the i915 driver.
Since posting v1 I have removed the pixel normalize property, as it's not needed
for basic functionality. Also, I have been working on adding support to
userspace, but we can't land any patches until drm_fourcc.h has been u
On Sat, Jan 26, 2019 at 01:25:23PM +0100, Sam Ravnborg wrote:
> The use of drmP.h is discouraged and removal of it from
> drm_modeset_helper.h caused vboxvideo to fail to build.
>
> This patch introduce the necessary fixes to prepare for the
> drmP.h removal from drm_modeset_helper.h.
>
> In the
Quoting Tvrtko Ursulin (2019-02-01 17:29:45)
>
> On 01/02/2019 10:52, Chris Wilson wrote:
> > diff --git a/drivers/gpu/drm/i915/i915_gem.c
> > b/drivers/gpu/drm/i915/i915_gem.c
> > index 4067eeaee78a..e47d53e9b634 100644
> > --- a/drivers/gpu/drm/i915/i915_gem.c
> > +++ b/drivers/gpu/drm/i915/i91
On 01/02/2019 10:52, Chris Wilson wrote:
If we get caught in a kernel bug, we may never idle. Let the user regain
control of their system^Wterminal by responding to SIGINT!
v2: Push the signal checking into the loop around flush_work.
Reported-by: Tvrtko Ursulin
Signed-off-by: Chris Wilson
C
On Wed, Jan 30, 2019 at 03:48:50PM -0800, Matt Roper wrote:
> On Wed, Jan 30, 2019 at 09:57:10PM +0100, Daniel Vetter wrote:
> > On Wed, Jan 30, 2019 at 10:56:26AM -0800, Matt Roper wrote:
> > > On Wed, Jan 30, 2019 at 10:51:19AM -0800, Matt Roper wrote:
> > > > Previous patch series was here:
> >
On Fri, Feb 01, 2019 at 02:15:23PM +0800, Zhenyu Wang wrote:
>
> Hi,
>
> This should be last gvt-next pull for this round, which adds VFIO edid
> region support in GVT, VM manager can use this to specify custom EDID
> for VM, which can be used for e.g UI resize, etc.
Pulled, thanks
>
> p.s, Ne
== Series Details ==
Series: drm/i915: Set ->connectors_changed to force HDCP updates
URL : https://patchwork.freedesktop.org/series/56089/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5525_full -> Patchwork_12119_full
Sum
== Series Details ==
Series: DC states igt tests patch series
URL : https://patchwork.freedesktop.org/series/56093/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5525 -> IGTPW_2335
Summary
---
**SUCCESS**
No regre
From: Jyoti Yadav
Added new subtest for DC5 entry during DPMS on/off cycle.
During DPMS on/off cycle DC5 counter is incremented.
v2: Rename the subtest with meaningful name.
v3: Rebased.
v4: Addressed review comments.
Signed-off-by: Jyoti Yadav
Signed-off-by: Anshuman Gupta
---
tests/pm_dc.c
From: Jyoti Yadav
Currently this test validates DC5 upon PSR entry for supported platforms.
Added new file for compilation inside Makefile and Meson.
v2: Used the debugfs entry for DC counters instead of Registers.
Used shorter names for variables.
Introduced timeout to read DC counters.
From: Jyoti Yadav
Added new subtest for DC6 entry during DPMS on/off cycle.
During DPMS on/off cycle DC6 counter is incremented.
v2: Renamed the subtest name.
v3: Rebased.
v4: Rebased and address review comment.
Signed-off-by: Jyoti Yadav
Signed-off-by: Anshuman Gupta
---
tests/pm_dc.c | 9 +
From: Jyoti Yadav
This patch add subtest to check DC6 entry on PSR for the supported
platforms.
v2: Rename the subtest with more meaningful name.
v3: Rebased.
v4: Rebased and addressed review comment.
Signed-off-by: Jyoti Yadav
Signed-off-by: Anshuman Gupta
---
tests/pm_dc.c | 13 +++
From: Jyoti Yadav
It will be used by new test pm_dc.c which will validate Display C States.
So moving the same to igt_pm library.
v2: Simplify the comment section.
v3: Remove . from the subject line.
v4: Rebased and addressed the review comments.
Signed-off-by: Jyoti Yadav
Signed-off-by: Anshu
This patch series adds new tests to validate Display C states.
DC states like DC5 and DC6 are validated during PSR entry/exit
and during DPMS on/off cycle.
Sending new revision of patch series after addressing review comments.
Jyoti Yadav (5):
lib/igt_pm: Moves Dmc_loaded() function into library
== Series Details ==
Series: drm/i915: Set ->connectors_changed to force HDCP updates
URL : https://patchwork.freedesktop.org/series/56089/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5525 -> Patchwork_12119
Summary
-
Hi Jose,
On Wed, Jan 23, 2019 at 10:51:35AM -0800, José Roberto de Souza wrote:
> Some unpowered USB type-c dongles requires some time to power on
> before being able to process aux channel transactions.
>
> It was not a problem for older platforms because there was a hardware
> bridge between DD
== Series Details ==
Series: drm/i915: Set ->connectors_changed to force HDCP updates
URL : https://patchwork.freedesktop.org/series/56089/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
e2f23aecb4c1 drm/i915: Set ->connectors_changed to force HDCP updates
-:29: WARNING:NO_AUTHO
On Fri, Feb 01, 2019 at 03:55:19PM +0100, Daniel Vetter wrote:
> ->mode_changed will be eaten by fastset, which is now enabled by
> default on at least some platforms. Once we have modeset-less hdcp, we
> need to go back to ->mode_changed (or maybe directly setting
> ->update_pipe) to avoid the mod
Hi Dave, Daniel,
Here is the drm-misc-next PR for this week.
Thanks!
Maxime
drm-misc-next-2019-02-01:
drm-misc-next for 5.1:
UAPI Changes:
Cross-subsystem Changes:
Core Changes:
- Split out some part of drm_crtc_helper.h into drm_probe_helper.h
- DRIVER_* flags improvements
- New tasks
->mode_changed will be eaten by fastset, which is now enabled by
default on at least some platforms. Once we have modeset-less hdcp, we
need to go back to ->mode_changed (or maybe directly setting
->update_pipe) to avoid the modeset.
Cc: Maarten Lankhorst
Cc: Hans de Goede
Cc: Ramalingam C
Sign
To inject a GPU hang, we should ask the kernel first if it is legal to
do so.
Signed-off-by: Chris Wilson
---
tests/i915/gem_mocs_settings.c | 54 +-
1 file changed, 34 insertions(+), 20 deletions(-)
diff --git a/tests/i915/gem_mocs_settings.c b/tests/i915/gem_mo
CI has a HSW GT1 with a single subslice. Accept this a possible truth
value.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106600
Signed-off-by: Chris Wilson
Cc: Lionel Landwerlin
---
tests/i915/query.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/i915/quer
CI has a HSW GT1 with a single subslice. Accept this a possible truth
value.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106600
Signed-off-by: Chris Wilson
Cc: Lionel Landwerlin
---
tests/i915/query.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/i915/quer
Quoting Lionel Landwerlin (2019-01-11 19:53:36)
> There is no reason not to whitelist those registers. In particular
> MI_PREDICATE_RESULT can be loaded outside of MI_PREDICATE through
> other registers to predicate other commands.
Link to userspace changes?
Regards, Joonas
>
> Signed-off-by: L
== Series Details ==
Series: drm/i915: Avoid uninterruptible spinning in debugfs
URL : https://patchwork.freedesktop.org/series/56079/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5524 -> Patchwork_12117
Summary
---
== Series Details ==
Series: drm/i915: Avoid uninterruptible spinning in debugfs (rev2)
URL : https://patchwork.freedesktop.org/series/56079/
State : failure
== Summary ==
Applying: drm/i915: Avoid uninterruptible spinning in debugfs
error: sha1 information is lacking or useless
(drivers/gpu/
If we get caught in a kernel bug, we may never idle. Let the user regain
control of their system^Wterminal by responding to SIGINT!
v2: Push the signal checking into the loop around flush_work.
Reported-by: Tvrtko Ursulin
Signed-off-by: Chris Wilson
Cc: Tvrtko Ursulin
---
drivers/gpu/drm/i915
Quoting Chris Wilson (2019-02-01 10:22:48)
> If we get caught in a kernel bug, we may never idle. Let the user regain
> control of their system^Wterminal by responding to SIGINT!
>
> Reported-by: Tvrtko Ursulin
> Signed-off-by: Chris Wilson
> Cc: Tvrtko Ursulin
> ---
> drivers/gpu/drm/i915/i91
If we get caught in a kernel bug, we may never idle. Let the user regain
control of their system^Wterminal by responding to SIGINT!
Reported-by: Tvrtko Ursulin
Signed-off-by: Chris Wilson
Cc: Tvrtko Ursulin
---
drivers/gpu/drm/i915/i915_debugfs.c | 4
1 file changed, 4 insertions(+)
diff
== Series Details ==
Series: drm/i915/cfl: Adding another PCI Device ID.
URL : https://patchwork.freedesktop.org/series/56075/
State : success
== Summary ==
CI Bug Log - changes from CI_DRM_5522_full -> Patchwork_12116_full
Summary
---
Hi,
On 31-01-19 14:36, Maarten Lankhorst wrote:
Op 29-01-2019 om 15:22 schreef Hans de Goede:
We really want to have fastboot enabled by default to avoid an ugly
modeset during boot.
Currently we are enabling fastboot by default on gen9+ (Skylake and newer).
The intention is to enable it on ol
Quoting Chris Wilson (2019-01-31 16:20:37)
> Quoting Chris Wilson (2019-01-31 13:39:50)
> > Quoting Tvrtko Ursulin (2019-01-31 13:19:31)
> > >
> > > On 30/01/2019 02:19, Chris Wilson wrote:
> > > > Having introduced per-context seqno, we now have a means to identity
> > > > progress across the sys
Quoting Patchwork (2019-02-01 05:05:57)
> == Series Details ==
>
> Series: restore WaEnableFloatBlendOptimization
> URL : https://patchwork.freedesktop.org/series/56071/
> State : success
>
> == Summary ==
>
> CI Bug Log - changes from CI_DRM_5521_full -> Patchwork_12113_full
> ===
58 matches
Mail list logo