On Mon, Apr 03, 2017 at 01:42:18PM -0400, Sean Paul wrote:
> Along with a recipe for creating a topic branch and sending a pull
> request from it.
>
> Signed-off-by: Sean Paul
One more: The maintainer's duties section in drm-misc.rst talks about
topic branches, pls add a link there to this new e
On Mon, Apr 03, 2017 at 03:42:50PM -0400, Sean Paul wrote:
> Instead of hardcoding ~/tmp in dim (and failing when it doesn't
> exist), use mktemp to create the pull-request mail file.
>
> Signed-off-by: Sean Paul
lgtm, I'll push it in a bit.
-Daniel
> ---
> dim | 33 +++
On Mon, Apr 03, 2017 at 01:42:18PM -0400, Sean Paul wrote:
> Along with a recipe for creating a topic branch and sending a pull
> request from it.
>
> Signed-off-by: Sean Paul
> ---
> dim.rst | 50 ++
> 1 file changed, 50 insertions(+)
>
> diff --
On Tue, Apr 4, 2017 at 12:13 AM, kbuild test robot wrote:
> [if your patch is applied to the wrong git tree, please drop us a note to
> help improve the system]
It should compile just fine on latest linux-next (if there is one)
where this code in vmwgfx is already removed. Well you just need the
On Thu, 2017-03-30 at 01:42 -0700, Dhinakaran Pandiyan wrote:
> From: "Pandiyan, Dhinakaran"
>
> drm_dp_atomic_find_vcpi_slots() should be called from ->atomic_check() to
> check there are sufficient vcpi slots for a mode and to add that to the
> state. This should be followed by a call to drm_dp
I missed this one, and looks like it's already in. So a belated:
Reviewed-by: Sinclair Yeh
for the vmwgfx part
On Wed, Mar 22, 2017 at 10:50:57PM +0100, Daniel Vetter wrote:
> Surprisingly a lot of legacy drivers roll their own, for
> runtime pm and because vmwgfx.
>
> Also make nouveau's set
== Series Details ==
Series: drm: Add DPCD definitions for DP 1.4 DSC feature (rev5)
URL : https://patchwork.freedesktop.org/series/19666/
State : success
== Summary ==
Series 19666v5 drm: Add DPCD definitions for DP 1.4 DSC feature
https://patchwork.freedesktop.org/api/1.0/series/19666/revisi
From: "Navare, Manasi D"
Display stream compression is supported on DP 1.4 DP
devices. This patch adds the corersponding DPCD
register definitions for DSC.
v4:
* Add DSC Enable DPCD register def (Ander)
v3:
* Add some SHIFTS and MASKS for uniformity (Jani Nikula)
v2:
* Rebased on drm-tip
Signed
On Thu, Mar 16, 2017 at 03:47:46PM +0200, Ander Conselvan De Oliveira wrote:
> On Tue, 2017-03-14 at 13:01 -0700, Manasi Navare wrote:
> > From: "Navare, Manasi D"
> >
> > Display stream compression is supported on DP 1.4 DP
> > devices. This patch adds the corersponding DPCD
> > register definit
Hi Daniel,
[auto build test ERROR on next-20170330]
[cannot apply to drm/drm-next drm-intel/for-linux-next robclark/msm-next
v4.9-rc8 v4.9-rc7 v4.9-rc6 v4.11-rc5]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-
On Mon, Apr 03, 2017 at 05:42:39PM +, Vivi, Rodrigo wrote:
> On Mon, 2017-04-03 at 10:07 -0700, Jim Bride wrote:
> > On SKL+ there is a bit in SRD_CTL that software is not supposed to
> > modify, but we currently clobber that bit when we enable PSR. In
> > order to preserve the value of that b
On Mon, Apr 03, 2017 at 06:17:51PM +0300, Jani Nikula wrote:
> On Thu, 30 Mar 2017, Daniel Vetter wrote:
> > I'm getting real lazy, let's start scripting this. Very rough draft,
> > but adds a Link: (patchwork tracks pull requests too, maybe we'll
> > start CI-ing them too), and sob line. In the f
Hi Daniel,
[auto build test ERROR on next-20170330]
[also build test ERROR on v4.11-rc5]
[cannot apply to drm/drm-next drm-intel/for-linux-next robclark/msm-next
v4.9-rc8 v4.9-rc7 v4.9-rc6]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
On Fri, Mar 31, 2017 at 04:25:31PM -0700, Rodrigo Vivi wrote:
> On Mon, Mar 13, 2017 at 1:12 AM, Lee, Shawn C wrote:
> > From: "Lee, Shawn C"
> >
> > Display driver read DPCD register 0x202, 0x203 and 0x204 to identify
> > eDP sink status.If PSR exit is ongoing at eDP sink, and eDP source
> > rea
== Series Details ==
Series: series starting with [1/3] drm/i915: Use LINEAR modifier instead of
NONE (rev3)
URL : https://patchwork.freedesktop.org/series/21854/
State : failure
== Summary ==
LD drivers/acpi/acpica/built-in.o
CC [M] drivers/gpu/drm/i915/gvt/execlist.o
CC [M] dri
This was based on a patch originally by Kristian. It has been modified
pretty heavily to use the new callbacks from the previous patch.
v2:
- Add LINEAR and Yf modifiers to list (Ville)
- Combine i8xx and i965 into one list of formats (Ville)
- Allow 1010102 formats for Y/Yf tiled (Ville)
v
Launch $EDITOR when extracting tags to curate the tags immediately. Once the
tags are proper, automatically add them before the first Signed-off-by line
to all patches in the range.
Signed-off-by: Sean Paul
---
Changes in v2:
- Append the tags before the committer's SoB (Ville)
-
Instead of hardcoding ~/tmp in dim (and failing when it doesn't
exist), use mktemp to create the pull-request mail file.
Signed-off-by: Sean Paul
---
dim | 33 +++--
1 file changed, 19 insertions(+), 14 deletions(-)
diff --git a/dim b/dim
index 8357d4f..d51be6b 10075
vmwgfx part: Reviewed-by: Sinclair Yeh
On Mon, Apr 03, 2017 at 10:33:01AM +0200, Daniel Vetter wrote:
> Atomic helpers really want this instead of the hacked-up legacy
> backoff trick, which unfortunately prevents drivers from using their
> own private drm_modeset_locks.
>
> Aside: There's a fe
I like the changes, definitely simplifies things.
>-Original Message-
>From: Wajdeczko, Michal
>Sent: Friday, March 31, 2017 4:57 AM
>To: intel-gfx@lists.freedesktop.org
>Cc: Wajdeczko, Michal ; Srivatsa, Anusha
>; Hiler, Arkadiusz ;
>Ursulin, Tvrtko
>Subject: [PATCH] drm/i915/huc: Simpli
Thanks for this. This and "drm/vmwgfx: merge fixup for set_config API change":
Reviewed-by: Sinclair Yeh
On Mon, Apr 03, 2017 at 01:31:29PM +1000, Stephen Rothwell wrote:
> Hi all,
>
> After merging the drm-misc tree, today's linux-next build (x86_64
> allmodconfig) failed like this:
>
> dri
Em Sex, 2017-03-31 às 21:00 +0300, ville.syrj...@linux.intel.com
escreveu:
> From: Ville Syrjälä
>
> The clipped src coordinates have already been rotated by 270 degrees
> for
> when the plane rotation is 90/270 degrees, hence the FBC code should
> no
> longer swap the width and height.
I've nev
== Series Details ==
Series: drm/i915/psr: Clean-up intel_enable_source_psr1()
URL : https://patchwork.freedesktop.org/series/22375/
State : success
== Summary ==
Series 22375v1 drm/i915/psr: Clean-up intel_enable_source_psr1()
https://patchwork.freedesktop.org/api/1.0/series/22375/revisions/1
On Mon, 2017-04-03 at 10:07 -0700, Jim Bride wrote:
> On SKL+ there is a bit in SRD_CTL that software is not supposed to
> modify, but we currently clobber that bit when we enable PSR. In
> order to preserve the value of that bit, go ahead and read SRD_CTL and
> do a field-wise setting of the vari
Along with a recipe for creating a topic branch and sending a pull
request from it.
Signed-off-by: Sean Paul
---
dim.rst | 50 ++
1 file changed, 50 insertions(+)
diff --git a/dim.rst b/dim.rst
index bc4d9a0..4b905ad 100644
--- a/dim.rst
+++ b/dim
On Sat, 01 Apr 2017, Zhenyu Wang wrote:
> Hi,
>
> Here's left gvt fixes for 4.11.
Pulled to drm-intel-fixes, thanks.
BR,
Jani.
>
> p.s It's working day for us really, so we can be out for next three days. ;)
>
> Thanks
> --
> The following changes since commit bc2d4b62db67f817b09c782219996630e9
On Fri, 31 Mar 2017, Sean Paul wrote:
> Instead of hardcoding ~/tmp in dim (and failing when it doesn't
> exist), use mktemp to create the pull-request mail file.
A few nitpicks below, otherwise lgtm.
BR,
Jani.
>
> Signed-off-by: Sean Paul
> ---
> dim | 28
> 1 f
On SKL+ there is a bit in SRD_CTL that software is not supposed to
modify, but we currently clobber that bit when we enable PSR. In
order to preserve the value of that bit, go ahead and read SRD_CTL and
do a field-wise setting of the various bits that we need to initialize
before writing the regis
Does a few sanity checks to avoid common gotchas:
- make sure the backmerge is in drm-tip already
- check that git rerere resolves all conflict, and cuation if not
- merge commit template.
Cc: Sean Paul
Signed-off-by: Daniel Vetter
---
bash_completion | 2 +-
dim | 54 +
Jani Nikula writes:
>> +
>> +git commit --amend -s
>
> I think the intention is to just add the signoff, but this ends up
> trying to fire up the editor, which is really not good for piping.
>
You probably want --no-edit for that.
--
Gabriel Krisman Bertazi
___
On Thu, 30 Mar 2017, Daniel Vetter wrote:
> I'm getting real lazy, let's start scripting this. Very rough draft,
> but adds a Link: (patchwork tracks pull requests too, maybe we'll
> start CI-ing them too), and sob line. In the future we might add more
> checks here ...
>
> Signed-off-by: Daniel V
On Sun, 02 Apr 2017, Martin Kepplinger wrote:
> Am 2. April 2017 13:50:26 MESZ schrieb Thorsten Leemhuis
> :
>>Lo! On 22.03.2017 11:36, Jani Nikula wrote:
>>> On Wed, 22 Mar 2017, Martin Kepplinger wrote:
I know something similar is here:
https://bugs.freedesktop.org/show_bug.cgi?id=1
On ke, 2017-03-29 at 16:56 +0100, Chris Wilson wrote:
> If the user requires patching of their batch or auxiliary buffers, we
> currently make the alterations on the cpu. If they are active on the GPU
> at the time, we wait under the struct_mutex for them to finish executing
> before we rewrite the
On Mon, Apr 03, 2017 at 11:54:47AM -, Patchwork wrote:
> == Series Details ==
>
> Series: series starting with [1/2] drm/i915: intel_ring.engine is unused
> URL : https://patchwork.freedesktop.org/series/22358/
> State : success
>
> == Summary ==
>
> Series 22358v1 Series without cover let
On ma, 2017-04-03 at 12:34 +0100, Chris Wilson wrote:
> Rather than call intel_engine_cleanup() with a partially constructed
> engine, unwind the error during intel_init_ring_common().
>
> Signed-off-by: Chris Wilson
> Cc: Joonas Lahtinen
Reviewed-by: Joonas Lahtinen
Regards, Joonas
--
Joona
== Series Details ==
Series: series starting with [1/2] drm/i915: intel_ring.engine is unused
URL : https://patchwork.freedesktop.org/series/22358/
State : success
== Summary ==
Series 22358v1 Series without cover letter
https://patchwork.freedesktop.org/api/1.0/series/22358/revisions/1/mbox/
Rather than call intel_engine_cleanup() with a partially constructed
engine, unwind the error during intel_init_ring_common().
Signed-off-by: Chris Wilson
Cc: Joonas Lahtinen
---
drivers/gpu/drm/i915/intel_ringbuffer.c | 77 +++--
1 file changed, 36 insertions(+), 41
Or rather it is used only by intel_ring_pin() to extract the
drm_i915_private which we can easily pass in. As this is a relatively
rare operation, save the space in the struct, and as such it is even
break even in the extra code for passing around the parameter:
add/remove: 0/0 grow/shrink: 2/3 up
== Series Details ==
Series: drm/i915: Park the signaler before sleeping
URL : https://patchwork.freedesktop.org/series/22357/
State : success
== Summary ==
Series 22357v1 drm/i915: Park the signaler before sleeping
https://patchwork.freedesktop.org/api/1.0/series/22357/revisions/1/mbox/
Test
On Monday, 2017-03-27 10:45:44 +0200, Daniel Vetter wrote:
> I wanted to get Sean Paul to run the drm-misc show for a bit, for
> training reasons and to increase the bus factor. And then realized
> there's no docs about what maintainers are doing.
>
> Fix that.
>
> v2: Add backmerges and taking t
If the signal to park arrives before we sleep, then we need to check
kthread_should_park() before sleeping to avoid missing the signal.
Otherwise, if the signal arrives whilst we are processing completed
requests, we will reset the current->state back to TASK_INTERRUPTIBLE
and so miss the wakeup.
== Series Details ==
Series: acquire ctx wire-up, part 2
URL : https://patchwork.freedesktop.org/series/22354/
State : success
== Summary ==
Series 22354v1 acquire ctx wire-up, part 2
https://patchwork.freedesktop.org/api/1.0/series/22354/revisions/1/mbox/
Test gem_exec_flush:
Subgrou
On pe, 2017-03-31 at 15:10 +0100, Chris Wilson wrote:
> Rebrand the current (pointer | bits) pack/unpack utility macros as
> explicit bit twiddling for PAGE_SIZE so that we can use the more
> flexible underlying macros for different bits.
>
> Signed-off-by: Chris Wilson
Pass by pointer when the
On Tue, Mar 21, 2017 at 09:13:54AM +0100, Thierry Reding wrote:
> From: Thierry Reding
>
> FB helper code falls back to a 1024x768 mode if no outputs are connected
> or don't report back any modes upon initialization. This can be annoying
> because outputs that are added to FB helper later on can
On Wed, Mar 29, 2017 at 04:43:56PM +0200, Thierry Reding wrote:
> From: Thierry Reding
>
> The existing drm_fb_helper_hotplug_event() function needs to take the
> top-level fb-helper lock. However, the function can also be called from
> code that has already taken this lock. Introduce an unlocked
Just the groundwork to prepare for adding the acquire cxt parameter to
the ->gamma_set hook. Again we need a temporary hack to fill out
mode_config.acquire_ctx until the atomic helpers are switched over.
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_color_mgmt.c | 33 -
I got confused every time I audited what that lock_all is doing in
there until realizing it's for legacy kms only. Make that a notch more
obvious by having 2 entirely different paths.
While at it also move the atomic version of this into
drm_framebuffer.c, there's no reason it needs to be in drm_a
It just doesn't work. It probably stopped working way, way before that
(e.g. i915 grabbed random mutexes all over in modeset code at least
since gen6), but with atomic and all the ww_mutex stuff it's indeed
hopeless.
Remove ->mode_set_base_atomic from the 2 atomic drivers (i915 and
nouveau) that s
Another one knocked down.
With this we can also remove the temporary hack in the gamma_set
ioctl.
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_atomic_helper.c | 13 ++---
drivers/gpu/drm/drm_color_mgmt.c| 1 -
2 files changed, 2 insertions(+), 12 deletions(-)
diff --git a/
The goal is to push all the kms locking down into these separate
_atomic and _legacy functions, so that we can correctly pass the
acquire ctx into all atomic drivers. Instead of playing games with
hidden ctx in mode_config.acquire_ctx. All the fbdev state will be
protected by a new fbdev private lo
Atomic helpers really want this instead of the hacked-up legacy
backoff trick, which unfortunately prevents drivers from using their
own private drm_modeset_locks.
Aside: There's a few atomic drivers (nv50, vc4, soon vmwgfx) which
don't yet use the new atomic color mgmt/gamma table stuff. Would be
This is only for legacy paths that need to grab the crtc/plane lock
combo. If you want to lock a crtc, just use drm_modeset_lock().
Reviewed-by: Harry Wentland
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_crtc_internal.h | 3 +++
drivers/gpu/drm/drm_modeset_lock.c | 14 --
It's not wired up, and if it is, it should be moved over to the new
fancy standardized zpos property exposed through
drm_plane_create_zpos_property().
Cc: Rob Clark
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/msm/mdp/mdp5/mdp5_plane.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/dr
If we push the locks down we don't have to take them all at the same
time.
Aside: Making dump_info fully safe should be fairly simple, if we
protect the ->state pointers with rcu. Simply putting a
synchronize_rcu() into the drm_atomic_state free function should be
all that's roughly needed. Well e
Properties, i.e. the struct drm_property specifying the type and value
range of a property, not the instantiation on a given object, are
invariant over the lifetime of a driver.
Hence no locking at all is needed, we can just remove it.
While at it give the function some love and simplify it, to g
Atomic code rely shouldn't rely on the magic hidden acquire context.
v2: Remove unused config local var (gcc).
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_atomic_helper.c | 16
1 file changed, 12 insertions(+), 4 deletions(-)
diff --git a/drivers/gpu/drm/drm_atomic_he
The last user, the cursor ioctl, can just open-code this too. We
simply have to move the acquire ctx dance from the universal function
up into the top-level ioctl handler.
Reviewed-by: Harry Wentland
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_crtc_internal.h | 3 --
drivers/gpu/drm/d
We don't call into drivers at all here, this is enough. Also, we can
reduce the critical section a bit to simplify the code.
crtc->gamma_size is set up once at driver load and then invariant, so
also doesn't need any protection.
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/drm_color_mgmt.c |
We do set DRIVER_ATOMIC now.
Signed-off-by: Daniel Vetter
---
drivers/gpu/drm/i915/intel_display.c | 44 +---
1 file changed, 1 insertion(+), 43 deletions(-)
diff --git a/drivers/gpu/drm/i915/intel_display.c
b/drivers/gpu/drm/i915/intel_display.c
index ba6687e31
With all the callers of drm_modeset_lock_crtc gone, and all the places
it was formerly used properly wiring the acquire ctx through, we can
remove this.
The only hidden context magic we still have is now the global one.
Reviewed-by: Harry Wentland
Signed-off-by: Daniel Vetter
---
drivers/gpu/d
Hi all,
Partially this is a resend of the patches now unblocked by the vmwgfx atomic
conversion just merged. I could entirely drop the vmwgfx patch since it's all
fixed now.
Then a bit of follow-up, plus converting the gamma_set/get ioctls. fbdev
emulation and the property paths are still infeste
On la, 2017-04-01 at 11:01 +0100, Chris Wilson wrote:
> Or rather it is used only by intel_ring_pin() to extract the
> drm_i915_private which we can easily pass in. As this is a relatively
> rare operation, save the space in the struct, and as such it is even
> break even in the extra code for pass
Hi Maarten,
sorry for delay in reply...
In Option 3:
We know maximum number of plane for any given CRTC, We also know, what
is the maximum downscaling supported (only downscaling affects WM) per
pipe/plane.
Maximum downscaling per plane can be :
max plane hscale * max plane
63 matches
Mail list logo